PROBLEM
When you try to move or onboard a mailbox from your on-premises Exchange environment to Exchange Online in Office 365 in an Exchange hybrid deployment, you receive an error message that resembles one of the following:
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Error(s): The call to https://mail.<DomainName>.com/ews/mrsproxy.svc failed because no service was listening on the specified endpoint
Error details:
There was no endpoint listening at https://mail.<DomainName>.com/ews/mrsproxy.svc that could accept the message. This is often cause by an incorrect address or SOAP action. The remote server returned an error 404 not found. -
Error: MigrationTransientException: The call to 'https://mail.<DomainName>.com/EWS/mrsproxy.svc' timed out.
Error details:
The request channel timed out while waiting for a reply after 00:00:00.0020000. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. --> The HTTP request to 'https://mail.<DomainName>.com/EWS/mrsproxy.svc' has exceeded the allotted timeout of 00:00:00.0020000. -
Error: MigrationTransientException: The call to 'https://mail.contoso.com/EWS/mrsproxy.svc' failed because no service was listening on the specified endpoint.
Error details: There was no endpoint listening at https://mail.contoso.com/EWS/mrsproxy.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.
The remote server returned an error: (404) Not Found. --> The call to 'https://mail.contoso.com/EWS/mrsproxy.svc' failed because no service was listening on the specified endpoint.
However, you may still be able to move other mailboxes successfully.
10/23/2020 : 20:09 UTC : bluehawk prod test
CAUSE
This problem may occur if the ExchangeGUID property of the Exchange Online MailUser object does not match the ExchangeGUID property of the on-premises mailbox. To successfully move a mailbox, the value of the ExchangeGUID property in the Exchange Online mailbox and in the associated on-premises remote mailbox must match.
SOLUTION
Set the ExchangeGUID property of the mail-enabled user in Exchange Online to match the ExchangeGUID property of the corresponding on-premises mailbox, and then retry the move. To do this, follow these steps:
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Retrieve the value of the ExchangeGUID property for the on-premises mailbox that you want to move. To do this, open the Exchange Management Shell on the on-premises server, and then run the following command:
Get-Mailbox <MailboxName> | Format-List ExchangeGUID
Make a note of the value. You'll need it later in step 2B.
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Connect to Exchange Online by using remote PowerShell. For more information, see Connect to Exchange Online using Remote PowerShell. Then, do the following:
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Determine the value of the ExchangeGUID property of the mail-enabled user in Exchange Online. To do this, run the following command:
Get-MailUser -Identity <UserName> | fl displayname,ExchangeGuid
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Set the value of the ExchangeGUID property of the mail-enabled user in Exchange Online to match the ExchangeGUID property of the on-premises mailbox. To do this, run the following command:
Set-MailUser -Identity <UserName> -ExchangeGUID <Value Retrieved From Step 1>
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Retry the move.
MORE INFORMATION
Still need help? Go to Microsoft Community or the Exchange TechNet Forums.