Jak sprawdzić i usunąć nieprawidłowe odwołania w Edytorze Visual Basic w programie Word

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 308340 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W Edytorze Visual Basic Word firmy Microsoft można utworzyć odwołania do bibliotek obiektów lub kod w zewnętrznych dokumentu lub szablonu. Umożliwia to wywołanie procedury zewnętrznego tak, jakby były napisane w własne Projekt. Uwaga Jeśli wskazane pliki są przenoszone mogą wystąpić problemy lub uszkodzona. Mogą wystąpić błędy magazynowania makr oraz Odwołania okno dialogowe może stać się niedostępne.

W tym artykule w tym artykule opisano sposób tworzenia odwołań do innych języka Microsoft Visual Basic dla Projekty Applications (VBA), jak sprawdzić, czy odwołania są poprawne, i jak usunąć programowo niepoprawne odwołania.

Uprzednia wiedza wymagane jest:
  • Podstawowych umiejętności programowania w języku VB i VBA
  • Podstawowe umiejętności pakietu Microsoft Office
  • Umiejętności w Eksploratorze Windows
W tym artykule używanie Edytora Visual Basic do wykazania jak:
  • Tworzenie odwołania do własnych niestandardowych VBA Projekt.
  • Pisanie kodu, aby sprawdzić, czy istnieje odwołanie.
  • Pisanie kodu, aby usunąć nieprawidłowe odwołanie.
  • Napisać kod Dodaj odwołanie do tyłu.

Ustawianie uprawnień zabezpieczeń programu Project

  1. W programie Microsoft Word na Narzędzia menu, wskaż Makro, a następnie kliknij przycisk Zabezpieczenia Aby wyświetlić Zabezpieczenia okno dialogowe.
  2. Na Poziom zabezpieczeń Karta, należy ustawić poziom zabezpieczeń Średni, tak aby mieli wybór włączanie makr.
  3. Na Zaufanych źródeł Karta, sprawdź, czy Ufaj dostępowi do programu Visual Basic Projekt pole wyboru jest zaznaczone. Dzięki temu można używać kodu VBA w sieci projekty.
  4. Kliknij przycisk OK.
W Program Word 2007, wykonaj następujące kroki:
  1. Na Deweloper Kliknij pozycję Makro Zabezpieczenia w Kod Grupa.
  2. W lewym okienku kliknij przycisk Ustawienia makr.
  3. W prawym okienku kliknij przycisk Włącz wszystkie makra, a następnie kliknij przycisk Wybierz Ufaj dostępowi do modelu obiektowego projektu VBA pole wyboru.
  4. Kliknij przycisk OK.

Tworzenie odwołania projektu

Utworzy projekt, który zawiera informacje o procedurach a Utwórz odwołanie do tego projektu z nowego projektu VBA.

Aby utworzyć plik biblioteki:
  1. Utwórz nowy dokument w programie Microsoft Word, a następnie zapisz jako szablon, wykonaj następujące czynności:
    1. Na Plik menu, kliknij przycisk Zapisz jako Aby wyświetlić Zapisz jako okno dialogowe.

      Uwaga W Program Word 2007, kliknij przycisk Przycisk Microsoft Office, a następnie kliknij przycisk Zapisz Jako.
    2. Zmiana Nazwa pliku pole Refme.
    3. Zmiana Zapisz jako typ pole Szablon dokumentu (* .dot).

      Uwaga W programie Word 2007, zmienianie Zapisz jako typ pole Szablon programu Word 97-2003 (* .dot)
    4. Zapisz szablon w folderze "C:\TestFiles" (użytkownik Musisz utworzyć ten folder, jeśli nie istnieje).
  2. Naciśnij klawisz ALT + F11. Aby uruchomić Edytor Visual Basic.
  3. W Eksploratorze projektu zaznacz TemplateProject (Refme). Na Wstaw menu, kliknij przycisk Moduł. Służy do dodania nowego modułu o nazwie "module1" Projekt.
  4. W oknie Kod Module1 wpisz następujący kod:
    Public Sub CallMe()
    
      Msgbox "Hello World!"
    
    End Sub
    					
  5. Kliknij przycisk podprocedurę, a następnie, na Uruchom menu, kliknij przycisk Uruchom makro. Zostanie wyświetlone okno komunikatu "Hello World!". Zamknij tę wiadomość pole.
  6. Na Widok menu, kliknij przycisk Program Microsoft Word (ALT + F11) Aby powrócić do programu Word.
  7. W programie Word Zapisz i zamknij plik szablonu.
Aby utworzyć odwołanie:
  1. W programie Word utwórz nowy dokument, a następnie zapisz go jako "Myproj.doc" w folderze "C:\TestFiles".
  2. Uruchom Edytor Visual Basic (naciśnij klawisze ALT + F11). W Eksplorator projektu, wybierz Projekt (Myproj).
  3. Tworzenie odwołania do szablonu Refme w następujący sposób:
    1. Na Narzędzia menu, kliknij przycisk Odwołania.
    2. W Odwołania okno dialogowe, kliknij przycisk Przeglądaj.
    3. W Dodaj odwołanie okno dialogowe, ustawianie Pliki typu Aby Dokumenty programu Word (* .doc; * .dot).

      Uwaga W programie Word 2007 Pliki typu Aby Dokumenty programu Word (*.docm; *.dotm.doc; * .dot).
    4. Wybierz folder "C:\TestFiles" Refme szablon.
    5. Kliknij przycisk Otwórz Aby powrócić do Odwołania okno dialogowe.
    6. Kliknij przycisk OK Aby powrócić do edytora Visual Basic.
  4. W Eksploratorze projektu rozwiń węzeł Projekt (Myproj). Rozwiń węzeł Odwołania i sprawdź, czy lista odwołania zawiera Odniesienie do Refme.dot.
  5. Na Wstaw menu, kliknij przycisk Moduł Aby wstawić nowy moduł do projektu. Zapisz poniższy kod w module do wywoływania procedury CallMe:
    Public Sub Test()
    
      Call CallMe
    
    End Sub
    					
  6. Przetestować procedurę, aby sprawdzić jego działania, a następnie zwrócić do programu Word.
  7. Zapisz i zamknij plik dokumentu, a następnie zamknij Program Word.

Programowy test odwołania projektu

Możesz teraz zostanie celowo zerwanie odwołania programu, a następnie sprawdź dokładność odwołania programu.

Aby przerwać odniesienia:
  1. W Eksploratorze Windows (prawym przyciskiem myszy Windows Start menu, a następnie kliknij przycisk Eksploruj w menu skrótów) Zmień nazwę szablonu Refme.dot do "Refme.old". Aby to zrobić, kliknij prawym przyciskiem myszy Refme.dot a następnie kliknij przycisk Zmień nazwę w menu skrótów. Typ refme.old i następnie naciśnij klawisz ENTER.
  2. Powróć do programu Word i ponownym otwarciu dokumentu "Myproj.doc".
  3. Ponieważ poziom zabezpieczeń jest ustawiony na Średni, zapyta, czy chcesz włączyć lub wyłączyć makra w tym dokumencie. Kliknij przycisk Włącz makra.

    UwagaTo zachowanie nie występuje w programie Word 2007.
  4. Uruchom Edytor Visual Basic (naciśnij klawisze ALT + F11), a następnie uruchom Procedura badania. Kliknij przycisk OK Aby następujący komunikat o błędzie kompilacji:
    Nie można odnaleźć projektu lub biblioteki
  5. Powinna być w trybie przerwania (Brak żółtą banderolą poprzez wiersz podrzędny). Na Uruchom menu, kliknij przycisk Resetuj Aby powrócić do trybu projektowania.
  6. Na Narzędzia menu, kliknij przycisk Odwołania Aby wyświetlić Odwołania okno dialogowe. Widać, że Refme.dot jest oznaczony jako "Brak".
  7. Kliknij przycisk Anuluj Aby zamknąć Odwołania okno dialogowe.
Aby sprawdzić programowo brakujących odwołań:
  1. W Eksploratorze projektu zaznacz Projekt (Myproj).
  2. Na Narzędzia menu, kliknij przycisk Odwołania a następnie dodać odwołanie do programu Microsoft Visual Basic for Biblioteka Applications Extensibility 5.3. Ta biblioteka zawiera obiekty, odnoszą się do projektów VBA.
  3. Przed kliknięciem przycisku OK, należy sprawdzić, czy nowe odwołanie jest dodawana powyżej odwołanie "Brak". Kliknij strzałkę kilka razy, aby zmienić priorytet, przenoszenie Nowe odwołanie powyżej odniesienia "Brak", a następnie kliknij OK.
  4. W module utworzyć nową procedurę typu sub o nazwie "checkreference", a następnie zapisu następujący kod:
    Sub CheckReference()
    
       Dim vbProj As VBProject ' This refers to your VBA project.
       Dim chkRef As Reference ' A reference.
      
       ' Refer to the activedocument's VBA project.
       Set vbProj = ActiveDocument.VBProject
    
       ' Check through the selected references in the References dialog box.
       For Each chkRef In vbProj.References
      
          ' If the reference is broken, send the name to the Immediate Window.
          If chkRef.IsBroken Then
             Debug.Print chkRef.Name
          End If
    
       Next
    
    End Sub
    					
  5. Na Widok menu, kliknij przycisk Bezpośrednim (CTRL + G) Aby otworzyć okienko bezpośrednie.
  6. Uruchom procedurę typu sub CheckReference. Nazwa i lokalizacja pliku jest wyświetlany w oknie bezpośrednim.

Usuwać i przywracać odwołania projektu

W tej sekcji opisano, jak usunąć programowo i Przywraca odwołanie.

Aby usunąć brakujące odwołanie:
  1. Zmiany w procedurze sub CheckReference Debug.Print oświadczenie w następujący sposób. Spowoduje to usunięcie wszelkich brakujących odwołań z Projekt:
       vbProj.References.Remove chkRef
    					
  2. Uruchom procedurę CheckReference.
  3. Sprawdź, czy odwołanie zostało usunięte w Odwołania okno dialogowe (na Narzędzia menu, kliknij przycisk Odwołania).
Aby przywrócić (Dodaj) odniesienie:
  1. W Eksploratorze Windows, Refme.old z powrotem do zmiany nazwy "Refme.dot".
  2. Powrócić do projektu Myproj w Edytorze Visual Basic w Program Word.
  3. Napisz nową procedurę typu sub o nazwie "addreference" w następujący sposób:
    Sub AddReference()
    
       Dim vbProj as VBProject
    
       Set vbProj = ActiveDocument.VBProject
       vbProj.References.AddFromFile "C:\TestFiles\Refme.dot"
    
    End Sub
    					
  4. Uruchom procedurę AddReference.
  5. Upewnij się, że odwołanie do Refme.dot zostało przywrócone. W przypadku można wyświetlić odwołań, w programie Project Explorer lub kliknięciu Odwołania na Narzędzia menu.

Rozwiązywanie problemów

  • Jeśli dokonuje się odniesienia do macierzystego pliku aplikacji, możesz należy zachować rozszerzenie pliku macierzystym. W przeciwnym razie mogą wystąpić problemy Kiedy użyć odwołania. Aby wyświetlić te problemy, spróbuj odnieść się do plik Refme.old w pliku Refme.dot w przykładzie wcześniej artykuł.
  • Jeśli użytkownik pracuje ze składnikiem zarejestrowane, można dodać Identyfikator GUID odwołanie do projektu. Użyj AddFromGUID Metoda w tym celu.

Właściwości

Numer ID artykułu: 308340 - Ostatnia weryfikacja: 18 września 2011 - Weryfikacja: 3.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
Słowa kluczowe: 
kbprogramming kbvba kbhowtomaster kbmt KB308340 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:308340

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com