Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

For a Windows 2000 version of this article, see 124550.

Symptoms

When you attempt to start Windows XP, you may receive one of the following error messages:

Error message 1

Windows could not start because of a computer disk hardware configuration problem.

Could not read from the selected boot disk. Check boot path and disk hardware.

Please check the Windows documentation about hardware disk configuration and your hardware reference manuals for additional information.

Error message 2

Windows NT could not start because the following file is missing or corrupt:

Winnt_root\System32\Ntoskrnl.exe

Please re-install a copy of the above file.

Error message 3

Winnt_root\System32\Hal.dll missing or corrupt:

Please re-install a copy of the above file.

Additionally, you may experience one or more of the following behaviors:

  • If you start the computer to the Recovery Console, a command prompt may appear with no option to log on to the Windows installation.

  • If you try to access the Windows folder, you may receive the following error message:

    Access denied.

  • If you try to perform a Repair operation from the Windows XP CD-ROM, the Windows installation is not detected and you cannot repair Windows.

Cause

This behavior can occur if any or some of the following conditions are true:

  • The Default value in the [Boot Loader] section of the Boot.ini file is missing or invalid.

  • Windows XP is not installed in the location specified in the Boot.ini file.

  • The Ntoskrnl.exe file is missing or damaged.

  • The partition path in the Boot.ini file is not set correctly.

  • General hardware failure.

Resolution

To resolve this issue, use either of the following methods.

Method 1

Edit the Boot.ini file to restore or correct the Default entry and to ensure that the other entries in the [Operating Systems] section of the Boot.ini file point to the appropriate directories.

For more information about how to edit the Boot.ini file, click the following article number to view the article in the Microsoft Knowledge Base:

289022 How to edit the Boot.ini file in Windows XP

Method 2

Use the Bootcfg utility in the Recovery Console to correct the Boot.ini file:

  1. Use the Windows XP CD-ROM to start your computer.

  2. When you receive the message to press R to repair Windows by using the Recovery Console, press the R key.

  3. Select the Windows installation that you want, and then type the administrator password when prompted.

  4. Type bootcfg /rebuild, and then press ENTER.

  5. When the Windows installation is located, the following instructions are displayed:

    Add installation to boot list? (Yes/No/All)
    [Type Y in response to this message.]

    Enter Load Identifier:
    [This is the name of the operating system. Type Windows XP Professional or Windows XP Home Edition.]

    Enter OS Load options:
    [Leave this field blank, and then press ENTER].
    After you perform the preceding steps, restart the computer, and then select the first item on the boot menu. This should allow Windows XP to start normally.

    After Windows XP has successfully loaded, the Boot.ini can be modified to remove the incorrect entry.

For more information about how to edit the Boot.ini file, click the following article number to view the article in the Microsoft Knowledge Base:

289022 How to edit the Boot.ini file in Windows XP

Method 3

  1. Start the computer by using your Windows XP CD-ROM. Press any key to boot from the CD.

  2. After the setup files are finished loading press R to repair using Recovery Console.

  3. When you are in the recovery console, select the installation to log on to (usually number 1), and then press ENTER.

  4. Login to the Administrator account by typing the password for this account, and then press ENTER.

  5. At the recovery console command prompt, type the following command, and then press ENTER:

    For Uni-Processor systems:

    expand <cd-drive>:\i386\ntoskrnl.ex_ <hd-drive>:\Windows\system32\ntoskrnl.exeFor Multi-Processor systems:

    expand <cd-drive>:\i386\ntkrnlmp.ex_ <hd-drive>:\Windows\system32\ntoskrnl.exe
    Note In these two commands, the <cd-drive> placeholder represents the drive letter of your CD drive, and the <hd-drive> placeholder represents the drive letter of the hard disk on which windows is installed.

  6. If you receive a prompt to overwrite the file, press Y.

  7. Type exit, and press ENTER at the command prompt.

Method 4

Start the computer by using the Recovery Console, and then run theCHKDSK /rcommand.

Note You do not have to include the /p switch in the Chkdsk command-line because the /r switch causes the Chkdsk utility to locate bad sectors and recover readable information. This command implies the /p switch..

More Information

If the Default value in the [Boot Loader] section of the Boot.ini file is missing, Windows XP displays a new entry, Windows (default), on the OS Loader (boot loader) menu, and then defaults to the new entry. The Windows (default) entry points to the following path to load Windows XP:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
For more information about the Boot.ini file, click the following article number to view the article in the Microsoft Knowledge Base:

102873 Boot.ini and ARC path naming conventions and usage

For more information about Recovery Console in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

307654 How to install and use the Recovery Console in Windows XP

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×