Help and Support

文書番号: 314503 - 最終更新日: 2007年12月10日 - リビジョン: 3.2

Windows XP の起動時にコンピュータが応答を停止し、黒い画面が表示される

目次

すべて展開する | すべて折りたたむ

現象

Windows XP の起動時に、Power On Self Test (POST) が終了した直後、Windows ロゴが画面に表示される前に、コンピュータが黒い空白の画面を表示したままで応答を停止 (ハング) することがあります。

原因

この問題は、次のいずれかの条件に該当する場合に発生することがあります。

原因 1

この問題は、コンピュータの起動時に、CD、DVD、またはフロッピー ドライブに CD、DVD、またはフロッピー ディスクが挿入されている場合に発生することがあります。

原因 2

この問題は、以下のいずれか、または複数の要素が破損し、コンピュータのブート シーケンス中に読み込まれない場合に発生します。
  • マスタ ブート レコード
  • パーティション テーブル
  • ブート セクタ
  • NTLDR ファイル

解決方法

この問題を解決するには、以下の手順を実行します。

原因 1 の解決方法

この問題を解決するには、CD、DVD、またはフロッピー ドライブからメディアを取り出して、コンピュータを再起動します。

高度なトラブルシューティング

このセクションは、上級ユーザーを対象としています。高度なトラブルシューティングに自信がない場合は、サポート担当者にお問い合わせください。お問い合わせ方法については、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

原因 2 の解決方法

この問題を解決するには、Windows XP CD-ROM が必要です。使用可能な Windows XP CD-ROM がない場合は、コンピュータの製造元に問い合わせて、この問題のトラブルシューティングを行う必要があります。

Windows XP CD-ROM がある場合は、次のいずれかの方法を使用します。
方法 1 : Windows で読み込むことができない特定の要素のトラブルシーティングを行う
: この方法では、問題の原因となっている要素を特定するために、複数の手順を実行する必要があります。この方法を使用した場合は、Windows のユーザー設定を保持することができます。
  1. コンピュータをセーフ モードで再起動します。これを行うには、Windows の起動中に F8 キーを押します。次に、Windows XP ブート ディスクを作成してコンピュータを起動します。

    Windows XP ブート ディスクの作成方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    305595? (http://support.microsoft.com/kb/305595/ ) [HOW TO] Windows XP を使用して、NTFS パーティションまたは FAT パーティションにブート ディスクを作成する方法
    315222? (http://support.microsoft.com/kb/315222/ ) Windows XP のセーフ モード ブート オプションについて
    ブート ディスクからコンピュータを起動でき、エラー メッセージが表示されなければ、破損しているのはマスタ ブート レコード、ブート セクタ、または NTLDR ファイルに限定されます。Windows XP を実行した後、すぐにすべてのデータのバックアップを作成してから、ブート セクタを修復します。

    ディスクの管理を使用して、パーティション情報を表示し、ディスク パーティションが正常であることを確認します。ディスクの管理を使用するには、以下の手順を実行します。
    1. [スタート] ボタンをクリックし、[マイ コンピュータ] を右クリックし、[管理] をクリックします。
    2. [記憶域] を展開し、[ディスクの管理] をクリックします。
    無効なパーティションが存在する場合、またはブート ディスクを使用してコンピュータを起動できない場合は、Windows XP を再インストールした後で最新のバックアップからデータと構成情報を復元します。

    データの最新のバックアップ コピーがない場合は、コンピュータの専門家に相談して、データの回復と構成に最適の方法を検討してください。
  2. 最新のウイルス検出プログラムを実行して、ウイルスが存在しないかどうかを確認します。
  3. Windows XP 回復コンソールから FIXMBR コマンドを実行して、マスタ ブート レコードを修復します。

    回復コンソールの使用方法の詳細情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    307654? (http://support.microsoft.com/kb/307654/ ) Windows XP での回復コンソールのインストールおよび使用方法
    : FIXMBR コマンド実行時に表示されることのあるエラー メッセージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    266745? (http://support.microsoft.com/kb/266745/ ) fixmbr コマンド実行時のエラー メッセージ
    警告 : コンピュータがウイルスに感染している場合に FIXMBR コマンドを使用すると、コンピュータを起動できなくなることがあります。このコマンドを使用する前に、コンピュータがウイルスに感染していないことを確認してください。
  4. プライマリ ブート パーティションが FAT パーティションの場合、Windows XP 回復コンソールから FIXBOOT コマンドを使用して新しいブート セクタをシステム パーティションに書き込み、次に FIXMBR コマンドを使用してマスタ ブート レコードを修復します。
方法 2 : インストールされている Windows を修復する
: インストールされている Windows を修復すると、Windows の構成が変更されることがあります。また、方法 1 の手順に記載されているすべてのトラブルシューティングを実行しても問題が解決されなかった場合は、この手順を実行する必要があります。
  1. Windows XP の CD-ROM を使用してコンピュータを起動します。[セットアップの開始] 画面で Enter キーを押し、Windows XP のセットアップを開始します。
  2. F8 キーを押して使用許諾契約に同意します。
  3. 方向キーを使用して、修復する Windows XP インストールを選択し、R キーを押します。

    Windows XP セットアップによりインストール ファイルが修復され、Windows XP が自動的に再起動し、Windows XP インストールの修復が完了します。
  4. 残りの手順を実行して Windows のセットアップを完了します。

    : これらの手順を実行するには 25 文字のプロダクト キーが必要です。
  5. この問題が解決されたら、すぐに、ファイアウォールが有効になっていることを確認し、以下のマイクロソフト Web サイトにアクセスして、最新の更新プログラムを再インストールしてください。
    http://windowsupdate.microsoft.com/ (http://windowsupdate.microsoft.com/)
  6. ウイルスが原因で、要素が破損される問題が発生する場合があるため、コンピュータでウイルス スキャンを実行します。

詳細

回復コンソールの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
229716? (http://support.microsoft.com/kb/229716/ ) Windows 2000 回復コンソールについて
235364? (http://support.microsoft.com/kb/235364/ ) [NT]修復コンソールにおける SET コマンドの説明
310497? (http://support.microsoft.com/kb/310497/ ) Windows XP Professional でグループ ポリシーを使用して回復コンソールに機能を追加する方法
上記の資料で問題が解決しなかった場合、または、この資料に記載されている現象とは異なる現象が発生する場合は、詳細について「サポート技術情報」 (Microsoft Knowledge Base) を検索してください。「サポート技術情報」を検索するには、次のマイクロソフト Web サイトにアクセスします。
http://support.microsoft.com (http://support.microsoft.com/)
[サポート技術情報の検索] ボックスに、表示されるエラー メッセージを入力するか、問題の詳細を入力してください。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbresolve kbvirus kbenv kbfaq kbprb kbusage KB314503
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers