คอมพิวเตอร์หยุดการตอบสนองโดยหน้าจอเป็นสีดำเมื่อคุณเริ่ม Windows XP

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 314503 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อคุณพยายามเริ่มต้น Microsoft Windows XP คอมพิวเตอร์อาจหยุดการตอบสนอง (แฮงค์) โดยแสดงหน้าจอเปล่า สีดำทันทีหลังผ่านกระบวนการ power-on self test (POST) และก่อนที่โลโก้ Windows XP จะปรากฏขึ้นตามปกติในหน้าจอ

สาเหตุ

ปัญหานี้อาจเกิดขึ้น หากสถานการณ์ใดๆ ต่อไปนี้เป็นจริง:
  • Master boot record
  • ตารางพาร์ทิชัน
  • บูตเซกเตอร์
  • แฟ้ม NTLDR

การแก้ไข

การแก้ปัญหานี้ ให้ทำตามขั้นตอนต่างๆ ต่อไปนี้:
  1. สร้างแผ่นดิสก์สำหรับบูตของ Windows XP เพื่อเริ่มต้นระบบคอมพิวเตอร์

    สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสร้างดิสก์สำหรับบูตของ Windows XP Setup ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base:
    305595 วิธีการสร้าง Boot Disk สำหรับพาร์ทิชัน NTFS หรือ FAT ใน Windows XP
    หากคุณสามารถเริ่มคอมพิวเตอร์โดยใช้ดิสก์สำหรับบูตโดยไม่ได้รับข้อความแสดงข้อผิดพลาด ความเสียหายเกิดขึ้นกับมาสเตอร์บูตเรคคอร์ด หรือแฟ้ม NTLDR เท่านั้น หลังจาก Windows XP ทำงานได้แล้ว ให้สำรองข้อมูลทั้งหมดทันที ก่อนที่จะพยายามแก้ไขปัญหาของบูตเซกเตอร์

    ใช้ Disk Management เพื่อดูข้อมูลพาร์ทิชันและตรวจดูว่าการแบ่งพาร์ทิชันของดิสก์ (หรือพาร์ทิชันต่างๆ) ถูกต้อง เมื่อต้องการใช้ Disk Management ให้ทำตามขั้นตอนต่อไปนี้:
    1. คลิก Start คลิกขวาที่My Computerแล้วคลิก Manage
    2. ขยาย Storageแล้วคลิก Disk Management
    หากปรากฎพาร์ทิชันที่ไม่ถูกต้องหรือคุณไม่สามารถเริ่มต้นคอมพิวเตอร์โดยใช้ดิสก์สำหรับบูตได้ ให้ติดตั้ง Windows XP ในคอมพิวเตอร์ของคุณใหม่และเรียกคืนข้อมูลและข้อมูลการกำหนดค่าต่างๆ จากการสำรองข้อมูลล่าสุด

    หากคุณไม่มีสำรองข้อมูลล่าสุดของข้อมูลในคอมพิวเตอร์ของคุณ โปรดติดต่อผู้เชี่ยวชาญด้านคอมพิวเตอร์เพื่อหาวิธีการที่ดีที่สุดในการกู้คืนข้อมูลและการกำหนดค่าต่างๆ
  2. รันโปรแกรมสแกนไวรัสเพื่อตรวจดูว่าไม่มีไวรัสในระบบ
  3. ซ่อมแซมมาสเตอร์บูตเรคคอร์ดโดยใช้คำสั่ง FIXMBR จาก Windows XP Recovery Console

    สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการใช้ Recovery Console คลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
    307654 วิธีการติดตั้งและใช้งาน Recovery Console ใน Windows XP (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
    หมายเหตุ สำหรับข้อมูลเพิ่มเติมเกี่ยวกับข้อความแสดงข้อผิดพลาดที่คุณอาจได้รับเมื่อใช้คำสั่ง FIXMBR ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
    266745 ข้อความแสดงข้อผิดพลาดเมื่อคุณรันคำสั่ง fixmbr (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
    คำเตือน หากคอมพิวเตอร์ของคุณมีไวรัส และคุณใช้คำสั่ง FIXMBR คุณอาจไม่สามารถเริ่มต้นคอมพิวเตอร์ได้ ก่อนที่จะใช้คำสั่งนี้ ให้ตรวจสอบให้แน่ใจว่าคอมพิวเตอร์ไม่ได้ติดไวรัส
  4. หากพาร์ทิชันสำหรับบูต primary เป็นพาร์ทิชันแบบ FAT ใช้คำสั่ง FIXBOOT จาก Windows XP Recovery Console เพื่อเขียนบูตเซกเตอร์ใหม่ในพาร์ทิชันระบบ จากนั้นใช้คำสั่ง FIXMBR เพื่อซ่อมแซมมาสเตอร์บูตเรคคอร์ด
คุณอาจใช้โปรแกรมติดตั้ง Windows XP เพื่อซ่อมแซมการติดตั้งนี้ได้ด้วย โดยให้ทำตามขั้นตอนต่อไปนี้:
  1. ใช้แผ่น Windows XP CD-ROM เพื่อเริ่มต้นคอมพิวเตอร์ของคุณ ที่หน้าจอต้อนรับ ให้กด ENTER เพื่อเริ่มการติดตั้ง Windows XP
  2. กด F8 เพื่อยอมรับข้อตกลงว่าด้วยการใช้งาน
  3. ใช้ปุ่มลูกศรเพื่อเลือกการติดตั้ง Windows XP ที่คุณต้องการซ่อมแซม แล้วกด R

    Windows XP ซ่อมแซมแฟ้มต่างๆ สำหรับติดตั้ง, เริ่มต้น Windows XP ใหม่โดยอัตโนมัติ จากนั้นโปรแกรมติดตั้งจบการซ่อมแซมการติดตั้ง Windows XP ของคุณ
  4. ทำตามขั้นตอนที่เหลือเพื่อติดตั้ง Windows

    หมายเหตุ คุณต้องมีหมายเลขผลิตภัณฑ์ที่เป็นอักขระ 25 ตัวเพื่อทำงานในขั้นตอนนี้

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับ Recovery Console โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
229716 คำอธิบายของ Windows 2000 Recovery Console
235364 คำอธิบายของคำสั่ง SET ใน Recovery Console (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
310497 วิธีการเพิ่มความสามารถให้กับ Recovery Console โดยใช้ Group Policy ใน Windows XP Professional (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)

คุณสมบัติ

หมายเลขบทความ (Article ID): 314503 - รีวิวครั้งสุดท้าย: 30 พฤศจิกายน 2549 - Revision: 2.3
ใช้กับ
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Keywords: 
kbvirus kbenv kbfaq kbprb kbusage KB314503

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com