При установке программы в Windows XP появляется сообщение об ошибке «Нет доступа к службе установки Windows»

Переводы статьи Переводы статьи
Код статьи: 315353 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

При попытке установки программы, например Microsoft Plus! для Windows XP или Microsoft Office 2003 в Microsoft Windows XP может появиться следующее сообщение об ошибке:
Нет доступа к службе установки Windows.
Возможно, система запущена в безопасном
режиме или установшик Windows установлен
неправильно. Обратитесь в службу поддержки.

Причина

Проблема может возникать в случае одновременного выполнения следующих условий.
  • Система Windows XP работает в обычном режиме.
  • Служба установщика Windows, которая входит в состав Windows XP, не зарегистрирована или повреждена.

Решение

Для решения проблемы выполните следующие действия:
  1. Войдите в систему с учетной записью администратора.
  2. В меню Пуск выберите пункт Выполнить.
  3. В поле Открыть введите команду cmd и нажмите кнопку ОК.
  4. В командной строке введите msiexec.exe /unregister и нажмите клавишу ВВОД.
  5. Введите msiexec /regserver и нажмите клавишу ВВОД.
  6. Убедитесь в том, что учетная запись SYSTEM имеет полные разрешения на доступ к кусту
    HKEY_CLASSES_ROOT
    в реестре Windows. В некоторых случаях может потребоваться добавить учетные записи администратора. Для этого выполните следующие действия:Важно! В данный раздел, метод или задачу включены действия по изменению параметров реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем. Поэтому такие действия необходимо выполнять очень внимательно. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. При возникновении неполадок реестр можно восстановить. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
    322756 Создание резервной копии и восстановление реестра Windows
    1. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду regedit и нажмите кнопку ОК.
    2. Выберите следующий куст реестра:
      HKEY_CLASSES_ROOT
    3. В меню Правка выберите пункт Разрешения.
    4. Если учетная запись SYSTEM отсутствует в списке Группы или пользователи, нажмите кнопку Добавить и убедитесь в том, что имя локального компьютера отображается в поле В следующем месте, введите system в поле Введите имена выбираемых объектов, нажмите кнопку Проверить имена и нажмите кнопку ОК.
    5. Выберите пункт SYSTEM в списке Группы или пользователи и установите флажок Полный доступ в столбце Разрешить раздела Разрешения для SYSTEM.
    6. Нажмите кнопки Применить и ОК, после чего закройте редактор реестра.
  7. Перезагрузите компьютер. Если проблема повторится, восстановите систему Windows XP. Дополнительные сведения о восстановлении Windows XP см. в следующей статье базы знаний Майкрософт:
    9787800 Как выполнить обновление (переустановку) Microsoft Windows XP
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 315353 - Последний отзыв: 25 марта 2014 г. - Revision: 2.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003
Ключевые слова: 
kbPubTypeKC kbtshoot kberrmsg kbprb KB315353

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com