Při pokusu o přístup k webu systému Windows Update nebo Microsoft Update se zobrazí chybová zpráva Pouze skupina Administrators (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 316524 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při pokusu o návštěvě webu Windows Update nebo webu Microsoft Update může zobrazit chybová zpráva podobná následující:
Číslo chyby: 0x8DDD0002

Instalovat položky ze systému Windows Update, musíte být přihlášeni jako správce nebo člen skupiny Administrators. Pokud je počítač připojen k síti, může být provedení tohoto postupu znemožněno také nastavením síťových zásad.
Zobrazí tato zpráva, přestože jste již přihlášeni jako správce nebo člen Administrators skupiny.

Poznámka: Další informace o webu Windows Update a serveru Microsoft Update naleznete v části "Další informace".

Příčina

Toto chování může dojít některý z následujících důvodů:
  1. Není jste přihlášeni jako uživatel, který patří do místní skupiny Administrators.
  2. Máte oprávnění klíče registru konkrétní nebo složek.
  3. Operační systém nemůže číst data ve složce %Systemroot%\System32\Catroot2.

Řešení

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které sdělit, jak upravit registr. Po nesprávné úpravě registru však mohou nastat závažné problémy. Postupujte proto pečlivě podle uvedených kroků. Pro zvýšení bezpečnosti registr zálohujte jestě před jeho úpravami. Potom můžete v případě potíží registr obnovit. Další informace o zálohování a obnovení registru naleznete následujícím článku znalostní v databáze Microsoft Knowledge Base:
322756Zálohování a obnovení registru v systému Windows


Chcete-li tento problém vyřešit, použijte jednu z následujících metod. Pokud metoda 1 problém nevyřeší, použijte metodu 2.
  • Metoda 1

    Ověřte, že jste přihlášeni jako uživatel, který patří do místní skupiny Administrators.

    na systém Windows XP

    Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte nusrmgr.cpl a potom klepněte na tlačítko OK otevřete okno uživatelské účty.

    Pokud jsou součástí síťové domény, postupujte takto:
    1. V okně Uživatelské účty klepnutím vyberte účet ze seznamu a klepněte na příkaz Vlastnosti.
    2. Na kartě Členství ověřte jsou ve skupině Administrators.
    Pokud jste jsou součástí síťové domény, postupujte takto:
    1. V okně Uživatelské účty klepněte na svůj účet a ověřte, že se zobrazí pod název účtu Správce počítače.

    WINDOWS 2000

    1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz compmgmt.msc a klepněte na tlačítko OK.
    2. V okně Správa počítače rozbalte položku Systémové nástroje, rozbalte položku Uživatelé a skupiny a klepněte na složku Uživatelé.
    3. V pravém podokně počítač správy okno, klepněte pravým tlačítkem myši uživatele, jehož uživatelských práv, které chcete ověřit a potom klepněte na příkaz Vlastnosti.
    4. Na kartě členů ověřte, zda Administrators je uvedena v členem pole.
    Přihlášen jako správce zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, není pokračujte v řešení potíží.
  • Metoda 2

    Odstranit dočasné soubory Internetu. Postupujte takto:
    1. Otevřete okno Aplikace Internet Explorer klepněte na tlačítko Nástroje a klepněte na příkaz Možnosti Internetu.
    2. V okně Možnosti Internetu klepněte na kartu Obecné v části Temporary Internet soubory, klepněte na tlačítko Odstranit soubory a potom klepněte na tlačítko OK.
    Zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, není pokračujte v řešení potíží.
  • Metoda 3

    Ověřte oprávnění ke klíčům registru, které používá klient systému Windows Update a Microsoft Update klienta.
    1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.

      Poznámka: V systému Microsoft Windows 2000 nebo Microsoft Windows NT 4.0 zadejte příkaz regedt32 namísto "regedit."
    2. Vyhledejte a vyberte následující klíč registru:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
    3. V nabídce Úpravy klepněte na tlačítko oprávnění, klepněte na tlačítko Přidat a zadejte everyone v dialogovém okně, které se zobrazí.

      Poznámka: V systému Windows 2000 nebo Windows NT 4.0 v nabídce zabezpečení klepněte na tlačítko oprávnění.
    4. Klepněte na tlačítko Kontrola jmen a klepněte na tlačítko OK.
    5. Everyone vyberte v seznamu skupiny nebo jméno uživatele.
    6. V části oprávnění pro všechny klepněte ve sloupci Povolit zaškrtněte políčko Úplný.

      Nyní je také vybrána poznámka čtení zaškrtávací políčko ve sloupci Povolit.
    7. Naopak, vyberte každý uživatel v seznamu skupiny nebo jméno uživatele a potom ověřte, zda jsou zaškrtnuta žádná políčka ve sloupci Odepřít. Klepnutím zrušte zaškrtnutí políček, které jsou vybrány v sloupci Odepřít.
    8. Klepněte na tlačítko Upřesnit, klepnutím zaškrtněte políčko Nahradit položky oprávnění na všechny podřízené objekty a potom klepněte na tlačítko OK.
    9. Pokud výzvy pro potvrzení a pak klepněte na tlačítko OK zavřete dialogové okno, klepněte na tlačítko Ano.
    Zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, není pokračujte v řešení potíží.
  • Metoda 4

    Ověřte oprávnění můžete na strukturu složek používají klient systému Windows Update nebo Microsoft Update klienta.
    1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz explorer a klepněte na tlačítko OK.
    2. Rozbalte položku osobního počítače, rozbalte System Drive a rozbalte WINDOWS.
    3. Klepněte pravým tlačítkem myši SoftwareDistribution a potom klepněte na příkaz Vlastnosti.
    4. V okně Vlastnosti SoftwareDistribution okno, klepněte na kartu zabezpečení a ověřte, zda jste v seznamu skupiny nebo jméno uživatele.
    5. Vyberte v seznamu skupiny nebo jméno uživateleEveryone. V části oprávnění pro všechny klepněte ve sloupci Povolit zaškrtněte políčko Úplný.

      Všimněte si, že políčko Číst ve sloupci Povolit je nyní také vybrána.
    Zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, není pokračujte v řešení potíží.
  • Metodu 5

    Přejmenujte složku Catroot2. Příkazového řádku, stisknutím klávesy ENTER po každém řádku zadejte následující příkazy:
    net stop cryptsvc
    ren %systemroot%\system32\catroot2 oldcatroot2
    net start cryptsvc
    Potom zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, není pokračujte v řešení potíží.
  • Metoda 6

    Přejmenujte složku SoftwareDistribution. Postupujte takto.
    1. Restartujte počítač v nouzovém režimu.
    2. Vyhledejte a přejmenujte Drive: \Windows\SoftwareDistribution složku SoftwareDistribution.old.

      Poznámka:Drive je zástupný symbol pro systémové jednotky.
    3. Restartujte počítač v normálním režimu.

Další informace

Musí být místní správce Windows navštivte webu Update nebo webu Microsoft Update. Při přihlášení jako bez správce nemůže navštivte web společnosti, přestože používáte Spustit jako se spustit aplikaci Internet Explorer pod účtem správce. K tomuto problému dochází, protože jiných služeb systému přicházejí v procesu.Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
326686Pokud správce systému zakáže přístup k systému Windows Update nebo Microsoft Update, zobrazí se nejméně jedna chybová zpráva

Vlastnosti

ID článku: 316524 - Poslední aktualizace: 14. září 2010 - Revize: 12.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Update
  • Microsoft Update
Klíčová slova: 
kbmt kbwindowsupdatev6 kbenv kberrmsg kbprb ocsso KB316524 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:316524

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com