Windows Update サイトまたは Microsoft Update サイトにアクセスしたときに "管理者のみ" というエラー メッセージが表示される

文書翻訳 文書翻訳
文書番号: 316524 - 対象製品
この記事は、以前は次の ID で公開されていました: JP316524
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

現象

Windows Update サイトまたは Microsoft Update Web サイトにアクセスしたときに、以下のようなメッセージが表示されることがあります。
エラー番号: 0x8DDD0002

Windows Update から項目をインストールするには、Administrator、または Administrators グループのメンバとしてログオンされていなければなりません。コンピュータがネットワークに接続している場合は、ネットワーク ポリシー設定により、この手順を完了できない可能性もあります。
このメッセージは、ユーザーが Administrator または Administrators グループのメンバとしてログオンしている場合にも表示されることがあります。

: Windows Update サイトと Microsoft Update サイトの詳細については、「詳細」を参照してください。

原因

この現象は、以下のいずれかの条件に該当する場合に発生することがあります。
  1. ローカルの Administrators グループに所属しているユーザーとしてログオンしていません。
  2. 特定のレジストリ キーまたはフォルダに対してアクセス許可がありません。
  3. オペレーティング システムが %Systemroot%\System32\Catroot2 フォルダ内のデータを読み取れません。

解決方法

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。

この問題を解決するには、以下のいずれかの方法を使用します。方法 1 で問題を解決できない場合は、方法 2 を使用します。
  • 方法 1

    ローカルの Administrators グループに所属するユーザーとしてログオンしていることを確認します。

    Windows XP

    [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。nusrmgr.cpl と入力し、[OK] をクリックします。[ユーザー アカウント] ウィンドウが開きます。

    ネットワーク ドメインに参加している場合は、以下の手順を実行します。
    1. [ユーザー アカウント] ウィンドウで、一覧から自分のアカウントを選択し、[プロパティ] をクリックします。
    2. [グループ メンバシップ] タブで、Administrators グループに所属していることを確認します。
    ネットワーク ドメインに参加していない場合は、以下の手順を実行します。
    1. [ユーザー アカウント] ウィンドウで、自分のアカウントをクリックし、アカウント名の下に [コンピュータの管理者] と表示されることを確認します。

    Windows 2000

    1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。compmgmt.msc と入力し、[OK] をクリックします。
    2. [コンピュータの管理] ウィンドウで、[システム ツール]、[ローカル ユーザーとグループ] の順に展開し、[ユーザー] をクリックします。
    3. [コンピュータの管理] ウィンドウの右側のウィンドウで、確認するユーザー権利を持つユーザーを右クリックし、[プロパティ] をクリックします。
    4. [所属するグループ] タブで、[所属するグループ] ボックスに [Administrators] が表示されることを確認します。
    管理者としてログオンし、Windows Update Web サイトまたは Microsoft Update Web サイトに再度アクセスします。問題が解決した場合は、トラブルシューティングを終了します。
  • 方法 2

    次の手順を実行して、コンピュータからインターネット一時ファイルを削除します。
    1. Internet Explorer を開き、[ツール] メニューの [インターネット オプション] をクリックします。
    2. [インターネット オプション] ウィンドウで [全般] タブをクリックし、[インターネット一時ファイル] で [ファイルの削除] をクリックします。次に、[OK] をクリックします。
    Windows Update Web サイトまたは Microsoft Update Web サイトに再度アクセスします。問題が解決した場合は、トラブルシューティングを終了します。
  • 方法 3

    Windows Update クライアントまたは Microsoft Update クライアントによって使用されるレジストリ キーのアクセス許可を確認します。
    1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に regedit と入力し、[OK] をクリックします。

      : Microsoft Windows 2000 または Microsoft Windows NT 4.0 では、regedit ではなく regedt32 と入力します。
    2. 次のレジストリ キーを見つけてクリックします。
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
    3. [編集] メニューの [アクセス許可] をクリックし、[追加] をクリックします。次に、表示されたダイアログ ボックスで everyone と入力します。

      : Windows 2000 または Windows NT 4.0 では、[セキュリティ] メニューの [アクセス許可] をクリックします。
    4. [名前の確認] をクリックし、[OK] をクリックします。
    5. [グループ名またはユーザー名] (または [名前]) ボックスの [Everyone] をクリックします。
    6. [Everyone のアクセス許可] ボックスで、[許可] 列の [フル コントロール] チェック ボックスをオンにします。

      [許可] 列の [読み取り] のチェック ボックスもオンになります。
    7. [グループ名またはユーザー名] (または [名前]) ボックスの一覧の各ユーザーを順に選択して、[拒否] 列のチェック ボックスがオンになっていないことを確認します。[拒否] 列のチェック ボックスがオンになっている場合は、オフにします。
    8. [詳細設定] (または [詳細]) をクリックし、[子オブジェクトすべてのアクセス許可エントリを、ここに表示されているエントリで子オブジェクトに適用するもので置換する] (または [すべての子オブジェクトのアクセス許可を元に戻し、継承可能なアクセス許可を継承できるようにする]) チェック ボックスをオンにしてから、[OK] をクリックします。
    9. 確認のメッセージが表示されたら、[はい] をクリックし、[OK] をクリックしてダイアログ ボックスを閉じます。
    Windows Update Web サイトまたは Microsoft Update Web サイトに再度アクセスします。問題が解決した場合は、トラブルシューティングを終了します。
  • 方法 4

    Windows Update クライアントまたは Microsoft Update クライアントによって使用されるフォルダ構造に対する自分のアクセス許可を確認します。
    1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。explorer と入力し、[OK] をクリックします。
    2. [マイ コンピュータ]、[System Drive]、[WINDOWS] (または [WINNT]) の順に展開します。
    3. [SoftwareDistribution] を右クリックし、[プロパティ] をクリックします。
    4. [SoftwareDistribution のプロパティ] ウィンドウで [セキュリティ] タブをクリックし、[グループ名またはユーザー名] ボックスの一覧に自分が含まれているかどうかを確認します。
    5. [グループ名またはユーザー名] ボックスで、[Everyone] をクリックします。[Everyone のアクセス許可] ボックスで、[許可] 列の [フル コントロール] チェック ボックスをオンにします。

      [許可] 列の [読み取り] のチェック ボックスもオンになります。
    Windows Update Web サイトまたは Microsoft Update Web サイトに再度アクセスします。問題が解決した場合は、トラブルシューティングを終了します。
  • 方法 5

    Catroot2 フォルダの名前を変更します。この操作を行うには、コマンド プロンプトに以下のコマンドを入力します。1 行ごとに Enter キーを押します。
    net stop cryptsvc
    ren %systemroot%\system32\catroot2 oldcatroot2
    net start cryptsvc
    次に、再度、Windows Update Web サイトまたは Microsoft Update Web サイトにアクセスします。問題が解決した場合は、トラブルシューティングを終了します。
  • 方法 6

    SoftwareDistribution フォルダの名前を変更します。これを行うには、次の手順を実行します。
    1. セーフ モードでコンピュータを再起動します。
    2. Drive:\Windows\SoftwareDistribution フォルダを見つけ、名前を SoftwareDistribution.old に変更します。

      : Drive は、システム ドライブです。
    3. 通常モードでコンピュータを再起動します。

詳細

Windows Update Web サイトまたは Microsoft Update Web サイトにアクセスするには、ローカル管理者である必要があります。管理者以外のユーザーとしてログオンした場合、[別のユーザーとして実行] を使用して管理者アカウントで Internet Explorer を起動しても、これらの Web サイトにはアクセスできません。この問題は、他のシステム サービスがこのプロセスに関与しているため発生します。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
326686 システム管理者が Windows Update または Microsoft Update を無効にするとエラー メッセージが表示される

プロパティ

文書番号: 316524 - 最終更新日: 2010年9月14日 - リビジョン: 12.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows Update
  • Microsoft Update
キーワード:?
kbwindowsupdatev6 kbenv kberrmsg kbprb ocsso KB316524
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com