Zobrazí chybové hlásenie „len správca", keď navštívite webovú lokalitu Windows Update alebo Microsoft Update

Preklady článku Preklady článku
ID článku: 316524 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Pri pokuse na lokalite www Windows Update alebo Webovú lokalitu Microsoft Update, môže sa zobraziť chybové hlásenie podobné takto:
Číslo chyby: 0x8DDD0002

Na inštalovať položky z lokality Windows Update, musíte byť prihlásení ako správca alebo člen skupiny Administrators. Ak váš počítač je pripojený k sieť, nastavenie sieťovej politiky môže tiež zabráni v dokončení tohto postup.
Zobrazí toto hlásenie, aj keď ste už prihlásení ako správca alebo ako člen správcov skupina.

Poznámka Ďalšie informácie o lokalite Windows Update a Microsoft Update lokality, nájdete v časti "Ďalšie informácie".

PRICINA

Toto správanie sa môže vyskytnúť na jeden z nasledujúcich dôvody:
  1. Nie ste prihlásení ako používateľ, ktorý patrí do miestnej Skupiny Administrators.
  2. Nemáte povolenie na kľúče databázy registry špecifické alebo priečinky.
  3. Operačný systém nemôže čítať údaje v %Systemroot%\System32\Catroot2 priečinok.

RIESENIE

Dôležité Tento oddiel, metóda alebo úloha obsahuje kroky, ktoré vám povedať, ako upraviť databázu registry. Avšak, môžu nastať vážne problémy Ak databázu registry upravíte nesprávne. Preto dbajte, aby ste postupujte opatrne. Pridané ochrany, zálohovať register pred úpravou je. Potom môžete obnoviť databázu registry, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy registry nájdete po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
322756 Zálohovanie a obnovovanie databázy registry v systéme Windows


Ak chcete vyriešiť tento problém, použite jeden z nasledujúcich metódy. Ak metóda 1 nevyrieši problém, použite metódu 2.
  • Metóda 1

    Overte, či ste prihlásení ako používateľ, ktorý patrí do miestnej Skupiny Administrators.

    Systém Windows XP

    Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typunusrmgr.cpl, a potom kliknite na tlačidlo ok Ak chcete otvoriť The Používateľské kontá okno.

    Ak ste súčasťou sieť domény, postupujte nasledovne:
    1. V Používateľské kontá okno, kliknite na v zozname vyberte konto a potom kliknite na Vlastnosti.
    2. Na Členstvo v skupine kartu, skontrolujte že ste v skupine Administrators.
    Ak nie ste súčasťou sieťovej domény, postupujte podľa týchto kroky:
    1. V Používateľské kontá okno, kliknite na tlačidlo vášho účtu a potom overiť, že Správca počítačapod názov konta sa zobrazí.

    Windows 2000

    1. Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typu compmgmt.exe, a potom kliknite na tlačidlo ok.
    2. V Správa počítača okno, Rozbaľte Systémové nástroje, rozbaľte Používatelia a skupiny, a potom kliknite na tlačidlo Užívatelia priečinok.
    3. V pravej table Počítač riadenie okno, kliknite pravým tlačidlom myši, používateľ ktorých užívateľské práva budete chcieť overiť, a potom kliknite na tlačidlo Vlastnosti.
    4. Na Člen kartu, skontrolujte Správcovia je uvedené v Členrámček.
    Po prihlásení ako správca, skúste navštíviť Webovú lokalitu Windows Update alebo Microsoft Update Web site znova. Ak problém je vyriešený, nepokračujte, riešenie problémov.
  • Metóda 2

    Odstránenie dočasných internetových súborov. Chcete urobiť, postupujte nasledovne:
    1. Otvorené Program Internet Explorer okno, kliknite na tlačidlo Nástroje, a potom kliknite na tlačidlo Možnosti siete Internet.
    2. V Možnosti siete Internet okno, kliknite na tlačidlo The Všeobecné kartu pod Dočasné internetové súbory, kliknite na tlačidlo Odstrániť súbory, a potom kliknite na tlačidlo ok.
    Pokúsite sa navštíviť webovú lokalitu Windows Update alebo Microsoft Aktualizácia webovej lokalite znova. Ak problém vyriešený, nepokračujte riešenie problémov.
  • Metóda 3

    Skontrolujte povolenia pre kľúče databázy registry, ktoré používa Klient služby Windows Update a Microsoft Update klienta.
    1. Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typu regedit, a potom kliknite na tlačidlo ok.

      Poznámka V systéme Microsoft Windows 2000 alebo Microsoft Windows NT 4.0, zadajte Regedt32 namiesto z "regedit."
    2. Vyhľadajte a vyberte nasledovný kľúč databázy registry:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
    3. Na Upraviť ponuky, kliknite na tlačidlo Povolenia, kliknite na tlačidlo Pridať, a potom zadajte všetci v dialógovom okne, ktoré sa zobrazí.

      Poznámka V systéme Windows 2000 alebo v systéme Windows NT 4.0 kliknite Povolenia na Zabezpečenia ponuka.
    4. Kliknite na tlačidlo Kontrolu mien, a potom kliknite na tlačidlo ok.
    5. Vyberte Všetci v Skupina alebo mená používateľov zoznam.
    6. Podľa Povolenia pre každého, kliknite na tlačidlo Vyberte Úplné ovládanie políčko Povoliť stĺpec.

      Všimnite si, že Čítaniepolíčko Povoliť stĺpec je teraz tiež vybratá.
    7. Vyberte každého používateľa v poradí, v Skupinu alebo používateľa názvy zoznam a potom overiť, že sú začiarknuté žiadne políčka v Poprieť stĺpec. Zrušte začiarknutie políčok, ktoré sú vybraté v Poprieť stĺpec.
    8. Kliknite na tlačidlo Rozšírené, kliknutím vyberte možnosť Pre všetky podradené objekty nahradiť zobrazenými položkami políčko a kliknite na tlačidlo ok.
    9. Kliknite na tlačidlo áno Ak sa zobrazí výzva na potvrdenie a potom kliknite na tlačidlo ok zavrite dialógové okno rámček.
    Pokúsite sa navštíviť webovú lokalitu Windows Update alebo Microsoft Aktualizácia webovej lokalite znova. Ak problém vyriešený, nepokračujte riešenie problémov.
  • Metóda 4

    Skontrolujte povolenia pre vás v štruktúre priečinkov používa Klient služby Windows Update alebo Microsoft Update klienta.
    1. Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typu Program Explorer, a potom kliknite na tlačidlo ok.
    2. Rozbaľte Môj počítač, rozbaľte Systémová jednotka, a potom rozbaľte položku WINDOWS.
    3. Kliknite pravým tlačidlom myši SoftwareDistribution, a kliknite na tlačidlo Vlastnosti.
    4. V SoftwareDistribution vlastnostiokno, kliknite na tlačidlo Zabezpečenia karte a potom overte či ste v Skupinu alebo používateľa mená zoznam.
    5. V Skupinu alebo používateľa mená zoznam, Vyberte Všetci. Podľa Povolenia pre Všetci, kliknutím vyberte možnosť Úplné ovládanie políčko v Povoliť stĺpec.

      Všimnite si, že Čítanie políčko Povoliť Teraz je stĺpec tiež vybratá.
    Pokúsite sa navštíviť webovú lokalitu Windows Update alebo Microsoft Aktualizácia webovej lokalite znova. Ak problém vyriešený, nepokračujte riešenie problémov.
  • Metóda 5

    Premenovanie priečinka Catroot2. Chcete urobiť, zadajte nasledujúce príkazy v príkazovom riadku, stlačením klávesu ENTER po každom riadku:
    net stop cryptsvc
    ren %systemroot%\system32\catroot2 oldcatroot2
    net start cryptsvc
    Potom skúste navštíviť webovú lokalitu Windows Update alebo Microsoft Aktualizácia webovej lokalite znova. Ak problém vyriešený, nepokračujte riešenie problémov.
  • Metóda 6

    Premenovanie priečinka SoftwareDistribution. Chcete urobiť, postupujte podľa týchto krokov.
    1. Reštartujte počítač v núdzovom režime.
    2. Vyhľadajte a premenujte Jednotka: \Windows\SoftwareDistribution priečinok SoftwareDistribution.old.

      Poznámka Jednotka je zástupný symbol pre systémovej jednotky.
    3. Reštartujte počítač v normálnom režime.

DALSIE INFORMACIE

Musíte byť lokálny správca na návštevu okná Aktualizujte webovú lokalitu alebo webovú lokalitu Microsoft Update. Keď prihlásite ako non-správca, vám nemôžu nájdete na webovej lokalite dokonca aj vtedy, ak používate Spustiť ako Ak chcete spustiť program Internet Explorer pod konto správcu. Toto problém sa vyskytuje, pretože sa zúčastňujú iné systémové služby proces. Ďalšie informácie nájdete po kliknutí na nasledovné číslo článku zobrazíte článok v databáze Microsoft Knowledge Base:
326686Dostanete jeden alebo viac chybové hlásenia, keď správca systému vypne systém Windows Update alebo Microsoft Update

Vlastnosti

ID článku: 316524 - Posledná kontrola: 8. novembra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows Update
  • Microsoft Update
Kľúčové slová: 
kbwindowsupdatev6 kbenv kberrmsg kbprb ocsso kbmt KB316524 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:316524

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com