Код статьи: 318030 - Последнее изменение :: 13 апреля 2010 г. - Редакция: 5.0

Не удается получить доступ к общим файлам и папкам, а также просмотреть данные на других компьютерах рабочей группы с помощью Windows XP

Совет по использованию системыЭта статья относится к операционной системе, отличной от установленной на вашем компьютере. Содержимое, не относящееся к используемой системе, отключено.

Чтобы продолжить получать обновления для системы безопасности Windows XP, установите пакет обновления 3 (SP3) для этой системы. Дополнительные сведения см. на указанном ниже веб-сайте корпорации Майкрософт. Заканчивается поддержка некоторых версий Windows (http://windows.microsoft.com/ru-ru/windows/help/end-support-windows-xp-sp2-windows-vista-without-service-packs?os=xp)

На этой странице

Развернуть все | Свернуть все

Проблема

На компьютерах с системой Windows XP в составе рабочей группы в одноранговой сети возможно появление указанных ниже симптомов.
  • Не удается получить доступ к общим файлам и папкам.
  • Не удается найти другие компьютеры рабочей группы.
  • Если два раза щелкнуть значок рабочей группы в окне «Сетевое окружение», появляется следующее сообщение об ошибке:
    "Нет доступа к имя_рабочей_группы. Возможно, у вас нет прав на использование этого сетевого ресурса."
Примечание. В одноранговой сети все компьютеры имеют равные права и могут являться инициаторами сеансов связи. В этом состоит их отличие от сетей клиент-сервер.

Причина

Подобное поведение наблюдается при выполнении всех указанных ниже условий.
  • На некоторых компьютерах рабочей группы не включен протокол NetBIOS через TCP/IP.
  • На некоторых компьютерах рабочей группы служба браузера компьютеров не запущена или отключена.
Кроме того, оно может возникать, если совместный доступ к файлам и принтерам для сетей Майкрософт не установлен или заблокирован брандмауэром Windows.

Решение

Чтобы включить NetBIOS через TCP/IP и запустить службу браузера компьютеров, перейдите к разделу Помощь в решении проблемы. Если вы предпочитаете решить проблему самостоятельно, перейдите к разделу Самостоятельное решение проблемы.

Помощь в решении проблемы



Чтобы устранить проблему автоматически, щелкните ссылку или кнопку Устранить проблему. В диалоговом окне Загрузка файла нажмите кнопку Выполнить и следуйте инструкциям мастера устранения проблем.


Устранить проблему
Исправление Майкрософт 50393


Примечания.
  • Этот вариант решения предназначен для системы Windows XP с пакетом обновления 3 (SP3).
  • Кроме того, для его использования требуется активное подключение к сети.
  • Мастер может быть доступен только на английском языке. Однако автоматическое исправление можно применять в версиях Windows на любых языках.
  • Решение по устранению проблем можно загрузить на любой компьютер, а затем сохранить его на устройство флэш-памяти или компакт-диск и запустить на нужном компьютере.

Теперь перейдите к разделу Проблема устранена?



Решить проблему самостоятельно

Способ 1. Включение NetBIOS через TCP/IP и запуск службы браузера компьютеров

Чтобы решить эту проблему, необходимо включить протокол NetBIOS через TCP/IP и запустить службу браузера компьютеров на каждом компьютере в составе рабочей группы. Для этого выполните указанные ниже действия.

Действие 1. Включите NetBIOS через TCP/IP

.
  1. Нажмите кнопку Пуск, выберите пункт Панель управления, а затем — Сеть и подключения к Интернету.
  2. Щелкните ссылку Сетевые подключения.
  3. Щелкните правой кнопкой мыши значок Подключение по локальной сети и выберите команду Свойства.
  4. Выделите пункт Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  5. Откройте вкладку Общие и нажмите кнопку Другие.
  6. Откройте вкладку WINS.
  7. В разделе Параметры NetBIOS выберите вариант Включить NetBIOS через TCP/IP, а затем два раза нажмите кнопку ОК.
  8. Нажмите кнопку Закрыть, чтобы закрыть диалоговое окно Свойства подключения по локальной сети.
  9. Закройте окно «Сетевые подключения».

Действие 2. Запустите службу браузера компьютеров

.
  1. Нажмите кнопку Пуск, щелкните Мой компьютер правой кнопкой мыши и выберите Управление.
  2. Дважды щелкните значок Службы и приложения.
  3. Дважды щелкните значок Службы.
  4. На правой панели щелкните правой кнопкой мыши службу Браузер компьютеров и выберите команду Пуск.
  5. Закройте окно управления компьютером.

Способ 2. Установка совместного доступа к файлам и принтерам, а также отключение его блокировки брандмауэром Windows

Действие 1. Установите совместный доступ к файлам и принтерам для сетей Майкрософт

.
  1. Выберите в меню Пуск пункт Выполнить, введите команду ncpa.cpl и нажмите кнопку .
  2. Щелкните правой кнопкой мыши значок Подключение по локальной сети и выберите команду Свойства.
  3. Откройте вкладку Общие и нажмите кнопку Установить.
  4. Выберите пункт Служба и нажмите кнопку Добавить.
  5. В поле Сетевая служба выберите Совместный доступ к файлам и принтерам для сетей Майкрософт и нажмите кнопку OK.
  6. Нажмите кнопку Закрыть.

Действие 2. Проверьте, не блокирует ли совместный доступ к файлам и принтерам брандмауэр Windows

.
  1. Выберите в меню Пуск пункт Выполнить, введите команду firewall.cpl и нажмите кнопку ОК.
  2. На вкладке Общие проверьте, не установлен ли флажок Не разрешать исключения.
  3. Откройте вкладку Исключения.
  4. Убедитесь, что на вкладке Исключения установлен флажок Совместный доступ к файлам и принтерам, и нажмите кнопку .

Проблема устранена?

  • Проверьте, устранена ли проблема. Если да, пропустите дальнейшие инструкции, приведенные в этом разделе. Если проблему устранить не удалось, обратитесь в службу поддержки (http://support.microsoft.com/contactus) .
  • Мы ценим ваши замечания. Чтобы отправить отзыв или сообщить о проблемах, связанных с этим решением, добавьте комментарий в блог Помощь в решении проблемы (http://blogs.technet.com/fixit4me/) или отправьте сообщение по электронной почте (mailto:fixit4me@microsoft.com?Subject=KB) .

Дополнительная информация

Служба браузера компьютеров ведет список компьютеров в сети, а также передает его компьютерам, определенным в качестве браузеров. Если служба остановлена, то список не поддерживается и не обновляется. Если она выключена, то не запускаются другие, явно зависящие от нее службы.

Дополнительные сведения о мастере настройки сети в Windows XP см. в указанной ниже статье базы знаний Майкрософт.
308522  (http://support.microsoft.com/kb/308522/ ) Описание мастера настройки сети в составе ОС Windows
Дополнительные сведения о подключении к сетевым ресурсам в Windows XP см. в указанной ниже статье базы знаний Майкрософт.
311079  (http://support.microsoft.com/kb/311079/ ) Как на компьютере под управлением Windows XP подключиться к сетевому ресурсу без сопоставления диска или порта
Дополнительные сведения о совместном использовании файлов в Windows XP см. в указанной ниже статье базы знаний Майкрософт.
304040  (http://support.microsoft.com/kb/304040/ ) Описание разрешений и совместного доступа к файлам в Microsoft Windows XP
Дополнительные сведения о настройке рабочих групп в Windows XP Home Edition см. в указанной ниже статье базы знаний Майкрософт.
813936  (http://support.microsoft.com/kb/813936/ ) Настройка малой сети в системе Windows XP Home Edition (ЧАСТЬ 1) (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Ключевые слова: 
kbfixme kbmsifixme kbresolve kbacwsurvey kberrmsg kbnetwork kbprb KB318030