Excel ワークシートに記載された住所を使用して Word でラベルを作成する方法

文書翻訳 文書翻訳
文書番号: 318117 - 対象製品
すべて展開する | すべて折りたたむ

目次

概要

Microsoft Excel ワークシートのデータを使用することにより、Microsoft Word の差し込み印刷機能を使用して、大量の郵便物に使用するラベルを作成および印刷できます。この資料には、このようなリストを作成するための手順が記載されています。

Word の差し込み印刷機能を使用すると、"メイン文書" に "アドレス帳" が差し込まれて、一連の "出力文書" が生成されます。
  • メイン文書には、すべての出力文書に共通する基礎となるテキストが含まれています。レターヘッド、テキスト、および個々の出力文書によって異なる挿入テキスト (宛先の名前や住所) に対応する "差し込みフィールド" 内の命令が含まれる場合があります。
  • アドレス帳は、出力文書に差し込み印刷するデータを含んだ Microsoft Access 2002 データベース ファイルや Excel ブックなどのデータベースです。通常、このデータベースは名前、住所、および電話番号のリストです。
  • 出力文書は、差し込み印刷の結果です。出力文書に含まれるテキストには、すべての出力文書で同一の書式を使用することもできますが、特定の文書に書式を設定することもできます。

手順 1 : Excel データ ファイルのセットアップ

差し込み印刷ウィザードを開始する前に、使用する Excel ワークシートが、差し込み印刷に適した構造であるかどうかを確認します。次に示すデータ テーブルの要件に注意してください。
  • 最初の行には、"頭語"、"役職"、"名前"、"ミドル ネーム"、"姓"、"住所 1"、および "住所 2" など、各列のフィールド名が含まれている必要があります。
  • 各フィールド名は、一意である必要があります。
  • 各行には、特定のアイテムに関する情報が含まれている必要があります。たとえば、アドレス帳の場合は、各行に特定の宛先に関する情報が含まれている場合があります。
  • テーブルに空の行が含まれないようにする必要があります。
Excel データ ファイルを配置するには、次の手順を実行します。
  1. Excel データファイルを作成し、次のサンプル データ ファイルに示すように、ラベルに使用するフィールドを使用して配置します。

    名前 役職 住所 市区町村 郵便番号
    Davolio Nancy Sales Representative 1234 Main St. Apt. 2A Seattle 14222 USA
    Fuller Andrew Vice President, Sales 1235 Main St. Tacoma 14222 USA
    Leverling Janet Sales Representative 1235 Elm St. Kirkland 14222 USA
    Peacock Margaret Sales Representative 1236 Main St. Redmond 14222 USA
    Buchanan Steven Sales Manager 1237 Main St London SW2 8MR UK
    Suyama Michael Sales Representative 1238 Elm St. London EC3 7HR UK
    King Robert Sales Representative 1239 Main St. London RK2 9NP UK
    Callahan Laura Inside Sales Coordinator 1230 Elm St. Seattle 14222 USA
    Dodsworth Anne Sales Representative 1231 Elm St. London WG2 7LT UK


  2. Excel データ ファイルを作成した後、データ ファイルを保存し、閉じます。
差し込み印刷のアドレス帳を作成する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
294688 Word で差し込み印刷のアドレス帳を設計および設定する方法

手順 2 : メイン文書のセットアップ

  1. Microsoft Office Word 2003 またはそれ以前のバージョンの Word を起動し、[ツール] メニューの [はがきと差し込み印刷] をポイントし、[差し込み印刷] をクリックします。

    Microsoft Office Word 2007 を起動し、[差し込み文書] タブをクリックし、[差し込み印刷の開始] の [差し込み印刷の開始] をクリックします。次に、[差し込み印刷ウィザード] をクリックします。
  2. [文書の種類を選択] で [ラベル] をクリックします。

    作業中の文書がメイン文書になります。メイン文書は、差出人住所や定型書簡のあいさつ文など、差し込み印刷される各文書に共通するテキストおよびグラフィックスを含む文書です。
  3. [次へ : ひな形の選択] をクリックします。

    : 差し込み印刷機能を十分に理解している場合や、ウィザードを使用せずに作業する場合は、[差し込み印刷] ツール バーを使用できます。
  4. 以下のいずれかの手順を実行します。
    • 新しいラベル シートを作成するには、次の手順を実行します。
      1. [文書レイアウトの変更] をクリックします。
      2. [ラベル オプション] をクリックします。
      3. [ラベル オプション] ダイアログ ボックスで、ラベルの種類やサイズなど、適切なオプションを選択し、[OK] をクリックします。

        オプションに関するヘルプを表示するには、疑問符をクリックしてから、目的のオプションをクリックします。
    • 既存のラベル シートから開始するには、次の手順を実行します。
      1. [既存の文書から開始] をクリックします。
      2. [既存のファイルから] ボックスで適切な文書を選択し、[開く] をクリックします。
      3. 目的の文書が表示されない場合は、[その他のファイル] をクリックし、[開く] をクリックします。[ファイルを開く] ダイアログ ボックスで目的の文書を見つけてクリックし、[開く] をクリックします。

        文書が文書ウィンドウに表示されます。別のラベル文書を使用する場合は、[既存の文書から開始] をクリックし、別の文書を選択します。レイアウトを変更する場合は、[文書レイアウトの変更] をクリックし、[ラベル オプション] をクリックします。
  5. [次へ : 宛先の選択] をクリックします。

手順 3 : Excel データ ソースの指定

  1. [宛先の選択] で、[既存のリストを使用] をクリックします。
  2. [参照] をクリックします。
  3. [データ ファイルの選択] ダイアログ ボックスで、使用する Excel ワークシートを見つけてクリックします。

    デフォルトでは、[My Data Sources] フォルダが開きます。
  4. [開く] をクリックします。
  5. 複数のシートに情報が含まれている場合は、目的の情報を含むシートをクリックしてから [OK] をクリックする必要があります。データ ソース内のすべてのエントリが [差し込み印刷の宛先] ダイアログ ボックスに表示され、差し込み印刷に含める宛先のリストを選択できます。

手順 4 : 宛先の選択

  1. [差し込み印刷の宛先] ダイアログ ボックスで、リストに含める宛先を選択します。これを行うには、次のいずれかの手順を実行します。
    • チェック ボックスを使用して宛先を指定します。

      この方法は、リストが短い場合に最も便利な方法です。リストに含める宛先の横にあるチェック ボックスをオンにし、除外する宛先の横にあるチェック ボックスをオフにします。

      : リストの大部分のレコードを含めることがわかっている場合は、[すべて選択] をクリックしてから、特定のレコードのチェック ボックスをオフにします。同様に、リスト内の数個のレコードのみを含める場合は、[すべてクリア] をクリックしてから、必要なレコードを選択します。
    • リスト内のアイテムを並べ替えます。

      この方法は、アイテムを五十音順または番号順に表示する場合に便利な方法です。並べ替えを行う場合は、並べ替えるアイテムの列見出しをクリックします。たとえば、姓の五十音順でリストを表示する場合は、列見出し [姓] をクリックします。
    • リスト内のアイテムをフィルタします。

      この方法は、表示する必要がない、または差し込み印刷に含める必要がないことがわかっているレコードがリストに含まれている場合に便利です。リストをフィルタした後、上記の方法で、チェック ボックスを使用してレコードを含めたり除外したりすることができます。リストをフィルタするには、次の手順を実行します。
      1. フィルタするアイテムの列見出しの横にある矢印をクリックします。
      2. 次のいずれかをクリックします。
        • [(データ無し)] をクリックすると、該当するフィールドが空白になっているすべてのレコードが表示されます。
        • [(データ有り)] をクリックすると、該当するフィールドに情報が含まれているすべてのレコードが表示されます。
        • データ ソースに、同一の情報を共有するレコードが含まれており、列に 10 個以下の一意な値が含まれている場合は、特定の情報を使用してフィルタできます。たとえば、国/地域がオーストラリアである住所が複数含まれている場合は、オーストラリアでフィルタできます。
    • [差し込み印刷の宛先] ダイアログ ボックスに、指定したレコードのみが表示されます。すべてのレコードを再表示するには、[(すべて)] をクリックします。
    :
    • 高度な並べ替えやフィルタリングについては、列名の横の矢印をクリックし、[(詳細)] をクリックします。[レコードのフィルタ] タブと [レコードの並べ替え] タブを使用して、必要な並べ替えクエリやフィルタ クエリをセットアップします。
    • アドレス確認用のソフトウェアをインストールしている場合は、[差し込み印刷の宛先] ダイアログ ボックスの [確認] をクリックして、宛先の住所を確認できます。
  2. [OK] をクリックして差し込み印刷ウィザードに戻ります。

    差し込み印刷用に指定した宛先が使用されます。
  3. [次へ : ラベルの配置] をクリックします。

手順 5 : ラベルの内容の配置

ラベルの内容を配置するには、次の手順を実行します。

差し込みフィールドを挿入する

名前、住所、および郵便番号バーコードなどのその他の情報を差し込む差し込みフィールドを挿入します。たとえば、差し込みフィールド "市区町村" を挿入して、"市区町村" データ フィールドに保存されている "アトランタ" などの市区町村の名前が挿入されるようにします。差し込みフィールドを挿入するには、次の手順を実行します。
  1. メイン文書で、フィールドを挿入する場所をクリックします。
  2. 次のいずれかを挿入します。
    • 名前、住所、およびその他の情報が含まれている住所ブロック
      1. [住所ブロック] をクリックします。
      2. [住所ブロックの挿入] ダイアログ ボックスで、挿入する住所要素と書式を選択し、[OK] をクリックします。Word 2007 でヘルプを表示するには、疑問符をクリックします。

      3. [フィールドの対応] ダイアログ ボックスが表示される場合は、住所ブロックに必要な情報の一部を検出できなかった可能性があります。[(対応なし)] の横の矢印をクリックし、差し込み印刷に必要なフィールドに対応するフィールドを、データ ソースから選択します。
    • あいさつ文
      1. [あいさつ文 (英文)] または [あいさつ文 (日本語)] をクリックします。
      2. [あいさつ文 (英文)] の場合は、頭語、名前の形式、および句読点を含む、あいさつ文の形式を選択します。
      3. [あいさつ文 (英文)] の場合は、データ ソースに宛先の姓または名前が含まれておらず、会社名のみが含まれている場合など、宛先名がわからない場合に表示するテキストを選択します。
      4. [OK] をクリックします。
      5. [フィールドの対応] ダイアログ ボックスが表示される場合は、あいさつ文に必要な情報の一部を検出できなかった可能性があります。[(対応なし)] の横の矢印をクリックし、差し込み印刷に必要なフィールドに対応するフィールドを、データ ソースから選択します。
    • その他の情報フィールド
      1. [差し込みフィールドの挿入] をクリックします。
      2. 以下のいずれかの手順を実行します。
        • データ ソースに差し込み先と同じ名前のフィールドがない場合でも、差し込み先のフィールドとデータ ソース内のフィールドを自動的に対応させるには、[標準フィールド] をクリックします。
        • 常にデータベースの列から直接データを取得するには、[データベース フィールド] をクリックします。
      3. [フィールド] ボックスで、必要なフィールドをクリックします。
      4. [挿入] をクリックし、[閉じる] をクリックします。
      5. [フィールドの対応] ダイアログ ボックスが表示される場合は、フィールドの挿入に必要な情報の一部を検出できなかった可能性があります。[(対応なし)] の横の矢印をクリックし、差し込み印刷に必要なフィールドに対応するフィールドを、データ ソースから選択します。

        : データベース フィールドの一覧からフィールドを挿入した後、同じ名前の列が含まれていないデータ ソースに切り替えると、そのフィールド情報を差し込み印刷の文書に挿入できなくなります。
    • 電子切手

      電子切手を追加するには、先に電子切手用のソフトウェアをインストールしておく必要があります。電子切手用のソフトウェアは、Web 上のサービスなどから購入します。電子切手を使用するには、次の手順を実行します。
      1. [電子切手] をクリックします。

        電子切手用のソフトウェアをインストールしていない場合は、電子切手用のソフトウェアをインストールする必要があること、および次のマイクロソフト Web サイトを参照するかどうかをたずねるメッセージが表示されます。
        Microsoft Office Web サイト
      2. プログラムの指示に従って電子切手を挿入します。
    • 郵便番号バーコード

      POSTNET バーコードをサポートするラベルまたは封筒の種類を選択する必要があります。郵便番号バーコードを使用するには、次の手順を実行します。
      1. [郵便番号バーコード] をクリックします。
      2. [バーコードの挿入] ダイアログ ボックスで、適切な住所フィールドを選択します。

        : [郵便番号バーコード] オプションは、地域の言語に米国を使用している場合にのみ表示されます。
      3. 挿入するすべてのフィールドに対して、手順 a. および手順 b. を繰り返します。

        :
        • Word 2003 およびそれ以前のバージョンの Word の場合は、差し込みフィールド文字 (<< >>) を入力したり、[挿入] メニューの [記号と特殊文字] を使用して挿入することはできません。

          Word 2007 の場合は、差し込みフィールド文字 (<< >>) を入力したり、[挿入] タブの [記号と特殊文字] にある [記号と特殊文字] を使用して挿入することはできません。
        • 差し込みフィールドが { MERGEFIELD City } のように中かっこ内に表示される場合は、フィールドの結果ではなくフィールド コードが表示されています。フィールド コードが表示されることは差し込み印刷には影響しませんが、フィールドの結果を表示する場合は、フィールド コードを右クリックし、[フィールド コードの表示/非表示] をクリックします。
    : Word 2003 およびそれ以前のバージョンの Word では、差し込みフィールドの挿入、差し込み印刷のメイン文書の処理、または差し込み印刷の実行を、[差し込み印刷] ツール バーを使用して行うこともできます。[差し込み印刷] ツール バーを表示するには、[ツール] メニューの [はがきと差し込み印刷] をポイントし、[[差し込み印刷] ツールバーの表示] をクリックします。[差し込み印刷] ツール バーには、差し込み印刷ウィザードの作業ウィンドウには表示されないコマンドも表示されます。たとえば、[差し込み印刷] ツール バーの [Word フィールドの挿入] ボックスを使用して Word フィールドを挿入し、差し込み印刷処理を制御できます。たとえば、特定の差し込みフィールドに特定の値が含まれる場合にのみテキストを挿入する IF フィールドなどがこれに該当します。または、[エラーの確認] をクリックして差し込み印刷を実行し、メイン文書に含まれるすべてのエラーを記録することができます。

差し込みデータの書式を変更する

差し込みデータの書式を設定するには、メイン文書で差し込みフィールドの書式を設定する必要があります。データ ソースのデータに書式を設定しないでください。データ ソースで設定された書式は、データを文書に差し込んだときに失われます。差し込みデータの書式を変更するには、以下の手順を実行します。
  1. メイン文書で、書式を設定する情報が含まれているフィールドを、両端の差し込みフィールド文字 (<< >>) を含めて選択します。
  2. Word 2003 およびそれ以前のバージョンの Word の場合は、[書式] メニューの [フォント] をクリックし、必要なオプションを選択します。

    Word 2007 の場合は、[ホーム] タブをクリックし、[フォント] の [フォント] をクリックして [フォント] ダイアログ ボックスを開き、必要なオプションを選択します。

フィールド コードを使用して書式を設定する

書式の他の項目を制御するには、Alt + F9 キーを押してフィールド コードを表示し、差し込みフィールドにスイッチを追加します。フィールドを処理する場合、スイッチは特定のアクションを発生させる特殊な命令です。一般に、結果を変更するために、スイッチをフィールドに追加します。

以下に例を示します。
  1. 数値 "34987.89" を "$34,987.89" と表示するには、数値書式スイッチ (\#) を追加します。
  2. 顧客の名前を大文字で印刷するには、一般書式スイッチ (\*) を追加します。
  3. 差し込んだ情報に、差し込みフィールドに適用するのと同じフォントやポイント サイズを設定するには、\* Charformat スイッチを追加します。
最初のラベルの書式とレイアウトを、同じページ上のその他すべてのラベルに適用するには、[すべてのラベルの更新] をクリックします。

たとえば、この資料に示したサンプル データベースでは、"住所ブロック" フィールドのみを挿入し、[すべてのラベルの更新] をクリックした場合、次のようなページが表示されます。

<<住所ブロック>><<Next Record>><<住所ブロック>>

<<Next Record>><<住所ブロック>><<Next Record>><<住所ブロック>>

手順 6 : 文書の保存

メイン文書での作業が完了し、すべての差し込みフィールドを挿入したら、次の手順に進む前に文書を保存します。
  1. Word 2003 および以前のバージョンの Word の場合は、[ファイル] メニューの [名前を付けて保存] をクリックします。

    Word 2007 の場合は、Microsoft Office ボタンをクリックし、[名前を付けて保存] をクリックします。
  2. 文書に名前を付け、[保存] をクリックします。
  3. [次へ : ラベルのプレビュー表示] をクリックします。

手順 7 : ラベルのプレビュー表示とアドレス帳の調整

ウィザードの手順 5 の差し込み印刷作業ウィンドウが表示される段階で、メイン文書内の各差し込みフィールドがアドレス帳の最初のエントリの実際のテキストで置き換えられ、最初の出力文書がどのように表示されるのかを確認できます。

たとえば、上記のサンプル データベースを引き続き使用した場合、[次へ : ラベルのプレビュー表示] をクリックすると、最初のページは次のように表示されます。
Vice President, Sales Andrew Fuller     Sales Representative Anne Dodsworth
1235 Main St                            1231 Elm St.
Tacoma                                  London
	
	
Sales Representative Janet Leverling     Inside Sales Coordinator Laura Callahan
1235 Elm St.                             1230 Elm St.
Kirkland                                 Seattle
				
他のエントリもプレビュー表示するには、以下のいずれかを実行します。
  • アイテムを順番にプレビュー表示するには、左矢印または右矢印をクリックします。

    シート上の最初のラベルに各レコードがプレビュー表示されます。
  • 特定のアイテムを見つけてプレビュー表示するには、[宛先の検索] をクリックし、[エントリの検索] ダイアログ ボックスで検索条件を入力します。
特定の宛先を除外するなど、アドレス帳を調整するには、以下の手順を実行します。
  1. [アドレス帳の変更] をクリックし、[差し込み印刷の宛先] ダイアログ ボックスで必要な変更を行い、[OK] をクリックします。
  2. [次へ : 差し込み印刷の完了] をクリックします。

手順 8 : 差し込み印刷の完了

差し込み印刷を完了するには、以下のいずれかを実行します。

個々のラベルをカスタマイズする

個々のラベルをカスタマイズするには、差し込み印刷を完了し、生成された差し込み印刷した文書で必要となる情報を編集します。
  1. [各ラベルの編集] をクリックします。
  2. [新規文書へ差し込み] ダイアログ ボックスで、差し込み印刷に必要なレコードを選択します。
  3. [OK] をクリックします。

    差し込み印刷された新しい文書が作成され、開かれます。メイン文書も開いたままなので、すべてのアイテムを変更する必要がある場合には、メイン文書に切り替えることができます。
  4. 編集する情報までスクロールし、変更します。
  5. 通常の文書と同様に印刷または保存します。

ラベル シートを印刷する

ラベル シートを印刷するには、以下のいずれかの手順を実行します。
  • アイテムをカスタマイズし、差し込み印刷された文書がアクティブになっている場合は、以下の手順を実行します。
    1. Word 2003 およびそれ以前のバージョンの Word の場合は、[ファイル] メニューの [印刷] をクリックします。

      Word 2007 の場合は、Microsoft Office ボタンをクリックし、[印刷] をポイントし、[印刷] をクリックします。
    2. 必要なオプションを選択します。
  • 差し込み印刷ウィザードから直接印刷する場合は、次の手順を実行します。
    1. 差し込み印刷ウィザードの手順 6 ([差し込み印刷の完了]) で、[印刷] をクリックします。
    2. [プリンタに差し込み] ダイアログ ボックスで以下のいずれかの手順を実行し、[OK] をクリックします。
      • すべての文書を印刷するには、[すべて] をクリックします。
      • 文書ウィンドウに表示されている文書を印刷するには、[現在のレコード] をクリックします。
      • 特定の範囲の文書を印刷するには、[最初のレコード] をクリックし、[最初のレコード] ボックスと [最後のレコード] ボックスにレコード番号を入力し、[OK] をクリックします。
    3. [印刷] ダイアログ ボックスで、必要なオプションを選択します。

後で使用するためにラベル シートを保存する

差し込み印刷したラベルを編集するか、後で使用するために保存する場合、差し込み印刷したラベルを 1 つの文書にまとめることができます。
  1. [各ラベルの編集] をクリックします。
  2. [新規文書への差し込み] ダイアログ ボックスで以下のいずれかの手順を実行し、[OK] をクリックします。
    • すべての文書を差し込み印刷するには、[すべて] をクリックします。
    • 文書ウィンドウに表示されている文書のみを差し込み印刷するには、[現在のレコード] をクリックします。
    • 特定の範囲の文書を差し込み印刷するには、[最初のレコード] をクリックし、[最初のレコード] ボックスと [最後のレコード] ボックスにレコード番号を入力し、[OK] をクリックします。
  3. すべてのラベルが含まれた新しい単一の文書が開かれます。その文書を後で使用するために、通常の文書と同様に保存できます。

関連情報

IF フィールドに関する詳細については、F1 キーを押して Word ヘルプを開きます。次に、[検索] ボックスにフィールド コード : IF フィールドと入力し、[検索の開始] をクリックして、表示されるトピックを参照します。

MERGESEQ フィールドに関する詳細については、F1 キーを押して Word ヘルプを開きます。次に、[検索] ボックスにフィールド コード : MERGESEQ フィールドと入力し、[検索の開始] をクリックして、表示されるトピックを参照します。

SET フィールドに関する詳細については、F1 キーを押して Word ヘルプを開きます。次に、[検索] ボックスにフィールド コード : SET フィールドと入力し、[検索の開始] をクリックして、表示されるトピックを参照します。

一般的なフィールド書式設定スイッチに関する詳細については、F1 キーを押して Word ヘルプを開きます。次に、[検索] ボックスに一般書式スイッチと入力し、[検索の開始] をクリックして、表示されるトピックを参照します。
294686 [WD2002] 差し込み印刷機能を使ってカテゴリ順にソートされたリストを作成する方法
290408 Word 2002 の差し込み印刷に関してよく寄せられる質問 (FAQ)
294688 Word で差し込み印刷のアドレス帳を設計および設定する方法
294693 Word で差し込み印刷を使用して名簿を作成する方法
294683 Word で差し込み印刷を使用して定型書簡を作成する方法

プロパティ

文書番号: 318117 - 最終更新日: 2007年6月22日 - リビジョン: 4.2
この資料は以下の製品について記述したものです。
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002
キーワード:?
kbhowtomaster kbmerge KB318117
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com