Como utilizar endereços de uma folha de cálculo do Excel para criar etiquetas no Word

Traduções de Artigos Traduções de Artigos
Artigo: 318117 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Pode utilizar a funcionalidade Impressão em Série do Microsoft Word para criar e imprimir etiquetas para enviar correio em massa utilizando dados de uma folha de cálculo do Microsoft Excel. Este artigo contém instruções que pode utilizar para criar uma lista deste tipo.

Quando utiliza a funcionalidade de impressão em série do Word, este intercala um "documento principal" com uma "lista de destinatários" para gerar uma série de "documentos de saída":
  • O documento principal contém o texto básico que é igual em todos os documentos de saída. Poderá conter papel timbrado, texto e instruções em "campos de impressão em série" para inserir texto (tal como os nomes e endereços dos destinatários), que variam entre os vários documentos de saída.
  • A lista de destinatários é uma base de dados (por exemplo, um ficheiro de base de dados do Microsoft Access 2002 ou um livro do Excel) que contenha os dados a intercalar nos documentos de saída. Tipicamente, esta base de dados é uma lista de nomes, endereços e números de telefone.
  • Os documentos de saída são o resultado da impressão em série. O texto existente num documento de saída pode ser igual em todos os documentos de saída, mas é possível aplicar formatação a documentos específicos.

Passo 1: Configurar o Ficheiro de Dados do Excel

Antes de continuar com o Assistente de Impressão em Série, certifique-se de que a folha de cálculo do Excel está correctamente estruturada para esta finalidade. Anote os requisitos seguintes da tabela de dados:
  • A primeira linha deve conter os nomes dos campos de cada coluna. Por exemplo, Cargo, Saudação, Nome Próprio, Segundo Nome, Apelido, Endereço1 e Endereço2.
  • Cada nome de campo tem de ser exclusivo.
  • Cada linha tem de fornecer informações sobre um item específico. Por exemplo, numa lista de correio, cada linha pode incluir informações sobre um destinatário específico.
  • A tabela não pode ter linhas em branco.
Para dispor o ficheiro de dados do Excel, siga estes passos:
  1. Crie o ficheiro de dados do Excel e disponha-o utilizando os campos que pretende utilizar para a etiqueta, conforme mostrado no ficheiro de dados de exemplo seguinte:

    Apelido Nome Próprio Cargo Endereço Localidade Código Postal País
    Davolio Nancy Representante de Vendas 1234 Main St. Apt. 2A Seattle 14222 EUA
    Fuller Andrew Vice-presidente, Vendas 1235 Main St. Tacoma 14222 EUA
    Leverling Janet Representante de Vendas 1235 Elm St. Kirkland 14222 EUA
    Peacock Margaret Representante de Vendas 1236 Main St. Redmond 14222 EUA
    Buchanan Steven Director de Vendas 1237 Main St Londres SW2 8MR Reino Unido
    Suyama Michael Representante de Vendas 1238 Elm St. Londres EC3 7HR Reino Unido
    King Robert Representante de Vendas 1239 Main St. Londres RK2 9NP Reino Unido
    Callahan Laura Coordenadora de Vendas Internas 1230 Elm St. Seattle 14222 EUA
    Dodsworth Anne Representante de Vendas 1231 Elm St. Londres WG2 7LT Reino Unido


  2. Depois de criar o ficheiro de dados do Excel, guarde-o e feche-o.
Para obter mais informações sobre como criar uma lista de endereços de impressão em série, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
294688 Como criar e configurar uma lista de endereços de impressão em série no Word

Passo 2: Configurar o Documento Principal

  1. Inicie o Microsoft Office Word 2003 ou uma versão anterior do Word, aponte para Cartas e Mailings no menu Ferramentas e clique em Assistente de Impressão em Série.

    Inicie o Microsoft Office Word 2007, clique no separador Mailings, clique em Iniciar Impressão em Série no grupo Iniciar Impressão em Série e, em seguida, clique em Assistente de Impressão em Série Passo a Passo.
  2. Em Seleccionar o tipo de documento, clique em Etiquetas.

    O documento activo passa a ser o documento principal (o documento que contém o texto e os gráficos que permanecem iguais para todas as versões do documento intercalado; por exemplo, o endereço do remetente ou o início de uma carta de formulário).
  3. Clique em Seguinte: Iniciar o documento.

    NOTA: Se estiver familiarizado com a funcionalidade de impressão em série ou se preferir trabalhar sem o assistente, poderá utilizar a barra de ferramentas Impressão em Série.
  4. Efectue um dos seguintes procedimentos:
    • Criar uma nova folha de etiquetas:
      1. Clique em Alterar o esquema do documento.
      2. Clique em Opções de etiqueta.
      3. Na caixa de diálogo Opções de Etiqueta, seleccione as opções pretendidas, tal como o tipo e o tamanho da etiqueta, e clique em OK.

        Para obter ajuda para uma opção, clique no ponto de interrogação e clique na opção pretendida.
    • Começar com uma folha de etiquetas existente:
      1. Clique em A partir de documento existente.
      2. Na caixa A partir de, seleccione o documento pretendido e clique em Abrir.
      3. Se não visualizar o documento, clique em Mais ficheiros e clique em Abrir. Na caixa de diálogo Abrir, localize o documento pretendido e clique em Abrir.

        O Word apresenta o documento na janela de documento. Se decidir utilizar outro documento de etiquetas, clique em Iniciar no documento existente e seleccione outro documento. Se pretender alterar o esquema, clique em Alterar o esquema do documento e clique em Opções de etiqueta.
  5. Clique em Seguinte: Seleccionar destinatários.

Passo 3: Especificar a Origem de Dados do Excel

  1. Em Seleccionar destinatários, clique em Utilizar uma lista existente.
  2. Clique em Procurar.
  3. Na caixa de diálogo Seleccionar Origem de Dados, localize e clique na folha de cálculo do Excel que pretende utilizar.

    Por predefinição, o Word abre a pasta As Minhas Origens de Dados.
  4. Clique em Abrir.
  5. Se a folha de cálculo do Excel tiver informações em vários separadores, terá de seleccionar o separador que contém as informações pretendidas e clicar em OK. Todas as entradas existentes na origem de dados são apresentadas na caixa de diálogo Destinatários de Impressão em Série, onde poderá aperfeiçoar a lista de destinatários para incluir na impressão em série.

Passo 4: Seleccionar os Destinatários

  1. Na caixa de diálogo Destinatários de Impressão em Série, seleccione os destinatários que pretende incluir. Para o fazer, efectue qualquer um dos seguintes procedimentos:
    • Utilize as caixas de verificação para indicar os destinatários.

      Este método é bastante útil se a lista for curta. Seleccione as caixas de verificação existentes junto dos destinatários que pretende incluir e desmarque as caixas existentes junto dos destinatários que pretende excluir.

      NOTA: Se souber antecipadamente que pretende incluir na intercalação a maior parte destinatários existentes na lista, clique em Seleccionar Tudo e, em seguida, desmarque os registos específicos. Do mesmo modo, se pretender incluir apenas alguns registos na lista, clique em Desmarcar Tudo e seleccione os registos pretendidos.
    • Ordene os itens na lista.

      Isto é útil se pretender ver os itens por ordem alfabética ou numérica. Clique no cabeçalho da coluna do item pelo qual pretende efectuar a ordenação. Por exemplo, se pretender ordenar a lista alfabeticamente por apelido, clique no cabeçalho de coluna Apelido.
    • Filtre os itens na lista.

      Isto é útil se a lista contiver registos que sabe antecipadamente que não pretende ver ou incluir na intercalação. Depois de ter filtrado a lista, poderá utilizar as caixas de verificação para incluir e excluir registos conforme descrito na secção anterior. Para filtrar a lista, siga estes passos:
      1. Clique na seta existente junto ao cabeçalho de coluna do item pelo qual pretende filtrar.
      2. Clique em qualquer uma das seguintes opções:
        • (Em branco) apresenta todos os registos nos quais o campo correspondente esteja em branco.
        • (Não em branco) apresenta todos os registos nos quais o campo correspondente contém informações.
        • Se a origem de dados contiver registos que partilhem as mesmas informações e existirem dez ou menos valores exclusivos na coluna, poderá filtrar por informações específicas. Por exemplo, se existirem vários endereços que listem Austrália como país/região, poderá filtrar por Austrália.
    • A caixa de diálogo Destinatários da Impressão em Série só apresenta os registos designados. Para apresentar novamente todos os registos, clique em (Todos).
    NOTAS:
    • Para efectuar operações avançadas de ordenação e filtragem, clique na seta existente junto do nome de qualquer coluna e clique em (Avançadas). Utilize os separadores Filtrar Registos e Ordenar Registos para configurar a consulta de ordenação ou filtragem pretendida.
    • Se tiver instalado software de validação de endereços, poderá clicar em Validar na caixa de diálogo Destinatários da Impressão em Série para validar as moradas dos destinatários.
  2. Clique em OK para regressar ao Assistente de Impressão em Série.

    O Word utilizará os destinatários que indicou para a intercalação.
  3. Clique em Seguinte: Preparar as etiquetas.

Passo 5: Dispor o Conteúdo das Etiquetas

Para dispor o conteúdo das etiquetas, siga estes passos.

Inserir Campos de Impressão em Série

Insira campos de impressão em série onde pretender intercalar nomes, endereços e outras informações, tal como um código de barras postal. Por exemplo, insira o campo de impressão em série "Localidade" para que o Word insira o nome da localidade (tal como "Lisboa") armazenado no campo de dados Localidade. Para inserir campos de impressão em série, siga estes passos:
  1. No documento principal, clique no local onde pretende inserir o campo.
  2. Insira qualquer um dos seguintes itens:
    • Blocos de endereços com nome, endereço e outras informações
      1. Clique em Bloco de Endereços.
      2. Na caixa de diálogo Inserir Bloco de Endereços, seleccione os elementos de endereço que pretende incluir, bem como os formatos pretendidos, e clique em OK. Para obter ajuda para uma opção, clique no ponto de interrogação e clique na opção pretendida.

      3. Se a caixa de diálogo Atribuir Campos for apresentada, o Word poderá não ter conseguido encontrar algumas das informações de que necessita para o bloco de endereços. Clique na seta existente junto de (não disponível) e seleccione o campo de origem de dados correspondente ao campo necessário para a impressão em série.
    • Linha de saudações
      1. Clique em Linha de saudações.
      2. Seleccione o formato da linha de saudações, que inclui a saudação, o formato do nome e a pontuação.
      3. Seleccione o texto que pretende apresentar nos casos em que o Word não consegue interpretar o nome do destinatário; por exemplo, quando a origem de dados não contém o nome próprio e o apelido do destinatário, mas apenas o nome da empresa.
      4. Clique em OK.
      5. Se a caixa de diálogo Atribuir Campos for apresentada, o Word poderá não ter conseguido encontrar algumas das informações de que necessita para a linha de saudações. Clique na seta existente junto de (não disponível) e seleccione o campo da origem de dados correspondente ao campo necessário para a impressão em série.
    • Outros campos de informações
      1. Clique em Mais itens.
      2. Efectue um dos seguintes procedimentos:
        • Para seleccionar campos de endereço que sejam automaticamente mapeados para os campos correspondentes na origem de dados, mesmo que os campos da origem de dados não tenham o mesmo nome que os seus campos, clique em Campos de Endereço.
        • Para seleccionar campos que obtêm sempre os dados directamente a partir de uma coluna numa base de dados, clique em Campos da Base de Dados.
      3. Na caixa Campos, clique no campo pretendido.
      4. Clique em Inserir e clique em Fechar.
      5. Se a caixa de diálogo Atribuir Campos for apresentada, o Word poderá não ter conseguido encontrar algumas das informações de que necessita para inserir o campo. Clique na seta existente junto de (não disponível) e seleccione o campo da origem de dados correspondente ao campo necessário para a impressão em série.

        NOTA: Se inserir um campo a partir da lista Campos da Base de Dados e, em seguida, mudar para uma origem de dados que não possua uma coluna com o mesmo nome, o Word não conseguirá inserir as informações desse campo no documento intercalado.
    • Franquia Electrónica

      Para adicionar franquia electrónica, terá de instalar primeiro um programa de franquia electrónica; por exemplo, um programa que tenha adquirido a um serviço existente na World Wide Web. Para utilizar a franquia electrónica, siga estes passos:
      1. Clique em Franquia Electrónica.

        Se não tiver um programa de franquia electrónica instalado, o Word pede-lhe para instalar um e pergunta-lhe se pretende aceder ao seguinte Web site da Microsoft:
        Microsoft Office Web
      2. Introduza a franquia de acordo com as instruções do programa.
    • Para adicionar franquia electrónica, terá de instalar primeiro um programa de franquia electrónica; por exemplo, um programa que tenha adquirido a um serviço existente na World Wide Web.

      Tem de seleccionar um tipo de etiqueta ou envelope que suporte o código de barras POSTNET. Para utilizar o Código de barras postal, siga estes passos:
      1. Clique em Código de barras postal.
      2. Na caixa de diálogo Inserir Código de Barras Postal, seleccione os campos de endereço adequados.

        NOTA: A opção Código de barras postal só aparece se estiver a utilizar a versão do Word no idioma inglês (E.U.A.).
      3. Repita os passos a e b para todos os campos que pretenda inserir.

        NOTAS:
        • No Word 2003 e em versões anteriores do Word, não pode introduzir os caracteres de campo de impressão em série (" ") nem inseri-los utilizando o comando Símbolo no menu Inserir.

          No Word 2007, não pode introduzir os caracteres de campo de impressão em série (" ") nem inseri-los utilizando o comando Símbolo no grupo Símbolos do menu Inserir.
        • Se os campos de impressão em série forem apresentados entre chavetas, tal como { MERGEFIELD Localidade }, o Word está a apresentar os códigos de campo em vez dos resultados destes. Isto não afecta a intercalação mas, se pretende apresentar os resultados, clique com o botão direito do rato no código de campo e clique em Alternar Códigos de Campo no menu de atalho.
    Nota No Word 2003 e em versões anteriores do Word, também pode utilizar a barra de ferramentas Impressão em Série para inserir campos de impressão em série, trabalhar com o documento principal de impressão em série ou executar uma impressão em série. Para visualizar a barra de ferramentas Impressão em Série, aponte para Cartas e Mailings no menu Ferramentas e clique em Mostrar Barra de Ferramentas de Impressão em Série. A barra de ferramentas Impressão em Série fornece comandos adicionais não incluídos nos painéis de tarefas do Assistente de Impressão em Série. Por exemplo, pode utilizar o menu pendente Inserir campo do Word, na barra de ferramentas Impressão em Série, para inserir campos do Word para controlar o processo de impressão em série (por exemplo, um campo IF que só insere texto se um campo de impressão em série tiver um valor especificado). Alternativamente, poderá clicar em Procurar Erros para que o Word execute a impressão em série e comunique quaisquer erros contidos no documento principal.

Alterar o Formato dos Dados Intercalados

Para formatar dados intercalados, tem de formatar os campos de impressão em série existentes no documento principal. Não formate os dados existentes na origem de dados, porque a formatação não é retida quando intercalar os dados no documento. Para alterar o formato dos dados intercalados, siga estes passos:
  1. No documento principal, seleccione o campo que contém as informações que pretende formatar, incluindo os caracteres de campo de impressão em série ("" "") que o rodeiam.
  2. No Word 2003 e em versões anteriores do Word, clique em Tipo de Letra no menu Formatar e seleccione as opções pretendidas.

    No Word 2007, no menu Base, clique em Tipo de Letra no grupo Tipo de Letra para abrir a caixa de diálogo Tipo de Letra e seleccione as opções pretendidas.

Formatar Utilizando Códigos de Campo

Para controlar outros aspectos da formatação, prima ALT+F9 para apresentar códigos de campo e adicione parâmetros aos campos de impressão em série. Quando trabalha com campos, um parâmetro é uma instrução especial que causa a ocorrência de uma acção específica. De uma maneira geral, um parâmetro é adicionado a um campo para modificar um resultado.

Por exemplo:
  1. Para apresentar o número "34987,89" como "34.987,89?", adicione o parâmetro Formato Numérico (\#).
  2. Para imprimir os nomes dos clientes em maiúsculas, adicione o parâmetro Formatar (\*).
  3. Para garantir que as informações intercaladas têm o mesmo tipo de letra e tamanho aplicados ao campo de impressão em série, adicione o parâmetro \* Charformat.
Para copiar a formatação e esquema da primeira etiqueta para todas as outras etiquetas existentes na página, clique em Actualizar todas as etiquetas.

Por exemplo, na base de dados de exemplo mostrada anteriormente neste artigo, se inserir apenas o campo AddressBlock e clicar em Actualizar todas as etiquetas, a página deverá ter um aspecto semelhante ao seguinte:

<<AddressBlock>><<Registo Seguinte>><<AddressBlock>>

<<Registo Seguinte>><<AddressBlock>><<Registo Seguinte>><<AddressBlock>>

Passo 6: Guardar o Documento

Depois de ter concluído o documento principal e inserido todos os campos de impressão em série, guarde o documento antes de continuar.
  1. No Word 2003 e em versões anteriores do Word, clique em Guardar Como no menu Ficheiro.

    No Word 2007, clique no Botão do Microsoft Office e clique em Guardar Como.
  2. Atribua um nome ao documento e clique em Guardar.
  3. Clique em Seguinte: Pré-visualizar as etiquetas.

Passo 7: Pré-visualizar as Etiquetas e Aperfeiçoar a Lista de Destinatários

Quando o assistente apresenta o painel de tarefas Passo 5 Impressão em Série, substitui os campos de impressão em série existentes no documento principal pelo texto real existente na primeira entrada da lista de destinatários, para que possa ver o aspecto que o primeiro documento de saída terá.

Por exemplo, se continuar a utilizar a base de dados de exemplo apresentada anteriormente, depois de clicar em Seguinte: Pré-visualizar as etiquetas, a primeira página deverá ter um aspecto semelhante ao seguinte:
Vice-presidente Vendas, Sales Andrew Fuller   Representante de Vendas Anne Dodsworth
1235 Main St                                  1231 Elm St.
Tacoma                                        Londres
	
	
Representante de Vendas Janet Leverling       Coordenadora de Vendas Internas Laura Callahan
1235 Elm St.                                  1230 Elm St.
Kirkland                                      Seattle
				
Para pré-visualizar entradas adicionais, efectue um dos seguintes procedimentos:
  • Para pré-visualizar os itens por ordem, clique nos botões de seta para a esquerda ou de seta para a direita.

    Cada registo é pré-visualizado na primeira etiqueta da folha.
  • Para localizar e pré-visualizar um item específico, clique em Localizar um destinatário e introduza os critérios de procura na caixa de diálogo Localizar Entrada.
Para aperfeiçoar a lista de destinatários (por exemplo, para excluir um destinatário):
  1. Clique em Editar a lista de destinatários e, em seguida, efectue as alterações na caixa de diálogo Destinatários da Impressão em Série.
  2. Clique em Seguinte: Concluir a intercalação.

Passo 8: Concluir a Intercalação

Para concluir a intercalação, efectue qualquer um dos seguintes procedimentos:

Personalizar Etiquetas Individuais

Para personalizar etiquetas individuais, conclua a intercalação e edite as informações pretendidas no documento intercalado resultante.
  1. Clique em Editar etiquetas individuais.
  2. Na caixa de diálogo Enviar a Impressão em Série para um Novo Documento, seleccione os registos que pretende intercalar.
  3. Clique em OK.

    O Word cria e abre um novo documento intercalado. O documento principal também permanece aberto, podendo alternar para este se pretender efectuar uma alteração a todos os itens.
  4. Desloque-se para as informações que pretende editar e efectue as alterações pretendidas.
  5. Imprima ou guarde o documento, tal como faria a qualquer documento normal.

Imprimir a Folha de Etiquetas

Para imprimir a folha de etiquetas, efectue um dos seguintes procedimentos:
  • Se tiver personalizado os itens e o documento intercalado estiver activo:
    1. No Word 2003 e em versões anteriores do Word, clique em Imprimir no menu Ficheiro.

      No Word 2007, clique no Botão do Microsoft Office, aponte para Imprimir e clique em Imprimir.
    2. Seleccione as opções pretendidas.
  • Se pretender imprimir directamente a partir do Assistente de Impressão em Série:
    1. No Passo 6 do Assistente de Impressão em Série (Concluir a Intercalação), clique em Imprimir.
    2. Na caixa de diálogo Enviar a Impressão em Série para a Impressora, efectue um dos seguintes procedimentos e clique em OK:
      • Para imprimir todos os documentos, clique em Tudo.
      • Para imprimir o documento actualmente apresentado na janela de documento, clique em Registo actual.
      • Para imprimir um intervalo de documentos, clique em De e introduza os números dos registos nas caixas De e Até.
    3. Na caixa de diálogo Imprimir, seleccione as opções pretendidas.

Guardar a Folha de Etiquetas para Utilização Posterior

Se pretender editar as etiquetas intercaladas ou guardá-las para utilização posterior, poderá recolhê-las num só documento.
  1. Clique em Editar etiquetas individuais.
  2. Na caixa de diálogo Enviar Impressão Em Série para Novo Documento, efectue um dos seguintes procedimentos e clique em OK:
    • Para intercalar todos os documentos, clique em Todos.
    • Para intercalar apenas o documento actualmente apresentado na janela de documento, clique em Registo actual.
    • Para intercalar um intervalo de documentos, clique em De e introduza os números dos registos nas caixas De e Até.
  3. O Word abre um documento novo que contém todas as etiquetas individuais. Em seguida, poderá guardar o documento para utilização posterior, tal como faria a qualquer documento normal.

REFERÊNCIAS

Para obter mais informações sobre campos IF, prima F1 para abrir a Ajuda do Word, escreva Códigos de Campo: campo IF na caixa de procura e clique em Procurar para ver os tópicos devolvidos.

Para obter mais informações sobre campos MERGESEQ, prima F1 para abrir a Ajuda do Word, escreva Códigos de Campo: campo MERGESEQ na caixa de procura e clique em Procurar para ver os tópicos devolvidos.

Para obter mais informações sobre campos SET, prima F1 para abrir a Ajuda do Word, escreva Códigos de Campo: campo SET na caixa de procura e clique em Procurar para ver os tópicos devolvidos.

Para obter mais informações sobre parâmetros gerais de formatação de campos, prima F1 para abrir a Ajuda do Word, escreva parâmetros gerais na caixa de procura e clique em Procurar para ver o tópico.
294686 WD2002: Como utilizar a impressão em série para criar uma lista ordenada por categoria
290408 WD2002: Perguntas mais frequentes sobre a impressão em série
294688 Como criar e configurar uma lista de endereços de impressão em série no Word
294693 WD2002: Como utilizar a impressão em série para criar uma lista
294683 Como utilizar a impressão em série para criar cartas de formulário no Word

Propriedades

Artigo: 318117 - Última revisão: 27 de março de 2012 - Revisão: 5.0
A informação contida neste artigo aplica-se a:
  • Microsoft Office Excel 2007
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbhowtomaster kbmerge KB318117

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com