如何使用 Excel 工作表中的地址資料,在 Word 中建立標籤

文章翻譯 文章翻譯
文章編號: 318117 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

您可以使用 Microsoft Word 的合併列印功能結合 Microsoft Excel 工作表中的資料,來建立及列印大量郵件的標籤。本文包含可用來建立此清單的指示。

當您使用 Word 的合併列印功能時,Word 會合併「主文件」與「收件者清單」來產生一組「輸出文件」:
  • 主文件會包含所有輸出文件中都相同的基本文字。其中可能包含信紙信頭、文字及「合併欄位」,合併欄位中的指示可以用來插入因不同輸出文件而異的文字 (例如收件者姓名和地址)。
  • 收件者清單是資料庫 (例如 Microsoft Access 2002 資料庫檔案或 Excel 活頁簿),其中包含要合併到輸出文件的資料。此資料庫通常是一份含有姓名、地址及電話號碼的清單。
  • 輸出文件是合併列印的結果。輸出文件中的文字在所有輸出文件中可以相同,但您也可以對特定文件套用不同的格式。

步驟 1:設定 Excel 資料檔案

在以 [合併列印精靈] 繼續進行之前,請確定 Excel 工作表的結構完善,適合此用途。請注意資料表的下列需求:
  • 第一列應包含每一欄的欄位名稱。例如:尊稱、問候語、名字、中間名、姓氏、地址1 及地址2。
  • 每一個欄位名稱都必須是唯一的。
  • 每一列都必須提供特定項目的資訊。例如,在郵件清單中,每一列可能包含特定收件者的相關資訊。
  • 資料表中不得有空白列。
如果要排列 Excel 資料檔案,請依照下列步驟執行:
  1. 建立 Excel 資料檔案,並根據您要用於標籤的欄位來排列,如下列範例資料檔案所示:

    Last Name First Name Title Address City Postal Code Country
    Davolio Nancy Sales Representative 1234 Main St. Apt. 2A Seattle 14222 USA
    Fuller Andrew Vice President, Sales 1235 Main St. Tacoma 14222 USA
    Leverling Janet Sales Representative 1235 Elm St. Kirkland 14222 USA
    Peacock Margaret Sales Representative 1236 Main St. Redmond 14222 USA
    Buchanan Steven Sales Manager 1237 Main St London SW2 8MR UK
    Suyama Michael Sales Representative 1238 Elm St. London EC3 7HR UK
    King Robert Sales Representative 1239 Main St. London RK2 9NP UK
    Callahan Laura Inside Sales Coordinator 1230 Elm St. Seattle 14222 USA
    Dodsworth Anne Sales Representative 1231 Elm St. London WG2 7LT UK


  2. 建立 Excel 資料檔案之後,儲存然後關閉資料檔案。
如需有關如何建立合併列印通訊清單的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
294688 如何在 Word 中設計及設定合併列印通訊清單

步驟 2:設定主文件

  1. 啟動 Microsoft Office Word 2003 或舊版的 Word,指向 [工具] 功能表上的 [信件與郵件],然後按一下 [合併列印精靈]

    啟動 Microsoft Office Word 2007,按一下 [郵件] 索引標籤,按一下 [啟動合併列印] 群組中的 [啟動合併列印],然後按一下 [逐步合併列印精靈]
  2. 按一下 [選取文件類型] 底下的 [標籤]

    使用中的文件會變成主文件 (此文件所包含的文字和圖形在合併文件的每一個版本中都一樣;例如,套印信件的寄件者地址和問候語)。
  3. 按一下 [下一步: 開始文件]

    注意:如果您熟悉合併列印功能,或不習慣使用精靈工作,您可以使用 [合併列印] 工具列。
  4. 請執行下列其中一項操作:
    • 建立新的整張標籤:
      1. 按一下 [變更文件版面配置]
      2. 按一下 [標籤選項]
      3. [標籤選項] 對話方塊中,選取您要的選項,例如標籤類型和大小,然後按一下 [確定]

        如需選項的說明,請按一下問號,然後按一下該選項。
    • 從現有的整張標籤開始:
      1. 按一下 [從現有文件開始]
      2. [自現有啟動] 對話方塊中,選取您要的文件,然後按一下 [開啟]
      3. 如果您未看到文件,請按一下 [更多檔案],然後按一下 [開啟]。在 [開啟舊檔] 對話方塊中,選取您要的文件,然後按一下 [開啟]

        Word 會在文件視窗中顯示文件。如果您決定改用不同的標籤文件,請按一下 [從現有文件開始],然後選取不同文件。如果您想要變更版面配置,請按一下 [變更文件版面配置],然後按一下 [標籤選項]
  5. 按一下 [下一步: 選取收件者]

步驟 3:指定 Excel 資料來源

  1. 按一下 [選取收件者] 底下的 [使用現有清單]
  2. 按一下 [瀏覽]
  3. [選取資料來源] 對話方塊中,找出並按一下您要使用的 Excel 工作表。

    根據預設,Word 會開啟 [我的資料來源] 資料夾。
  4. 按一下 [開啟]
  5. 如果 Excel 工作表的資訊出現在多個索引標籤上,您必須選取包含所要資訊的索引標籤,然後按一下 [確定]。資料來源中的所有項目都會出現在 [合併列印收件者] 對話方塊中,您可以進一步篩選要納入合併的收件者清單。

步驟 4:選取收件者

  1. [合併列印收件者] 對話方塊中,選取您要包含的收件者。如果要執行這項操作,請完成下列其中一項程序:
    • 使用核取方塊來指定收件者。

      如果清單簡短,此方法最好用。選取您要包含的收件者旁邊的核取方塊,並清除您要排除的收件者旁邊的核取方塊。

      注意:如果您要將大部分清單納入合併中,請按一下 [全選],然後清除特定記錄。同樣地,如果您只想要納入清單中的少許記錄,請按一下 [全部清除],然後選取您要的記錄。
    • 排序清單中的項目。

      如果您希望看到項目依英文字母順序或數字順序顯示,這樣做很有幫助。按一下您要依據排序的項目欄位標題。例如,如果您想要依據姓氏的字母順序顯示清單,請按一下 [姓氏] 欄位標題。
    • 篩選清單中的項目。

      如果清單中包含您不想看到或不要納入合併的記錄,這麼做很有幫助。在篩選清單之後,您可以使用核取方塊來納入或排除記錄,如上一節所述。如果要篩選清單,請依照下列步驟執行:
      1. 按一下您要依據篩選之項目欄位標題旁邊的箭號。
      2. 按一下下列任何一項:
        • (空白) 顯示其對應欄位為空白的所有記錄。
        • (非空白) 顯示其對應欄位包含資訊的所有記錄。
        • 如果資料來源包含共用相同資訊的記錄,且欄位內的唯一值不超過十個,您就可以依據特定資訊進行篩選。例如,如果有多個地址將澳洲列為國家/地區,您就可以使用「澳洲」進行篩選。
    • [合併列印收件者] 對話方塊只會顯示指定的記錄。如果要重新顯示所有記錄,請按一下 [(全部)]
    注意
    • 如需進行進階排序及篩選,請按一下任何欄位名稱旁邊的箭號,然後按一下 [(進階)]。使用 [資料篩選] 索引標籤和 [資料排序] 索引標籤,來設定您要的排序或篩選查詢。
    • 如果您已安裝地址驗證軟體,可以按一下 [合併列印收件者] 對話方塊中的 [驗證],來驗證收件者地址。
  2. 按一下 [確定] 以回到 [合併列印精靈]。

    Word 將使用您指定的收件者進行合併。
  3. 按一下 [下一步: 安排標籤]

步驟 5:排列標籤的內容

如果要排列標籤的內容,請依照下列步驟執行:

插入合併欄位

在您要合併姓名、地址及其他資訊 (例如郵件條碼) 之處插入合併欄位。例如,插入「縣市」合併欄位,即可讓 Word 插入儲存在 [City] 資料欄位中的縣市名稱,例如「Atlanta」。如果要插入合併欄位,請依照下列步驟執行:
  1. 在主文件中,按一下您要插入欄位之處。
  2. 插入下列任何一項:
    • 含有姓名、地址及其他資訊的地址區塊
      1. 按一下 [地址區塊]
      2. [插入地址區塊] 對話方塊中,選取您要納入的地址元素和您要的格式,然後按一下 [確定]。如需選項的說明,請按一下問號,然後按一下該選項。

      3. 如需選項的說明,請按一下問號,然後按一下該選項。如果出現 [符合欄位] 對話方塊,表示 Word 可能找不到需要的一些地址區塊資訊。按一下 [(找不到)] 旁邊的箭號,然後從資料來源中選取對應到合併列印所需欄位的那個欄位。
    • 問候行
      1. 按一下 [問候行]
      2. 選取問候行格式,包括問候語、姓名格式及後面的標點符號。
      3. 選取當 Word 無法解譯收件者姓名的情況下 (例如,當資料來源不包含收件者的名字或姓氏,只包含公司名稱時),您希望顯示的文字。
      4. 按一下 [確定]
      5. 如果出現 [符合欄位] 對話方塊,表示 Word 可能找不到需要的一些問候行資訊。按一下 [(找不到)] 旁邊的箭號,然後從資料來源中選取對應到合併列印所需欄位的那個欄位。
    • 其他資訊欄位
      1. 按一下 [其他項目]
      2. 請執行下列其中一項操作:
        • 如果要在資料來源的欄位名稱與您的欄位名稱不同時,也要選取會自動對應到資料來源之對應欄位的地址欄位,請按一下 [地址欄位]。
        • 如果要選取一律直接從資料庫的資料行取用資料的欄位,請按一下 [資料庫欄位]
      3. [欄位] 方塊中,按一下您想要的欄位。
      4. 按一下 [插入],然後按一下 [關閉]
      5. 如果 [符合欄位] 對話方塊出現,表示 Word 可能找不到插入該欄位所需的一些資訊。按一下 [(找不到)] 旁邊的箭號,然後從資料來源中選取對應到合併列印所需欄位的那個欄位。

        注意:如果您插入 [資料庫欄位] 清單中的欄位,後來又切換到沒有同名欄位的資料來源,Word 無法將該欄位資訊插入合併文件中。
    • 電子郵資 如果要新增電子郵資,您必須先安裝電子郵資程式,例如您透過全球資訊網的服務購買的程式。如果要使用電子郵資,請依照下列步驟執行:
      1. 按一下 [電子郵資]

        如果您沒有安裝電子郵資程式,Word 會提示您進行安裝,並詢問您是否要連接到下列 Microsoft 網站:
        Microsoft Office Web
      2. 請依照程式的指示插入郵資。
    • 如果要新增電子郵資,您必須先安裝電子郵資程式,例如您透過全球資訊網的服務購買的程式。如果要使用電子郵資,請依照下列步驟執行:郵件條碼 您必須選取支援 POSTNET 條碼的標籤或信封類型。如果要使用郵件條碼,請依照下列步驟執行:
      1. 按一下 [郵件條碼]
      2. [插入郵件條碼] 對話方塊中,選取適合的地址欄位。

        注意:唯有當您使用英文版的 Word 時,才會出現 [郵件條碼] 選項。
      3. 對您要插入的所有欄位重複步驟 a 和 b。

        注意
        • 在 Word 2003 和舊版的 Word 中,您不能輸入合併欄位字元 (" "),或使用 [插入] 功能表上的 [符號] 命令插入它們。

          在 Word 2007 中,您不能輸入合併欄位字元 (" "),或使用 [插入] 索引標籤上的 [符號] 群組中的 [符號] 命令插入它們。
        • 如果合併欄位出現在大弧括內,例如 { MERGEFIELD City },則 Word 會顯示功能變數代碼而非功能變數結果。這不會影響合併,但如果您想要顯示結果,請以滑鼠右鍵按一下功能變數代碼,然後按一下捷徑功能表上的 [切換功能變數代碼]
    注意 在 Word 2003 和舊版的 Word 中,您也可以使用 [合併列印] 工具列來插入合併欄位、使用合併列印主文件,或執行合併列印。如果要顯示 [合併列印] 工具列,請指向 [工具] 功能表上的 [信件與郵件],然後按一下 [顯示合併列印工具列]。[合併列印] 工具列提供 [合併列印] 精靈工作窗格不包括的其他命令。例如,您可以使用 [合併列印] 工具列上的 [插入 Word 功能變數] 下拉式功能表,來插入控制合併程序的 Word 功能變數 (例如,IF 功能變數,以便在特定合併欄位含有指定值時才插入文字)。或者,您可以按一下 [自動檢查錯誤],讓 Word 執行合併列印並報告主文件包含的任何錯誤。

變更合併資料的格式

如果要將合併資料格式化,您必須將主文件中的合併欄位格式化。請勿將資料來源中的資料格式化,因為當您將資料合併到文件中時,不會保留格式。如果要變更合併資料的格式,請依照下列步驟執行:
  1. 在主文件中,選取包含您要格式化其資訊的欄位,包括括住它的合併欄位字元 ("" "")。
  2. 在 Word 2003 和舊版的 Word 中,按一下 [格式] 功能表上的 [字型],然後選取您要的選項。

    在 Word 2007 的 [常用] 索引標籤上,按一下 [字型] 群組中的 [字型] 來開啟 [字型] 對話方塊,然後選取您要的選項。

使用功能變數代碼格式化

如果要控制其他方面的格式,請按 ALT+F9 以顯示功能變數代碼,然後將參數新增至合併欄位。處理欄位時,參數是可以使特定動作發生的特殊指令。一般而言,您可以將參數新增至欄位來修改結果。

例如:
  1. 如果要將數字 "34987.89" 顯示為 "$34,987.89",請新增數值顯示格式參數 (\#)。
  2. 如果要以大寫字母列印客戶姓名,請新增格式參數 (\*)。
  3. 如果要確定合併的資訊與您套用至合併欄位的字型和大小相同,請加入 \* Charformat 參數。
如果要將第一個標籤的格式和版面配置複製到頁面上的所有其他標籤,請按一下 [更新所有標籤]

例如,在本文前面所顯示的範例資料庫中,如果您只插入 AddressBlock 欄位,然後按一下 [更新所有標籤],頁面應該會顯示類似下列內容:

<<AddressBlock>><<Next Record>><<AddressBlock>>

<<Next Record>><<AddressBlock>><<Next Record>><<AddressBlock>>

步驟 6:儲存文件

在完成主文件及插入所有合併欄位之後,請先儲存該文件再繼續。
  1. 在 Word 2003 和舊版的 Word 中,按一下 [檔案] 功能表上的 [另存新檔]

    在 Word 2007 中,請按一下 [Microsoft Office 按鈕],然後按一下 [另存新檔]
  2. 輸入文件的名稱,然後按一下 [儲存]
  3. 按一下 [下一步: 預覽標籤]

步驟 7:預覽標籤和微調收件者清單

當精靈顯示 [步驟 5: 合併列印] 工作窗格時,它會將主文件中的每一個合併欄位,取代成收件者清單第一個項目中的實際文字,讓您能夠看到第一份輸出文件的樣子。

例如,如果您繼續使用先前顯示的範例資料庫,在按一下 [下一步: 預覽標籤] 之後,第一頁看起來應該類似如下:
Vice President, Sales Andrew Fuller     Sales Representative Anne Dodsworth
1235 Main St                            1231 Elm St.
Tacoma                                  London
	
	
Sales Representative Janet Leverling     Inside Sales Coordinator Laura Callahan
1235 Elm St.                             1230 Elm St.
Kirkland                                 Seattle
				
如果要預覽其他項目,請執行下列其中一項步驟:
  • 如果要依序預覽項目,按一下向左鍵或向右鍵按鈕。

    如此會在工作表的第一個標籤中預覽每一筆記錄。
  • 如果要尋找及預覽特定項目,請按一下 [尋找收件者],然後在 [尋找項目] 對話方塊中輸入搜尋條件。
如果要微調收件者清單,例如,若要排除某位收件者:
  1. 按一下 [編輯收件者清單],然後在 [合併列印收件者] 對話方塊中進行變更。
  2. 按一下 [下一步: 完成合併]

步驟 8:完成合併

如果要完成合併,請執行下列其中一項步驟:

個人化個別標籤

如果要個人化個別標籤,請完成合併,然後在產生的合併文件中編輯您要的資訊。
  1. 按一下 [編輯個別標籤]
  2. [合併到新文件] 對話方塊中,選取您要合併的記錄。
  3. 按一下 [確定]

    Word 會建立及開啟新的合併文件。主文件也會保持開啟,如果您想要變更所有項目,可以切換回到主文件。
  4. 捲動到您要編輯的資訊,並進行變更。
  5. 列印或儲存文件,就像對一般文件一樣。

列印整張標籤

如果要列印整張標籤,請執行下列其中一項步驟:
  • 如果您有將項目個人化,且合併的文件正在使用中:
    1. 在 Word 2003 和舊版的 Word 中,按一下 [檔案] 功能表上的 [列印]

      在 Word 2007 中,按一下 [Microsoft Office 按鈕],指向 [列印],然後按一下 [列印]
    2. 選取您要的選項。
  • 如果您想要直接從 [合併列印精靈] 列印:
    1. 在 [合併列印精靈] 的步驟 6 (完成合併) 中,按一下 [列印]
    2. [合併到印表機] 對話方塊中,執行下列其中一項,然後按一下 [確定]
      • 如果要列印所有文件,請按一下 [全部]
      • 如果要列印您在文件視窗中看到的文件,請按一下 [目前的記錄]
      • 如果要列印文件範圍,按一下 [從],然後在 [從][到] 方塊中輸入記錄號碼。
    3. [列印] 對話方塊中,選取您要的選項。

儲存整張標籤供稍後使用

如果您想要編輯合併標籤或儲存它們供稍後使用,可以將它們收集到單一文件中。
  1. 按一下 [編輯個別標籤]
  2. [合併到新文件] 對話方塊中,執行下列其中一項,然後按一下 [確定]
    • 如果要合併有文件,請按一下 [全部]
    • 如果只要合併您在文件視窗中看到的文件,請按一下 [目前的記錄]
    • 如果要合併文件範圍,按一下 [從],然後在 [從][到] 方塊中輸入記錄號碼。
  3. Word 會開啟單一新文件,並在其中包含所有個別標籤。然後您可以儲存文件供稍後使用,就像對一般文件一樣。

參考

如需有關 IF 功能變數的詳細資訊,請按 F1 開啟 Word 說明,並在搜尋方塊中輸入 Field Codes:IF field,然後按一下 [搜尋] 以檢視傳回的主題。

如需有關 MERGESEQ 功能變數的詳細資訊,請按 F1 開啟 Word 說明,並在搜尋方塊中輸入 Field Codes:MERGESEQ field,然後按一下 [搜尋] 以檢視傳回的主題。

如需有關 SET 功能變數的詳細資訊,按 F1 開啟 Word 說明,並在搜尋方塊中輸入 Field Codes:SET 功能變數,然後按一下 [搜尋] 以檢視傳回的主題。

如需有關一般欄位格式參數的詳細資訊,按 F1 開啟 Word 說明,並在搜尋方塊中輸入 general switches,然後按一下 [搜尋] 以檢視該主題。
294686 如何使用合併列印,在 Word 中建立依類別排序的清單
290408 WD2002:合併列印的常見問題解答
294688 如何在 Word 中設計及設定合併列印通訊清單
294693 如何使用合併列印功能在 Word 中建立目錄
294683 如何使用合併列印功能在 Word 中建立套印信件

屬性

文章編號: 318117 - 上次校閱: 2012年3月27日 - 版次: 5.0
這篇文章中的資訊適用於:
  • Microsoft Office Excel 2007
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
關鍵字:?
kbhowtomaster kbmerge KB318117
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com