Como usar o recurso mala direta no Word para criar e imprimir cartas que usam os dados de uma planilha do Excel

Traduções deste artigo Traduções deste artigo
ID do artigo: 318118 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Este artigo explica como usar o recurso mala direta no Microsoft Word para criar e imprimir cartas usando dados de uma planilha do Microsoft Excel.

Quando você usa o recurso de mala direta do Word, o Word mescla um documento principal com uma lista de destinatários para gerar um conjunto de documentos de saída :
  • O documento principal contém o texto básico que é o mesmo em todos os documentos de saída. Ele pode conter um papel timbrado, texto e as instruções em campos de mesclagem para inserir texto (como nomes e endereços dos destinatários) que variam de um documento de saída para outra.
  • A lista de destinatário é um banco de dados que contém os dados que deve ser mesclados em documentos de saída. Por exemplo, a lista de destinatários é um arquivo de banco de dados do Microsoft Access ou uma planilha do Excel.

    Este banco de dados normalmente é uma lista de nomes, endereços, números de telefone e outras categorias de informações pessoais.
  • Os documentos de saída são o resultado da mala direta. O texto em um documento de saída pode ser o mesmo em todos os documentos de saída, mas você pode aplicar uma formatação para documentos específicos.

Etapa 1: Configurar o arquivo de dados do Excel

Antes de prosseguir com o Assistente de mala direta, certifique-se que sua planilha do Excel é bem estruturada para essa finalidade. Observe os seguintes requisitos para a tabela de dados:
  • A primeira linha deve conter nomes de campo para cada coluna--por exemplo, título, saudação, nome, segundo nome, sobrenome, endereço1 e endereço2.
  • Cada nome de campo deve ser exclusivo.
  • Cada linha deve fornecer informações sobre um item específico. Por exemplo, em uma lista de endereçamento, cada linha pode incluir informações sobre um determinado destinatário.
  • A tabela deve conter não linhas em branco.
Crie o arquivo de dados do Excel e organizá-lo usando os campos que você deseja usar para a carta, como mostra o arquivo de dados de exemplo a seguir.
Last Name First Name Title Address City Postal Code Country
Davolio Nancy Sales Representative 507 - 20th Ave. E. Apt. 2A Seattle 98122 USA
Fuller Andrew Vice President, Sales 908 W. Capital Way Tacoma 98401 USA
Leverling Janet Sales Representative 722 Moss Bay Blvd. Kirkland 98033 USA
Peacock Margaret Sales Representative 4110 Old Redmond Rd. Redmond 98052 USA
Buchanan Steven Sales Manager 14 Garrett Hill London SW1 8JR UK
Suyama Michael Sales Representative Coventry House Miner Rd. London EC2 7JR UK
King Robert Sales Representative Edgeham Hollow Winchester Way London RG1 9SP UK
Callahan Laura Inside Sales Coordinator 4726 - 11th Ave. N.E. Seattle 98105 USA
Dodsworth Anne Sales Representative 7 Houndstooth Rd. London WG2 7LT UK


Depois de criar o arquivo de dados do Excel, salve-o e feche o arquivo de dados.

Para obter mais informações sobre como criar uma lista de endereço de mala direta, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
294688Como criar e configurar uma lista de endereço de mala direta no Word 2002 e em versões posteriores do Word

Etapa 2: Configurar o documento principal

  1. No Microsoft Office Word 2003 e em versões anteriores do Word, aponte para Cartas e correspondências no menu Ferramentas e, em seguida, clique em Assistente de mala .

    No Microsoft Word 2007, clique em Iniciar mala direta no grupo Iniciar mala direta guia correspondências e clique em Step by Step pelo Assistente de mala direta .
  2. Em Selecione o tipo de documento , clique em cartas .

    O documento ativo se torna o documento principal. O documento principal contém o texto e elementos gráficos que são os mesmos para cada versão do documento mesclado. Por exemplo, o endereço do remetente e a saudação em uma carta modelo são os mesmos para cada versão.
  3. Clique em Avançar: documento inicial .
  4. Use um dos seguintes métodos:
    • Iniciar com o documento é mostrado no momento na janela do documento. Para fazer isso, clique em usar o documento atual .

      Você pode, em seguida, digite a letra na janela do documento ou esperar até o assistente solicitar que você faça isso em uma etapa posterior.
    • Iniciar com um modelo. Para fazer isso, execute as seguintes etapas:
      1. Clique em Iniciar a partir de um modelo .
      2. Clique em Selecionar modelo .
      3. Na guia de mala direta , selecione o modelo que deseja na caixa de diálogo Selecionar modelo e, em seguida, clique em OK .
    • Iniciar com um documento existente. Para fazer isso, execute as seguintes etapas:
      1. Clique em Iniciar com base em documento existente .
      2. Na caixa Iniciar com base em , selecione o documento que deseja e, em seguida, clique em Abrir .
      3. Se você não vir o documento, clique em mais arquivos e, em seguida, clique em Abrir . Na caixa de diálogo Abrir , localize o documento que deseja e, em seguida, clique em Abrir .
  5. Clique em Avançar: Selecionar destinatários .

Etapa 3: Especificar a fonte de dados do Excel

  1. Em Selecione os destinatários , clique em usar uma lista existente .
  2. Clique em Procurar .
  3. Na caixa de diálogo Selecionar fonte de dados , localize e clique em planilha do Excel que você deseja usar.

    Por padrão, o Word abre a pasta "Minhas fontes de dados".
  4. Clique em Abrir .
  5. Se sua planilha do Excel contiver informações sobre várias guias, selecione a guia que contém as informações que você deseja e, em seguida, clique em OK .
  6. Todas as entradas a fonte de dados aparecem na caixa de diálogo Destinatários da mala direta . Aqui, você pode refinar a lista de destinatários a serem incluídos na mesclagem.

Etapa 4: Selecionar os destinatários

  1. Na caixa de diálogo Destinatários da mala direta , selecione os destinatários que você deseja incluir. Para fazer isso, use um dos seguintes métodos:
    • Use as caixas de seleção para designar destinatários.

      Este método é mais útil se a lista for pequena. Clique em para marcar as caixas de seleção ao lado para os destinatários que você deseja incluir e, em seguida, clique para desmarcar as caixas de seleção ao lado para os destinatários que você deseja excluir.

      Observação Se você já sabe que você deseja incluir a maior parte da lista na mesclagem, clique em Selecionar tudo e, em seguida, clique para desmarcar registros específicos. Da mesma forma, se você desejar incluir apenas alguns registros na lista, clique em Limpar tudo e, em seguida, selecione os registros que você deseja.
    • Classificar itens na lista.

      Este método é útil se você desejar ver os itens em ordem alfabética ou numérica. Clique no cabeçalho da coluna do elemento pelo qual você deseja classificar. Por exemplo, se você desejar exibir a lista em ordem alfabética por sobrenome, clique em cabeçalho da coluna Sobrenome .
    • Filtre itens na lista.

      Esse método é útil se a lista contiver registros que você sabe que você não deseja exibir ou incluir na mala direta. Depois de filtrar a lista, você pode usar as caixas de seleção para incluir e excluir registros, conforme descrito anteriormente. Para filtrar a lista, execute estas etapas:
      1. Clique na seta ao lado no cabeçalho da coluna do elemento que você deseja filtrar.
      2. Clique em qualquer um destes procedimentos:
        • (em branco) : esta opção exibe todos os registros nos quais o campo correspondente está em branco.
        • (preenchido) : esta opção exibe todos os registros nos quais o campo correspondente contém informações.
        • Se a fonte de dados contiver registros que compartilham as mesmas informações e se há 10 ou menos valores exclusivos na coluna, você pode filtrar por informações específicas. Por exemplo, se houver vários endereços que listam Austrália como país, você pode filtrar por Austrália .
    • A caixa de diálogo Destinatários da mala direta exibe somente os registros designados. Para exibir todos os registros novamente, clique em (Tudo) .
    anotações
    • Para classificação e filtragem avançadas, clique na seta ao lado de qualquer nome de coluna e, em seguida, clique em (Avançado) . Use as guias Filtrar os registros e Classificar os registros para definir a classificação ou filtragem de consulta que você deseja.
    • Se você tiver instalado o software de validação de endereço, clicar em Validar na caixa de diálogo Destinatários da mala direta para validar os endereços de seus destinatários.
  2. Clique em OK para retornar ao Assistente de mala direta.

    O Word usa os destinatários que você designou para a mesclagem.
  3. Clique em Próxima: Escreva a carta .

Etapa 5: Concluir a letra e adicionar campos de mesclagem

Se você ainda não tiver feito isso, digite o texto que você deseja que apareçam em cada carta no documento principal.

Inserir campos de mesclagem

Inserir campos de mesclagem onde você deseja mesclar nomes, endereços e outras informações da fonte de dados. Para inserir campos de mesclagem, execute estas etapas:
  1. No documento principal, clique onde você deseja inserir o campo.
  2. Insira um destes procedimentos:
    • Bloco de endereço com nome, endereço e outras informações:
      1. Clique em Bloco de endereço .
      2. Na caixa de diálogo Inserir bloco de endereço , selecione os elementos de endereço que você deseja incluir e os formatos que você deseja e, em seguida, clique em OK . Para obter ajuda sobre uma opção, clique no interrogação de ponto e, em seguida, clique na opção.

      3. Para obter ajuda sobre uma opção, clique no interrogação de ponto e, em seguida, clique na opção. Se a caixa de diálogo Coincidir campos será exibida, o Word talvez não é possível localizar algumas das informações necessárias para o bloco de endereço. Clique na seta ao lado de (não disponível) e, em seguida, selecione o campo da fonte de dados que corresponde ao campo necessário para a mala direta.
    • Linha de saudação:
      1. Clique em linha de saudação .
      2. Selecione o formato linha de saudação que inclui a saudação, formato de nome e pontuação seguinte.
      3. Selecione o texto que você deseja que apareça nos casos em que o Word não consegue interpretar o nome do destinatário. Por exemplo, o Word não é possível interpretar o nome quando a fonte de dados não contém nenhum nome ou sobrenome de um destinatário, mas somente um nome de empresa.
      4. Clique em OK .
      5. Se a caixa de diálogo Coincidir campos será exibida, o Word talvez não é possível localizar algumas das informações necessárias para a linha de saudação. Clique na seta ao lado de (não disponível) e, em seguida, selecione o campo da fonte de dados que corresponde ao campo necessário para a mala direta.
    • Outros campos de informações:
      1. Clique em mais itens .
      2. Use um dos seguintes métodos:
        • Clique em Campos de endereço para selecionar em campos de endereço que serão mapeado automaticamente para os campos correspondentes na fonte de dados, mesmo se os campos da fonte de dados não tiverem o mesmo nome de seus campos.
        • Clique em Campos de banco de dados para selecionar em campos que sempre carregam dados diretamente de uma coluna em um banco de dados.
      3. Na caixa campos , clique no campo que você deseja.
      4. Clique em Inserir e, em seguida, clique em Fechar .
      5. Se a caixa de diálogo Coincidir campos será exibida, o Word não poderá localizar algumas informações necessárias para inserir o campo. Clique na seta ao lado de (não disponível) e, em seguida, selecione o campo da fonte de dados que corresponde ao campo necessário para a mala direta.

        Observação Se você inserir um campo da lista de Campos de banco de dados , e se posteriormente você alternar para uma fonte de dados que não tenha uma coluna com o mesmo nome, o Word não pode inserir as informações de campo no documento mesclado.
    • Postagem eletrônica:

      Para adicionar postagem eletrônica, você deve primeiro instalar um programa de postagem eletrônica, como aquele que você pode comprar de um provedor de terceiros na Web. Para usar postagem eletrônica, execute estas etapas:
      1. Clique em postagem eletrônica .

        Se você não tiver um programa de postagem eletrônica instalado, o Word solicita que você instalar um e oferece para se conectar ao seguinte site do Microsoft Office:
        Imprimir postagem online
        http://office.microsoft.com/services/service.aspx?sid=2.4
      2. Insira a postagem de acordo com às instruções do programa.
    • Para adicionar postagem eletrônica, você deve primeiro instalar um programa de postagem eletrônica, como aquele que você pode comprar de um provedor de terceiros na Web. Para usar postagem eletrônica, execute estas etapas: código de barras postal: você deve selecionar um tipo de carta ou envelope que o código de barras POSTNET. Para usar o código de barras postal, execute estas etapas:
      1. Clique em código de barras postal .
      2. Em Inserir código de barras postal diálogo, selecione os campos de endereço apropriado.

        Observação A opção de código de barras postal aparece somente se você estiver usando a versão de idioma dos EUA do Word.
      3. Repita as etapas um e b para todos os campos que você deseja inserir. Observações :
        • Você não pode digitar caracteres de campo de mesclagem ("") ou inseri-los usando o comando símbolo no menu Inserir .
        • Se os campos de mesclagem aparecerem entre chaves, como {MERGEFIELD Cidade}, o Word está exibindo códigos de campo em vez dos resultados de campo. Isso não afeta a mesclagem, mas se você deseja exibir os resultados em vez disso, clique com o botão direito do mouse o código de campo e, em seguida, clique em Alternar códigos de campo no menu de atalho.
      Por exemplo, usando o banco de dados exemplo mostrado anteriormente, a letra da sua pode conter os campos AddressBlock e GreetingLine e, portanto, sua primeira página aparece semelhante à seguinte:
      26 de fevereiro de 2002

      AddressBlock

      GreetingLine

      Digite sua carta aqui.

      Pedimos,

      Digite seu nome aqui

    Observação Você também pode usar a barra de ferramentas mala direta para inserir campos de mesclagem, trabalhar com seu documento principal de mala direta ou executar uma mala direta. Para exibir a barra de ferramentas mala direta , aponte para Cartas e correspondências no menu Ferramentas e clique em Mostrar barra de ferramentas Mala direta .

    A barra de ferramentas mala direta fornece comandos adicionais que não estão incluídos nos painéis de tarefas Assistente de mala direta. Por exemplo, você pode usar o menu Inserir campo do Word na barra de ferramentas mala direta para inserir campos do Word para controlar o processo de mesclagem. Por exemplo, você pode inserir um campo IF que insere texto somente se um determinado campo tiver um valor especificado.

    Como alternativa, você pode clicar em Verificar para erros de torná-lo executar o mala direta e relatório de erros que estão contidos no documento principal.

Alterar o formato dos dados mesclados

Para formatar dados mesclados, você deve formatar os campos de mesclagem do documento principal. Não formate os dados na fonte de dados, porque sua formatação não é preservada quando você mescla os dados no documento. Para alterar o formato dos dados mesclados, execute as seguintes etapas:
  1. No documento principal, selecione o campo que contém as informações que você deseja formatar, incluindo caracteres de campo de mesclagem delimitador (<>).
  2. No Word 2003 e em versões anteriores do Word, clique em fonte no menu Formatar e, em seguida, selecione as opções que você deseja.

    No Word 2007, clique na opção que deseja na caixa de Fontes de tema do grupo a fonte na guia início .

Formato usando códigos de campo

Para controlar outros aspectos da formatação, pressione as teclas ALT+F9 para exibir códigos de campos e adicione opções aos campos de mesclagem. Quando você trabalha com campos, um switch é uma instrução especial que faz com que uma ação específica ocorra. Geralmente, uma opção é adicionada a um campo para modificar o resultado.

Exemplos de como usar as opções são:
  • Para exibir o número 34987,89 como r$ 34.987,89 , adicione a opção Imagem numérica (\ #).
  • Para imprimir nomes de cliente em letras maiúsculas, adicione o formato de opção (\ *).
  • Para que se as informações mescladas tem a mesma fonte e tamanho de ponto que você aplicar ao campo de mesclagem, adicione a opção Charformat (\ *).

Etapa 6: Salvar o documento

Após ter concluído o documento principal e inserir todos os campos de mesclagem, certifique-se de que você salve o documento antes de prosseguir. Para fazer isso, execute as seguintes etapas:
  1. No Word 2003 e em versões anteriores do Word, clique em Salvar como no menu arquivo .

    No Word 2007, clique no Botão Microsoft Office e, em seguida, clique em Salvar como .
  2. Nomeie o documento e em seguida, clique em Salvar .
  3. Clique em Próxima: Visualize as cartas .

Etapa 7: Visualizar as cartas e Fine-Tune lista de destinatários

Quando o assistente exibe o painel de tarefas "etapa 5 mala direta", o assistente substitui os campos de mesclagem no documento principal que contém o texto real da primeira entrada da list.Therefore destinatário, você pode ver como ficará o primeiro documento de saída.

Por exemplo, se você continuar a usar o banco de dados exemplo mostrado anteriormente, a primeira página ser deve semelhante a seguinte página após você clicar em Próxima: Visualize as cartas :
26 de fevereiro de 2002

Andrew Mattos
Método de maiúscula w. 908
Tacoma 98401

Prezado Andrew Mattos,

Digite sua carta aqui.

Pedimos,

Digite seu nome aqui
Para visualizar entradas adicionais, use um dos seguintes métodos:
  • Para visualizar os itens em ordem, clique nos botões seta esquerda ou direita.
  • Para localizar e visualizar um item específico, clique em Localizar um destinatário e, em seguida, insira os critérios de pesquisa na caixa de diálogo Localizar entrada .
Ajuste a lista de destinatários se você desejar. Para fazer isso, use um dos seguintes métodos:
  • Para excluir um determinado destinatário da operação de mesclagem, clique em Excluir este destinatário .
  • Para alterar a lista de destinatários, clique em Editar lista de destinatários e faça as alterações na caixa de diálogo Destinatários da mala direta .

Etapa 8: Concluir a operação

Para concluir a mesclagem, utilize qualquer um dos seguintes métodos.

Personalizar cartas individualmente

Para personalizar itens individuais, você terá que concluir a mesclagem e edite informações que deseja no documento mesclado resultante. Para fazer isso, execute as seguintes etapas:
  1. Clique em Editar cartas individualmente .
  2. Na caixa de diálogo Mesclar para novo documento , selecione os registros que você deseja mesclar.
  3. Clique em OK .

    Word cria e abre um novo documento mesclado. O documento principal também permanece aberto, e você pode voltar para ele se você deseja alterar todos os documentos.
  4. Role as informações que você deseja editar e, em seguida, faça as alterações.
  5. Imprimir ou salvar o documento como faria com qualquer documento comum.

Imprimir as cartas

Para imprimir as cartas, use um dos seguintes métodos:
  • Se você personalizado os itens e se o documento mesclado estiver ativo, execute estas etapas:
    1. No Word 2003 e em versões anteriores do Word, clique em Imprimir no menu arquivo .

      No Word 2007, clique no Botão Microsoft Office e, em seguida, clique em Imprimir .
    2. Selecione as opções que você deseja.
  • Se você desejar imprimir diretamente a partir o Assistente de mala direta, execute estas etapas:
    1. Na etapa 6 do Assistente de mala direta ( Conclua a mesclagem ), clique em Imprimir .
    2. Na caixa de diálogo Mesclar para impressora , use um dos seguintes métodos e, em seguida, clique em OK :
      • Para imprimir todos os documentos, clique em Tudo .
      • Para imprimir o documento que você vê na janela do documento, clique em registro atual .
      • Para imprimir um intervalo de documentos, clique em e em seguida, digite os números de registros nas caixas de e até .
    3. Na caixa de diálogo Imprimir , selecione as opções que você deseja.

Salvar letras mescladas para uso posterior

Se você desejar editar cartas mescladas ou salvá-las para uso posterior, você pode reuni-las em um único documento. Para fazer isso, execute as seguintes etapas:
  1. Clique em Editar cartas individualmente .
  2. Na caixa de diálogo Mesclar para novo documento , use um dos seguintes métodos e, em seguida, clique em OK :
    • Para mesclar todos os documentos, clique em Tudo .
    • Para mesclar somente o documento que você vê na janela do documento, clique em registro atual .
    • Para mesclar um intervalo de documentos, clique em e em seguida, digite os números de registros nas caixas de e até .
  3. Word abre um novo documento único que contém todas as letras individuais. Em seguida, você pode salvar o documento para uso posterior, como faria com qualquer documento comum.

Referências

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
318117Como usar endereços de uma planilha do Excel para criar etiquetas no Word
318115Como criar uma carta modelo usando informações de um banco de dados do Access no Word 2002
318112Como usar endereços de um banco de dados do Access 2002 para criar etiquetas no Word 2002
294686Como usar mala direta para criar uma lista classificada por categoria no Word 2002 e em versões posteriores do Word
290408Perguntas freqüentes sobre mala direta no Word 2002
294688Como criar e configurar uma lista de endereço de mala direta no Word 2002 e em versões posteriores do Word
294693Como usar mala direta para criar um diretório no Word 2002 e em versões posteriores do Word
294683Como usar mala direta para criar cartas de formulário no Word 2002 e em versões posteriores do Word

Propriedades

ID do artigo: 318118 - Última revisão: terça-feira, 12 de dezembro de 2006 - Revisão: 2.7
A informação contida neste artigo aplica-se a:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbmt kbexpertisebeginner kbforms kbprint kbhowtomaster kbmerge KB318118 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 318118

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com