Mensagem de erro "O serviço Windows Installer não pôde ser acedido" ao instalar a aplicação

Artigo: 319624 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Depois de actualizar para o Windows Installer versão 2.0, o serviço Windows Installer poderá não ser iniciado e poderá receber a seguinte mensagem de erro:
O serviço Windows Installer não pôde ser acedido. Isto pode acontecer caso esteja a executar o Windows em modo seguro ou se o Windows não está instalado correctamente. Contacte o suporte técnico para obter assistência.

[The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or the Windows Installer is not correctly installed. Contact your support personnel for assistance.]
Nota: este comportamento não ocorre nos seguintes produtos:
  • Microsoft Windows XP
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98

Causa

Este comportamento poderá ocorrer quando se verifica uma das seguintes condições:
  • Nas permissões de DCOM, o nível de autenticação predefinido está definido como Nenhum (None), e o nível de representação predefinido está definido como Anónimo (Anonymous).
  • A conta de sistema não tem permissões totais sobre uma pasta ou uma chave de registo a que o Windows Installer está a tentar aceder. Isto é NTFS específico.

Resolução

Dependendo do problema, utilize um ou todos os métodos que se seguem:
  • Método 1: Anular o registo e voltar a registar o Windows Installer.
  • Método 2: Verificar as permissões de DCOM.
  • Método 3: Conceder permissão de controlo total à conta SYSTEM.
  • Método 4: Verificar as permissões de registo.
  • Método 5: Corrigir a chave de segurança danificada para o serviço MsiServer.

Antes de começar: Verificar se o Service Pack está instalado

Se estiver a utilizar o Windows 2000, certifique-se de que o SP 2 está instalado.
Se estiver a utilizar o Windows NT 4.0, certifique-se de que o SP 6 está instalado.

Se não instalar os Service Packs adequados, os passos indicados na secção "Mais informação" deste artigo poderão não funcionar como previsto.

Mais Informação

Método 1: Anular o registo e voltar a registar o Windows Installer

  1. Clique em Iniciar (Start), clique em Executar (Run), escreva MSIEXEC /UNREGISTER e clique em OK. Mesmo que efectue o processo correctamente, poderá parecer que nada ocorre.
  2. Clique em Iniciar (Start), clique em Executar (Run), escreva MSIEXEC /REGSERVER e clique em OK. Mesmo que efectue o processo correctamente, poderá parecer que nada ocorre ou poderá ver por breves momentos uma ampulheta. Depois de executar este comando, a operação está concluída.
  3. Tente instalar novamente a aplicação baseada no Windows Installer.

Método 2: Verificar as permissões de DCOM

Este método implica a alteração do nível de representação DCOM predefinido para Identificar, removendo o ficheiro Msisip.dll e voltando a instalar o SP 3 do Windows 2000.

Para tal, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva dcomcnfg e clique em OK.
  2. No separador Propriedades predefinidas:
    1. Na lista Nível de autenticação predefinido, clique em Ligar.
    2. Na lista Nível de representação predefinido, clique em Identificar e clique em OK.
  3. Clique em Iniciar, clique em Executar, escreva explorer /select, %windir%\system32\msisip.dll e clique em OK.
  4. Mude o nome do ficheiro Msisip.dll para Msisip.old.
  5. Volte a instalar o Windows 2000 Service Pack 3.

Método 3: Conceder permissão de controlo total à conta SYSTEM

  1. Inicie o Explorador do Windows (Windows Explorer), clique com o botão direito do rato no disco rígido raiz do computador e clique em Propriedades (Properties).
  2. Clique no separador Segurança (Security) e clique em Adicionar (Add).
  3. Na caixa de diálogo Seleccionar Utilizadores, Computadores ou Grupos (Select Users, Computers, or Groups), clique na conta SYSTEM, clique em Adicionar (Add) e clique em OK.
  4. Em Permitir (Allow), clique para seleccionar a caixa de verificação Controlo total (Full Control) e clique em OK.
  5. Clique na pasta TEMP e certifique-se de que a conta SYSTEM tem controlo total.

Método 4: Verificar as permissões de registo

  1. Clique em Iniciar (Start), clique em Executar (Run) e escreva Regedt32.
  2. Para cada um dos ramos de registo, siga estes passos:
    1. Seleccione o ramo.
    2. Para o Windows XP, no menu Editar, clique em Permissões.

      Para o Windows 2000 e o Windows NT 4, no menu Segurança (Security), clique em Permissões (Permissions).
  3. Certifique-se de que a conta SYSTEM foi adicionada e de que tem controlo total. Caso contrário, adicione a conta SYSTEM com controlo total.

Método 5: Corrigir a chave de segurança danificada para o serviço MsiServer

  1. Inicie o computador utilizando o Windows 2000.
  2. Clique em Iniciar, clique em Executar, escreva regedit.exe e mude o nome da seguinte chave para Old_Security:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\Security
  3. Reinicie o computador (esta acção é necessária).
  4. Execute novamente o Instmsiw.exe do Installer 2.0; isto corrige a chave de segurança danificada para o serviço MSI.

Propriedades

Artigo: 319624 - Última revisão: quinta-feira, 15 de Março de 2007 - Revisão: 6.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Installer 1.0 nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 1.1 nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 1.2 nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 2.0 nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
Palavras-chave: 
kbpubtypekc kbprb KB319624

Submeter comentários