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You cannot add a printer and you receive printer spooler error messages in Windows XP

Article ID:324757
Last Review:September 25, 2008
Revision:7.0
This article was previously published under Q324757
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SYMPTOMS

You may experience any of the following symptoms on your Windows XP-based computer:
After you start your computer, you may receive the following error message:
Spooler subsystem app has encountered a problem and needs to close.
When you try to start the Print Spooler service, you may receive the following error message:
Spooler subsystem app has encountered a problem and needs to close.
When you try to stop the Print Spooler service, you may receive the following error message:
Spooler subsystem app has encountered a problem and needs to close.
When you click Start, and then click Printers and Faxes, you may receive the following error message:
Spooler subsystem app has encountered a problem and needs to close.
When you click Start, and then click Printers and Faxes to try to view your printers, no printers appear. This issue may occur even if you have a printer installed.
When you click Add a printer, or when you try to print, you may receive the following error message and cannot add a printer:
Operation could not be completed.

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CAUSE

This issue may occur if a third-party printer driver or a third-party service that is installed prevents you from adding printers, or if the third-party printer driver or the third-party service affects the functionality of a newly installed printer.

For example, this issue may occur if the Lexmark print service (LexBce Server service) is installed and is running on your computer before you try to add another printer.

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RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows
If you have a Lexmark printer installed, start with the "Turn off Lexmark print service" section and then, if it is necessary, follow the remaining steps in the order presented to resolve this issue. If you do not have a Lexmark printer installed, go to the "Start computer in safe mode" section, and then follow the remaining steps in the order in which they are presented to resolve this issue. You may find it easier to follow the steps if you print this article first.

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Turn off Lexmark print service

If the Lexmark print service is installed on your computer, turn off the LexBce Server service. To do this, follow these steps:
1.Click Start, right-click My Computer, and then click Manage.
2.Expand Services and Applications, and then click Services.
3.In the details pane, right-click LexBce Server, and then click Properties.
4.On the General tab in the Startup type list, click Disabled.
5.Under Service status, click Stop, and then click OK.
6.Right-click the Print Spooler service, and then click Start (if it is stopped).
7.Exit Computer Management.
Test whether the issue is resolved. If the issue is resolved, you do not have to follow the remaining steps. If the issue is not resolved, go to the "Start computer in safe mode" section, and then follow the remaining steps.

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Start computer in safe mode

Start the computer in safe mode so that you can remove spool files. To do this, follow these steps:
1.Restart your computer and start pressing the F8 key on your keyboard. On a computer that is configured to start multiple operating systems, you can press the F8 key when the Boot menu appears.
2.Select Safe Mode when the Windows Advanced Options menu appears, and then press ENTER.
3.If the Boot menu appears again and you are prompted to select the operating system on the computer, use the arrow keys to select the operating system, and then press ENTER.

Note For more information about how to start your computer in safe mode, click Start, click Help and Support, type safe mode in the Search box, press the ENTER key, and then click the Start Windows in safe mode topic.

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Now delete spool printer and driver files

In safe mode, delete the spool printer and driver files. To do this, start Microsoft Windows Explorer, and then delete all the files and the folders in the following two folders (where C: is the drive where you have Windows XP installed):
C:\Windows\System32\Spool\Printers
C:\Windows\System32\Spool\Drivers\w32x86

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Next, edit the registry

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

First, remove Windows NT subkeys

Remove the potentially problematic registry entries for Windows NT x86 service subkeys. These may have been installed by third-party printer setup programs and may be interfering with the print spool service. Use the following steps to keep the drivers, print spools, and registry entries that came with Windows on your computer and remove all others that may be causing issues.
1.Start Registry Editor. To do this, click Start, click Run, type regedit in the Open box, and then click OK.
2.Locate and expand the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
View the list of subkeys (subfolders). There should only be the following subkeys:
Drivers
Print Processors
3.If there are any subkeys other than the subkeys that are listed in step 2, follow these steps:
a. On the File menu, click Export.
b. In the File Name box, type the name that you want to use for this key, such as WindowsNTx86regkey, and then click Save.

NoteYou can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86 registry key to restore the key if you experience any issues after you complete this procedure.
c. Delete all the subkeys other than the subkeys that are listed in step 2. To do this, right-click each subkey that is not on the list, and then click Delete. Click Yes when you are prompted to confirm the deletion.

Second, remove registry entries for printer drivers

Remove the potentially problematic printer driver subkeys, which may be interfering with the printer you want to use. These may have been installed by third-party printer setup programs. Use the following steps to keep the printer driver and registry entries that came with Windows on your computer and remove all others that may be causing issues.
1.Start Registry Editor if it is not open. To do this, click Start, click Run, type regedit in the Open box, and then click OK.
2.Locate and then expand the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers
The registry entries for the printer drivers that are installed on the computer are stored in the Version-x subkey or subkeys, where x is a number (typically 2 or 3).
3.Export the Version-x subkey or subkeys. To do this, follow these steps:
a. On the File menu, click Export.
b. In the File Name box, type the name that you want to use for this key, such as print driver, and then click Save.
4.Expand the Version-x subkey or subkeys, and then delete the printer driver entries. To do this, right-click each printer driver subkey, and then click Delete. Click Yes when you are prompted to confirm the deletion.

Third, remove registry entries for default print monitors

Remove the potentially problematic print monitor subkeys, which may be interfering with the printer you want to use. These may have been installed by third-party printer setup programs. Use the following steps to keep the print monitors and registry entries that came with Windows and remove all others that may be causing issues.
1.Start Registry Editor if it is not open. To do this, click Start, click Run, type regedit in the Open box, and then click OK.
2.Locate and then expand the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
View the list of subkeys. There should only be the following subkeys for the default print monitors:
BJ Language Monitor
Local Port
PJL Language Monitor
Standard TCP/IP Port
USB Monitor
3.If there are any subkeys other than the subkeys that are listed in step 1, follow these steps:
a. On the File menu, click Export.
b. In the File Name box, type the name that you want to use for this key, such as MonitorsRegkey, and then click Save.

NoteYou can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors registry key to restore the key if you experience any issues after you complete this procedure.
c. Delete all the subkeys other than the subkeys that are listed in step 2. To do this, right-click each subkey that is not on the list, and then click Delete. Click Yes when you are prompted to confirm the deletion.
4.Exit Registry Editor.
5.If you have a printer attached to the computer, disconnect the printer cable from the computer, and then restart the computer.

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Now verify that the print spooler service is running

Verify that the print spooler service is running. To do this, follow these steps:
1.Click Start, right-click My Computer, and then click Manage.
2.Expand Services and Applications, and then click Services.
3.In the details pane, right-click the Print Spooler service, and then click Start (if it is stopped).
4.Exit Computer Management.
If you cannot start the Print Spooler service, follow the steps in the following Microsoft Knowledge Base article to start the Print Spooler service:
919750 (http://support.microsoft.com/kb/919750/) You experience problems printing, viewing printer icons, and adding printers, the Print Spooler service does not function correctly, and you receive print-related error messages on a Windows XP-based computer

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Finally, add a printer and print a test page

If you have a printer attached, reconnect the printer cable to the computer, install the printer by adding it to the computer through the Add Printer Wizard, and then try to print a test page. To install the printer you want, follow these steps:
1.Click Start, and then click Printers and Faxes.
2.Click Add a printer. The Add Printer Wizard starts.
3.Follow the instructions in the Add Printer Wizard to install the printer that you want.
4.Print a test page to make sure that you can print.
If you still cannot print or if you are still receiving print spool errors, go to the "Next Steps" Section.

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NEXT STEPS

If these methods did not work for you, you can use the Microsoft Customer Support Services Web site to find other solutions to your problem. Services that the Microsoft Customer Support Services Web sites provide include the following:
Searchable Knowledge Base (http://support.microsoft.com/search/?adv=1): Search technical support information and self-help tools for Microsoft products.
Solution Centers (http://support.microsoft.com/select/?target=hub): View product-specific frequently asked questions and support highlights.
Microsoft Customer Support Newsgroups (http://www.microsoft.com/communities/newsgroups/default.mspx): Contact counterparts, peers, and Microsoft Most Valuable Professionals (MVPs).
Other Support Options (http://support.microsoft.com/default.aspx?pr=csshome): Use the Web to ask a question, contact Microsoft Customer Support Services, or provide feedback.
If you continue to have printing problems, you might want to contact Support:
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

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MORE INFORMATION

For more information about how to troubleshoot printing problems in Windows XP, click the following article numbers to view the articles in the Microsoft Knowledge Base:
314085 (http://support.microsoft.com/kb/314085/) Advanced troubleshooting for when you cannot print in Windows XP
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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APPLIES TO
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition

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Keywords: 
kbtshoot kbresolve kbregistry kb3rdparty kbenv kbprint kbdriver kberrmsg kbprb KB324757

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