Δεν είναι δυνατή η προσθήκη εκτυπωτή και εμφανίζονται μηνύματα σφάλματος ουράς εκτύπωσης στα Windows XP

Αναγν. άρθρου: 324757 - Δείτε τα προϊόντα στα οποία αναφέρεται το συγκεκριμένο άρθρο.
Ανάπτυξη όλων | Σύμπτυξη όλων

Σε αυτήν τη σελίδα

Συμπτώματα

Ενδέχεται να αντιμετωπίσετε κάποιο από τα παρακάτω συμπτώματα στον υπολογιστή σας με Windows XP:
  • Μετά την εκκίνηση του υπολογιστή σας, ενδέχεται να εμφανιστεί το ακόλουθο μήνυμα σφάλματος:
    Η εφαρμογή Spooler subsystem app αντιμετώπισε πρόβλημα και πρέπει να τερματιστεί η λειτουργία της. (Spooler subsystem app has encountered a problem and needs to close.)
  • Όταν προσπαθείτε να ξεκινήσετε την υπηρεσία "Ουρά εκτύπωσης" (Print Spooler), ενδέχεται να εμφανιστεί το ακόλουθο μήνυμα σφάλματος:
    Η εφαρμογή Spooler subsystem app αντιμετώπισε πρόβλημα και πρέπει να τερματιστεί η λειτουργία της. (Spooler subsystem app has encountered a problem and needs to close.)
  • Όταν προσπαθείτε να διακόψετε την υπηρεσία "Ουρά εκτύπωσης" (Print Spooler), ενδέχεται να εμφανιστεί το ακόλουθο μήνυμα σφάλματος:
    Η εφαρμογή Spooler subsystem app αντιμετώπισε πρόβλημα και πρέπει να τερματιστεί η λειτουργία της. (Spooler subsystem app has encountered a problem and needs to close.)
  • Όταν κάνετε κλικ στο μενού Έναρξη (Start) και, στη συνέχεια, κάνετε κλικ στην επιλογή Εκτυπωτές και φαξ (Printers and Faxes), ενδέχεται να εμφανιστεί το ακόλουθο μήνυμα σφάλματος:
    Η εφαρμογή Spooler subsystem app αντιμετώπισε πρόβλημα και πρέπει να τερματιστεί η λειτουργία της. (Spooler subsystem app has encountered a problem and needs to close.)
  • Όταν κάνετε κλικ στο μενού Έναρξη (Start) και, στη συνέχεια, κάνετε κλικ στην επιλογή Εκτυπωτές και φαξ (Printers and Faxes) για να προβάλετε τους εκτυπωτές σας, δεν εμφανίζεται κανένας εκτυπωτής. Αυτό το ζήτημα ενδέχεται να παρουσιαστεί ακόμα και αν υπάρχει εγκατεστημένος εκτυπωτής.
  • Όταν κάνετε κλικ στην επιλογή Προσθήκη εκτυπωτή (Add a printer) ή προσπαθείτε να εκτυπώσετε, ενδέχεται να εμφανιστεί το ακόλουθο μήνυμα σφάλματος και να μην είναι δυνατή η προσθήκη εκτυπωτή:
    Η λειτουργία δεν ήταν δυνατό να ολοκληρωθεί. (Operation could not be completed.)

Αιτία

Αυτό το ζήτημα μπορεί να παρουσιαστεί όταν ένα πρόγραμμα οδήγησης εκτυπωτή άλλου κατασκευαστή ή μια υπηρεσία άλλου κατασκευαστή που είναι εγκατεστημένα στον υπολογιστή σας αποτρέπουν την προσθήκη εκτυπωτών ή όταν το πρόγραμμα οδήγησης εκτυπωτή άλλου κατασκευαστή ή η υπηρεσία άλλου κατασκευαστή επηρεάζουν τις λειτουργίες ενός πρόσφατα εγκατεστημένου εκτυπωτή.

Για παράδειγμα, αυτό το ζήτημα μπορεί να παρουσιαστεί αν εγκατασταθεί και εκτελείται στον υπολογιστή σας η υπηρεσία εκτύπωσης της Lexmark (υπηρεσία LexBce Server) πριν να προσπαθήσετε να προσθέσετε άλλον εκτυπωτή.

Για να επιλυθεί αυτό το πρόβλημα από εμάς, μεταβείτε στην ενότητα "Αυτόματη επίλυση". Αν προτιμάτε να επιλύσετε το πρόβλημα μόνοι σας, μεταβείτε στην ενότητα "Επίλυση από το χρήστη".

Αυτόματη επίλυση

Για την αυτόματη επίλυση του προβλήματος, κάντε κλικ στη σύνδεση Επίλυση του προβλήματος. Στη συνέχεια, επιλέξτε το στοιχείο Εκτέλεση (Run) στο παράθυρο διαλόγου Λήψη αρχείου (File Download) και ακολουθήστε τα βήματα αυτού του οδηγού.

Επίλυση του προβλήματος
Αυτόματη επίλυση της Microsoft 50126



Σημείωση Η Επίλυση μπορεί να εκτελεστεί σε Light ή σε Πλήρη λειτουργία.

Η Light λειτουργία πραγματοποιεί αλλαγές στην ουρά που κανονικά δεν απαιτούν την πραγματοποίηση άλλων αλλαγών εκ μέρους σας. Η Πλήρης λειτουργία επαναφέρει την ουρά εκτύπωσης στις προεπιλεγμένες ρυθμίσεις και απαιτεί την εκ νέου εγκατάσταση των εκτυπωτών σας.

Σημείωση Ο οδηγός αυτός ενδέχεται να είναι διαθέσιμος μόνο στα Αγγλικά. Ωστόσο, η αυτόματη επιδιόρθωση λειτουργεί και για άλλες εκδόσεις γλώσσας των Windows.

Σημείωση Αν δεν βρίσκεστε στον υπολογιστή που παρουσιάζει το πρόβλημα, αποθηκεύστε την αυτόματη επιδιόρθωση σε μια μονάδα δίσκου flash ή σε ένα CD και εκτελέστε την αργότερα στον υπολογιστή που παρουσιάζει το πρόβλημα.

Τώρα, μεταβείτε στην ενότητα "Επιλύθηκε το πρόβλημα;".

Επίλυση από το χρήστη

Σημαντικό Αυτή η ενότητα, μέθοδος ή εργασία περιέχει βήματα που σας καθοδηγούν στην τροποποίηση του μητρώου. Ωστόσο, ενδέχεται να προκύψουν σοβαρά προβλήματα αν δεν τροποποιήσετε σωστά το μητρώο. Κατά συνέπεια, βεβαιωθείτε ότι θα ακολουθήσετε προσεκτικά αυτά τα βήματα. Για επιπλέον προστασία, δημιουργήστε αντίγραφα ασφαλείας του μητρώου πριν το τροποποιήσετε. Στη συνέχεια, μπορείτε να επαναφέρετε το μητρώο, αν προκύψει πρόβλημα. Για περισσότερες πληροφορίες σχετικά με τον τρόπο δημιουργίας αντιγράφων ασφαλείας και επαναφοράς του μητρώου, κάντε κλικ στον αριθμό του άρθρου παρακάτω για να προβάλετε το άρθρο της Γνωσιακής Βάσης (Knowledge Base) της Microsoft:
322756 Τρόπος δημιουργίας αντιγράφων ασφαλείας και επαναφοράς του μητρώου στα Windows XP
Αν ο εγκατεστημένος εκτυπωτής είναι Lexmark, ξεκινήστε με την ενότητα "Απενεργοποιήστε την υπηρεσία εκτύπωσης της Lexmark" και, στη συνέχεια, αν είναι απαραίτητο, ακολουθήστε τα υπόλοιπα βήματα με τη σειρά που παρουσιάζονται για να επιλύσετε το ζήτημα. Αν ο εγκατεστημένος εκτυπωτής δεν είναι Lexmark, μεταβείτε στην ενότητα "Κάντε εκκίνηση του υπολογιστή σε ασφαλή λειτουργία" και, στη συνέχεια, ακολουθήστε τα υπόλοιπα βήματα με τη σειρά που παρουσιάζονται για να επιλύσετε το ζήτημα. Ίσως είναι ευκολότερο να ακολουθήσετε αυτά τα βήματα αν πρώτα εκτυπώσετε αυτό το άρθρο.

Απενεργοποιήστε την υπηρεσία εκτύπωσης της Lexmark

Αν είναι εγκατεστημένη στον υπολογιστή σας η υπηρεσία εκτύπωσης της Lexmark, απενεργοποιήστε την υπηρεσία LexBce Server. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Κάντε κλικ στο μενού Έναρξη (Start), κάντε δεξί κλικ στο στοιχείο Ο Υπολογιστής μου (My Computer) και, στη συνέχεια, κάντε κλικ στην επιλογή Διαχείριση (Manage).
  2. Αναπτύξτε το στοιχείο Υπηρεσίες και εφαρμογές (Services and Applications) και, στη συνέχεια, κάντε κλικ στο στοιχείο Υπηρεσίες (Services).
  3. Στο παράθυρο λεπτομερειών, κάντε δεξί κλικ στο στοιχείο LexBce Server και, στη συνέχεια, κάντε κλικ στην επιλογή Ιδιότητες (Properties).
  4. Στην καρτέλα Γενικά (General), στη λίστα Τύπος εκκίνησης (Startup type), κάντε κλικ στην επιλογή Απενεργοποίηση (Disabled).
  5. Στην περιοχή Κατάσταση υπηρεσίας (Service status), κάντε κλικ στο κουμπί Διακοπή (Stop) και κατόπιν κάντε κλικ στο κουμπί OK.
  6. Κάντε δεξιό κλικ στην υπηρεσία Ουρά εκτύπωσης (Print Spooler) και, στη συνέχεια, κάντε κλικ στην εντολή Εκκίνηση (Start) (εάν έχει διακοπεί).
  7. Κλείστε τη Διαχείριση Υπολογιστή (Computer Management).
Ελέγξτε αν έχει επιλυθεί το ζήτημα. Εάν το ζήτημα έχει επιλυθεί, μην ακολουθήσετε τα υπόλοιπα βήματα. Αν το ζήτημα δεν έχει επιλυθεί, μεταβείτε στην ενότητα "Κάντε εκκίνηση του υπολογιστή σε ασφαλή λειτουργία" και, στη συνέχεια, ακολουθήστε τα υπόλοιπα βήματα.

Κάντε εκκίνηση του υπολογιστή σε ασφαλή λειτουργία

Ξεκινήστε τον υπολογιστή σας σε ασφαλή λειτουργία ώστε να μπορείτε να καταργήστε τα αρχεία εκτύπωσης σε ουρά. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Κάντε επανεκκίνηση του υπολογιστή σας και αρχίστε να πιέζετε το πλήκτρο F8 στο πληκτρολόγιο. Σε έναν υπολογιστή που έχει ρυθμιστεί για εκκίνηση πολλών λειτουργικών συστημάτων, μπορείτε να πιέσετε το πλήκτρο F8 όταν δείτε το μενού Εκκίνηση (Boot).
  2. Επιλέξτε την Ασφαλή λειτουργία (Safe Mode) όταν εμφανιστεί το μενού Επιλογές για προχωρημένους των Windows (Windows Advanced Options) και, στη συνέχεια, πιέστε το πλήκτρο ENTER.
  3. Αν εμφανιστεί ξανά το μενού Εκκίνηση (Boot) και σας ζητηθεί να επιλέξετε το λειτουργικό σύστημα του υπολογιστή, χρησιμοποιήστε τα πλήκτρα βέλους για να επιλέξετε το λειτουργικό σύστημα και, στη συνέχεια, πιέστε το πλήκτρο ENTER.

    Σημείωση Για περισσότερες πληροφορίες σχετικά με τον τρόπο εκκίνησης του υπολογιστή σας σε ασφαλή λειτουργία, κάντε κλικ στο μενού Έναρξη (Start), επιλέξτε το στοιχείο Βοήθεια και υποστήριξη (Help and Support), πληκτρολογήστε safe mode στο πλαίσιο Αναζήτηση (Search), πιέστε το πλήκτρο ENTER και, στη συνέχεια, κάντε κλικ στο θέμα Εκκίνηση των Windows σε ασφαλή λειτουργία (Start Windows in safe mode).

Τώρα, διαγράψτε τα αρχεία εκτύπωσης σε ουρά και τα αρχεία προγραμμάτων οδήγησης

Στην ασφαλή λειτουργία, διαγράψτε τα αρχεία εκτύπωσης σε ουρά και τα αρχεία προγραμμάτων οδήγησης. Για να το κάνετε αυτό, ξεκινήστε την Εξερεύνηση των Microsoft Windows (Microsoft Windows Explorer) και, στη συνέχεια, διαγράψτε όλα τα αρχεία και τους φακέλους στους εξής δύο φακέλους (όπου C: είναι η μονάδα δίσκου όπου είναι εγκατεστημένα τα Windows XP):
  • C:\Windows\System32\Spool\Printers
  • C:\Windows\System32\Spool\Drivers\w32x86

Στη συνέχεια, επεξεργαστείτε το μητρώο

Προειδοποίηση Ενδέχεται να προκύψουν σοβαρά προβλήματα σε περίπτωση λανθασμένης τροποποίησης του μητρώου με χρήση του Επεξεργαστή Μητρώου (Registry Editor) ή άλλης μεθόδου. Λόγω αυτών των προβλημάτων, ενδέχεται να χρειαστεί εκ νέου εγκατάσταση του λειτουργικού συστήματος. Η Microsoft δεν μπορεί να εγγυηθεί ότι τα προβλήματα αυτά είναι δυνατό να επιλυθούν. Τροποποιήστε το μητρώο με δική σας ευθύνη.

Πρώτα, καταργήστε τα δευτερεύοντα κλειδιά των Windows NT

Καταργήστε τις πιθανώς προβληματικές καταχωρήσεις μητρώου για τα δευτερεύοντα κλειδιά υπηρεσίας των Windows NT x86. Αυτά τα δευτερεύοντα κλειδιά ενδέχεται να έχουν εγκατασταθεί από προγράμματα εγκατάστασης εκτυπωτών άλλων κατασκευαστών και να επηρεάζουν την υπηρεσία ουράς εκτύπωσης. Χρησιμοποιήστε τα ακόλουθα βήματα για να διατηρήσετε τα προγράμματα οδήγησης, τις ουρές εκτύπωσης και τις καταχωρήσεις μητρώου που ήταν προεγκατεστημένα με τα Windows στον υπολογιστή σας και για να καταργήσετε όλα τα υπόλοιπα που ενδεχομένως προκαλούν τυχόν ζητήματα.
  1. Εκκινήστε τον Επεξεργαστή Μητρώου (Registry Editor). Για να το κάνετε αυτό, κάντε κλικ στο μενού Έναρξη (Start), κάντε κλικ στην επιλογή Εκτέλεση (Run), πληκτρολογήστε regedit στο πλαίσιο Άνοιγμα (Open) και, στη συνέχεια, κάντε κλικ στο κουμπί ΟΚ.
  2. Εντοπίστε και αναπτύξτε το εξής κλειδί μητρώου:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
    Προβάλετε τη λίστα των δευτερευόντων κλειδιών (υποφακέλων). Πρέπει να υπάρχουν μόνο τα ακόλουθα δευτερεύοντα κλειδιά:
    • Drivers
    • Print Processors
  3. Αν υπάρχουν και άλλα δευτερεύοντα κλειδιά εκτός από τα δευτερεύοντα κλειδιά που αναφέρονται στο βήμα 2, ακολουθήστε τα εξής βήματα:
    1. Στο μενού Αρχείο (File), κάντε κλικ στην εντολή Εξαγωγή (Export).
    2. Στο πλαίσιο Όνομα αρχείου (File Name), πληκτρολογήστε το όνομα που θέλετε να χρησιμοποιήσετε για αυτό το κλειδί, όπωςWindowsNTx86regkey και, στη συνέχεια, κάντε κλικ στο κουμπί Αποθήκευση (Save).

      ΣημείωσηΜπορείτε να χρησιμοποιήσετε αυτό το αντίγραφο του κλειδιού μητρώου
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
      για να επαναφέρετε το κλειδί σε περίπτωση που αντιμετωπίσετε τυχόν ζητήματα μετά την ολοκλήρωση αυτής της διαδικασίας.
    3. Διαγράψτε όλα τα δευτερεύοντα κλειδιά εκτός από αυτά που αναφέρονται στο βήμα 2. Για να το κάνετε αυτό, κάντε δεξί κλικ σε κάθε δευτερεύον κλειδί που δεν αναφέρεται στη λίστα και, στη συνέχεια, κάντε κλικ στην εντολή Διαγραφή (Delete). Κάντε κλικ στο κουμπί Ναι (Yes), όταν σας ζητηθεί να επιβεβαιώσετε τη διαγραφή.

Δεύτερον, διαγράψτε τις καταχωρήσεις μητρώου για τα προγράμματα οδήγησης εκτυπωτών

Καταργήστε τα πιθανώς προβληματικά δευτερεύοντα κλειδιά προγραμμάτων οδήγησης εκτυπωτών, που ενδέχεται να επηρεάζουν τον εκτυπωτή που θέλετε να χρησιμοποιήσετε. Αυτά τα δευτερεύοντα κλειδιά ενδέχεται να έχουν εγκατασταθεί από προγράμματα εγκατάστασης εκτυπωτών άλλων κατασκευαστών. Χρησιμοποιήστε τα ακόλουθα βήματα για να διατηρήσετε τα προγράμματα οδήγησης εκτυπωτών και τις καταχωρήσεις μητρώου που ήταν προεγκατεστημένα με τα Windows στον υπολογιστή σας και για να καταργήσετε όλα τις υπόλοιπα που ενδεχομένως προκαλούν τυχόν ζητήματα.
  1. Εκκινήστε τον Επεξεργαστή Μητρώου (Registry Editor), αν δεν είναι ανοικτός. Για να το κάνετε αυτό, κάντε κλικ στο μενού Έναρξη (Start), κάντε κλικ στην επιλογή Εκτέλεση (Run), πληκτρολογήστε regedit στο πλαίσιο Άνοιγμα (Open) και, στη συνέχεια, κάντε κλικ στο κουμπί ΟΚ.
  2. Εντοπίστε και κατόπιν αναπτύξτε το παρακάτω κλειδί μητρώου:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers
    Οι καταχωρήσεις μητρώου για τα προγράμματα οδήγησης εκτυπωτών που είναι εγκατεστημένα στον υπολογιστή αποθηκεύονται στο δευτερεύον κλειδί ή τα δευτερεύοντα κλειδιά Version-x, όπου x είναι ένας αριθμός (συνήθως το 2 ή το 3).
  3. Εξαγάγετε το δευτερεύον κλειδί ή τα δευτερεύοντα κλειδιά Version-x. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
    1. Στο μενού Αρχείο (File), κάντε κλικ στην εντολή Εξαγωγή (Export).
    2. Στο πλαίσιο Όνομα αρχείου (File Name), πληκτρολογήστε το όνομα που θέλετε να χρησιμοποιήσετε για αυτό το κλειδί, όπωςprint driver και, στη συνέχεια, κάντε κλικ στο κουμπί Αποθήκευση (Save).
  4. Αναπτύξτε το δευτερεύον κλειδί ή τα δευτερεύοντα κλειδιά Version-x και, στη συνέχεια, διαγράψετε τις καταχωρήσεις των προγραμμάτων οδήγησης εκτυπωτών. Για να το κάνετε αυτό, κάντε δεξιό κλικ σε κάθε δευτερεύον κλειδί προγράμματος οδήγησης εκτυπωτή και κατόπιν κάντε κλικ στην εντολή Διαγραφή (Delete). Κάντε κλικ στο κουμπί Ναι (Yes), όταν σας ζητηθεί να επιβεβαιώσετε τη διαγραφή.

Τρίτον, διαγράψτε τις καταχωρήσεις μητρώου για τα προγράμματα εποπτείας εκτυπώσεων

Καταργήστε τα πιθανώς προβληματικά δευτερεύοντα κλειδιά προγραμμάτων εποπτείας εκτυπώσεων, που ενδέχεται να επηρεάζουν τον εκτυπωτή που θέλετε να χρησιμοποιήσετε. Αυτά τα δευτερεύοντα κλειδιά ενδέχεται να έχουν εγκατασταθεί από προγράμματα εγκατάστασης εκτυπωτών άλλων κατασκευαστών. Χρησιμοποιήστε τα ακόλουθα βήματα για να διατηρήσετε τα προγράμματα εποπτείας εκτυπώσεων και τις καταχωρήσεις μητρώου που περιλαμβάνονταν στα Windows και για να καταργήσετε όλα τις υπόλοιπα που ενδεχομένως προκαλούν τυχόν ζητήματα.
  1. Εκκινήστε τον Επεξεργαστή Μητρώου (Registry Editor), αν δεν είναι ανοικτός. Για να το κάνετε αυτό, κάντε κλικ στο μενού Έναρξη (Start), κάντε κλικ στην επιλογή Εκτέλεση (Run), πληκτρολογήστε regedit στο πλαίσιο Άνοιγμα (Open) και, στη συνέχεια, κάντε κλικ στο κουμπί ΟΚ.
  2. Εντοπίστε και κατόπιν αναπτύξτε το παρακάτω κλειδί μητρώου:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    Προβάλετε τη λίστα των δευτερευόντων κλειδιών. Πρέπει να υπάρχουν μόνο τα ακόλουθα δευτερεύοντα κλειδιά για τα προεπιλεγμένα προγράμματα εποπτείας εκτυπώσεων:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  3. Αν υπάρχουν και άλλα δευτερεύοντα κλειδιά εκτός από τα δευτερεύοντα κλειδιά που αναφέρονται στο βήμα 1, ακολουθήστε τα εξής βήματα:
    1. Στο μενού Αρχείο (File), κάντε κλικ στην εντολή Εξαγωγή (Export).
    2. Στο πλαίσιο Όνομα αρχείου (File Name), πληκτρολογήστε το όνομα που θέλετε να χρησιμοποιήσετε για αυτό το κλειδί, όπωςMonitorsRegkey και, στη συνέχεια, κάντε κλικ στο κουμπί Αποθήκευση (Save).

      ΣημείωσηΜπορείτε να χρησιμοποιήσετε αυτό το αντίγραφο του κλειδιού μητρώου
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
      για να επαναφέρετε το κλειδί σε περίπτωση που αντιμετωπίσετε τυχόν ζητήματα μετά την ολοκλήρωση αυτής της διαδικασίας.
    3. Διαγράψτε όλα τα δευτερεύοντα κλειδιά εκτός από αυτά που αναφέρονται στο βήμα 2. Για να το κάνετε αυτό, κάντε δεξί κλικ σε κάθε δευτερεύον κλειδί που δεν αναφέρεται στη λίστα και, στη συνέχεια, κάντε κλικ στην εντολή Διαγραφή (Delete). Κάντε κλικ στο κουμπί Ναι (Yes), όταν σας ζητηθεί να επιβεβαιώσετε τη διαγραφή.
  4. Κλείστε τον Επεξεργαστή Μητρώου (Registry Editor).
  5. Αν είναι συνδεδεμένος στον υπολογιστή κάποιος εκτυπωτής, αποσυνδέστε το καλώδιο του εκτυπωτή από τον υπολογιστή και, στη συνέχεια, κάντε επανεκκίνηση του υπολογιστή.

Τώρα επιβεβαιώστε ότι εκτελείται η υπηρεσία ουράς εκτύπωσης

Επιβεβαιώστε ότι εκτελείται η υπηρεσία ουράς εκτύπωσης. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Κάντε κλικ στο μενού Έναρξη (Start), κάντε δεξί κλικ στο στοιχείο Ο Υπολογιστής μου (My Computer) και, στη συνέχεια, κάντε κλικ στην επιλογή Διαχείριση (Manage).
  2. Αναπτύξτε το στοιχείο Υπηρεσίες και εφαρμογές (Services and Applications) και, στη συνέχεια, κάντε κλικ στο στοιχείο Υπηρεσίες (Services).
  3. Στο παράθυρο λεπτομερειών, κάντε δεξί κλικ στην υπηρεσία Ουρά εκτύπωσης (Print Spooler) και, στη συνέχεια, κάντε κλικ στο κουμπί "Εκκίνηση" (Start) (αν έχει διακοπεί).
  4. Κλείστε τη Διαχείριση Υπολογιστή (Computer Management).
Σε περίπτωση που δεν μπορείτε να ξεκινήσετε την υπηρεσία "Ουρά εκτύπωσης" (Print Spooler), ακολουθήστε τα βήματα στο ακόλουθο άρθρο της Γνωσιακής Βάσης (Knowledge Base) της Microsoft για να ξεκινήσετε την υπηρεσία "Ουρά εκτύπωσης" (Print Spooler):
919750 Αντιμετωπίζετε προβλήματα εκτύπωσης, προβολής εικόνων εκτυπωτή και προσθήκης εκτυπωτών, η υπηρεσία Print Spooler δεν λειτουργεί σωστά και λαμβάνετε μηνύματα λάθους που σχετίζονται με την εκτύπωση σε έναν υπολογιστή που χρησιμοποιεί Windows XP

Τέλος, προσθέστε έναν εκτυπωτή και εκτυπώστε μια δοκιμαστική σελίδα

Αν είναι συνδεδεμένος κάποιος εκτυπωτής, συνδέστε ξανά το καλώδιο του εκτυπωτή στον υπολογιστή, εγκαταστήστε τον εκτυπωτή προσθέτοντας τον στον υπολογιστή μέσω του "Οδηγού προσθήκης εκτυπωτή" (Add Printer Wizard) και, στη συνέχεια, προσπαθήστε να εκτυπώσετε μια δοκιμαστική σελίδα. Για να εγκαταστήσετε τον εκτυπωτή που θέλετε, ακολουθήστε τα εξής βήματα:
  1. Κάντε κλικ στο μενού Έναρξη (Start) και κατόπιν κάντε κλικ στην επιλογή Εκτυπωτές και φαξ (Printers and Faxes).
  2. Κάντε κλικ στην επιλογή Προσθήκη εκτυπωτή (Add a printer). Ξεκινά ο "Οδηγός προσθήκης εκτυπωτή" (Add Printer Wizard).
  3. Ακολουθήστε τις οδηγίες του "Οδηγού προσθήκης εκτυπωτή" (Add Printer Wizard), για να εγκαταστήσετε τον εκτυπωτή που θέλετε.
  4. Εκτυπώστε μια δοκιμαστική σελίδα για να βεβαιωθείτε ότι μπορείτε να εκτυπώσετε.
Αν ακόμα δεν μπορείτε να εκτυπώσετε ή αν ακόμα εμφανίζονται σφάλματα ουράς εκτύπωσης, μεταβείτε στην ενότητα "Επιλύθηκε το πρόβλημα;".

Βήματα αντιμετώπισης προβλημάτων για προχωρημένους

Προειδοποίηση Ενδέχεται να προκύψουν σοβαρά προβλήματα σε περίπτωση λανθασμένης τροποποίησης του μητρώου με χρήση του Επεξεργαστή Μητρώου (Registry Editor) ή άλλης μεθόδου. Λόγω αυτών των προβλημάτων, ενδέχεται να χρειαστεί εκ νέου εγκατάσταση του λειτουργικού συστήματος. Η Microsoft δεν μπορεί να εγγυηθεί ότι τα προβλήματα αυτά είναι δυνατό να επιλυθούν. Τροποποιήστε το μητρώο με δική σας ευθύνη.

Τα ακόλουθα βήματα έχει επιβεβαιωθεί ότι διορθώνουν το πρόβλημα κατά το οποίο η υπηρεσία "Ουρά εκτύπωσης" (Print Spooler) δεν ξεκινά και εμφανίζονται μηνύματα σφάλματος RPC όταν στον υπολογιστή σας υπάρχουν εγκατεστημένα προγράμματα οδήγησης εκτυπωτή της Lexmark.

Υπάρχουν περιπτώσεις όπου η υπηρεσία "Ουρά εκτύπωσης" (Print Spooler) δεν ξεκινά μετά την απενεργοποίηση της υπηρεσίας LexBce Server και την κατάργηση των προγραμμάτων οδήγησης εκτυπωτών της Lexmark. Αυτό το ζήτημα μπορεί να παρουσιαστεί όταν η υπηρεσία "Ουρά εκτύπωσης" (Print Spooler) εξαρτάται από την υπηρεσία LexBce Server. Για να καταργήσετε την εξάρτηση και να ρυθμίσετε την υπηρεσία "Ουρά εκτύπωσης" (Print Spooler) ώστε να εξαρτάται αποκλειστικά από την υπηρεσία κλήσης απομακρυσμένης διαδικασίας (RPC), ακολουθήστε τα εξής βήματα:
  1. Εκκινήστε τον Επεξεργαστή Μητρώου (Registry Editor). Για να το κάνετε αυτό, κάντε κλικ στο μενού Έναρξη (Start), κάντε κλικ στην επιλογή Εκτέλεση (Run), πληκτρολογήστε regedit στο πλαίσιο Άνοιγμα (Open) και, στη συνέχεια, κάντε κλικ στο κουμπί ΟΚ.
  2. Διαγράψτε την υπηρεσία LexBce Server. Για να το κάνετε αυτό, διαγράψτε το ακόλουθο κλειδί μητρώου:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LexBces
  3. Βεβαιωθείτε ότι η υπηρεσία "Ουρά εκτύπωσης) (Print Spooler) εξαρτάται μόνο από την υπηρεσία RPC. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
    1. Εντοπίστε και κατόπιν κάντε κλικ στο εξής κλειδί μητρώου:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Spooler
    2. Στο παράθυρο λεπτομερειών, εάν η τιμή DependOnService εμφανίζει τις τιμές RPCSS και LexBce, κάντε δεξιό κλικ στην επιλογή DependOnService και, στη συνέχεια, κάντε κλικ στην εντολή Τροποποίηση (Modify).
    3. Στο πλαίσιο Δεδομένα τιμής (Value data), πληκτρολογήστε LexBce και κατόπιν κάντε κλικ στο κουμπί ΟΚ.
  4. Κλείστε τον Επεξεργαστή Μητρώου (Registry Editor).
  5. Κάντε επανεκκίνηση της υπηρεσίας "Ουρά εκτύπωσης" (Print Spooler). Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
    • Κάντε κλικ στο μενού Έναρξη (Start), κάντε κλικ στην επιλογή Εκτέλεση (Run), πληκτρολογήστε net stop spooler στο πλαίσιο Άνοιγμα (Open) και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
    • Κάντε κλικ στο μενού Έναρξη (Start), κάντε κλικ στην επιλογή Εκτέλεση (Run), πληκτρολογήστε net start spooler στο πλαίσιο Άνοιγμα (Open) και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
Ελέγξτε αν το ζήτημα έχει επιλυθεί. Αν το ζήτημα δεν έχει επιλυθεί, μεταβείτε στην ενότητα "Επιλύθηκε το πρόβλημα;".

Επιλύθηκε το πρόβλημα;

Ελέγξτε αν το πρόβλημα έχει επιλυθεί. Αν το πρόβλημα επιλύθηκε, δεν χρειάζεστε πλέον αυτό το άρθρο. Αν αυτές οι μέθοδοι δεν απέδωσαν, μπορείτε να χρησιμοποιήσετε την τοποθεσία των Υπηρεσιών Υποστήριξης Πελατών της Microsoft στο Web για να βρείτε άλλες λύσεις για το πρόβλημα που αντιμετωπίζετε. Η τοποθεσία των Υπηρεσιών Υποστήριξης Πελατών της Microsoft στο Web περιλαμβάνει τις εξής υπηρεσίες:

Περισσότερες πληροφορίες

Για περισσότερες πληροφορίες σχετικά με τον τρόπο αντιμετώπισης προβλημάτων εκτύπωσης στα Windows XP, κάντε κλικ στους αριθμούς των άρθρων παρακάτω, για να προβάλετε τα άρθρα της Γνωσιακής Βάσης της Microsoft (Knowledge Base):
314085 Εφαρμογή αντιμετώπισης προβλημάτων για προχωρημένους για την περίπτωση όπου δεν μπορείτε να κάνετε εκτύπωση στα Windows XP
Τα προϊόντα άλλων κατασκευαστών που αναφέρονται σε αυτό το άρθρο έχουν κατασκευαστεί από εταιρείες ανεξάρτητες από τη Microsoft. Η Microsoft δεν παρέχει καμία εγγύηση, σιωπηρή ή άλλη, σχετικά με τις επιδόσεις ή την αξιοπιστία αυτών των προϊόντων.

Για βοήθεια σχετικά με προβλήματα εκτυπωτών στα Windows Vista, επισκεφθείτε την ακόλουθη τοποθεσία της Microsoft στο Web:
Σημείωση Αυτό είναι ένα άρθρο «ΤΑΧΕΙΑΣ ΔΗΜΟΣΙΕΥΣΗΣ» που δημιουργήθηκε απευθείας από τον οργανισμό υποστήριξης της Microsoft. Οι πληροφορίες που περιλαμβάνονται σε αυτό το άρθρο, παρέχονται ως απόκριση σε θέματα που προκύπτουν. Ως αποτέλεσμα της ταχύτητας διάθεσής του, το υλικό ενδέχεται να έχει τυπογραφικά λάθη και να αναθεωρηθεί ανά πάσα στιγμή χωρίς ειδοποίηση. Ανατρέξτε στους Όρους χρήσης για άλλα ζητήματα.

Ιδιότητες

Αναγν. άρθρου: 324757 - Τελευταία αναθεώρηση: Παρασκευή, 28 Οκτωβρίου 2011 - Αναθεώρηση: 11.0
Οι πληροφορίες σε αυτό το άρθρο ισχύουν για:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Λέξεις-κλειδιά: 
kbfixme kbmsifixme kbtshoot kbresolve kbregistry kb3rdparty kbenv kbprint kbdriver kberrmsg kbprb KB324757

Αποστολή σχολίων