Help and Support
 

powered byLive Search

Messages d'erreur "L'application sous-système spouleur a rencontré un problème et doit fermer" et "Impossible de terminer cette opération"

Numéro d'article:324757
Dernière mise à jour:dimanche 30 septembre 2007
Version:5.1
Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 (http://support.microsoft.com/kb/256986/) Description du Registre de Microsoft Windows

Symptômes

Vous pouvez rencontrer l'un des problèmes suivants sur votre ordinateur Microsoft Windows XP :
?Lorsque vous démarrez votre ordinateur, lorsque vous essayez de démarrer ou d'arrêter le service Spouleur d'impression, ou lorsque vous cliquez sur Démarrer, puis sur Imprimantes et télécopieurs, le message d'erreur suivant peut s'afficher :
L'application sous-système spouleur a rencontré un problème et doit fermer.
?Lorsque vous cliquez sur Démarrer, puis sur Imprimantes et télécopieurs pour essayer d'afficher vos imprimantes, aucune imprimante n'apparaît, bien que vous en ayez installé une. Si vous cliquez sur Ajouter une imprimante ou si vous tentez d'imprimer, le message d'erreur suivant peut s'afficher :
Impossible de terminer cette opération.
De ce fait, vous ne pouvez pas ajouter d'imprimante.

Retour au début

Cause

Ce problème peut se produire si un pilote d'imprimante ou un service d'impression tiers installé sur votre ordinateur vous empêche d'ajouter des imprimantes ou si le pilote d'imprimante ou le service d'impression tiers affecte le fonctionnement d'une imprimante récemment installée.

Par exemple, ce problème peut se produire si le service d'impression Lexmark (service LexBce Server) est installé et en cours d'exécution sur votre ordinateur avant que vous n'essayiez d'ajouter une autre imprimante.

Retour au début

Résolution

Avertissement Toute utilisation incorrecte de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

Pour résoudre ce problème, procédez comme suit :
1.Si le service d'impression Lexmark est installé sur votre ordinateur, désactivez le service LexBce Server. Pour cela, procédez comme suit :
a. Cliquez sur Démarrer, cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Gérer.
b. Développez Services et applications, puis cliquez sur Services.
c. Dans le volet droit, cliquez avec le bouton droit sur LexBce Server, puis cliquez sur Propriétés.
d. Sous l'onglet Général, dans la liste Type de démarrage, sélectionnez Désactivé.
e. Sous Statut du service, cliquez sur Arrêter, puis sur OK.
f. Cliquez avec le bouton droit sur le service Spouleur d'impression, puis cliquez sur Démarrer (s'il est arrêté).
g. Quittez la Gestion de l'ordinateur.
2. Vérifiez si le problème est résolu. Si tel est le cas, n'effectuez pas les autres étapes indiquées. Dans le cas contraire, passez à l'étape 3 et poursuivez la procédure décrite.
3.Démarrez l'ordinateur en mode sans échec.

Pour plus d'informations sur la façon de démarrer votre ordinateur en mode sans échec, cliquez sur Démarrer, sur Aide et support, tapez mode sans échec dans la zone Rechercher, appuyez sur la touche ENTRÉE, puis cliquez sur la rubrique Démarrer l'ordinateur en mode sans échec.
4. Démarrez l'Explorateur Microsoft Windows, puis supprimez tous les fichiers et dossiers des deux dossiers suivants (où C: correspond au lecteur où Windows XP est installé) :
?C:\Windows\System32\Spool\Printers
?C:\Windows\System32\Spool\Drivers\w32x86
5.Démarrez l'Éditeur du Registre. Pour cela, cliquez sur Démarrer, sur Exécuter, tapez regedit dans la zone Ouvrir, puis cliquez sur OK.
6.Recherchez et développez la clé de Registre suivante :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
Affichez la liste des sous-clés. Seules les sous-clés suivantes doivent être présentes :
?Drivers
?Print Processors
7.Si des sous-clés autres que celles répertoriées à l'étape 6 sont présentes, procédez comme suit :
a. Dans le menu Fichier, cliquez sur Exporter.
b. Dans la zone Nom de fichier, tapez un nom descriptif pour cette clé (par exemple, WindowsNTx86regkey), puis cliquez sur Enregistrer.

Vous pouvez utiliser cette sauvegarde de la clé de Registre HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86 pour restaurer la clé si vous rencontrez des problèmes après avoir effectué cette procédure.
c. Supprimez toutes les sous-clés autres que celles répertoriées à l'étape 6. Pour cela, cliquez avec le bouton droit sur chaque sous-clé qui ne figure pas dans la liste, puis cliquez sur Supprimer. Cliquez sur Oui lorsque vous êtes invité à confirmer la suppression.
8.Recherchez, puis développez la clé de Registre suivante :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers
Les entrées du Registre relatives aux pilotes d'imprimante installés sur l'ordinateur sont stockées dans la ou les sous-clés Version-x, où x est un nombre (généralement 2 ou 3).
9.Développez la ou les sous-clés Version-x, puis supprimez les entrées des pilotes d'imprimante. Pour cela, cliquez avec le bouton droit sur la sous-clé de chaque pilote d'imprimante, puis cliquez sur Supprimer. Cliquez sur Oui lorsque vous êtes invité à confirmer la suppression.
10.Recherchez et développez la clé de Registre suivante :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
Affichez la liste des sous-clés. Seules les sous-clés suivantes doivent être présentes pour les moniteurs d'impression par défaut :
?BJ Language Monitor
?Local Port
?PJL Language Monitor
?Standard TCP/IP Port
?USB Monitor
11. Si des sous-clés autres que celles répertoriées à l'étape 10 sont présentes, procédez comme suit :
a. Dans le menu Fichier, cliquez sur Exporter.
b. Dans la zone Nom de fichier, tapez un nom descriptif pour cette clé (par exemple, clé_reg_Moniteurs), puis cliquez sur Enregistrer.

Vous pouvez utiliser cette sauvegarde de la clé de Registre HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors pour restaurer la clé si vous rencontrez des problèmes après avoir effectué cette procédure.
c. Supprimez toutes les sous-clés autres que celles répertoriées à l'étape 10. Pour cela, cliquez avec le bouton droit sur chaque sous-clé qui ne figure pas dans la liste, puis cliquez sur Supprimer. Cliquez sur Oui lorsque vous êtes invité à confirmer la suppression.
12.Si une imprimante locale est connectée, débranchez son câble de l'ordinateur, puis redémarrez l'ordinateur.
13.Vérifiez que le service Spouleur d'impression est en cours d'exécution. Pour cela, procédez comme suit :
a. Cliquez sur Démarrer, cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Gérer.
b. Développez Services et applications, puis cliquez sur Services.
c. Dans le volet droit, cliquez avec le bouton droit sur le service Spouleur d'impression, puis cliquez sur Démarrer (s'il est arrêté).
d. Quittez la Gestion de l'ordinateur.
14.Rebranchez le câble de l'imprimante à l'ordinateur (si une imprimante locale est connectée), ajoutez l'imprimante voulue, puis essayez d'imprimer une page de test. Pour ajouter votre imprimante, procédez comme suit :
a. Cliquez sur Démarrer, puis sur Imprimantes et télécopieurs.
b. Cliquez sur Ajouter une imprimante.

L'Assistant Ajout d'imprimante démarre.
c. Suivez les instructions fournies par l'Assistant Ajout d'imprimante pour installer l'imprimante voulue.

Retour au début

Plus d'informations

Pour plus d'informations sur la façon de supprimer manuellement des pilotes d'imprimante, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
135406 (http://support.microsoft.com/kb/135406/) Procédure manuelle de suppression et de réinstallation d'un pilote d'imprimante
Pour plus d'informations sur la façon de résoudre des problèmes d'impression dans Windows XP, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
314085 (http://support.microsoft.com/kb/314085/) Résolution des problèmes généraux d'impression dans Windows XP
Les produits tiers mentionnés dans le présent article proviennent de sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

Retour au début


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
?Microsoft Windows XP Professional
?Microsoft Windows XP Édition familiale

Retour au début

Mots-clés : 
kberrmsg kbregistry kbprint kbenv kbprb kb3rdparty kbdriver KB324757

Retour au début

L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.