文書番号: 330184 - 対象製品
すべて展開する | すべて折りたたむ

現象

Microsoft Windows XP にアップグレードした後、コンピューターを起動するときに、次のいずれかまたは両方のエラー メッセージが表示される場合があります。
無効な BOOT.INI ファイルです
次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした:

Windows\System32\Hal.dll

原因

この問題は、Boot.ini ファイルが存在しないか破損している場合、または Boot.ini ファイルに誤ったエントリが含まれている場合に発生することがあります。

解決方法

この問題を解決するには、Windows XP CD-ROM からコンピューターを起動し、回復コンソールを起動して、Bootcfg.exe ツールを使用し、Boot.ini ファイルを再構築します。これを行うには、以下の手順を実行します。
  1. コンピューターを CD-ROM ドライブまたは DVD-ROM ドライブから起動するように構成します。この方法については、コンピューターのマニュアルを参照するか、コンピューターの製造元に問い合わせてください。
  2. Windows XP の CD-ROM を CD-ROM ドライブまたは DVD-ROM ドライブに挿入し、コンピューターを再起動します。
  3. "Press any key to boot from CD" というメッセージが表示されたら、任意のキーを押してコンピューターを Windows XP の CD-ROM から起動します。
  4. "セットアップの開始" メッセージが表示されたら、R キーを押して回復コンソールを起動します。
  5. デュアル ブートまたはマルチ ブートのコンピューターの場合は、インストール済みのオペレーティング システムのうち、回復コンソールを使用する必要があるシステムを選択します。
  6. Administrator のパスワードを要求されたら、パスワードを入力し、Enter キーを押します。
  7. コマンド プロンプトで「bootcfg /list」と入力し、Enter キーを押します。画面に現在の Boot.ini ファイルのエントリが表示されます。
  8. コマンド プロンプトで「bootcfg /rebuild」と入力し、Enter キーを押します。このコマンドでは、コンピューターのハード ディスク上で Windows XP、Microsoft Windows 2000、Microsoft Windows NT のインストールがスキャンされ、結果が表示されます。画面の指示に従って、Windows インストールを Boot.ini ファイルに追加します。以下に、Windows XP インストールを Boot.ini ファイルに追加する方法の例を示します。
    1. 次のようなメッセージが表示されたら、Y キーを押します。
      Windows のインストールとして認識された合計数: 1

      [1] C:\Windows
      インストールをブート一覧に追加しますか? (Yes/No/All)
    2. 次のようなメッセージが表示されます。
      読み込み識別子を入力してください
      これはオペレーティング システムの名前です。このメッセージが表示されたら、オペレーティング システムの名前を入力し、Enter キーを押します。これは Microsoft Windows XP ProfessionalMicrosoft Windows XP Home Edition のいずれかです。
    3. 次のようなメッセージが表示されます。
      読み込みオプションを入力してください
      このメッセージが表示されたら、「/fastdetect」と入力して Enter キーを押します。

      : 画面に表示される指示は、コンピューターの構成によって異なることがあります。
  9. exit」と入力して Enter キーを押し、回復コンソールを終了します。コンピューターが再起動し、"オペレーティング システムの選択" メッセージに、更新されたブート一覧が表示されます。

詳細

Bootcfg.exe ツールの詳細については、以下のサポート技術情報番号をクリックしてください。
291980 Bootcfg コマンドとその使用法について
回復コンソールの詳細については、以下のサポート技術情報番号をクリックしてください。
289022 Windows XP で Boot.ini ファイルを編集する方法
307654 Windows XP での回復コンソールのインストールおよび使用方法
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。

プロパティ

文書番号: 330184 - 最終更新日: 2013年6月10日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
キーワード:?
kbenv kberrmsg kbprb KB330184
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com