文章编号: 330184 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

当您升级到 Microsoft Windows XP 之后,在启动计算机时,可能会收到以下两条或其中一条错误信息:
Invalid Boot.ini
Windows could not start because the following file is missing or corrupt:

Windows\System32\Hal.dll

原因

如果 Boot.ini 文件丢失、损坏或包含不正确的项,就可能会发生此问题。

解决方案

要解决此问题,请从 Windows XP 安装光盘启动计算机,启动故障恢复控制台,然后使用 Bootcfg.exe 工具重新生成 Boot.ini 文件。为此,请按照下列步骤操作:
  1. 将计算机配置为从 CD-ROM 或 DVD-ROM 驱动器启动。有关如何进行此配置的信息,请参阅您的计算机文档或与您的计算机制造商联系。
  2. 将 Windows XP 安装光盘插入 CD-ROM 或 DVD-ROM 驱动器中,然后重新启动计算机。
  3. 在收到“按任意键以从 CD 启动”消息时,请按任意键以从 Windows XP 安装光盘启动计算机。
  4. 在收到“欢迎使用安装程序”消息时,按 R 键以启动故障恢复控制台。
  5. 如果您使用的是双启动或多启动计算机,请从故障恢复控制台中选择需要使用的安装。
  6. 出现提示时,键入管理员密码,然后按 Enter 键。
  7. 在命令提示符处,键入 bootcfg /list,然后按 Enter 键。当前 Boot.ini 文件中的各项会显示在屏幕上。
  8. 在命令提示符处,键入 bootcfg /rebuild,然后按 Enter 键。此命令会扫描计算机硬盘中的 Windows XP、Microsoft Windows 2000 或 Microsoft Windows NT 安装,然后显示扫描结果。按照屏幕上显示的说明将 Windows 安装添加到 Boot.ini 文件中。例如,按照下列步骤将 Windows XP 安装添加到 Boot.ini 文件中:
    1. 收到一条与以下消息类似的消息时,请按 Y 键:
      总共识别的 Windows 安装:1

      [1] C:\Windows
      将安装添加到启动列表吗?(是/不/全部)
    2. 您会收到一条与以下消息类似的消息:
      输入加载标识符
      这是操作系统的名称。收到此消息时,请键入操作系统的名称,然后按 Enter 键。该名称为 Microsoft Windows XP ProfessionalMicrosoft Windows XP Home Edition
    3. 您会收到一条与以下消息类似的消息:
      输入 OS 加载选项
      收到此消息时,请键入 /fastdetect,然后按 Enter 键。

      注意:显示在屏幕上的这些说明可能会因您计算机的配置而有所不同。
  9. 键入 exit,然后按 Enter 键退出故障恢复控制台。计算机重新启动,在收到“请选择要启动的操作系统”消息时,会显示已更新的启动列表。

更多信息

有关 Bootcfg.exe 工具的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
291980 Bootcfg 命令及其用法讨论
有关故障恢复控制台的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
289022 如何在 Windows XP 中编辑 Boot.ini 文件
307654 如何安装和使用 Windows XP 的故障恢复控制台

属性

文章编号: 330184 - 最后修改: 2013年6月10日 - 修订: 6.1
这篇文章中的信息适用于:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
关键字:?
kbenv kberrmsg kbprb KB330184
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com