Help and Support

Cómo resolver problemas comunes de "Windows Installer"

Autor: Yuval Sinay MVP
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente. Si ve errores y desea ayudar con este esfuerzo, rellene la encuesta en la parte inferior de este artículo.
Haga clic aquí para ver el artículo original (en inglés): 555175 (http://support.microsoft.com/kb/555175/en-us/)
Id. de artículo:555175
Última revisión:miércoles, 04 de junio de 2008
Versión:1.0

Resumen

Este knowledgebase le puede ayudar a resolver problemas comunes de Windows Installer.

Volver al principio

Síntomas

Cuando intenta install/uninstall algún application/s, los mensajes de advertencia como pueden aparecer:
 
"No se podría tener el acceso al servicio Windows Installer"
 
"Se inicia couldnÆt de servicio Windows Installer"
 
"No podría iniciar el servicio Windows Installer en equipo local." " Error 5 : Acceso denegado . "

Volver al principio

Causa

Los mensaje de error aparecen normalmente después de que se produce error en instalación de Paquete de MSI o de Deshabilitado servicio Windows Installer.

Volver al principio

Solución

< STRONG / > 
Método 1
< STRONG / > 
< STRONG / > 
Anule el registro de Windows Installer y a continuación, vuelva a registrar Windows Installer. Para ello, siga estos pasos:
 
Estar puesto "Iníciese <STRONG> usted" menú </STRONG> hace clic " se ejecuta <STRONG> : </STRONG> . " 1
 
Dentro "Ábrase <STRONG>" </STRONG> empaqueta, escribe " msiexec /unreg" y a continuación, presiona ENTRAR 2.
 
Estar puesto "Iníciese <STRONG> usted" menú </STRONG> hace clic en "se ejecuta <STRONG>" </STRONG> 3.
 
Dentro "Ábrase <STRONG>" </STRONG> empaqueta, escribe " msiexec /regserver" y a continuación, presiona ENTRAR 4.
 
 
Método 2
< STRONG / > 
< STRONG / > < STRONG / > 
Actualice a versión 2 de Windows Installer o versión más reciente. Para ello, siga estos pasos:
 
1 Inicie Microsoft Internet Explorer y a continuación, vaya al sitio Web de Microsoft siguiente:
 
     http://msdn.microsoft.com/downloads
 
2 En el menú de árbol de panel izquierdo, hace clic " <STRONG> programa de instalación y administración del sistema "</STRONG> y a continuación clic" <STRONG> Configura " </STRONG>.
 
3 Clic " <STRONG> Windows Installer " </STRONG> y a continuación, hace clic en el vínculo correspondiente para su sistema operativo.
 
4 Hace clic en "Descárguese <STRONG>" </STRONG> para descargar e instalar versión 2 de Windows Installer o versión más reciente.
 
 
Método 3
< STRONG / > 
< STRONG / > 
Utilice utilidad CleanUp de Windows Installer para desinstalar el producto con error.
 
Descripción de la Herramienta de limpieza de Windows Installe
 
http://support.microsoft.com/default.aspx?scid=kb;en-us;290301
 
 
Método 4
 
< STRONG / > 
El servicio Windows Installer puede deshabilitada en el equipo.
 
1 Go > " Ejecutar" escribe " services.msc" y presiona en botón " Enter" a " Inicio".
 
2 Haga doble clic del servicio llamado " Windows Installer".
 
3 Protege el valor " Tipo de inicio <STRONG> : </STRONG> " campo. Está actualmente establecido en " Deshabilitado" es esto

      problema. Cámbielo seleccionando " Manual" en el cuadro desplegable.
 
 
Método 5
< STRONG / > 
< STRONG / > 
El usuario y sistema vacíos "hacer trabajo temporal" carpetas.
 
1 Vacía <STRONG> " %systemdrive%\temp </STRONG> " carpeta.
 
2 Vacía <STRONG> " %systemdrive%\%windir%\temp </STRONG> " carpeta.
 
3 Vacía <STRONG> " %systemdrive%\Documents y local\Temp Settings\%username%\Local </STRONG> ".
 
 
Método 6
< STRONG / > 
< STRONG / > 
Habilite Registro de Windows Installer y llame a soporte técnico PSS.
 
< STRONG / > cómo habilitar registro de Windows Installer
 
http://support.microsoft.com/default.aspx?kbid=223300
 
Cómo habilitar Windows Installer que registra en Windows XP
 
http://support.microsoft.com/default.aspx?scid=kb;EN-US;314852
 
 
Método 7
< STRONG / > 
 
Compruebe permisos correctos DCOM y Sistema:
 
http://support.microsoft.com/?id=319624
 
 
Método 8
 
 
< STRONG / > acaba de que actualiza estación de trabajo Windows XP con Service Pack 2 y el instalador de ventanas
 
problema aparece sólo después de esta actualización, revisa el knowledgebase siguiente:
 
http://support.microsoft.com/default.aspx?scid=kb;en-us;885894
 
 
Método 9
< STRONG / > 
< STRONG / > 
< STRONG / > comprobación que ejecutan la longitud de instalación de ruta de acceso y la longitud de variables de entorno
 
255 caracteres  
 
 
Método 10
< STRONG / > 
< STRONG / > 
" : " error 1628 error a instalación secuencias de comandos basadas completas si obtiene el error de mensaje
 
Siguió resolución didnÆt el problema a la instrucción anterior y a ello y se acaba de que crea nuevo
 
El paquete de instalación utilizando herramienta InstallShiled deshabilita "Almacene instalación en equipo local en caché"
 
La opción durante el paquete de instalación crea proceso.
 
 
Método 11
< STRONG / > 
< STRONG / > 
Comprueba ahí durante installation/s:
 
 
Warning: Sólo debería modificar estas entradas de Registro si sabe realmente lo que está haciendo. Primero realice su disco duro.  

Clave vacía a. de Registro "InProgress"
 
Compruebe la clave siguiente de Registro:

HKLM\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress

Y limpie cualquier entrada encontrada por usted.
 
Clave "PendingFileRenameOperations" b. Empty/Rename del Registro:
 
Compruebe la clave siguiente de Registro:

Manager\PendingFileRenameOperations HKLM\System\CurrentControlSet\Control\Session

Y limpie cualquier entrada encontrada por usted.
 
 
< STRONG / > 
Método 12
< STRONG / > 
< STRONG / > 
Obtiene actualiza Paquete de MSI del fabricante de software. 
 
 

Volver al principio

Más información

Las opciones de línea de comandos del Microsoft Windows Installer herramienta Msiexec.exe
 
http://support.microsoft.com/default.aspx?scid=kb;en-us;314881
 
Windows Installer 3.1 está disponible
 
http://support.microsoft.com/?id=893803
< U / > 
< U / > 
Windows Installer 4.5 redistribuible
 
http://www.microsoft.com/downloads/details.aspx?FamilyID=5a58b56f-60b6-4412-95b9-54d056d6f9f4&DisplayLang=en
 
Mensaje de error de Windows Installer
 
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/msi/setup/windows_installer_error_messages.asp
 
PRB: Mensaje error de "programa de instalación ha detectado que otro programa requiere al equipo que se reinicia" a que intenta instalar Visual Studio .NET

http://support.microsoft.com/default.aspx?scid=kb;en-us;830608
 

Volver al principio


La información de este artículo se refiere a:
?Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
?Microsoft Windows XP Professional
?Microsoft Windows XP Media Center Edition 2002
?Microsoft Windows XP Home Edition
?Microsoft Windows Server 2003, Standard Edition (32-bit x86)
?Microsoft Windows Server 2003, Web Edition
?Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
?Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
?Microsoft Small Business Server 2000 Standard Edition

Volver al principio

Palabras clave: 
kbpubmvp kbpubtypecca kbhowto KB555175 KbMtes kbmt

Volver al principio

RENUNCIA LEGAL DE COMMUNITY SOLUTIONS
NI MICROSOFT IBÉRICA S.R.L. ("MICROSOFT") NI SUS RESPECTIVOS PROVEEDORES GARANTIZAN LA IDONEIDAD, FIABILIDAD NI EXACTITUD DE LA INFORMACIÓN Y LOS GRÁFICOS INCLUIDOS. TODA LA INFORMACIÓN Y LOS GRÁFICOS RELACIONADOS SE PROPORCIONAN "TAL CUAL" SIN GARANTÍA DE NINGUNA CLASE. SIN PERJUICIO DE NINGUNA GARANTÍA IMPUESTA POR CUALQUIER LEY DE APLICACIÓN OBLIGADA, MICROSOFT Y/O SUS RESPECTIVOS PROVEEDORES RENUNCIAN POR LA PRESENTE A TODA GARANTÍA Y CONDICIÓN RESPECTO A ESTA INFORMACIÓN Y LOS GRÁFICOS RELACIONADOS, INCLUIDA CUALQUIER GARANTÍA Y CONDICIÓN IMPLÍCITA DE COMERCIABILIDAD, IDONEIDAD PARA UN DETERMINADO FIN, ESFUERZO RAZONABLE, TITULARIDAD Y AUSENCIA DE INFRACCIÓN. USTED ADMITE EXPRESAMENTE QUE, SIN PERJUICIO DE LOS CASOS EN LOS CUALES LA LEY VIGENTE PROHÍBA LA EXCLUSIÓN DE RESPONSABILIDAD POR DAÑOS, BAJO NINGÚN CONCEPTO, NI MICROSOFT NI SUS PROVEEDORES ACEPTARÁN RESPONSABILIDAD ALGUNA POR DAÑOS DIRECTOS O INDIRECTOS DE CUALQUIER ÍNDOLE U ORIGEN (INCLUYENDO, ENTRE OTROS, LOS DAÑOS POR PÉRDIDA DE USO, INFORMACIÓN O BENEFICIOS) QUE SE DERIVEN O ESTÉN RELACIONADOS CON EL USO O INCAPACIDAD DE USO DE LA INFORMACIÓN Y LOS GRÁFICOS RELACIONADOS INCLUIDOS.

Volver al principio

Seleccione idioma

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.