Nelze tisknout a zobrazuje se chybová zpráva V aplikaci Spooler SubSystem App došlo k problému a je třeba ji ukončit

Překlady článku Překlady článku
ID článku: 810894 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při pokusu o spuštění nebo zastavení služby Zařazování tisku nebo po kliknutí na tlačítko Start a následném kliknutí na položku Tiskárny a faxy se může zobrazit následující chybová zpráva:
V aplikaci Spooler SubSystem App došlo k problému a je třeba ji ukončit.
Při pokusu o tisk se zobrazí následující chybová zpráva:
Operaci nelze dokončit.

Příčina

K těmto potížím může dojít, pokud ovladač nebo služba tiskárny jiných výrobců ovlivňuje funkce nově instalované tiskárny.

Tyto potíže mohou vzniknout například tehdy, pokud jste před pokusem o přidání další tiskárny instalovali ovladač tiskárny Lexmark (LexBce).

Řešení

Při řešení těchto potíží postupujte takto: Provedení popsaných postupů může být snadnější, pokud si článek nejprve vytisknete.

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows

Krok 1: Spuštění počítače v nouzovém režimu

Chcete-li odebrat soubor zařazování, spusťte počítač v nouzovém režimu. Postupujte následujícím způsobem:
  1. Restartujte počítač a při jeho spouštění opakovaně stiskněte klávesu F8. V počítači, který je konfigurován pro spuštění více operačních systémů, stiskněte po zobrazení spouštěcí nabídky klávesu F8.
  2. Jakmile se zobrazí nabídka Upřesnit možnosti spuštění systému Windows, zvolte možnost Nouzový režim a stiskněte klávesu ENTER.
  3. Pokud se znovu zobrazí spouštěcí nabídka a jste vyzváni k výběru operačního systému, vyberte pomocí kláves se šipkami operační systém, který chcete spustit, a potom stiskněte klávesu ENTER.

    Poznámka: Chcete-li zobrazit další informace o spuštění počítače v nouzovém režimu, klikněte na tlačítko Start, vyberte příkaz Nápověda a odborná pomoc, do pole Hledat zadejte nouzový režim, stiskněte klávesu ENTER a klikněte na téma Spuštění systému Windows v nouzovém režimu.

Krok 2: Odstranění souborů zařazování a ovladačů

V nouzovém režimu odstraňte soubory zařazování a ovladačů. Spusťte Průzkumníka Windows a pak odstraňte všechny soubory a složky v těchto dvou složkách (kde C: je jednotka, v níž je nainstalován systém Windows XP):
  • C:\Windows\System32\Spool\Printers
  • C:\Windows\System32\Spool\Drivers\w32x86

Krok 3: Úprava registru

Upozornění: Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Odebrání podklíčů systému Windows NT

Odeberte potenciálně problematické položky registru pro podklíče služby Windows NT x 86. Je možné, že byly nainstalovány programy pro nastavení tiskárny jiných výrobců a interferují se službou Zařazování tisku. Pomocí následujícího postupu zachováte ovladače, soubory zařazování a položky registru, které byly součástí systému Windows, a odeberete všechny ostatní ovladače, soubory zařazování a položky registru, které mohou způsobovat potíže.
  1. Spusťte program Editor registru. V nabídce Start klikněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedit a potom klikněte na tlačítko OK.
  2. Vyhledejte a rozbalte následující klíč registru a pak si prohlédněte seznam podklíčů (podsložek):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
    Seznam podklíčů by měl obsahovat pouze následující podklíče:
    • Ovladače
    • Tiskové procesory
  3. Pokud se zobrazí jiné podklíče než ty, které jsou uvedeny v kroku 2, postupujte takto:
    1. V nabídce Soubor klikněte na příkaz Exportovat.
    2. Do pole Název souboru zadejte název, který chcete pro tento klíč použít (například WindowsNTx86regkey), a klikněte na tlačítko Uložit.

      V případě, že po dokončení postupu dojde k potížím, můžete vytvořenou zálohu klíče registru
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
      využít při obnovení klíče.
    3. Odstraňte všechny podklíče, které nejsou uvedeny v kroku 2. To provedete kliknutím pravým tlačítkem myši na jednotlivé podklíče, které nejsou uvedeny v seznamu, a výběrem příkazu Odstranit. Až se zobrazí výzva k potvrzení odstranění, klikněte na tlačítko Ano.

Odebrání položek registru pro výchozí sledování tisku

Odeberte potenciálně problematické podklíče sledování tisku, které by mohly být v konfliktu s tiskárnou, kterou chcete použít. Je možné, že byly nainstalovány programy pro nastavení tiskárny jiných výrobců. Pomocí následujícího postupu zachováte sledování tisku a položky registru, které byly součástí systému Windows, a odeberete všechny ostatní sledování tisku a položky registru, které mohou způsobovat potíže.
  1. Spusťte Editor registru, pokud ještě není spuštěn. V nabídce Start klikněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedit a potom klikněte na tlačítko OK.
  2. Vyhledejte a rozbalte následující klíč registru a pak si prohlédněte seznam podklíčů:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    Seznam podklíčů by měl obsahovat pouze následující podklíče pro výchozí sledování tisku:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  3. Pokud se zobrazí jiné podklíče než ty, které jsou uvedeny v kroku 2, postupujte takto:
    1. V nabídce Soubor klikněte na příkaz Exportovat.
    2. Do pole Název souboru zadejte název, který chcete pro tento klíč použít (například Monitorsx86regkey), a klikněte na tlačítko Uložit.
    3. V případě, že po dokončení postupu dojde k potížím, můžete vytvořenou zálohu klíče registru
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
      využít při obnovení klíče.
    4. Odstraňte všechny podklíče, které nejsou uvedeny v kroku 2. To provedete kliknutím pravým tlačítkem myši na jednotlivé podklíče, které nejsou uvedeny v seznamu, a výběrem příkazu Odstranit. Až se zobrazí výzva k potvrzení odstranění, klikněte na tlačítko Ano.
  4. Ukončete program Editor registru.
  5. Je-li tiskárna připojena k počítači, odpojte od počítače kabel tiskárny a pak restartujte počítač.

Krok 4: Instalace tiskárny a tisk zkušební stránky

Znovu připojte tiskový kabel k počítači, podle pokynů výrobce nainstalujte požadovanou tiskárnu a zkuste vytisknout zkušební stránku.

Pokud stále nelze tisknout nebo se zobrazuje chyba zařazování, přejděte k části Další kroky.

DALŠÍ KROKY

Pokud uvedené metody nefungují, můžete k nalezení dalších řešení rovněž použít web služeb podpory zákazníků společnosti Microsoft. Mezi služby poskytované na webu služeb podpory zákazníků společnosti Microsoft patří například následující:
  • Znalostní báze Knowledge Base s možností prohledávání: Slouží k hledání v informacích o technické podpoře a nástrojích samoobslužné podpory pro produkty společnosti Microsoft.
  • Centra řešení: Slouží k zobrazení nejčastějších dotazů k jednotlivým produktům a problémů řešených službami podpory.
  • Další možnosti podpory: Tento web umožňuje klást dotazy související s podporou, obrátit se na služby podpory zákazníků společnosti Microsoft nebo zaslat svůj názor.
Pokud máte potíže i nadále, obraťte se na oddělení podpory:
http://support.microsoft.com/contactus/?ln=cs#tab0

Další informace

Společnost Microsoft se vám snaží usnadnit získání technické podpory poskytnutím informací o kontaktech na jiné výrobce. Tyto kontaktní informace se mohou bez upozornění změnit. Společnost Microsoft neručí za správnost těchto informací o kontaktech.
Produkty jiných výrobců popisované v tomto článku vyrábějí společnosti, které jsou nezávislé na společnosti Microsoft. Společnost Microsoft neposkytuje žádnou záruku (implicitně předpokládanou ani jinou) týkající se výkonu a spolehlivosti těchto produktů.

Kroky při řešení potíží a automatickou opravu běžných potíží s tiskárnou v systému Windows naleznete na následujícím webové stránce společnosti Microsoft:


Poradce při potížích: Problémy s tiskárnou v systému Windows

Vlastnosti

ID článku: 810894 - Poslední aktualizace: 4. července 2013 - Revize: 5.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Klíčová slova: 
kberrmsg kbprb KB810894

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com