Печать невозможна, и появляется сообщение об ошибке «Диспетчер очереди печати - обнаружена ошибка. Приложение будет закрыто»

Переводы статьи Переводы статьи
Код статьи: 810894 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При попытке запустить или остановить службу диспетчера очереди печати или при нажатии кнопки Пуск и выборе команды Принтеры и факсы может появиться следующее сообщение об ошибке:
Диспетчер очереди печати - обнаружена ошибка. Приложение будет закрыто.
При попытке начать печать появляется следующее сообщение об ошибке:
Невозможно завершение операции.

Причина

Такая неполадка может возникнуть, если драйвер принтера или служба стороннего производителя влияют на функциональные возможности установленного принтера.

Например, эта проблема может возникнуть, если перед установкой другого принтера на компьютере уже был установлен драйвер принтера (LexBce) компании Lexmark.

Решение

Для решения проблемы выполните следующие ниже действия. Приведенные в статье указания будет проще выполнять, если предварительно распечатать статью.

Важно! В данный раздел, метод или задачу включены действия по изменению параметров реестра. Однако неправильное изменение параметров реестра может привести к возникновению серьезных проблем. Поэтому такие действия необходимо выполнять очень внимательно. Для дополнительной защиты нужно создать резервную копию реестра. Это позволит восстановить реестр при возникновении неполадок. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
322756 Создание резервной копии, редактирование и восстановление реестра Windows XP и Windows Server 2003

Шаг 1. Загрузите компьютер в безопасном режиме

Загрузите компьютер в безопасном режиме, чтобы удалить файлы очереди печати. Для этого выполните действия, указанные ниже.
  1. Перезагрузите компьютер и несколько раз подряд нажмите клавишу F8 при запуске компьютера. На компьютере, настроенном для загрузки нескольких операционных систем, нажмите клавишу F8, когда появится меню Загрузка.
  2. Выберите Безопасный режим в меню Меню дополнительных вариантов загрузки Windows и нажмите клавишу ВВОД.
  3. Если снова появляется меню Загрузка с запросом на выбор операционной системы, с помощью клавиш со стрелками выберите операционную систему и нажмите клавишу ВВОД.

    Примечание. Дополнительные сведения о загрузке компьютера в безопасном режиме можно получить, если нажать кнопку Пуск, выбрать команду Справка и поддержка, а затем в поле Поиск ввести слова безопасный режим, нажать клавишу ВВОД и выбрать раздел Запуск Windows в безопасном режиме.

Шаг 2. Удалите очередь печати принтера и файлы драйвера

В безопасном режиме удалите очередь печати принтера и файлы драйвера. Для этого запустите проводник Microsoft Windows и удалите все файлы и папки в следующих двух папках (где C: — это диск, на котором установлена Windows XP):
  • C:\Windows\System32\Spool\Printers
  • C:\Windows\System32\Spool\Drivers\w32x86

Шаг 3. Внесите изменения в реестр

Внимание! При неправильном изменении реестра с помощью редактора реестра или иным способом могут возникнуть серьезные проблемы. Эти проблемы могут привести к необходимости переустановки операционной системы. Корпорация Майкрософт не гарантирует разрешения этих проблем. Ответственность за изменение реестра несет пользователь.

Сначала удалите подразделы Windows NT

Удалите записи реестра для подраздела службы Windows NT x86. Они могут быть установлены программами установки принтера сторонних разработчиков и мешать работе службы диспетчера очереди печати. Выполните следующие действия для сохранения драйверов, очереди печати и записей реестра, включенных в Windows, и удаления других драйверов, очередей печати и записей реестра, которые могут быть причиной проблем.
  1. Откройте редактор реестра. Для этого выполните следующие действия: Нажмите кнопку Пуск, выберите пункт Выполнить, в поле Открыть введите команду regedit и нажмите кнопку ОК.
  2. Найдите и разверните следующий раздел реестра, чтобы просмотреть список подразделов.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
    В списке подразделов должны содержаться только следующие подразделы:
    • Drivers
    • Print Processors
  3. Если в данном разделе присутствуют другие подразделы, помимо перечисленных в действии 2, выполните указанные ниже действия.
    1. В меню Файл выберите команду Экспорт.
    2. В поле Имя файла введите имя для данного раздела, например WindowsNTx86regkey, и нажмите кнопку Сохранить.

      Резервную копию раздела реестра
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
      можно применить для восстановления этого раздела при возникновении неполадок после выполнения описанных действий.
    3. Удалите все подразделы, отличные от подразделов, представленных в действии 2. Для этого щелкните каждый подраздел правой кнопкой мыши и выберите команду Удалить. Нажмите кнопку Да, чтобы подтвердить удаление.

Затем удалите записи раздела для мониторов печати по умолчанию

Удалите потенциально проблемные подразделы монитора печати, которые могут мешать используемому принтеру. Они могут быть установлены программами установки принтера сторонних разработчиков. Выполните следующие действия для мониторов печати и записей реестра, включенных в Windows, и удаления мониторов печати и записей реестра, которые могут быть причиной проблем.
  1. Откройте редактор реестра, если он еще не открыт. Для этого выполните следующие действия. Нажмите кнопку Пуск, выберите пункт Выполнить, в поле Открыть введите команду regedit и нажмите кнопку ОК.
  2. Найдите и разверните следующий раздел реестра, чтобы просмотреть список подразделов.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    В списке подразделов должны находиться только следующие подразделы для заданных по умолчанию мониторов печати:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  3. Если в данном разделе присутствуют другие подразделы, помимо перечисленных в действии 2, выполните указанные ниже действия.
    1. В меню Файл выберите команду Экспорт.
    2. В поле Имя файла введите имя для данного раздела, например Monitorsx86regkey, затем нажмите кнопку Сохранить.
    3. Резервную копию раздела реестра
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
      можно применить для восстановления этого раздела при возникновении неполадок после выполнения описанных действий.
    4. Удалите все подразделы, отличные от подразделов, представленных в действии 2. Для этого щелкните каждый подраздел правой кнопкой мыши и выберите команду Удалить. Нажмите кнопку Да, чтобы подтвердить удаление.
  4. Закройте редактор реестра.
  5. Если принтер подключен к компьютеру, отсоедините кабель принтера от компьютера, затем перезагрузите компьютер.

Действие 4. Установите принтер и напечатайте пробную страницу

Снова подсоедините кабель принтера к компьютеру, установите принтер в соответствие с инструкциями производителя и напечатайте пробную страницу.

Если печать по-прежнему невозможна или возникает ошибка очереди печати, перейдите к разделу «Дополнительные действия».

ДАЛЬНЕЙШИЕ ДЕЙСТВИЯ

Если с помощью описанных способов проблему устранить не удалось, можно перейти на веб-сайт службы технической поддержки Майкрософт и попытаться найти другие способы устранения проблемы. Ниже перечислены некоторые услуги, которые можно найти на веб-узле службы технической поддержки Майкрософт.
  • База знаний с возможностью поиска. Поиск технических сведений и рекомендаций по использованию продуктов Майкрософт.
  • Центры решений. Список часто задаваемых вопросов и советов службы поддержки.
  • Прочие виды поддержки. Задайте вопрос в Интернете, обратитесь в службу технической поддержки Майкрософт или отправьте свой отзыв.
Если проблема по-прежнему не устранена, можно обратиться в службу поддержки по следующему адресу:
http://support.microsoft.com/contactus/?ln=ru

Дополнительная информация

Контактные данные сторонних организаций предоставляются с целью помочь пользователям получить необходимую техническую поддержку. Они могут быть изменены без предварительного уведомления. Корпорация Майкрософт не дает гарантий относительно правильности приведенных контактных данных сторонних организаций.
Упомянутые в данной статье сторонние продукты производятся компаниями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не дает никаких гарантий и обязательств в отношении производительности или надежности этих продуктов.

Для получения сведений по устранению неполадок и автоматическому устранению распространенных проблем с принтерами в Windows см. следующую веб-страницу Майкрософт:


Средство устранения неполадок: проблемы с принтерами в Windows
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 810894 - Последний отзыв: 10 июня 2013 г. - Revision: 2.1
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Ключевые слова: 
kberrmsg kbprb KB810894

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com