คุณไม่สามารถพิมพ์ได้ และได้รับข้อความแสดงข้อผิดพลาด "โปรแกรมประยุกต์ระบบย่อยของตัวจัดคิวพบปัญหาและจำต้องปิดโปรแกรม"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 810894 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามเปิดหรือปิดบริการ Print Spooler หรือเมื่อคุณคลิก เริ่ม แล้วคลิก เครื่องพิมพ์และโทรสาร คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้
โปรแกรมประยุกต์ระบบย่อย Spooler พบปัญหาและจำต้องปิดโปรแกรม
เมื่อคุณพยายามพิมพ์ อาจจะได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:
ไม่สามารถดำเนินการให้เสร็จสมบูรณ์

สาเหตุ

ปัญหานี้อาจเกิดขึ้น ถ้าโปรแกรมควบคุมหรือบริการเครื่องพิมพ์ของบริษัทอื่นมีผลกระทบต่อฟังก์ชันการทำงานของเครื่องพิมพ์ที่เพิ่งทำการติดตั้ง

ตัวอย่างเช่น ปัญหานี้อาจเกิดขึ้นถ้ามีการติดตั้งโปรแกรมควบคุมเครื่องพิมพ์แบบกำหนดเอง (LexBce) ของ Lexmark บนคอมพิวเตอร์ของคุณ เมื่อคุณเพิ่มเครื่องพิมพ์อีกเครื่องเข้าไป

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ให้ทำตามขั้นตอนที่นำเสนอต่อไปนี้ ขอแนะนำให้คุณพิมพ์บทความนี้ออกมาเพื่อให้สามารถปฏิบัติตามขั้นตอนต่างๆ ได้ง่ายขึ้น

สิ่งสำคัญ ส่วน วิธีการ หรืองานนี้ประกอบด้วยขั้นตอนต่างๆ เกี่ยวกับวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้อง ดังนั้น โปรดตรวจสอบให้แน่ใจว่าคุณได้ทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองข้อมูลรีจิสทรีก่อนทำการปรับเปลี่ยน เพื่อที่คุณจะสามารถคืนค่ารีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูลและคืนค่ารีจิสทรี ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base:
322756 วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows

ขั้นตอนที่ 1: เริ่มคอมพิวเตอร์ในเซฟโหมด

เริ่มคอมพิวเตอร์ในเซฟโหมดเพื่อเอาแฟ้มการจัดคิวออก โดยให้ทำตามขั้นตอนต่อไปนี้:
  1. เริ่มระบบของคอมพิวเตอร์ของคุณใหม่ และกดปุ่ม F8 ซ้ำๆ ในขณะที่คอมพิวเตอร์กำลังเริ่มต้น ในคอมพิวเตอร์ที่ได้รับการกำหนดค่าให้เรียกใช้ระบบปฏิบัติการหลายระบบ ให้กดปุ่ม F8 เมื่อเมนู เริ่มต้นระบบ ปรากฏขึ้น
  2. เลือก เซฟโหมด เมื่อเมนู ตัวเลือกขั้นสูงของ Windows ปรากฏขึ้น แล้วกด ENTER
  3. ถ้าเมนู เริ่มต้นระบบ ปรากฏขึ้นอีกครั้ง และคุณได้รับพร้อมท์ให้เลือกระบบปฏิบัติการ ให้ใช้ปุ่มลูกศรเพื่อเลือกระบบปฏิบัติการ แล้วกด ENTER

    หมายเหตุ สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการเริ่มคอมพิวเตอร์ในเซฟโหมด ให้คลิก เริ่ม คลิก วิธีใช้และบริการช่วยเหลือ พิมพ์ safe mode ในกล่อง ค้นหา กด ENTER แล้วคลิกหัวข้อ เริ่ม Windows ในเซฟโหมด

ขั้นตอนที่ 2: ให้ลบแฟ้มโปรแกรมควบคุมและเครื่องพิมพ์ที่มีการจัดคิว

ในเซฟโหมด ให้ลบแฟ้มโปรแกรมควบคุมและเครื่องพิมพ์ที่มีการจัดคิว ด้วยวิธีการดังนี้ เริ่ม Microsoft Windows Explorer จากนั้นลบแฟ้มและโฟลเดอร์ทั้งหมดในสองโฟลเดอร์ต่อไปนี้ (โดย C: คือไดรฟ์ที่มีการติดตั้ง Windows XP):
  • C:\Windows\System32\Spool\Printers
  • C:\Windows\System32\Spool\Drivers\w32x86

ขั้นตอนที่ 3: แก้ไขรีจิสทรี

คำเตือน ปัญหาร้ายแรงอาจเกิดขึ้นได้หากคุณปรับเปลี่ยนรีจิสทรีนี้ไม่ถูกต้องโดยใช้ตัวแก้ไขรีจิสทรีหรือโดยใช้วิธีการอื่น ปัญหาเหล่านี้อาจกำหนดให้คุณต้องติดตั้งระบบปฏิบัติการใหม่ Microsoft ไม่อาจรับประกันได้ว่าปัญหาเหล่านี้จะสามารถแก้ไขได้ ปรับเปลี่ยนรีจิสทรีนี้โดยที่คุณยอมรับความเสี่ยงเอง

ขั้นแรก ให้เอาคีย์ย่อยของ Windows NT ออก

เอารายการรีจิสทรีที่อาจเป็นปัญหาสำหรับคีย์ย่อยของบริการ Windows NT x86 ออก คีย์ย่อยเหล่านี้อาจได้รับการติดตั้งโดยโปรแกรมติดตั้งเครื่องพิมพ์ของบริษัทอื่น และอาจรบกวนบริการจัดคิวงานพิมพ์ ให้ปฏิบัติตามขั้นตอนเหล่านี้เพื่อเก็บโปรแกรมควบคุม การจัดคิวงานพิมพ์ และรายการรีจิสทรีที่รวมอยู่กับ Windows และเพื่อเอาโปรแกรมควบคุม การจัดคิวงานพิมพ์ และรายการรีจิสทรีอื่นๆ ทั้งหมดที่อาจก่อให้เกิดปัญหาออก
  1. เริ่มตัวแก้ไขรีจิสทรี ด้วยวิธีการดังนี้ คลิก เริ่ม คลิก เรียกใช้ พิมพ์ regedit ในกล่อง เปิด แล้วคลิก ตกลง
  2. ค้นหาและขยายรีจิสทรีคีย์ต่อไปนี้เพื่อดูรายการของคีย์ย่อย (โฟลเดอร์ย่อย):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
    ในรายการของคีย์ย่อย ควรมีคีย์ย่อยต่อไปนี้เท่านั้น:
    • โปรแกรมควบคุม
    • ตัวประมวลผลการพิมพ์
  3. ถ้ามีคีย์ย่อยใดๆ นอกเหนือจากคีย์ย่อยที่แสดงในขั้นตอนที่ 2 ให้ปฏิบัติตามขั้นตอนต่อไปนี้:
    1. ในเมนู แฟ้ม คลิก ส่งออก
    2. ในกล่อง ชื่อแฟ้ม ให้พิมพ์ชื่อที่คุณต้องการใช้สำหรับคีย์นี้ เช่น WindowsNTx86regkey แล้วคลิก บันทึก

      คุณสามารถใช้รีจิสทรีคีย์
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
      ที่สำรองไว้นี้เพื่อคืนค่าคีย์ ในกรณีที่คุณพบปัญหาใดๆ หลังจากทำขั้นตอนนี้เสร็จแล้ว
    3. ให้ลบคีย์ย่อยทั้งหมดที่ไม่ใช่คีย์ย่อยที่แสดงไว้ในขั้นตอนที่ 2 โดยคลิกขวาที่คีย์ย่อยแต่ละคีย์ที่ไม่ได้แสดงในรายการ แล้วคลิก ลบ คลิก ใช่ เมื่อคุณได้รับการพร้อมท์ให้ยืนยันการลบ

ขั้นที่สอง เอารายการรีจิสทรีสำหรับตัวตรวจสอบการพิมพ์เริ่มต้นออก

เอาคีย์ย่อยของตัวตรวจสอบการพิมพ์ที่อาจเป็นปัญหาที่อาจรบกวนเครื่องพิมพ์ที่คุณต้องการใช้ออก โดยคีย์ย่อยเหล่านี้อาจได้รับการติดตั้งโดยโปรแกรมติดตั้งเครื่องพิมพ์ของบริษัทอื่น ให้ปฏิบัติตามขั้นตอนเหล่านี้เพื่อเก็บตัวตรวจสอบการพิมพ์และรายการรีจิสทรีที่รวมอยู่กับ Windows และเพื่อเอาตัวตรวจสอบการพิมพ์และรายการรีจิสทรีอื่นๆ ทั้งหมดที่อาจเป็นปัญหาออก
  1. เริ่มตัวแก้ไขรีจิสทรี ถ้ายังไม่ได้เปิดไว้ ด้วยวิธีการดังนี้ คลิก เริ่ม คลิก เรียกใช้ พิมพ์ regedit ในกล่อง เปิด แล้วคลิก ตกลง
  2. ค้นหาและขยายรีจิสทรีคีย์ต่อไปนี้เพื่อดูรายการของคีย์ย่อย:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    ในรายการของคีย์ย่อย ควรมีเฉพาะคีย์ย่อยต่อไปนี้สำหรับตัวตรวจสอบการพิมพ์เริ่มต้น:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  3. ถ้ามีคีย์ย่อยใดๆ นอกเหนือจากคีย์ย่อยที่แสดงในขั้นตอนที่ 2 ให้ปฏิบัติตามขั้นตอนต่อไปนี้:
    1. ในเมนู แฟ้ม คลิก ส่งออก
    2. ในกล่อง ชื่อแฟ้ม ให้พิมพ์ชื่อที่คุณต้องการใช้สำหรับคีย์นี้ เช่น Monitorsx86regkey แล้วคลิก บันทึก
    3. คุณสามารถใช้รีจิสทรีคีย์
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
      ที่สำรองไว้นี้เพื่อคืนค่าคีย์ ในกรณีที่คุณพบปัญหาใดๆ หลังจากทำขั้นตอนนี้เสร็จแล้ว
    4. ให้ลบคีย์ย่อยทั้งหมดที่ไม่ใช่คีย์ย่อยที่แสดงไว้ในขั้นตอนที่ 2 โดยคลิกขวาที่คีย์ย่อยแต่ละคีย์ที่ไม่ได้แสดงในรายการ แล้วคลิก ลบ คลิก ใช่ เมื่อคุณได้รับการพร้อมท์ให้ยืนยันการลบ
  4. ออกจากตัวแก้ไขรีจิสทรี
  5. ถ้าเครื่องพิมพ์เชื่อมต่ออยู่กับคอมพิวเตอร์ ให้ถอดสายเคเบิลเครื่องพิมพ์ออกจากคอมพิวเตอร์ จากนั้นจึงเริ่มระบบของคอมพิวเตอร์ใหม่

ขั้นตอนที่ 4: ติดตั้งเครื่องพิมพ์ และพิมพ์หน้าทดสอบ

ต่อสายเครื่องพิมพ์เข้ากับคอมพิวเตอร์อีกครั้ง ติดตั้งเครื่องพิมพ์ตามคำแนะนำของผู้ผลิต จากนั้นทดลองพิมพ์หน้าทดสอบ

ถ้าคุณยังไม่สามารถพิมพ์ได้ หรือถ้าคุณยังคงได้รับข้อผิดพลาดเกี่ยวกับการจัดคิว ให้ไปที่ส่วน "ขั้นตอนต่อไป"

ขั้นตอนต่อไป

ถ้าวิธีการเหล่านี้ไม่ได้ผลสำหรับคุณ คุณสามารถใช้เว็บไซต์ฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อค้นหาวิธีแก้ไขอื่นๆ สำหรับปัญหาของคุณ บริการส่วนหนึ่งของเว็บไซต์ฝ่ายบริการสนับสนุนลูกค้าของ Microsoft ได้แก่
  • ฐานความรู้ที่ค้นหาได้: ค้นหาข้อมูลสนับสนุนทางเทคนิคและเครื่องมือสำหรับช่วยเหลือด้วยตนเองสำหรับผลิตภัณฑ์ของ Microsoft
  • ศูนย์แก้ไขปัญหา: ดูคำถามที่ถามบ่อยเฉพาะผลิตภัณฑ์และข้อมูลสนับสนุนที่สำคัญ
  • ตัวเลือกการสนับสนุนอื่นๆ: ใช้เว็บเพื่อสอบถามปัญหา ติดต่อฝ่ายบริการสนับสนุนลูกค้าของ Microsoft หรือแสดงความคิดเห็น
ถ้าคุณยังมีปัญหาอยู่ คุณอาจต้องการติดต่อฝ่ายสนับสนุน:
http://support.microsoft.com/contactus/?ln=th

ข้อมูลเพิ่มเติม

Microsoft ให้รายละเอียดสำหรับการติดต่อกับบริษัทอื่นๆ ดังกล่าว เพื่อช่วยให้คุณสามารถขอรับความสนับสนุนทางเทคนิคได้ รายละเอียดสำหรับการติดต่อนี้อาจมีการเปลี่ยนแปลงโดยไม่ต้องแจ้งให้ทราบล่วงหน้า Microsoft ไม่รับประกันเกี่ยวกับความถูกต้องของข้อมูลสำหรับการติดต่อกับบริษัทอื่นๆ เหล่านี้
ผลิตภัณฑ์อื่นๆ ซึ่งบทความนี้มีการกล่าวถึง เป็นผลิตภัณฑ์ที่ผลิตขึ้นโดยบริษัทอื่นๆ ที่ไม่เกี่ยวข้องกับ Microsoft Microsoft ไม่มีการรับประกัน ทั้งโดยนัยหรืออย่างอื่นใด เกี่ยวกับประสิทธิภาพหรือความน่าเชื่อถือของผลิตภัณฑ์เหล่านี้

สำหรับขั้นตอนการแก้ไขปัญหาและการแก้ไขอัตโนมัติสำหรับปัญหาทั่วๆ ไปเกี่ยวกับเครื่องพิมพ์ใน Windows โปรดดูเว็บเพจต่อไปนี้ของ Microsoft:


ตัวแก้ไขปัญหา: ปัญหาเกี่ยวกับเครื่องพิมพ์ใน Windows
หมายเหตุ นี่คือบทความ "FAST PUBLISH" (เผยแพร่ด่วน) ที่สร้างขึ้น โดยตรงจากหน่วยงานสนับสนุนภายในองค์กรของ Microsoft ข้อมูลที่มีอยู่ในที่นี้ได้รับการจัดทำขึ้นตามสภาพที่เป็นโดยตอบสนองต่อประเด็นปัญหาที่เกิดขึ้น เนื่องด้วยความรวดเร็วในการจัดทำเอกสารนี้ให้พร้อมใช้งาน เนื้อหาสาระในเอกสารดังกล่าวจึงอาจจะมีส่วนที่พิมพ์ผิดพลาดและอาจจะได้รับการตรวจทานแก้ไขเมื่อใดก็ได้โดยไม่จำเป็นต้องแจ้งให้ทราบ โปรดดู ข้อกำหนดการใช้งาน สำหรับประเด็นการพิจารณาอื่นๆ

คุณสมบัติ

หมายเลขบทความ (Article ID): 810894 - รีวิวครั้งสุดท้าย: 10 มิถุนายน 2556 - Revision: 1.1
ใช้กับ
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Keywords: 
kberrmsg kbprb KB810894

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com