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How to determine and to recover from Winsock2 corruption in Windows Server 2003, in Windows XP, and in Windows Vista

Article ID:811259
Last Review:January 18, 2008
Revision:14.5
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SYMPTOMS

When you try to release and renew the IP address by using the Ipconfig program (Ipconfig.exe), you may receive one of the following error messages.
Message 1
An error occurred while renewing interface 'Internet': An operation was attempted on something that is not a socket.
Message 2
An error occurred while renewing interface Local Area Connection: the requested service provider could not be loaded or initialized.
When you start Internet Explorer, you may receive the following error message:
The page cannot be displayed
When you use your computer, you may receive the following error message:
Initialization function INITHELPERDLL in IPMONTR.DLL failed to start with error code 10107
Additionally, you may have no IP address or no Automatic Private IP Addressing (APIPA) address, and you may be receiving IP packets but not sending them.

When you use the ipconfig /renew command, you may receive the following error messages.

Message 1
An error occurred while renewing interface local area connection: an operation was attempted on something that is not a socket. Unable to contact driver Error code 2.
Message 2
The operation failed since no adapter is in the state permissible for this operation.
Message 3
The attempted operation is not supported for the type of object referenced.
In Device Manager, when you click Show Hidden Devices, the TCP/IP Protocol Driver is listed as disabled under Non-Plug and Play drivers, and you receive error code 24.

When you create a dial-up connection, you may receive the following error message:
Error 720: No PPP Control Protocols Configured

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CAUSE

These issues may occur if the Winsock registry keys are damaged or corrupted.

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RESOLUTION

Guided Help to determine and recover from Winsock2 corruption

Guided Help
Guided Help is available to determine whether the Winsock2 key is corrupted and to recover from Winsock corruption. Guided Help can automatically perform the steps for you.

The actions that this Guided Help performs can be undone after Guided Help is finished. To undo this Guided Help, run Guided Help again. On the Welcome page, click Undo this Guided Help, and then follow the instructions.
For more information about Guided Help, click the following article number to view the article in the Microsoft Knowledge Base:
915092 (http://support.microsoft.com/kb/915092/) Description of Guided Help for Microsoft Knowledge Base articles

Requirements to install and to use this Guided Help

You must be logged on to Windows by using a computer administrator account to install and to use this Guided Help.
You must be running Windows XP Home Edition, Windows XP Professional, Windows XP Media Center Edition, or Windows XP Tablet PC Edition to install and to use this Guided Help.
You must first download Guided Help. To start, click the following link.
(http://support.microsoft.com/kb/811259/)

Manual steps to determine whether the Winsock2 key is corrupted for Windows XP users

To determine if the symptoms are caused by a problem with the Winsock2 key,use one of the following methods.

Method 1: Use the Netdiag tool

To use the Netdiag tool, you must install the Microsoft Windows XP Support Tools. To do so, follow these steps.

Notes
If you already have Support Tools installed, go to the second procedure in this section.
If you do not have Support Tools installed and you do not have the Windows XP Setup CD, go to Method 2.
1. Insert your Windows XP Setup CD, and then locate the Support\Tools folder.
2. Double-click the Setup.exe file.
3.Follow the steps on the screen until you reach the Select An Installation Type screen.
4.On the Select An Installation Type screen, click Complete, and then click Next.
When the installation is complete, follow these steps:
1. Click Start, click Run, type Command, and then click OK.
2.Type netdiag /test:winsock, and then press ENTER.
The Netdiag tool will return the test results for several network components, including the Winsock. For more details about the test, use /v at the end of the netdiag command: netdiag /test:winsock /v

Method 2: Use the Msinfo32 program

Note Use this method only if you do not have a Windows XP Setup CD and you do not have Support Tools installed.
1.Click Start, click Run, type Msinfo32, and then click OK.
2.Expand Components, expand Network, and then click Protocol.
3.You will have ten sections under Protocol. The section headings will include the following names if the Winsock2 key is undamaged:
MSAFD Tcpip [TCP/IP]
MSAFD Tcpip [UDP/IP]
RSVP UDP Service Provider
RSVP TCP Service Provider
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
If the names are anything different from those in this list, the Winsock2 key is corrupted, or you have a third-party add-on, such as proxy software, installed.
If you have a third-party add-on installed, the name of the add-on will replace the letters "MSAFD" in the list.

If there are more than ten sections in the list, you have third-party additions installed.

If there are fewer than ten sections, there is information missing.

Note These entries represent an installation with only the TCP/IP protocol installed. You can have a working Winsock and see additional entries if another protocol is installed. For example, if you install NWLink IPX/SPX, you will see 7 additional sections, for a total of 17. Below is an example heading of one of the new sections:
MSAFD nwlnkipx [IPX]
Also, each of the new sections that are created by installing NWLink IPX/SPX start with "MSAFD." Therefore, there are still only two sections that do not start with those letters.

If the Netdiag test fails, or if you determined that there is Winsock corruption by looking at Msinfo32, you must repair the Winsock2 key by using the steps in the next section.

Manual steps to recover from Winsock2 corruption

Windows XP with Service Pack 2 instructions

To repair Winsock if you have Windows XP Service Pack 2 (SP2) installed, type netsh winsock reset at the command prompt, and then press ENTER.

Note Restart the computer after you run this command. Additionally, for computers that are running Windows XP SP2, there is a new netsh command that can rebuild the Winsock key. For more information, visit the following Web site:
http://technet.microsoft.com/en-us/library/bb457156.aspx (http://technet.microsoft.com/en-us/library/bb457156.aspx)
Warning Programs that access or monitor the Internet such as antivirus, firewall, or proxy clients may be negatively affected when you run the netsh winsock reset command. If you have a program that no longer functions correctly after you use this resolution, reinstall the program to restore functionality.

Note If these steps do not resolve the problem, follow the steps in the next section.

Windows XP without Service Pack 2 instructions

To repair Winsock if you do not have Windows XP SP2 installed, delete the corrupted registry keys, and then reinstall the TCP/IP protocol.
Step 1: Delete the corrupted registry keys
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows


For more information about how to back up the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows XP and Windows Vista
1.Click Start, and then click Run.
2.In the Open box, type regedit, and then click OK.
3.In Registry Editor, locate the following keys, right-click each key, and then click Delete:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
4.When you are prompted to confirm the deletion, click Yes.
Note Restart the computer after you delete the Winsock keys. Doing so causes the Windows XP operating system to create new shell entries for those two keys. If you do not restart the computer after you delete the Winsock keys, the next step does not work correctly.
Step 2: Install TCP/IP
1.Right-click the network connection, and then click Properties.
2.Click Install.
3.Click Protocol, and then click Add.
4.Click Have Disk.
5.Type C:\Windows\inf, and then click OK.
6.On the list of available protocols, click Internet Protocol (TCP/IP), and then click OK.

If Internet Protocol (TCP/IP) does not appear, follow these steps:
a. Click Start, and then click Search.
b. In the Search Companion pane, click More advanced options.
c. Click to select the following three check boxes:
Search system folders
Search hidden files and folders
Search subfolders
d. In the All or part of the file name box, type nettcpip.inf, and then click Search.
e. In the results pane, right-click Nettcpip.inf, and then click Install.
7.Restart the computer.

Manual steps to determine whether the Winsock2 key is corrupted for Windows Vista users

1.Click Start, click Run, type Msinfo32, and then click OK.
2.Expand Components, expand Network, and then click Protocol.
3.Ten sections appear under Protocol. The section headings will include the following names if the Winsock2 key is undamaged:
MSAFD Tcpip [TCP/IP]
MSAFD Tcpip [UDP/IP]
MSAFD Tcpip [TCP/IPv6]
MSAFD Tcpip [UDP/IPv6]
RSVP UDP Service Provider
RSVP TCP Service Provider
RSVP UDPv6 Service Provider
RSVP TCPv6 Service Provider
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
If the names are anything different from those in this list, the Winsock2 key is corrupted, or you have a third-party add-on such as proxy software installed.
If you have a third-party add-on installed, the name of the add-on will replace the letters "MSAFD" in the list.

If there are more than ten sections in the list, you have third-party additions installed.

If there are fewer than ten sections, there is information missing.

Note These entries represent an installation with only the TCP/IP protocol installed. You can have a working Winsock and see additional entries if another protocol is installed. For example, if you install NWLink IPX/SPX, you will see 7 additional sections, for a total of 17. Below is an example heading of one of the new sections:
MSAFD nwlnkipx [IPX]
Also, each of the new sections that are created by installing NWLink IPX/SPX start with "MSAFD." Therefore, there are still only two sections that do not start with those letters.

If the Netdiag test fails, or if you determined that there is Winsock corruption by looking at Msinfo32, you must repair the Winsock2 key by using the steps in the next section.

Manual steps to recover from Winsock2 corruption for Windows Vista users

Winsock corruption can cause connectivity problems. To resolve this issue by using Network Diagnostics in Windows Vista, follow these steps:
1.Click , Startand then click Network.
2.Click Network and Sharing Center.
3.In the Network and Sharing Center box, click Diagnose and Repair.
Note You may also access the Network and Sharing Center in Control Panel.

If the Network and Diagnostic tool was unable to find a problem, you can manually repair or reset Winsock.

Manual steps to repair or to reset Winsock for Windows Vista users

1.Click Start, type cmd in the Start Search box, right-click cmd.exe, click Run as administrator, and then press Continue.
2.Type netsh winsock reset at the command prompt, and then press ENTER.

Note If the command is typed incorrectly, you will receive an error message. Type the command again. When the command is completed successfully, a confirmation appears, followed by a new command prompt. Then, go to step 3.
3.Type exit, and then press ENTER.

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Similar problems and solutions

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
936211 (http://support.microsoft.com/kb/936211/) How to troubleshoot network connectivity problems in Internet Explorer
For more information about how to troubleshoot network and Internet connection problems in Windows Vista, visit the following Microsoft Web site:
http://windowshelp.microsoft.com/Windows/en-US/Help/33307acf-0698-41ba-b014-ea0a2eb8d0a81033.mspx (http://windowshelp.microsoft.com/Windows/en-US/Help/33307acf-0698-41ba-b014-ea0a2eb8d0a81033.mspx)

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APPLIES TO
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate

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Keywords: 
kbacw kbhowto kbresolve kbhowto kbacwsurvey kbnetwork kberrmsg kbprb KB811259

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