Bluetooth のマウスまたはキーボードが機能しない問題を解決する

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文書番号: 811798
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目次

現象

この資料の対象製品として記載されているマイクロソフトのポインティング デバイスまたはキーボードのいずれかを使用するときに、デバイスがまったく機能しないことがあります。また、デバイスが Microsoft Windows で検出されないことがあります。

原因

以下のいずれかの理由により、この現象が発生する可能性があります。
  • コンピューターの BIOS が Bluetooth キーボードを認識しない場合、コンピューターを起動するときに次のようなエラーが発生します。
    Keyboard Error or No Keyboard Present Press F1 to continue, DEL to enter setup
  • ポータブル コンピューターの Bluetooth レシーバーが、Microsoft Bluetooth スタックと互換性がありません。
  • デバイスの信号が信号トランシーバーで検出されません。
  • デバイスまたはレシーバーに十分な電力が供給されていません。
  • 無線周波数が競合しています。
  • Windows XP が実行されていますが、Service Pack 2 (SP2) 以降の Service Pack に更新されていません。
  • ハードウェアに不具合があります。

解決方法

コンピューターを起動するときに、この資料の「原因」に記載されているキーボード エラーが発生する場合は、この資料の「解決方法」にある手順を参照してください。

この問題を解決するには、次のいずれかの手順を実行します。

方法 1: 互換性のない Bluetooth スタックを解決する

この現象を解決するには、ポータブル コンピューターの製造元に問い合わせて、トランシーバーが Microsoft Bluetooth スタックに対応しているかどうかを確認してください。さらに、Microsoft Bluetooth スタックを使用してデバイスを追加する方法を製造元に確認してください。マイクロソフトのデバイスに専用トランシーバーが含まれている場合は、そのマイクロソフトのトランシーバーを使用してこの現象を解決する必要があります。

使用しているポータブル コンピューターで Windows XP Service Pack 2 (SP2) またはそれよりも新しいバージョンの Windows が動作している場合、Windows でトランシーバーが検出され、その後に Microsoft Bluetooth スタックがインストールされます。このプロセスにより、Bluetooth 接続によるコンピューターへの未承認アクセスを防止します。サードパーティのスタックを削除したときも、Windows によりこのプロセスが開始され、Microsoft Bluetooth スタックが使用されるようになります。

方法 2: 電力のレベルを確認する

Bluetooth デバイスに十分な電力を確保するために、不要な USB デバイスの接続を外し、他の USB デバイスが接続されていない状態でデバイスをテストします。デバイスがルート ハブまたは電力が供給されている USB ハブに接続されていることを確認します。ただし、"バスパワード" USB ハブには接続しないでください。この種類のハブには、実際には電力が供給されません。

方法 3: 使用しているオペレーティング システム用の最新の更新プログラム (Service Pack) をインストールする

使用しているオペレーティング システム用の最新の更新プログラムがインストールされていることを確認します。Windows の場合、次のマイクロソフト Web サイトにアクセスしてください。
http://update.microsoft.com
Windows XP を実行している場合は、次のサポート技術情報番号をクリックしてください。
883258 Windows XP Service Pack 2 で Bluetooth の検出と接続に関する問題のトラブルシューティングを行う方法

方法 4: コントロール パネルでワイヤレス リンクのアイコンを探し、ワイヤレス デバイスとのリンクを再確立します。


Windows Vista または Windows 7
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[ハードウェアとサウンド] をクリックして、[Bluetooth デバイス] をクリックします。
  2. 一覧にデバイスが表示されない場合は、[追加] をクリックし、表示される指示に従ってデバイスを追加します。

    デバイスが一覧に表示されたら、その状態を確認します。以下の状態が考えられます。
    • 認証済み
    • 接続済み
    • Last Seen

      デバイスの状態が [Last Seen] と表示された場合は、そのデバイスを使用できるかどうかを試します。

      [認証済み] と [接続済み] が交互に表示される場合は、デバイスとコンピューターの間で通信が行われています。[削除] をクリックしてデバイスを削除し、削除したデバイスを [追加] をクリックして元に戻すこともできます。
  3. [プロパティ] をクリックし、[サービス] をクリックします。
  4. [Drivers for Device] チェック ボックスをオンにします。
  5. デバイスの横のチェック ボックスがオンになっている場合は、オフにします。

    : ワイヤレス リンクを使用してデバイスを追加すると、デバイスは既定のデバイスとして設定されません。
  6. [OK] をクリックします。
  7. [プロパティ] をクリックし、[サービス] をクリックします。
  8. [Drivers for Device] チェック ボックスをオンにします。
  9. ワイヤレス リンクのプロパティでチェック ボックスをオンにします。
  10. リンクが再確立されない場合は、コントロール パネルを使用してデバイスを削除し、再度デバイスの追加を試みてください。

    Windows Vista で Bluetooth 対応デバイスの問題のトラブルシューティングを行うには、Windows Vista のヘルプとサポートで「Bluetooth 対応デバイスに関する問題のトラブルシューティング」のトピックに示されている手順に従ってください。このトピックを表示するには、次の手順を実行します。
    1. [スタート] ボタン
      元に戻す画像を拡大する
      [スタート] ボタン
      をクリックし、[ヘルプとサポート] をクリックします。
    2. [ヘルプの検索] ボックスに「Bluetooth 対応デバイスの問題のトラブルシューティング」と入力し、[ヘルプの検索] をクリックします。
    3. 適切なトピックをクリックします。
Windows XP
  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [プリンターとその他のハードウェア] をクリックします。
  3. [ワイヤレス リンク] をクリックします。

    : 最初のタブに Bluetooth デバイスの画像が表示されない場合は、ソフトウェアが正しくインストールされていません。ソフトウェアを削除してから、この手順を続行してください。
  4. [Bluetooth] タブをクリックします。
  5. 一覧にデバイスが表示されない場合は、[追加] をクリックし、表示される指示に従ってデバイスを追加します。
  6. デバイスが一覧に表示されたら、その状態を確認します。以下の状態が考えられます。
    • 認証済み
    • 接続済み
    • Last Seen

      デバイスの状態が [Last Seen] と表示された場合は、そのデバイスを使用できるかどうかを試します。

      [認証済み] と [接続済み] が交互に表示される場合は、デバイスとコンピューターの間で通信が行われています。[削除] をクリックしてデバイスを削除し、削除したデバイスを [追加] をクリックして元に戻すこともできます。
  7. [Drivers for Device] チェック ボックスをオンにします。
  8. デバイスの横のチェック ボックスがオンになっている場合は、オフにします。

    : ワイヤレス リンクを使用してデバイスを追加すると、デバイスは既定のデバイスとして設定されません。
  9. [OK] をクリックします。
  10. [プロパティ] をクリックし、[サービス] をクリックします。[Drivers for Device] チェック ボックスをオンにします。
  11. ワイヤレス リンクのプロパティでチェック ボックスをオンにします。
  12. リンクが再確立されない場合は、コントロール パネルを使用してデバイスを削除し、再度デバイスの追加を試みてください。

方法 5: 通信範囲でデバイスに対して同じ周波数の干渉がないことを確認する

次の項目が環境内にあるかどうかを確認します。
  • 2.4 GHz の周波数範囲を使用するコードレス電話
  • 電子レンジ
  • 照明コントローラーやユニバーサル リモコンなどの X10 デバイス
  • Wireless Fidelity (Wi-Fi) ネットワーク

方法 6: デバイスを別のコンピューターでテストする

以上の方法で問題が解決しない場合は、デバイスを別のコンピューターで使用してみます。ハードウェアに不具合がある可能性があります。問題が引き続き発生し、デバイスが別のコンピューターで正常に機能する場合は、オペレーティング システムに問題がある可能性があります。デバイスがどのシステムでも正常に機能しない場合は、マイクロソフトに連絡してデバイスの交換について確認してください。確認の方法については、この資料の「関連情報」に記載されている「カスタマー インフォメーション センターの障害担当に問い合わせる方法」を参照してください。

回避策

コンピューターを起動するときに、この資料の「原因」に記載されている "Keyboard Error or No Keyboard Present" というエラーが表示される場合、問題を回避するには、BIOS の Halt on error 機能を無効にします。BIOS にアクセスしてこの機能を無効にする方法を確認するには、コンピューターに付属しているマニュアルを参照するか、コンピューターの製造元に問い合わせてください。

BIOS の Halt on error 機能を無効にしてもエラー メッセージは表示されますが、コンピューターの起動が続行されます。Microsoft Windows が起動した後、Bluetooth デバイスは正常に機能します。

Halt on error 機能を無効にできない場合は、コンピューターに PS/2 キーボードを接続すると、このエラー メッセージは表示されなくなります。

ハードウェアの製造元に連絡する方法については、次のハードウェアおよびソフトウェア サードパーティ製造元の連絡先情報を確認してください。これを行うには、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/gp/vendors

関連情報

Windows Vista または Windows 7 で Bluetooth 対応デバイスをセットアップする方法の詳細については、Windows のヘルプとサポートの「Bluetooth 対応デバイスをセットアップする」に示されている手順を参照してください。このトピックを表示するには、次の手順を実行します。
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[ヘルプとサポート] をクリックします。
  2. [ヘルプの検索] ボックスに「Bluetooth 対応デバイスのセットアップ」と入力し、[ヘルプの検索] をクリックします。
  3. 適切なトピックをクリックします。

カスタマー インフォメーション センターの障害担当に問い合わせる方法

米国およびカナダからは、以下の電話番号でカスタマー インフォメーション センターの障害担当に問い合わせることができます。
  • 米国: (800) 360-7561、月〜金、午前 5:00 〜午後 7:00 (太平洋標準時)
  • カナダ: (800) 933-4750、月〜金、午前 5:00 〜午後 7:00 (太平洋標準時)
  • マイクロソフト テキスト電話 (TTY): (800) 718-1599、月〜金、午前 5:00 〜午後 7:00 (太平洋標準時)
マイクロソフトのソフトウェア、ハードウェア、およびマニュアルを交換またはアップグレードする方法の詳細については、以下のサポート技術情報番号をクリックしてください。
326246 マイクロソフトのソフトウェアまたはハードウェアの交換方法、Service Pack と製品アップグレードの注文方法、および製品マニュアルの交換方法について
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

プロパティ

文書番号: 811798 - 最終更新日: 2011年3月5日 - リビジョン: 15.0
キーワード:?
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