Conversione di una singola colonna di indirizzi in un file di testo CSV in Excel

Traduzione articoli Traduzione articoli
Identificativo articolo: 819964 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo viene descritto come convertire una singola colonna di indirizzi di un foglio di lavoro di Microsoft Excel in un file CSV (Comma-Separated Value) che è possibile importare in un'altra applicazione, ad esempio Microsoft Word.

Nota Per l'esempio di indirizzi contenuto in questo articolo, nel foglio di lavoro di Excel sono contenute le informazioni seguenti:
   A1: Olga Ferraro
   A2: Microsoft
   A3: Via Carozzi 6
   A4: 20100 Milano
   A5:
   A6: Fausto Zaffaroni
   A7: Viale M. C. Savoia 35
   A8: 80100 Napoli

Informazioni

Se il foglio di lavoro di Microsoft Excel contiene dati di indirizzi in un singola colonna, ad esempio nella colonna A, e si desidera convertire tali dati in un file di testo CSV, attenersi alla seguente procedura.

Modifica del foglio di lavoro di Excel

  1. Aprire la cartella di lavoro di Excel contenente i dati degli indirizzi.
  2. Nell'esempio riportato, il primo indirizzo contiene quattro righe mentre il secondo ne contiene solo tre. Ciascun indirizzo, inoltre, è separato da una sola riga.

    Per convertire i dati degli indirizzi in un file di testo CSV, tutti gli indirizzi devono contenere lo stesso numero di righe ed essere separati dallo stesso numero di righe. Modificare l'esempio come indicato di seguito:
        A1: Olga Ferraro
        A2: Microsoft
        A3: Via Carozzi 6
        A4: 20100 Milano
        A5:
        A6:
        A7: Fausto Zaffaroni
        A8: Viale M. C. Savoia 35
        A9:
       A10: 80100 Napoli
    
    Nota Ogni indirizzo è ora separato da due righe e contiene quattro righe.

    Per inserire una nuova riga nel foglio di lavoro di Excel, selezionare l'intestazione della riga in cui si desidera effettuare l'inserimento. Scegliere Righe dal menu Inserisci.

    Nota In Excel 2007, per inserire una nuova riga in un foglio di lavoro occorre selezionare la riga in cui si desidera inserire la nuova riga, scegliere Inserisci nel gruppo Celle della scheda Home e fare clic su Inserisci righe foglio.
  3. Scegliere Salva con nome dal menu File.

    Nota In Excel 2007, fare clic sul pulsante Microsoft Office e scegliere Salva con nome.
  4. Nella finestra di dialogo Salva con nome:
    1. Nella casella Tipo file selezionare CSV (delimitato dal separatore di elenco) (*.csv).
    2. Nella casella Nome file digitare un nome da assegnare al file CSV, ad esempio Indirizzi.csv, quindi scegliere Salva.
    3. Scegliere OK quando viene visualizzato un messaggio analogo al seguente:
      Il tipo di file selezionato non supporta cartelle di lavoro contenenti fogli multipli.

      ? Per salvare solo il foglio attivo, scegliere OK.
      ? Per salvare tutti i fogli, salvarli individualmente con un nome univoco o scegliere un tipo di file che supporta fogli multipli.
    4. Scegliere quando viene visualizzato un messaggio analogo al seguente:
      Indirizzi.csv contiene caratteristiche non compatibili con CSV (delimitato dal separatore di elenco). Mantenere il formato della cartella di lavoro?

      ? Per mantenere il formato, perdendo le caratteristiche non compatibili, scegliere Sì.
      ? Per conservare le caratteristiche, scegliere No, quindi salvare una copia della cartella di lavoro nel formato di Excel più recente.
      ? Fare clic su ? per visualizzare le caratteristiche che verrebbero eliminate.
  5. Scegliere Chiudi dal menu File per chiudere Microsoft Excel.

    Nota In Excel 2007, fare clic sul pulsante Microsoft Office e scegliere Chiudi, quindi fare clic su Esci da Excel.

    Nota Potrebbe essere richiesto di salvare di nuovo il file. In questo caso è possibile scegliere , ripetere i passaggi c-d e chiudere Excel.

Modifica del file CSV in Microsoft Word

  1. Avviare Microsoft Word.
  2. Scegliere Apri dal menu File.

    Nota In Word 2007, fare clic sul pulsante Microsoft Office e scegliere Apri.
  3. Nella casella Tipo file selezionare Tutti i file (*.*).
  4. Fare clic sul file CSV salvato al passaggio 4 della sezione "Modifica del foglio di lavoro di Excel", quindi scegliere Apri.
  5. Scegliere Opzioni dal menu Strumenti.

    Nota In Word 2007, ignorare questo passaggio.
  6. Nella scheda Visualizza selezionare la casella di controllo Tutto e scegliere OK.

    Nota In Word 2007, attenersi alla procedura seguente:
    1. Fare clic sul pulsante Microsoft Office, quindi scegliere Opzioni di Word.
    2. Fare clic su Visualizza.
    3. Scegliere Segni di paragrafo in Mostra sempre questi segni di formattazione sullo schermo.


    Il documento di Microsoft Word sarà simile all'esempio seguente:
    Olga Ferraro¶
    Microsoft¶
    Via Carozzi 6¶
    "20100 Milano"¶
    ¶
    ¶
    Fausto Zaffaroni¶
    Viale M. C. Savoia 35¶
    ¶
    "80100 Napoli"¶
    
  7. Scegliere Sostituisci dal menu Modifica.

    Nota In Word 2007, scegliere Modifica nel gruppo Modifica della scheda Home, quindi scegliere Sostituisci.
  8. Nella finestra di dialogo Trova e sostituisci scegliere la scheda Sostituisci e attenersi alla seguente procedura:
    1. Nella casella Trova digitare ^p^p^p.
    2. Nella casella Sostituisci con digitare %%%%%.
    3. Scegliere Sostituisci tutto.
    4. Scegliere OK quando viene visualizzato un messaggio analogo al seguente:
      La ricerca è stata completata ed è stata effettuata 1 sostituzione.
    Il documento di Word sarà ora simile all'esempio seguente:
    Olga Ferraro¶
    Microsoft¶
    Via Carozzi 6¶
    "20100 Milano"%%%%%Fausto Zaffaroni¶
    Viale M. C. Savoia 35¶
    ¶
    "80100 Napoli"¶
    
  9. Nella finestra di dialogo Trova e sostituisci, effettuare le seguenti operazioni nella scheda Sostituisci:
    1. Nella casella Trova digitare ^p.
    2. Nella casella Sostituisci con digitare ,.
    3. Scegliere Sostituisci tutto.
    4. Scegliere OK quando viene visualizzato un messaggio analogo al seguente:
      La ricerca è stata completata e sono state effettuate 7 sostituzioni.
    5. Nella casella Trova digitare ,^p.
    6. Eliminare il testo presente nella casella Sostituisci con e lasciarla vuota.
    7. Scegliere Sostituisci tutto.
    8. Scegliere OK quando viene visualizzato un messaggio analogo al seguente:
      La ricerca è stata completata ed è stata effettuata 1 sostituzione.
    9. Nella casella Trova digitare %%%%%.
    10. Nella casella Sostituisci con digitare ^p.
    11. Scegliere Sostituisci tutto.
    12. Scegliere OK quando viene visualizzato un messaggio analogo al seguente:
      La ricerca è stata completata ed è stata effettuata 1 sostituzione.
  10. Chiudere la finestra di dialogo Trova e sostituisci.

    Il documento di Word sarà ora analogo all'esempio seguente:
    Olga Ferraro,Microsoft,Via Carozzi 6,"29100 Milano"¶
    Fausto Zaffaroni,Viale M. C. Savoia 35,,"80100 Napoli"¶
    
  11. Scegliere Salva dal menu File.

    Nota In Word 2007, fare clic sul pulsante Microsoft Office e scegliere Salva.

Proprietà

Identificativo articolo: 819964 - Ultima modifica: mercoledì 21 marzo 2007 - Revisione: 3.0
Le informazioni in questo articolo si applicano a
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Office Excel 2007
Chiavi: 
kbexpertisebeginner kbimport kbfindreplace kbsavefile kbconversion kbopenfile kbinfo KB819964
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com