Word 2003 でメタデータを最小限に抑える方法

文書翻訳 文書翻訳
文書番号: 825576 - 対象製品
すべて展開する | すべて折りたたむ

目次

概要

この資料では、Word 文書内のメタデータの量を最小限に抑えるために使用できる、さまざまな方法について説明します。

Microsoft Office Word 2003 で文書の作成、表示、または保存を行うと、文書を電子的に配布したときに第三者に見られては困る内容が文書に含まれる可能性があります。この情報はメタデータと呼ばれます。メタデータは、Office 文書の編集、表示、ファイリング、および検索を強化するためのさまざまな目的で使用されます。

一部のメタデータについては、Word のユーザー インターフェイスを介して簡単にアクセスできます。その他のメタデータについては、低レベルのバイナリ ファイル エディタで文書を開くなど、特殊な方法を使用することによってのみアクセスできます。以下に、文書に格納されるメタデータの例をいくつか示します。
  • 名前
  • 頭文字
  • 会社名と組織名
  • コンピュータ名
  • 文書を保存したネットワーク サーバーまたはハード ディスクの名前
  • その他のファイルのプロパティと概要情報
  • 埋め込み OLE オブジェクトの非表示部分
  • 文書の変更履歴
  • 文書のバージョン
  • テンプレートの情報
  • 隠し文字
  • コメント
Word 文書内でメタデータが作成される方法は、メタデータによってそれぞれ異なります。そのため、これらのメタデータを一括して文書から削除する方法はありません。以下に、Word 文書内でメタデータが保存される領域について説明します。

この資料では、Word 文書内のメタデータの量を最小限に抑えるために使用できる、さまざまな方法について説明します。

マイクロソフトは、この情報をプログラミング言語の使用方法の一例として提供するだけであり、市場性および特定目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。この資料は、例示されているプログラミング言語やプロシージャの作成およびデバッグに使用するツールについて理解されているユーザーを対象としています。Microsoft Support 担当者は、特定のプロシージャの機能についての問い合わせにはお答えできますが、ユーザー固有の目的に合わせた機能の追加、プロシージャの作成などの内容変更は行っておりません。 この資料のサンプル コードを使用する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
290140 サポート技術情報の Office XP プログラム用のサンプル コードを実行する方法

保存時に個人情報を自動的に削除する方法

文書の保存時に、個人情報を自動的に Word 文書から削除できるようになりました。このオプションを有効にするには、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックします。
  2. [セキュリティ] タブをクリックし、[プライバシー オプション] の下の [保存時にファイルのプロパティから個人情報を削除する] チェック ボックスをオンにし、[OK] をクリックします。
: Word 文書を保存するときに個人情報を削除するには、この方法が適しています。

文書からユーザー名を手動で削除する方法

現在のユーザー名を参照または変更するには、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックし、[ユーザー情報] タブをクリックします。

    以下のボックスが表示されます。
    名前
    頭文字
    住所
  2. これらの情報が文書に表示されないようにするには、自分を特定されない文字列かスペースを該当するボックスに入力し、[OK] を押して変更内容を確定します。
: 新しく作成するすべての文書には、Office のインストール時に入力した値ではなく、この情報が保存されます。ただし、既存の文書には、Office インストール時の値が既に含まれている場合があります。

個人の概要情報を手動で削除する方法

Word で文書を作成または保存すると、概要情報が文書内に保存される可能性があります。この情報にアクセスするには、いくつかの方法があります。
  • 文書を開き、[ファイル] メニューの [プロパティ] をクリックします。[ファイルの概要] タブ、[詳細情報] タブ、[ファイルの構成] タブ、および [ユーザー設定] タブにはすべて、名前、管理者の名前、および会社名など、さまざまなプロパティが含まれている可能性があります。
  • エクスプローラで文書を右クリックし、[プロパティ] をクリックします。[プロパティ] ダイアログ ボックス内のタブに情報が含まれている可能性があります。
  • Visual Basic for Applications (VBA) マクロやその他のプログラム コードを使用して、[プロパティ] ダイアログ ボックスに表示されるプロパティを読み取ることができます。
既存の文書またはテンプレートから概要情報を削除するには、以下の手順を実行します。
  1. 文書またはテンプレートを開きます。
  2. [ファイル] メニューの [プロパティ] をクリックします。
  3. [ファイルの概要] タブをクリックし、[作成者] ボックス、[管理者] ボックス、[会社名] ボックスなど、配布する文書に含めないようにする情報のボックスの内容を削除します。
  4. [ユーザー設定] タブをクリックし、配布する必要のない情報が入力されているプロパティをすべて削除します。
  5. [OK] をクリックします。

    [ファイル] メニューの [上書き保存] をクリックし、[閉じる] をクリックします。
この手順を実行すると、文書には削除した概要プロパティの情報は保存されません。

ネットワークに接続している場合に個人の概要情報を手動で削除する方法

ネットワークにログオンしている場合、文書を保存すると、[ファイルの概要] タブの [作成者] ボックス、および [詳細情報] タブの [最終保存者] フィールドに、ネットワーク ユーザー名が表示されることがあります。その他の個人情報をコンピュータからすべて削除しても、この情報が表示されることがあります。

ネットワークを利用している場合に、文書から概要情報を削除するには、次の手順を実行します。
  1. 文書がネットワーク サーバーに保存されている場合は、その文書をローカルのハード ディスクにコピーします。
  2. コンピュータを起動します。ただし、ネットワークにはログオンしないようにします。ネットワークのログオン ダイアログ ボックスが表示されたら、[キャンセル] をクリックするか Esc キーを押します。

    : Esc キーを押すと Windows を起動できない場合 (コンピュータで Windows NT、Windows 2000 または Windows XP を実行している場合など) は、この手順を続行することはできません。
  3. 文書を開きます。
  4. [ファイル] メニューの [プロパティ] をクリックします。
  5. [ファイルの概要] タブをクリックし、[作成者] ボックス、[管理者] ボックス、[会社名] ボックスなど、配布する文書に含めないようにする情報のボックスの内容を削除します。
  6. [ユーザー設定] タブをクリックし、配布する必要のない情報が入力されているプロパティをすべて削除します。
  7. [OK] をクリックします。

    [ファイル] メニューの [上書き保存] をクリックし、[閉じる] をクリックします。
ネットワークにログオンした場合は、ファイルを開かないようにします。ネットワークにログオンした状態でファイルを開くと、そのファイルにネットワーク ユーザー名が書き込まれる可能性があります。エクスプローラを使用して、ネットワーク サーバーかフロッピー ディスクにファイルをコピーすることができます。

文書のコメントを手動で削除する方法

Word には、文書にコメントを付加する機能が用意されています。通常、コメントを書き込んだユーザーを識別できるように、コメントには作成者の名前の情報が含まれています。

コメントのテキストは通常、強調表示されます。コメント内を右クリックし、[コメントの削除] をクリックすることにより、コメントを削除できます。

この資料の「文書からユーザー名を手動で削除する方法」に記載されている手順を実行して [オプション] ダイアログ ボックスでユーザー名を削除した場合、新しく作成するコメントにはユーザー名情報が含まれません。

文書からヘッダーとフッターを手動で削除する方法

文書のヘッダーとフッターに、ユーザー名などの識別情報が含まれていることがあります。ヘッダーやフッターから情報を削除するには、次の手順を実行します。
  1. [表示] メニューの [ヘッダーとフッター] をクリックします。
  2. 文書の各ページの上部と下部にヘッダーとフッターが表示されます。

    必要に応じて内容を変更します。
  3. [ヘッダーとフッター] ツール バーの [閉じる] をクリックします。

変更履歴を手動で削除する方法

文書には変更履歴を含めることができます。これを使用して、特定の変更を加えた更新者を判断することができます。変更履歴を反映するか元に戻すと、変更済みのテキストが文書に保存され、変更履歴は削除されます。

変更履歴を反映するか元に戻すには、次の手順を実行します。
  1. [ツール] メニューの [変更の履歴の記録] をクリックして、変更履歴を有効にします。
  2. [チェック/コメント] ツール バーの [前へ] または [次へ] をクリックして、特定の変更履歴を見つけて選択します。選択した変更履歴を反映するには、[変更の承諾] をクリックします。元に戻すには、[変更/削除コメントを元に戻す] をクリックします。
  3. 完了後、[閉じる] をクリックします。
: [チェック/コメント] ツール バーの [変更の履歴] をオフにしても、変更履歴は削除されません。

高速保存を無効にする方法

高速保存機能では、文書に加えられた変更部分のみを保存することにより、文書の保存処理を高速化します。

高速保存機能の仕様上、文書を保存した後でも、削除したテキストが文書内に残る可能性があります。削除したテキストが文書内に残ることで問題がある場合は、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックします。
  2. [保存] タブをクリックします。
  3. [高速保存] チェック ボックスをオフにし、[OK] をクリックします。
高速保存機能の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
291181 [WD2002] "高速保存" に関してよく寄せられる質問

隠し文字として書式設定されたテキストを検索および削除する方法

Word 文書では、テキストを隠し文字として書式設定することができます。隠し文字のテキストに、配布したくない情報が含まれている可能性があるため、必要に応じて隠し文字を表示し、削除してください。隠し文字として書式設定されているテキストをすべて文書から削除するには、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックし、[表示] タブをクリックします。
  2. [隠し文字] チェック ボックスをオンにし、[OK] をクリックします。
  3. [編集] メニューの [置換] をクリックします。
  4. [オプション] をクリックして検索オプションを表示します。
  5. [検索する文字列] ボックス内をクリックします。
  6. [書式] をクリックし、[フォント] をクリックします。

    [隠し文字] チェック ボックスをオンにし、[OK] をクリックします。
  7. [すべて置換] をクリックします。
すべての隠し文字が文書から削除されます。隠し文字を非表示にするには、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックし、[表示] タブをクリックします。
  2. [隠し文字] チェック ボックスをオフにし、[OK] をクリックします。

文書からハイパーリンクを削除する方法

文書には、他の文書またはイントラネットやインターネットの Web ページへのハイパーリンクが含まれていることがあります。ハイパーリンクは通常、青い下線付きのテキスト文字列として表示されます。

文書から 1 つのハイパーリンクを手動で削除するには、対象のハイパーリンクを右クリックし、[ハイパーリンクの削除] をクリックします。

VBA マクロを使用して、文書内のすべてのハイパーリンクを削除することができます。次のサンプル VBA マクロを使用すると、文書内のすべてのハイパーリンクを削除することができます。

: 以下のサンプル マクロでは、リンクのみが削除されます。ハイパーリンクのテキストは文書に残ります。

重要 : 以下のサンプル マクロを使用する前に、この資料の「免責」をお読みください。
	Sub RemoveHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Delete
	      Next
	   Next
	
	End Sub
ハイパーリンクとハイパーリンクのテキストの両方を文書からすべて削除するには、前のマクロではなく、次のサンプル マクロを使用します。
	Sub RemoveAllHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Range.Delete
	      Next
	   Next
	
	End Sub

文書からスタイルを削除する方法

文書内に、メタデータを含むスタイルが含まれていることがあります。これらのスタイルの削除、または名前の変更を行うには、以下の手順を実行します。
  1. スタイルを含む文書を開きます。
  2. [書式] メニューの [スタイルと書式] をクリックします。
  3. [スタイルと書式] 作業ウィンドウの [適用する書式の選択] ボックスで、削除または名前の変更を行うスタイルをポイントします。

    右側の下向き三角 (▼) をクリックし、[削除] をクリックしてスタイルを削除するか、[スタイルの変更] をクリックして名前を変更します。

文書から以前の版の情報を削除する方法

Word には、1 つのファイル内に同じ文書の複数の版を保存できるようにするための、ファイルの版の管理機能が含まれています。文書を他のユーザーと共有する前に、その文書の以前の版を削除しておくことをお勧めします。

文書の 1 つ以上の版を削除するには、次の手順を実行します。
  1. [ファイル] メニューの [版の管理] をクリックします。
  2. 削除する文書の版をクリックします。

    複数の版を選択するには、Ctrl キーを押しながら版をクリックします。
  3. [削除] をクリックします。
  4. 文書の以前の版の削除が完了したら、[ファイル] メニューの [上書き保存] をクリックします。

フィールド コードからリンクを削除する方法

Word 文書内のリンクされている画像やその他のオブジェクトには、リンク先の画像やオブジェクトのパスなどのリンク情報が含まれている場合があります。フィールド コードを編集することにより、文書からリンク情報を削除することができます。

フィールド コードを表示するには、以下の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックし、[表示] タブをクリックします。
  2. [フィールド コード] チェック ボックスをオンにし、[OK] をクリックします。
フィールド コードが表示されたら、識別情報が含まれているかどうかを確認することができます。

リンクされている画像やその他のオブジェクトからリンク情報を削除するには、次の手順を実行します。
  1. リンクされている画像またはオブジェクトをクリックします。フィールド コードが表示されている場合は、画像やオブジェクトのフィールド コードをクリックします。
  2. Ctrl + Shift + F9 キーを押します。
画像またはオブジェクトのリンクが削除されます。リンクを削除すると、その画像またはオブジェクトは編集できません。

テンプレートの名前と場所を削除する方法

Word で作成される文書は、すべてテンプレートに基づいています。デフォルトでは、Templates フォルダにある Normal.dot テンプレート ファイルが使用されます。しかし、他の場所にある別のテンプレートを基に文書を作成することもできます。このテンプレートのパスと名前は、文書のプロパティに格納されます。

テンプレートの名前と場所を表示するには、[ファイル] メニューの [プロパティ] をクリックし、[ファイルの概要] タブをクリックします。

テンプレートを文書と一緒に送信しない場合でも、文書にはテンプレートの名前と場所が格納されます。テンプレートの名前と場所を、個人を特定できない値に変更するには、次の手順を実行します。
  1. [ツール] メニューの [テンプレートとアドイン] をクリックします。
  2. [添付] をクリックします。
  3. ファイル名やパスに、重要な情報や固有の情報が含まれていないテンプレートをクリックします。

    たとえば、Word がインストールされているすべてのコンピュータには Normal.dot ファイルがあるため、Normal.dot を選択することもできます。
  4. [開く] をクリックし、[OK] をクリックします。
: テンプレートには、マクロ、定型句、ユーザー設定のスタイル、およびユーザー設定のツール バーが含まれていることがあります。文書で使用するテンプレートを変更すると、これらの項目を文書で利用できなくなる可能性があります。

回覧先情報を削除する方法

回覧先を使用して、電子メールで文書を送信すると、ルーティング情報が文書に添付される可能性があります。この情報を文書から削除するには、回覧先情報が保持されない形式で文書を保存する必要があります。

Word で、文書をリッチ テキスト形式 (RTF) または HTML 形式で保存します。文書を閉じてから、保存した新しいファイルを再度開きます。この作業により回覧先情報が削除されるため、作業の実行後、文書を Microsoft Word 形式で保存できます。

次の手順を使用することもできます。
  1. この資料の「高速保存を無効にする方法」に記載されている手順を実行して、高速保存を無効にします。
  2. [ファイル] メニューの [送信] をポイントし、[回覧先] をクリックします。
  3. [クリア] をクリックして回覧先を削除し、[OK] をクリックします。
  4. [ファイル] メニューの [上書き保存] をクリックします。
これにより、回覧先情報が何も含まれない状態で文書が保存されます。

Visual Basic のコードから自分の名前を削除する方法

重要 : 以下のサンプル マクロを使用する前に、この資料の「免責」をお読みください。

Word で VBA マクロを記録すると、記録されたマクロのヘッダーの冒頭に以下のようなテキストが含まれています。
	' Macro1 Macro
	' Macro recorded 3/11/1999 by <User Name>
記録したマクロからユーザー名を削除するには、以下の手順を実行します。
  1. マクロが含まれている文書を開きます。
  2. [ツール] メニューの [マクロ] をポイントし、[Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. プロジェクト ウィンドウで、対象となるマクロが含まれているモジュールをダブルクリックします。
  4. 記録されているマクロ コードから自分の名前を削除します。
名前の削除が完了したら、Alt + Q キーを押して、アプリケーションに戻ります。その後、[ファイル] メニューの [上書き保存] をクリックします。

他のファイルに対する Visual Basic の参照設定を削除する方法

Visual Basic Editor では、他のファイルへの参照を作成することができます。他のファイルへの参照が含まれている文書を開くと、参照先ファイルの名前が表示されます。

これらの参照を削除するには、以下の手順を実行します。
  1. 参照が含まれる文書を開きます。
  2. [ツール] メニューの [マクロ] をポイントし、[Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. [ツール] メニューの [参照設定] をクリックします。
  4. 参照先のファイルの横にあるチェック ボックスをオフにします。

    完了したら、[OK] をクリックします。
  5. Alt + Q キーを押します。
  6. [ファイル] メニューの [上書き保存] をクリックします。
: 他のファイルへの参照を削除すると、文書内のマクロが正常に動作するための機能が損なわれる可能性があります。

ネットワークやハード ディスクの情報を削除する方法

文書をローカルのハード ディスク、またはネットワーク サーバー上に保存すると、ローカル ハード ディスクやネットワーク サーバーを識別する情報が文書に書き込まれる可能性があります。

Word 文書からこの情報を削除するには、以下の手順を実行します。
  1. 文書を開きます。
  2. [ファイル] メニューの [名前を付けて保存] をクリックします。

    文書をフロッピー ディスク ドライブ (通常はドライブ A です) に保存します。
  3. [ファイル] メニューの [閉じる] をクリックします。
  4. フロッピー ディスク ドライブからフロッピー ディスクを取り出します。
これにより、エクスプローラを使用して、フロッピー ディスクから任意のハード ディスクやネットワーク サーバーに文書をコピーすることができます。

: フロッピー ディスクの容量に制限 (通常 1.44 MB) があるため、文書のファイル サイズがフロッピー ディスクの空き容量を超えている場合、この方法は使用できません。

文書内の埋め込みオブジェクトに含まれていることがあるメタデータ

文書内にオブジェクトを埋め込むと、文書に対してどのような操作を行っても、そのオブジェクト固有のプロパティは保持されます。たとえば、Microsoft Excel ブックを Word 文書内に埋め込んだ場合、文書とブックはそれぞれ独自のプロパティを持ちます。

埋め込みオブジェクトからメタデータを削除するには、オブジェクトをアクティブにし、前に記載されている手順を実行してメタデータをすべて削除し、そのオブジェクトが含まれる文書を再度アクティブにし、その文書を保存します。

: 文書の埋め込みオブジェクトをアクティブにする場合、埋め込みオブジェクトの一部のみが文書内に表示され、その他の情報は非表示のままオブジェクトに含まれている可能性があります。埋め込みオブジェクトの実際の内容ではなく、表示されている部分のみが文書に含まれるようにするには、[編集] メニューの [切り取り] コマンドを使用してオブジェクトを削除し、[形式を選択して貼り付け] コマンドを使用してオブジェクトをメタファイル形式で文書に貼り付けます。これを行った後、埋め込みオブジェクトの編集はできなくなりますが、メタデータは完全に含まれなくなります。

文書変数に含まれていることがあるメタデータ

重要 : 以下のサンプル マクロを使用する前に、この資料の「免責」をお読みください。

Word 文書に含まれている文書変数を削除するには、次のサンプル マクロを使用します。
	Sub DeleteDocVars()
	
	   Dim Response
	   Dim myVar As Variable
	
	   For Each myVar In ActiveDocument.Variables
	      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
	         "Value: " & myVar.Value & vbCr & vbCr & _
	         "Do you want to delete the variable from this document?", vbYesNo)
	            
	      If Response = "6" Then
	         ' Delete the variable.
	         myVar.Delete
	      Else
	         End
	      End If
	   Next myVar
	            
	   MsgBox "There are no variables in the document."
	   
	End Sub
変数の関連情報については、Visual Basic Editor で [ヘルプ] メニューの [Microsoft Visual Basic ヘルプ] をクリックし、Office アシスタントまたはアンサー ウィザードに Variables プロパティと入力し、[検索] をクリックして、該当する項目を参照してください。

セキュリティに関する一般的な注意事項

使用しているコンピュータ環境でセキュリティ レベルの強化に役立つ一般的な注意事項について記載します。
  • コンピュータのそばから離れるときは、パスワードで保護されたスクリーン セーバー、システム起動時のパスワード、または Windows NT のロック機能を必ず使用してコンピュータを保護します。
  • 使用しているコンピュータに共有フォルダがある場合は、必ずパスワードを適用して、許可されているユーザーのみが共有にアクセスできるようにします。より高いセキュリティを実現するためには、ユーザー レベルのアクセス制御を行って、コンピュータの共有にアクセスできるユーザーを厳密に制御します。
  • ファイルを削除した後、すぐにごみ箱を空にします。ファイルを削除するときに、自動的に完全消去または上書きを行うユーティリティの使用を検討することもできます。
  • バックアップしたデータは、金庫または鍵付きのキャビネットなどの安全な場所に保管します。
  • 重要な文書はパスワードで保護し、許可されているユーザー以外は開くことができないようにします。パスワードは、文書とは別の、安全な場所に保管します。パスワードを忘れた場合、パスワードで保護された文書の内容を復元する方法はありません。
  • 電子的な形態で文書を配布しないようにし、代わりに印刷します。プレゼンテーションなどで必要な場合を除いて、独自のフォント、透かし、ロゴ、または特殊な用紙など、相手から自分が特定されるような要素を使用しないようにします。
  • 電子メールは匿名では送受信されません。何らかの方法で文書に自分の識別情報が付加されることに心配がある場合は、文書を電子メールで送信しないようにします。
  • HTTP または FTP プロトコルを使用して、インターネット上で文書を送信しないようにします。これらのプロトコルを使用して送信される情報は、"クリア テキスト" で送信されます。このため、実際に行われる可能性は小さいですが、その文書の内容を盗み見ることが、技術的には可能です。

プロパティ

文書番号: 825576 - 最終更新日: 2006年6月20日 - リビジョン: 5.0
この資料は以下の製品について記述したものです。
  • Microsoft Office Word 2003
キーワード:?
kbregistry kbhowtomaster KB825576
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com