Applies ToGeneral

Symptoms

When you try to open a Microsoft Management Console snap-in that involves security policies (such as Local Security Policy, Group Policy, or Domain Security Policy), the console may not open, and you may receive an error message similar to one of the following error messages:Error message 1

Snap-in failed to initialize.Name: Group PolicyCLSID: {8FC0B734-A0E1-11D1-A7D3-0000F87571-E3}

Error message 2

Snap-in failed to initialize.Name: Resultant Set of PolicyCLSID:{6DC3804B-7212-458D-ADB0-9A07E2AE1FA2}

Error message 3

Snap-in failed to initialize.Name: Software Installation (Computers)CLSID:{942A8E4F-A261-11D1-A760-00C04FB9603F}

Error message 4

Snap-in failed to initialize.Name: <unknown>CLSID:{8FC0B734-A0E1-11D1-A7D3-0000F87571E3}

Cause

This behavior occurs because the PATH environment variable does not include the %SystemRoot%\System32\WBEM folder.

Resolution

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix it button or link. In the File Download dialog box, click Run, and then follow the steps in the Fix it Wizard.

Notes

  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD, and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.

Let me fix it myself

To resolve this behavior, add the %SystemRoot%\System32\WBEM folder to your PATH environment variable. To do so, follow these steps:

  1. Right-click My Computer, and then click Properties.

  2. On the Advanced tab, click Environment Variables.

  3. Under System Variables double-click the PATH environment variable.

  4. Type:

    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\system32\WBEMNote If other system variables appear, do not remove them.

  5. Click OK, and then click OK.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.

  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

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