How to add a hyperlink to a shape that opens in a new Web browser window in Visio

Article translations Article translations
Article ID: 827232 - View products that this article applies to.
Expand all | Collapse all

On This Page

SUMMARY

This article describes how to add a hyperlink to a shape in your Microsoft Office Visio 2007 or Microsoft Office Visio 2003 drawing so that when you click the hyperlink after you save your Visio drawing as a Web page, Microsoft Internet Explorer opens a new window and displays the destination Web site.

To configure the destination Web Page of a hyperlink in a shape to open in a new window in Internet Explorer, you must edit the ShapeSheet of the shape and set the NewWindow value to TRUE after you add the hyperlink to the shape in your drawing.

How to add a hyperlink to a shape that opens in a new Internet Explorer window

To add a hyperlink to a shape in your Visio drawing and configure the hyperlink to open in a new window in Internet Explorer, follow these steps:
  1. Start Visio and open your drawing.
  2. Add a hyperlink to a shape in your drawing. To do so, follow these steps:
    1. In your drawing, click the shape where you want to add the hyperlink.
    2. On the Insert menu, click Hyperlinks.
    3. In the Address box, do one of the following:
      • Type the URL of the Web site that you want to use as the destination for the hyperlink.

        -or-
      • Click Browse, click Internet Address, connect to the Web site that you want to use as the destination for the hyperlink, and then go back to your Visio drawing before you quit Internet Explorer.
    4. In the Description box, type the description that you want.
    5. Click OK.
  3. Edit the ShapeSheet of the shape. To do so, follow these steps:
    1. Click the shape that contains the hyperlink.
    2. On the Window menu, click Show ShapeSheet.
    3. In the Hyperlinks table, locate the row that represents the hyperlink that you added.
    4. In the NewWindow column, change the value that is displayed in the cell for the hyperlink from FALSE to TRUE.

      To do so, double-click the cell, and then click TRUE.
    5. Click the X in the upper-right corner of the ShapeSheet window to close it.
  4. Save your drawing as a Web page. To do so, follow these steps:
    1. On the File menu, click Save as Web Page.
    2. In the Save As dialog box, specify a name and location where you want to save the Web page, and then click Save.
    3. Open the Web page, and then click the shape that contains the hyperlink.

      The destination Web site for the hyperlink opens in a new Internet Explorer window.

REFERENCES

For more information about working with hyperlinks in Visio, see Visio Help. To do so, click Microsoft Office Visio Help on the Help menu, type hyperlinks in the Search for box, and then press ENTER to view the topics that are returned. For more information about how to troubleshoot issues with hyperlinks in Visio 2003, click the following article numbers to view the articles in the Microsoft Knowledge Base:
830041 A hyperlink does not work on a Web page that is created in Visio 2003
830042 Visio 2003 appears to stop responding when you right-click a shape in your Web site map diagram and then click Interactive Hyperlink Selection
828966 Web links to drawing pages do not work when the drawing is saved as a Web page in Visio 2003
For more information about Visio, visit the following Microsoft Web site:
http://www.microsoft.com/office/visio

Properties

Article ID: 827232 - Last Review: April 19, 2007 - Revision: 3.2
APPLIES TO
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
Keywords: 
kbhowtomaster KB827232

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com