Id. de artículo: 831429 - Última revisión: miércoles, 15 de septiembre de 2010 - Versión: 3.1

Windows XP deja de responder cuando descarga actualizaciones desde Windows Update

Nota acerca de su sistema operativoEste artículo se aplica a un sistema operativo distinto al que usa. El contenido del artículo que puede que no sea importante para usted, se deshabilitará

En esta página

Expandir todo | Contraer todo

Síntomas

Cuando intenta descargar una actualización del sitio Web de Windows Update en un equipo basado en Windows 2000 o en Windows XP, puede experimentar alguno de los síntomas siguientes:
  • Recibe el mensaje de error siguiente:
    Error de inicialización 0x8007007e
    En el archivo Windows Update.log del directorio de Windows puede aparecer un mensaje similar al siguiente:
    Error IUENGINE Determinando la configuración del equipo (Error 0x8007007E: No se puede encontrar el módulo especificado).
  • Su equipo puede dejar de responder tras aceptar el contrato de licencia para el usuario final.

Causa

Este problema podría deberse a que hay archivos del sistema dañados o que no se han incluido en el Registro.

Solución

Para resolver este problema, use los métodos siguientes según corresponda al sistema operativo en el orden en que aparecen.

Windows XP

Para comprobar los archivos del sistema, siga estos pasos:
  1. Haga clic en Inicio, en Ejecutar y escriba:Cmd.exe
  2. Haga clic en Aceptar.
  3. Escriba:
    SFC.exe /scannow
  4. Presione ENTRAR. Windows comprueba los archivos protegidos de Windows y puede que se muestre un mensaje que le pida que inserte el CD de Windows XP para restaurar los archivos.
  5. Cuando la comprobación de los archivos se complete, escriba:
    exit
  6. Presione ENTRAR.

Windows 2000

Método 1: incluir en el Registro los archivos del sistema

Para incluir en el Registro los archivos del sistema, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, y escriba:
    regsvr32 /i Urlmon.dll
  2. Haga clic en Aceptar.
  3. Cuando aparezca el mensaje "DllRegisterServer in urlmon.dll succeeded", haga clic en Aceptar e intente usar el sitio de Windows Update.
  4. Si el problema se repite, vuelva a realizar los pasos 1 a 3 para cada uno de los comandos siguientes:
    • regsvr32 /i Shdocvw.dll
    • regsvr32 Msjava.dll
    • regsvr32 Actxprxy.dll
    • regsvr32 Oleaut32.dll
    • regsvr32 /i Mshtml.dll
    • regsvr32 /i Browseui.dll
    • regsvr32 /i Shell32.dll
Si el problema no se resuelve, algunos archivos del sistema pueden ser incorrectos. Continúe con el método siguiente.

Método 2: ejecutar la herramienta de reparación de Internet Explorer

Para ejecutar la herramienta de reparación de Internet Explorer, siga estos pasos:
  1. Haga clic en Inicio, seleccione Configuración y haga clic en Panel de control.
  2. Haga doble clic en Agregar o quitar programas.
  3. En la ficha Cambiar o quitar programas, haga clic en Microsoft Internet Explorer.
  4. Haga clic en Cambiar o quitar, active la casilla Reparar Internet Explorer y haga clic en Aceptar.
  5. Cuando se le pregunte si desea detectar y reparar problemas con Internet Explorer, haga clic en .
Si el problema no se resuelve, continúe con el método siguiente.

Método 3: instalar el Analizador XML de Microsoft

Para obtener e instalar la versión más reciente del Analizador XML de Microsoft, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/downloads/details.aspx? FamilyId=2CF40AE6-368C-4B6B-A185-2DFA92FB7993&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyId=2CF40AE6-368C-4B6B-A185-2DFA92FB7993&displaylang=en)
Después de instalar el Analizador XML, intente conectarse al sitio de Windows Update.

La información de este artículo se refiere a:
  • Microsoft Windows Update
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
  • Enciclopedia Microsoft Encarta 2000 Deluxe
Palabras clave: 
kbenv kbprb KB831429