Windows XP'de CD sürücüsünü kullanmaya çalıştığınızda "Bir G/Ç aygıt hatası nedeniyle istek yürütülemedi" hata iletisini alıyorsunuz

Makale çevirileri Makale çevirileri
Makale numarası: 891894 - Bu makalenin geçerli olduğu ürünleri görün.
Şablon: Genel Sorun Makalesi
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Windows XP'de CD sürücüsünden bir program yüklemeye veya veri kopyalamaya çalıştığınızda, aşağıdaki hata iletilerinden birini alabilirsiniz:
Bir G/Ç aygıt hatası nedeniyle istek yürütülemedi
ReadProcessMemory veya WriteProcessMemory isteğinin sadece bir parçası tamamlandı

Neden

Bu hata iletisi sabit disk, CD sürücüsü veya ağ sürücüsü gibi bir aygıtı okuma veya aygıta yazma sorunu olduğunu gösterir. Bu sorun aşağıdaki nedenlerden herhangi birinden dolayı oluşabilir:
  • Windows, CD sürücüsünün kullanamadığı bir aktarım modu kullanmaya çalışıyor.
  • Erişmeye çalıştığınız donanım arızalı veya hata veriyor.
  • Donanımın aygıt sürücüleri hatalı veya uyumsuz.
  • Hatalı kablo gibi bir bağlantı sorunu var.
  • Erişmeye çalıştığınız CD bozuk.

BAŞLAMADAN ÖNCE

CD'yi okuma ile ilgili birçok genel sorun aşağıdaki basit adımlardan biriyle çözülebilir. Sorunun çözülüp çözülmediğini görmek için ilk önce bu adımları deneyin.
  • Bilgisayarı yeniden başlatın ve CD'yi tekrar deneyin.
  • Bir temizleme diski kullanarak CD Sürücüsü'nü temizleyin.
  • Başka bir bilgisayara erişiminiz varsa, CD'nin bozuk olmadığından emin olmak için CD'deki verilere diğer bilgisayarla erişmeyi deneyin. CD'ye diğer bilgisayardan da erişilemiyorsa, CD'yi temizleyip yeniden deneyin.
  • Başka bir bilgisayara erişiminiz yoksa, sorunun özgün CD ile değil bilgisayarla ilgili olduğundan emin olmak için CD sürücüsünde farklı bir CD kullanmayı deneyin.
Sorun çözülürse ve hata iletisini artık almıyorsanız işiniz tamamlanmış demektir. Sorun devam ediyorsa sonraki bölüme geçin.

Çözüm

Sorun gidermek ve sorunu çözmeye çalışmak için kullanabileceğiniz birkaç yöntem bulunmaktadır. Bu yöntemleri sunuldukları sırayla kullanın.

Bu makale yeni ve orta düzey bilgisayar kullanıcılarına yöneliktir.

Bu makaleyi yazdırarak adımları daha kolay izleyebilirsiniz.

Yöntem 1: Tüm kabloların doğru şekilde bağlandığından emin olma

CD sürücüsü bir USB aygıtı gibi bir harici sürücüyse, sürücüyü bilgisayara bağlayan kablonun düzgün çalıştığından emin olun. Kablo düzgün çalışmıyorsa CD sürücüsü de düzgün çalışmaz. Başka bir kablonuz varsa bu kabloyu kullanmayı ve başka bir USB bağlantı noktasına bağlamayı deneyin.

Not Masaüstü bilgisayarlarda yalnızca deneyimli bilgisayar kullanıcılarının dahili sürücü kablolarını değiştirmesi önerilir, çünkü kolayca hasar görebilecek birçok dahili öğe bulunmaktadır. Dizüstü veya taşınabilir bilgisayarlarda kabloları değiştirmeyi denememelisiniz.

Bağlantının düzgün çalıştığını doğrulayarak, başka bir USB bağlantı noktasına bağlayarak veya farklı bir kablo kullanarak sorunu çözerseniz işiniz tamamlanmış demektir. Bu yöntem sorunu gidermediyse yöntem 2'ye geçin.

Yöntem 2: Bilgisayarı temiz önyükleme durumunda yeniden başlatma

CD sürücüsüyle çakışan bir program veya sürücü olup olmadığını belirlemek için bilgisayarınızda temiz önyükleme gerçekleştirmeyi deneyin. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
310353 Windows XP bir "temiz önyükleme" durumunda başlatılacak biçimde nasıl yapılandırılır
Temiz önyükleme sorunu giderirse, bilgisayarda uyumsuz bir program veya sürücü olabilir. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
316434 Windows XP'de gelişmiş temiz önyükleme sorun gidermesi nasıl gerçekleştirilir
Bu yöntem sorunu çözdüyse, işleminiz tamamlanmıştır. Bu yöntem sorunu gidermediyse Yöntem 3'e geçin.

Yöntem 3: CD sürücüsü için IDE Kanalı Özellikleri'nde aktarım modunu değiştirme

CD sürücüsünün aktarım modu değiştirilmişse veya yanlışsa, Windows verileri CD'den bilgisayara aktaramaz. Doğru aktarım moduna geçerek bu sorunu çözebilirsiniz. Aktarım modunu değiştirmek için şu adımları izleyin:
  1. Başlat'ı ve ardından Çalıştır'ı tıklatın.
  2. kutusuna devmgmt.msc yazın ve ENTER tuşuna basın.

    Aygıt Yöneticisi iletişim kutusu açılır.
  3. IDE ATA/ATAPI denetleyiciler'i genişletin. Bilgisayardaki farklı IDE ATA/ATAPI kanallarının listelendiği bir alt küme açılır.
  4. CD sürücüsünün bağlı olduğu kanalı sağ tıklatın ve sonra Özellikler'i tıklatın. Genellikle bu kanal İkincil IDE Kanalı'dır.

    Uyarı Birincil IDE Kanalı olan Aygıt 0'ı değiştirmeyin, çünkü bu genelde sistem diskidir. Bu aktarım modu ayarının değiştirilmesi, bilgisayarın düzgün çalışmamasına veya hiç çalışmamasına neden olabilir.
  5. Gelişmiş Ayarlar sekmesinde, CD sürücünüzü temsil eden aygıtın Aktarım Modu kutusunda Salt PIO seçeneğini belirleyin. Genellikle bu Aygıt 0'dır. Sonra Tamam'ı tıklatın.
  6. CD sürücüsündeki CD'yi sınayın.
İkincil IDE kanal aygıtı 0 için aktarım modunu değiştirdikten sonra sorun çözülmezse, CD sürücüsü konumu bu olmayabilir. Aktarım modunu yeniden DMA kullanılabiliyorsa olarak değiştirmek için aynı yordamı kullanın. Ardından, 1-6 arasındaki adımları yineleyerek sorun çözülünceye kadar IDE aygıtlarının aktarım modunu aşağıdaki sırayla değiştirin:
  • Birincil IDE kanalı, aygıt 1
  • İkincil IDE kanalı, aygıt 1
Bu yöntem sorunu çözdüyse, işleminiz tamamlanmıştır. Bu yöntem sorunu gidermediyse yöntem 4'ü deneyin.

Yöntem 4: Aygıt Yöneticisi'nde aygıtın durumunu denetleme

Aygıt sürücüsünün düzgün çalıştığından emin olmak için Aygıt Yöneticisi'nde aygıtın durumunu denetleyebilirsiniz. Bir donanım arızası varsa veya aygıtın düzgün çalışmasını engelleyen bir yazılım çakışması bulunuyorsa, Aygıt Yöneticisi genellikle bu sorunu algılar. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
283658 NASIL YAPILIR: Windows XP'de Aygıtları Yönetme (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)
Bu yöntem sorunu çözmenize yardımcı olduysa, işleminiz tamamlanmıştır. Bu yöntem sorunu gidermediyse yöntem 5'e geçin.

Yöntem 5: Donanım üreticisine başvurma

CD sürücüsü için güncelleştirilmiş bellenim veya aygıt sürücüleri olabilir. Kullanabileceğiniz bir bellenim veya aygıt sürücüsü güncelleştirmesi olup olmadığını belirlemek için donanımın üreticisine başvurun. Donanım üreticiniz hakkında bilgi için aşağıdaki Web sitesini ziyaret edin:
http://support.microsoft.com/gp/vendors/
Microsoft, teknik destek bulmanıza yardımcı olmak üzere üçüncü taraf iletişim bilgilerini sağlamaktadır. Bu iletişim bilgileri önceden haber verilmeksizin değiştirilebilir. Microsoft bu üçüncü taraf iletişim bilgilerinin doğruluğunu garanti etmez. Bu yöntem işe yaramadıysa ve gelişmiş sorun giderme adımları konusunda deneyimliyseniz, "Gelişmiş sorun giderme" bölümüne geçin.

Gelişmiş sorun giderme adımları konusunda deneyimli değilseniz, "Sonraki Adımlar" bölümüne gidin.

GELİŞMİŞ SORUN GİDERME

Aygıta başka bir bilgisayarda erişmeyi deneme

Diğer tüm yöntemleri denediyseniz, CD sürücüsünü bilgisayardan fiziksel olarak çıkartıp başka bir bilgisayara takarak donanımın arızalı olup olmadığını belirleyebilirsiniz. Sorun devam ediyorsa ve CD sürücüsü farklı bir bilgisayarda çalışmıyorsa donanım arızalı olabilir. Yardım için donanımın üreticisine başvurun. Donanım üreticiniz hakkında bilgi için aşağıdaki Web sitesini ziyaret edin:
http://support.microsoft.com/gp/vendors/
Microsoft, teknik destek bulmanıza yardımcı olmak üzere üçüncü taraf iletişim bilgilerini sağlamaktadır. Bu iletişim bilgileri önceden haber verilmeksizin değiştirilebilir. Microsoft bu üçüncü taraf iletişim bilgilerinin doğruluğunu garanti etmez. Bu sorun giderme adımıyla sorunu çözemediyseniz "Sonraki Adımlar" bölümüne geçin.

SONRAKİ ADIMLAR

Benzer sorunlar ve çözümleri

Bu makalede listelenen tüm yöntemleri denediyseniz ve CD sürücüsü yine de düzgün çalışmıyorsa, sorunu gidermenize yardımcı olacak diğer destek makalelerini deneyebilirsiniz. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
324129 Windows XP'de CD-R veya CD-RW Optik Diske veri yazarken oluşan sorunları giderme
307148 Bilgisayar hazırla bekleme modundan çıktığında DVD-ROM sürücüsüne erişilemiyor (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)

Destek hizmetlerine başvurma

Bu yöntemler işe yaramadıysa, Microsoft Müşteri Destek Hizmetleri Web sitesini kullanarak sorununuza yönelik başka çözümler bulabilirsiniz Microsoft Müşteri Destek Hizmetleri Web sitesinin sağladığı bazı hizmetler şunlardır:
  • Aranabilir Bilgi Bankası: Microsoft ürünleri hakkında teknik destek bilgileri ve kendi kendinize yardım araçlarını arayın.
  • Çözüm Merkezleri: Ürüne özgü sık sorulan soruları ve önemli destek konularını görüntüleyin.
  • Microsoft Müşteri Destek Haber Grupları: Ortaklarınıza, meslektaşlarınıza ve Microsoft'un En Değerli Uzmanları'na (MVP) danışın.
  • Diğer Destek Seçenekleri: Web'i kullanarak bir soru sorun, Microsoft Müşteri Destek Hizmetleri'ne başvurun veya görüş bildirin.
Sorunları yaşamaya devam ediyorsanız Destek hizmetlerine başvurabilirsiniz:
http://support.microsoft.com/contactus


Windows Vista'da CD veya DVD sürücüsü sorunlarıyla ilgili yardım için aşağıdaki Microsoft Web sayfasını ziyaret edin:

Özellikler

Makale numarası: 891894 - Last Review: 19 Ekim 2009 Pazartesi - Gözden geçirme: 4.3
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Anahtar Kelimeler: 
kbexpertiseinter kbexpertisebeginner kbresolve kbtshoot kbprb KB891894

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com