ファイアウォールまたはプロキシ サーバーの内側にある Windows XP ベースのコンピューターから Windows Update Web サイトにアクセスすると更新プログラムをダウンロードできない

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文書番号: 896226 - 対象製品
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現象

ファイアウォールまたはプロキシ サーバーの内側にある Windows XP ベースのコンピューターから Windows Update Web サイトにアクセスしたときに、更新プログラムをダウンロードできません。また、Web ページの右上隅に次のいずれかのエラー メッセージが表示されることがあります。
[エラー番号: 0x80244017]
[エラー番号: 0x80244018]
[エラー番号: 0x80244019]
[エラー番号: 0x8024401B]
[エラー番号: 0x80244021]
: Windowsupdate.log ファイルを確認して、Windows Update または自動更新でエラーが発生したかどうかを判断できます。既定では、Windowsupdate.log ファイルにメッセージが記録されるように構成されています。このログ ファイルは %Windir% フォルダーにあります。%Windir% フォルダーは、コンピューター内で Windows がインストールされているフォルダーです。

原因

Windows XP では、Microsoft Windows HTTP サービス (WinHTTP) を使用して Windows Update Web サイトとの通信を行います。また、Windows XP では、バックグラウンド インテリジェント転送サービス (BITS) を使用して更新プログラムをダウンロードします。「現象」に記載されているエラー メッセージは、以下の内容を表しています。
  • クライアントはプロキシまたはファイアウォールを検出できました。
  • クライアントはエラー メッセージを受信しました。
  • クライアントは Windows Update サイトへのアクセスを拒否されました。

解決方法

この問題を解決するには、プロキシ サーバーまたはファイアウォールで Windows Update Web サイトへの匿名アクセスが構成されていることを確認します。Windows Update の宛先セットまたは URL セットを作成する際に、以下の宛先を含めます。
  • http://download.windowsupdate.com
  • https://*.update.microsoft.com
  • http://*.update.microsoft.com
  • http://update.microsoft.com
  • http://*.windowsupdate.com
  • http://download.microsoft.com
  • http://update.microsoft.com
  • http://ntservicepack.microsoft.com
  • http://wustat.windows.com
  • https://update.microsoft.com
  • http://*.download.windowsupdate.com
  • http://*.update.microsoft.com
  • https://*.update.microsoft.com
: プロキシ サーバーまたはファイアウォールを匿名アクセス用に構成する方法については、使用しているプロキシ サーバーまたはファイアウォールのマニュアルを参照してください。

ISA サーバーを匿名アクセス用に構成する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
885819 ISA Server を実行するサーバーを経由して Windows Update Version 5 の Web サイトにアクセスするときにエラーが発生する

回避策

この問題を回避するには、管理者が以下のいずれかの方法を使用して Windows 更新プログラムをインストールします。
  • Microsoft Software Update Services (SUS) を使用して更新プログラムをインストールします。SUS の詳細については、次のマイクロソフト Web サイトを参照してください。
    http://technet.microsoft.com/ja-jp/wsus/bb466186.aspx
  • Microsoft Systems Management Server を使用して更新プログラムをインストールします。Systems Management Server の詳細については、次のマイクロソフト Web サイトを参照してください。
    http://technet.microsoft.com/ja-jp/systemcenter/default.aspx
  • Windows XP の Service Pack、セキュリティ修正プログラム、および機能更新プログラムを手動でダウンロードします。これを行うには、次のマイクロソフト Web サイトを参照してください。
    http://www.microsoft.com/japan/windowsxp/downloads/updates/default.mspx

詳細

プロキシ サーバーまたはファイアウォールが既に匿名アクセス用に構成されている場合は、Network Monitor Capture Utility を使用することで、「現象」に記載されているエラー メッセージの実際の原因について、より詳細な情報を収集できます。Network Monitor Capture Utility でエラー メッセージの実際の原因を表示するには、Windows Update Web サイトにアクセスするときに、このユーティリティが実行されている必要があります。 Network Monitor Capture Utility の詳細については、以下のサポート技術情報番号をクリックしてください。
310875 Network Monitor Capture Utility について

プロパティ

文書番号: 896226 - 最終更新日: 2013年2月6日 - リビジョン: 9.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows Update
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Update
キーワード:?
kbtshoot KB896226
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