Не удается загрузить обновления с веб-сайта Центра обновления Windows на компьютер с Windows XP, защищенный брандмауэром или прокси-сервером

Переводы статьи Переводы статьи
Код статьи: 896226 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

Если заходить на веб-сайт Центра обновления Windows на компьютере с Windows XP, защищенном брандмауэром или прокси-сервером, не удается загрузить обновления. В правом верхнем углу веб-страницы вы также можете увидеть одно из следующих сообщений об ошибке:
[Номер ошибки: 0x80244017]
[Номер ошибки: 0x80244018]
[Номер ошибки: 0x80244019]
[Номер ошибки: 0x8024401B]
[Номер ошибки: 0x80244021]
Примечание Чтобы проверить, обнаружил ли Центр обновления Windows или служба автоматического обновления ошибку, вы можете просмотреть файл Windowsupdate.log По умолчанию файл журнала Windowsupdate.log настроен на запись сообщений в журнал. Этот файл хранится в папке %Windir%. %Windir% — папка, в которой установлена операционная система Windows на компьютере.

Причина

Windows XP использует службы Microsoft Windows HTTP (WinHTTP) для связи с веб-сайтом Центра обновления Windows. Для загрузки обновлений Windows XP также использует фоновую интеллектуальную службу передачи данных (BITS). В сообщениях об ошибках, описанных в разделе "Проблема", указывается следующее:
  • Клиент обнаружил прокси-сервер или брандмауэр.
  • Клиент получил сообщение об ошибке.
  • Клиенту был запрещен доступ к веб-сайту Центра обновления Windows.

Решение

Чтобы устранить эту проблему, убедитесь, что прокси-сервер или брандмауэр настроены для анонимного доступа к веб-сайту Центра обновления Windows. Создавая набор мест назначения или URL-адресов для Центра обновления Windows, включите в него следующие адреса:
  • http://download.windowsupdate.com
  • https://*.update.microsoft.com
  • http://*.update.microsoft.com
  • http://update.microsoft.com
  • http://*.windowsupdate.com
  • http://download.microsoft.com
  • http://update.microsoft.com
  • http://ntservicepack.microsoft.com
  • http://wustat.windows.com
  • https://update.microsoft.com
  • http://*.download.windowsupdate.com
  • http://*.update.microsoft.com
  • https://*.update.microsoft.com
Примечание Информацию о том, как настроить прокси-сервер или брандмауэр для анонимного доступа, см. в документации к ним.

Дополнительные сведения о настройке сервера ISA Server для анонимного доступа см. в следующей статье базы знаний Майкрософт:
885819 Проблемы с подключением к веб-сайту Центра обновления Windows версии 5 через сервер с ISA Server

Временное решение

Чтобы устранить эту проблему, администраторы могут использовать один из указанных ниже способов при установке обновлений Windows:
  • Установка обновлений с помощью Microsoft Software Update Services (SUS). Дополнительные сведения о Microsoft Software Update Services (SUS) см. на веб-сайте Майкрософт по адресу:
    http://technet.microsoft.com/ru-ru/wsus/bb466186.aspx
  • Установка обновлений с помощью сервера Microsoft Systems Management Server. Дополнительные сведения о Systems Management Server см. на веб-сайте корпорации Майкрософт по следующему адресу:
    http://technet.microsoft.com/ru-ru/sms/default.aspx
  • Ручная загрузка пакетов обновления, исправлений безопасности и обновлений компонентов Windows XP. Для этого посетите веб-сайт Майкрософт по следующему адресу:
    http://windows.microsoft.com/ru-ru/windows/xp-downloads#2TC=featured

Дополнительная информация

Если прокси-сервер или брандмауэр уже настроены для анонимного доступа, можно собрать дополнительную информацию о причине появления сообщений об ошибке, описанных в разделе "Проблема", используя программу записи сетевого монитора. Чтобы на экране отобразилась причина появления сообщений об ошибке, не отключайте программу записи сетевого монитора при попытке установить подключение к веб-сайту Центра обновления Windows. Дополнительные сведения о программе записи сетевого монитора см. в следующей статье базы знаний Майкрософт:
310875 Описание программы записи сетевого монитора

Свойства

Код статьи: 896226 - Последний отзыв: 25 июля 2013 г. - Revision: 4.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows Update
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Update
Ключевые слова: 
kbtshoot KB896226

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com