Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Dopo la connessione a un computer basato su Microsoft Windows Server 2003 Service Pack 1 tramite una sessione di servizi Terminal, il client Servizi Terminal può rendere un segnale acustico audio quando si verificano determinati eventi.

Ad esempio, questo problema si verifica quando si avvia il blocco note in un computer client di servizi Terminal, digitare alcuni caratteri e quindi chiudere Blocco note senza salvare le modifiche. Una finestra di messaggio viene chiesto di salvare le modifiche apportate. Verrà visualizzata la finestra di messaggio con un segnale acustico.

Nota: Questi sintomi si verificano dopo l'installazione di Windows Server 2003 Service Pack 1 su un Server Terminal.

Causa

Questo problema si verifica perché la funzione MessageBeep viene reindirizzata al computer client di servizi Terminal. Se il computer client di servizi Terminal non supporta l'audio, il segnale acustico viene riprodotto attraverso l'altoparlante di sistema.

Risoluzione

Informazioni sul Service pack

Per risolvere questo problema, procurarsi il service pack più recente per Windows Server 2003. Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

889100 informazioni su come ottenere il service pack più recente per Windows Server 2003

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di data e ora nel Pannello di controllo.

Windows Server 2003, versioni basate su x86

   Date         Time   Version            Size    File name
--------------------------------------------------------------
11-Jun-2005 03:02 5.2.3790.346 988,672 Kernel32.dll
11-Jun-2005 03:02 5.2.3790.346 222,208 Termsrv.dll
11-Jun-2005 03:02 5.2.3790.346 52,224 Winsta.dll
25-Feb-2005 03:51 6.1.22.4 371,936 Updspapi.dll

Windows Server 2003 con Service Pack 1, versioni basate su x86

   Date         Time   Version            Size    File name 
--------------------------------------------------------------------
30-Jun-2005 02:35 5.2.3790.360 988,672 Kernel32.dll
30-Jun-2005 02:35 5.2.3790.360 222,208 Termsrv.dll
30-Jun-2005 02:35 5.2.3790.360 52,224 Winsta.dll
05-Mar-2005 01:30 6.1.22.4 371,936 Updspapi.dll
30-Jun-2005 03:06 5.2.3790.2477 245,248 Termsrv.dll
30-Jun-2005 00:58 5.2.3790.2477 32,256 Arpidfix.exe

Windows Server 2003, versioni basate su Itanium

    Date         Time   Version            Size    File name       Platform
--------------------------------------------------------------------
10-Jun-2005 14:29 5.2.3790.346 1,851,392 Kernel32.dll IA-64
10-Jun-2005 14:29 5.2.3790.346 621,568 Termsrv.dll IA-64
10-Jun-2005 14:29 5.2.3790.346 141,824 Winsta.dll IA-64
10-Jun-2005 14:32 5.2.3790.346 934,912 Wkernel32.dll x86
10-Jun-2005 14:32 5.2.3790.346 52,224 Wwinsta.dll x86
24-Feb-2005 15:22 6.1.22.4 639,712 Updspapi.dll IA-64

Windows Server 2003 con Service Pack 1, versioni basate su Itanium

   Date         Time   Version            Size    File name         Platform
-----------------------------------------------------------------------
29-Jun-2005 15:02 5.2.3790.360 1,851,392 Kernel32.dll IA-64
29-Jun-2005 15:02 5.2.3790.360 621,568 Termsrv.dll IA-64
29-Jun-2005 15:02 5.2.3790.360 141,824 Winsta.dll IA-64
29-Jun-2005 15:02 5.2.3790.360 934,912 Wkernel32.dll x86
29-Jun-2005 15:02 5.2.3790.360 52,224 Wwinsta.dll x86
29-Jun-2005 15:02 5.2.3790.2477 696,320 Termsrv.dll IA-64
29-Jun-2005 15:02 5.2.3790.2477 74,752 Arpidfix.exe IA-64
29-Jun-2005 15:02 6.1.22.4 639,712 Updspapi.dll IA-64

Windows Server 2003, versioni basate su x64



Date Time Version Size File name
--------------------------------------------------------------
29-Jun-2005 15:02 5.2.3790.2477 363,008 Termsrv.dll
29-Jun-2005 15:02 5.2.3790.2477 43,008 Arpidfix.exe
29-Jun-2005 15:02 6.1.22.4 462,560 Updspapi.dll

Stato

Microsoft ha confermato che si tratta di un problema nei prodotti Microsoft elencati nella sezione "Si applica a". Il problema è stato risolto in Windows Server 2003 Service Pack 2.

Ulteriori informazioni

Importante Questa sezione, metodo o attività contiene passaggi su come modificare il Registro di sistema. Tuttavia, una modifica errata del registro di sistema potrebbe causare gravi problemi. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Cosicché sia possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

322756 come eseguire il backup e ripristinare il Registro di sistema Windows

Dopo avere applicato l'hotfix, è possibile utilizzare il Registro di sistema per attivare il reindirizzamento della funzione MessageBeep . A tale scopo, attenersi alla seguente procedura:

  1. Fare clic su Start, scegliere Esegui, digitare regedit e quindi fare clic su OK.

  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server

  3. Dal menu Modifica , scegliere Nuovoe quindi fare clic su Valore DWORD.

  4. Digitare DisableBeepe quindi premere INVIO.

  5. Destro DisableBeepe quindi fare clic su Modifica.

  6. Nella casella dati valore digitare 0 e quindi fare clic su OK.

    Nota: È possibile disattivare la funzione MessageBeep modificando il valore su 1.

  7. Chiudere l'Editor del Registro di sistema.

Per ulteriori informazioni sulla descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×