Po prevzatí aktualizácie zo služieb lokality Windows Update, Microsoft Update alebo Windows Server Update sa zobrazuje kód chyby 0x80070002 alebo 0x80070003

ID článku: 910336 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Opraviť problém automaticky

Opraviť tento problém
Microsoft Fix it 50202

Poznámka Súčasťou tohto riešenia Fix it Solution sú dva režimy – Predvolený a Dôrazný. Riešenie Fix it by ste mali spustiť v predvolenom režime a pred jeho spustením v dôraznom režime zistiť, či sa vyriešil problém s lokalitou Windows Update.

PoznámkaAk chcete tento problém vyriešiť sami, prejdite do časti Ja to vyriešim.

Poznámka Tento sprievodca môže byť iba v angličtine, automatická oprava však funguje tiež v ostatných jazykových verziách systému Windows.

Poznámka Ak nepracujete s počítačom, v ktorom sa vyskytol problém, môžete riešenie Fix it uložiť na jednotku flash alebo na disk CD a potom ho môžete spustiť v počítači s problémom.
Boli tieto informácie užitočné? Odošlite nám svoje pripomienky

PRIZNAKY

Aktualizáciu prevezmete z jedného z týchto umiestnení:
  • webová lokalita Microsoft Windows Update,
  • webová lokalita Microsoft Update,
  • server Microsoft Windows Server Update Services (WSUS).
Po vykonaní týchto krokov môže aktualizácia zlyhať a vedľa aktualizácie sa zobrazí červený znak X. V takom prípade sa môže zobraziť jeden z nasledovných chybových kódov:
  • 0x80070002
  • 0x80070003
Poznámka Ak chcete zobraziť chybové hlásenia, musíte na webovej stránke Zobraziť históriu aktualizácií kliknúť na červený znak X zobrazený vedľa aktualizácie, ktorá zlyhala.

PRICINA

Tento problém vznikne v prípade, ak chýbajú niektoré súbory aktualizácie, napriek tomu, že ste aktualizáciu úspešne prevzali a extrahovali.

Ja to vyriešim

Ak chcete problém vyriešiť sami, odstráňte adresár s prevzatými súbormi a znova sa pripojte na lokalitu, z ktorej ste aktualizáciu prevzali.
  1. Zastavte funkciu Automatické aktualizácie. Postupujte takto:
    1. Kliknite na tlačidlo Štart, kliknite na príkaz Spustiť, zadajte príkaz services.msc a potom kliknite na tlačidlo OK.
    2. Pravým tlačidlom myši kliknite na službu Automatické aktualizácie a potom kliknite na položku Zastaviť.
    3. Minimalizujte okno modulu Služby.
  2. Premenujte adresár SoftwareDistribution. Postupujte takto:
    1. Kliknite na tlačidlo Štart, kliknite na príkaz Spustiť, zadajte príkaz cmd a potom kliknite na tlačidlo OK.
    2. Zadajte text cd %windir% a potom stlačte kláves ENTER.
    3. Zadajte text ren SoftwareDistribution SDTemp a stlačte kláves ENTER.
    4. Zadajte príkaz exit a stlačte kláves ENTER.


    Poznámka Po odstránení priečinka %windir%\softwaredistribution sa zoznam histórie odstráni z časti Skontrolujte svoje aktualizácie (Review your Updates) na webovej lokalite Windows Update. Tento krok neovplyvní aktualizácie, ktoré sú nainštalované vo vašom počítači. V zozname histórie sa zobrazia aktualizácie, ktoré budú nasledovať.
  3. Spustite službu Automatické aktualizácie. Postupujte takto:
    1. Maximalizujte okno modulu Služby.
    2. Pravým tlačidlom myši kliknite na službu Automatické aktualizácie a potom kliknite na položku Spustiť.
    3. Zatvorte okno modulu Služby.
  4. Znova navštívte webovú lokalitu Windows Update, Microsoft Update alebo server WSUS a prevezmite aktualizáciu.
  5. Ak sa zobrazia tie isté chyby, overte, či ste správne vykonali kroky 1 až 3.
  6. Ak stále nedokážete nainštalovať aktualizáciu, prečítajte si tento článok databázy Microsoft Knowledge Base:
    906602 Návod na riešenie problémov s inštaláciou služieb lokality Windows Update, Microsoft Update alebo Windows Server Update

Vlastnosti

ID článku: 910336 - Posledná kontrola: 28. septembra 2011 - Revízia: 4.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Update
  • Microsoft Windows Update
Kľúčové slová: 
kbtshoot kbmsifixme kbfixme KB910336

Odošlite odozvu