Erro de jogo: "O arquivo d3dx9_xx.DLL não foi encontrado"

ID do artigo: 910813 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Nesta página

Sintomas

Quando você tenta iniciar um dos jogos Microsoft listados na seção ? aplica-se a ?, receber uma das seguintes mensagens de erro:
Mensagem de erro 1
D3dx9_25.dll arquivo não encontrado
Mensagem de erro 2
D3dx9_27.dll arquivo não encontrado

Causa

Esse problema pode ocorrer se o arquivo do Microsoft DirectX mencionado na mensagem de erro está corrompido ou não é copiado.

Resolução

Baixar e instalar a versão mais recente do DirectX

Para resolver esse problema, baixe e instale a versão mais recente do DirectX End-User Runtimes Web Installer. Para fazer isso, visite o seguinte site:
http://www.microsoft.com/downloads/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en
Observação Você pode receber a seguinte mensagem de erro durante a instalação:
Software que você está instalando não passou no teste do logotipo do Windows que verifica sua compatibilidade com esta versão do Windows. (Diga-me por que esse teste é importante.)
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento:
822798Você não pode instalar algumas atualizações ou programas

Copiar o arquivo manualmente

Para resolver esse problema, copie o arquivo D3dx9_25.dll ou o arquivo D3dx9_27.dll partir CD CD/1 DVD do CD/DVD jogo pack para a pasta correspondente do jogo. Para fazer isso, execute as etapas apropriadas para sua versão do Windows:

Windows 7 ou o Windows Vista

  1. Insira o disco 1 do CD/DVD para o seu jogo na unidade de CD/DVD do computador.
  2. Clique
    Recolher esta imagemExpandir esta imagem
    the Start button
    Iniciar e, em seguida, clique em documentos.
  3. Localize e clique em computador.
  4. Localize e clique em unidade de CD/DVD.
  5. Localize e clique na seguinte pasta:
    CDDrive: \ DirectX9
    Observação Nesse caminho, CDDrive representa a letra da unidade de unidade de CD.
  6. Clique duas vezes em Apr2005_d3dx9_25_x86.cab, clique com o botão direito do mouse d3dx9_25.dll e, em seguida, clique em Copiar.
    Observação Use o arquivo Apr2005_d3dx9_25_x64.cab para a versão de 64 x do sistema operacional Windows.
  7. Localize a seguinte pasta para o seu jogo:
    Drive: \Program Files\Microsoft Games\ Game Title
    Observação Nesse caminho, Drive representa a letra da unidade em que o jogo está instalado e Game Title representa o jogo que deseja reparar.
  8. Clique com o botão direito do mouse na pasta jogo que corresponde ao jogo que está instalado no computador e clique em Colar.

    Observação Se você tiver instalado mais de um jogo no computador, repita as etapas 7and 8 para outros jogos.

Windows XP

  1. Insira o disco 1 do CD/DVD para o seu jogo na unidade de CD/DVD do computador.
  2. Clique em Iniciar, aponte para Programs, aponte para Acessórios e clique em Windows Explorer.
  3. Localize e clique na seguinte pasta:
    CDDrive: \ DirectX9
    Observação Nesse caminho, CDDrive representa a letra da unidade de unidade de CD.
  4. Clique duas vezes em Apr2005_d3dx9_25_x86.cab, clique com o botão direito do mouse d3dx9_25.dll e, em seguida, clique em Copiar.
    Observação Use o arquivo Apr2005_d3dx9_25_x64.cab para a versão de 64 x do sistema operacional Microsoft Windows.
  5. Localize a seguinte pasta para o seu jogo:
    Drive: \Program Files\Microsoft Games\ Game Title
    Observação Nesse caminho, Drive representa a letra da unidade em que o jogo está instalado e Game Title representa o jogo que deseja reparar.
  6. Clique com o botão direito do mouse na pasta jogo que corresponde ao jogo que está instalado no computador e clique em Colar.

    Observação Se você tiver instalado mais de um jogo no computador, repita as etapas 5 e 6 para outros jogos.

Mais Informações

Se você precisar de mais ajuda, visite o site do Microsoft Customer Support Services para encontrar outras soluções. Este site fornece os seguintes serviços:

Propriedades

ID do artigo: 910813 - Última revisão: quinta-feira, 24 de dezembro de 2009 - Revisão: 7.0
A informação contida neste artigo aplica-se a:
  • Microsoft Flight Simulator X Deluxe
  • Microsoft Flight Simulator X Standard
  • Microsoft Flight Simulator X Acceleration Expansion Pack
  • Microsoft Flight Simulator X Service Pack 1
  • Microsoft Age of Empires III
  • Microsoft Age of Empires III : The WarChiefs
  • Microsoft Age of Empires III: The Asian Dynasties
  • Microsoft Dungeon Siege II
  • Fable: The Lost Chapters PC
  • Microsoft Gears of War (PC)
  • Microsoft Halo 2 for Windows Vista
  • Microsoft Shadowrun (PC)
  • Microsoft Viva Pinata (PC)
  • Microsoft Zoo Tycoon 2
  • Microsoft Zoo Tycoon 2: African Adventure
  • Microsoft Zoo Tycoon 2: Dino Danger
  • Microsoft Zoo Tycoon 2: Endangered Species
  • Microsoft Zoo Tycoon 2: Marine Mania
  • Microsoft Zoo Tycoon 2: Ultimate Collection
Palavras-chave: 
kbmt kberrmsg kbsetup kbtshoot KB910813 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 910813

Submeter comentários