Nelze spustit službu Brána firewall systému Windows v systému Windows XP SP2

Překlady článku Překlady článku
ID článku: 920074 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Po instalaci aktualizace Microsoft Windows XP Service Pack 2 (SP2) nelze spustit službu Brána firewall systému Windows. Konkrétně můžete zaznamenat jeden nebo více následujících příznaků:
  • V seznamu Služby v Ovládacích panelech není zobrazená služba Brána Firewall / Sdílení připojení k Internetu (ICS).
  • Služba Brána Firewall / Sdílení připojení k Internetu (ICS) je zobrazená v seznamu Služby, ale nelze ji spustit.
  • Při pokusu o přístup k nastavení brány firewall systému Windows se zobrazí chybová zpráva:
    Z důvodu neznámého problému nemůže systém Windows zobrazit nastavení brány firewall systému Windows.

Příčina

Tento problém je způsoben chybějícím nebo poškozeným souborem SharedAccess.reg. Soubor SharedAccess.reg který zastupuje službu brány Windows Firewall.

Poznámka: Služba brány Windows Firewall nahrazuje v systému Windows XP SP2 službu Brána firewall pro připojení k Internetu (ICF) z předchozích verzí systému Windows XP.

Řešení

Chcete-li tento problém vyřešit, použijte jednu z následujících metod:

Metoda 1: Instalace brány Windows Firewall voláním funkce Setup API InstallHinfSection

Chcete-li nainstalovat bránu Windows Firewall, postupujte takto:
  1. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz cmd a potom klepněte na tlačítko OK.
  2. Na příkazovém řádku zadejte následující příkaz a potom stiskněte klávesu ENTER:
    Rundll32 setupapi,InstallHinfSection Ndi-Steelhead 132 %windir%\inf\netrass.inf
  3. Restartujte systém Windows.
  4. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz cmd a potom klepněte na tlačítko OK.
  5. Na příkazovém řádku zadejte následující příkaz a poté stiskněte klávesu ENTER:
    Netsh firewall reset
  6. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz firewall.cpl a stiskněte klávesu ENTER. V dialogovém okně Brána firewall systému Windows klepněte na přepínač Zapnuto (doporučeno) a potom klepněte na tlačítko OK.

Metoda 2: Přidejte položku Brána firewall systému Windows do registru

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows


Chcete-li přidat položku Brána firewall systému Windows do registru, postupujte podle následujících kroků:
  1. Zkopírujte následující text do programu Poznámkový blok a potom soubor uložte s názvem Sharedaccess.reg:
    Windows Registry Editor Version 5.00
    
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess]
    "DependOnGroup"=hex(7):00,00
    "DependOnService"=hex(7):4e,00,65,00,74,00,6d,00,61,00,6e,00,00,00,57,00,69,00,\
      6e,00,4d,00,67,00,6d,00,74,00,00,00,00,00
    "Description"="Provides network address translation, addressing, name resolution and/or intrusion prevention services for a home or small office network."
    "DisplayName"="Windows Firewall/Internet Connection Sharing (ICS)"
    "ErrorControl"=dword:00000001
    "ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
      74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
      00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\
      6b,00,20,00,6e,00,65,00,74,00,73,00,76,00,63,00,73,00,00,00
    "ObjectName"="LocalSystem"
    "Start"=dword:00000002
    "Type"=dword:00000020
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch]
    "Epoch"=dword:00002cd0
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters]
    "ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\
      00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
      69,00,70,00,6e,00,61,00,74,00,68,00,6c,00,70,00,2e,00,64,00,6c,00,6c,00,00,\
      00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications\List]
    "%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications\List]
    "%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Setup]
    "ServiceUpgrade"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Setup\InterfacesUnfirewalledAtUpdate]
    "All"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Enum]
    "0"="Root\\LEGACY_SHAREDACCESS\\0000"
    "Count"=dword:00000001
    "NextInstance"=dword:00000001
  2. Poklepejte na soubor Sharedaccess.reg, čímž sloučíte jeho obsah s obsahem registru a vytvoříte položku Brána firewall systému Windows.
  3. Restartujte systém Windows.
  4. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz cmd a potom klepněte na tlačítko OK.
  5. Na příkazovém řádku zadejte následující příkaz a poté stiskněte klávesu ENTER:
    Netsh firewall reset
  6. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz firewall.cpl a potom klepněte na tlačítko OK.
  7. Nakonfigurujte požadované nastavení brány firewall systému Windows.
Pokud uvedené metody nefungují, přeinstalujte aktualizaci Windows XP SP2.

Další informace

Chcete-li ověřit, zda je služba Brána firewall systému Windows spuštěná, postupujte takto:
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz services.msc a pak klepněte na tlačítko OK.
  2. V seznamu služeb nalezněte položku Brána Firewall / Sdílení připojení k Internetu (ICS). Zkontrolujte, zda je stav služby uveden jako Spuštěno.
  3. Další informace o používání funkce Služby získáte klepnutím na příkaz Nápověda v nabídce Akce.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Odkazy

Další informace o použití brány firewall systému Windows v systému Windows XP Service Pack 2 naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
875357 Odstraňování problémů s nastavením brány Windows Firewall v systému Windows XP s aktualizací Service Pack 2
892199 Nelze spustit službu Brána firewall systému Windows v systému Windows XP Service Pack 2
Další informace o řešení potíží s branou firewall systému Windows v systému Windows XP SP2 naleznete na následujícím webu společnosti Microsoft:
http://technet.microsoft.com/cs-cz/library/bb457029.aspx

Vlastnosti

ID článku: 920074 - Poslední aktualizace: 2. července 2013 - Revize: 4.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
Klíčová slova: 
kbprb kbfirewall kbtshoot KB920074

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com