ID článku: 928218 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek poskytuje metody, které můžete podniknout pro odinstalovat nebo odebrat systém Microsoft Office 2007.

Opravdu chcete odinstalovat různé verze sady Microsoft Office?

Chcete-li zobrazit informace o tom, jak odebrat nebo odinstalovat jiné verze sady Microsoft Office, klepněte na odkaz, který se shoduje s vaší verzí sady Office:

Jak odinstalovat nebo odebrat systém Microsoft Office 2010
Jak odinstalovat nebo odebrat sady Microsoft Office 2003
Jak odinstalovat nebo odebrat Microsoft Office for Mac 2011
Jak odinstalovat nebo odebrat Microsoft Office for Mac 2008

Řešení

Doporučujeme postupovat podle metod uvedených v tomto článku v daném pořadí. Však pokud jste dříve vyzkoušeli jednu z metod odebrání sady Office se nezdařilo, můžete přejít k jiným způsobem rychle z tohoto seznamu:
  • Metoda 1: Odinstalace systému Microsoft Office 2007 z ovládacích panelů
  • Metoda 2: Odinstalace systému Microsoft Office 2007 pomocí Microsoft Fix it
  • Metoda 3: Odinstalovat Microsoft Office 2007 Suite pomocí Poradce při potížích Program nainstalovat a odinstalovat
  • Metoda 4: Ručně odeberte systém Microsoft Office 2007

Metoda 1: Odinstalace systému Microsoft Office 2007 z ovládacích panelů

Zmenšit tento obrázekZvětšit tento obrázek
assets folding start collapsed
V Ovládacích panelech odebrat Microsoft Office 2007, postupujte takto:
  1. Klepněte na tlačítko Start.
  2. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  3. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  4. Zadejte příkaz appwiz.cpla potom klepněte na tlačítko OK.
  5. V seznamu aktuálně nainstalovaných programů vyhledejte položku Microsoft Office.
  6. Vyberte jej a klepněte na tlačítko odinstalovat (nebo Odebrat v systému Windows XP).
Pokud máte problémy s odinstalací systému Microsoft Office 2007 v okně Ovládací panely, přejděte k další metodě.
Zmenšit tento obrázekZvětšit tento obrázek
assets folding end collapsed

Metoda 2: Odinstalace systému Microsoft Office 2007 pomocí Microsoft Fix it

Zmenšit tento obrázekZvětšit tento obrázek
assets folding start collapsed
Upozornění: The Fix to neodebere jednotlivé sady Office, které byly v počítači nainstalovány samostatně. Například pokud máte aplikaci Microsoft Office Professional 2007 a Microsoft Office Visio 2007, oprava se odebere pouze Microsoft Office Professional 2007. Aplikace Visio 2007 nebude odebrána. Klepnutím sem zobrazíte jak odinstalovat nebo odebrat systém Microsoft Office 2007.

DŮLEŽITÉ – před použitím opravy, přečtěte si následující poznámky je řešení:
  • Pokud máte operační systém Windows 64-bit, stáhnout a uložit oprava je řešení na pracovní plochu a poklepejte na ikonu a spustit na vašem počítači. Pokud se pokusíte spustit řešení přímo z článku máte nespustí správně.
  • Je nutné restartovat počítač, pokud použijete opravu jeho řešení.
  • Průvodce může být v angličtině. Nicméně tato automatická oprava také funguje pro ostatní jazykové verze systému Windows.
  • Pokud nejste v počítači, který má daný problém, uložit oprava je řešení na jednotku USB flash nebo disku CD nebo DVD a spusťte jej v počítači, který má potíže.
Tato oprava je pro systém Microsoft Office 2007 odebere všechny verze systému Office 2007. To zahrnuje všechny zkušební verze systému Office 2007.

Chcete-li automaticky odinstalovat sadu Microsoft Office 2007, klepněte na tlačítko opravit nebo odkaz. Klepněte na tlačítko Spustit v dialogovém okně Stažení souboru a potom postupujte podle pokynů průvodci opravou.
Zmenšit tento obrázekZvětšit tento obrázek
assets fixit1
Opravit tento problém
Oprava 50154
Zmenšit tento obrázekZvětšit tento obrázek
assets fixit2


Pokud stále nelze odinstalovat sadu Microsoft Office, přejděte k další metodě.
Zmenšit tento obrázekZvětšit tento obrázek
assets folding end collapsed

Metoda 3: Odinstalovat Microsoft Office 2007 Suite pomocí Poradce při potížích Program nainstalovat a odinstalovat

Zmenšit tento obrázekZvětšit tento obrázek
assets folding start collapsed
Zkuste odinstalovat sadu Microsoft Office tak, že spustíte Program nainstalovat a odinstalovat Poradce při potížích. Chcete-li spustit Poradce při potížích, naleznete v následujícím článku znalostní báze Microsoft knowledge base:



Pokud stále nelze odinstalovat sadu Microsoft Office, přejděte k další metodě.
Zmenšit tento obrázekZvětšit tento obrázek
assets folding end collapsed

Metoda 4: Ručně odeberte systém Microsoft Office 2007

Zmenšit tento obrázekZvětšit tento obrázek
assets folding start collapsed
Všimněte si, že je musíte být přihlášeni k systému Windows pomocí uživatelského účtu správce počítače k dokončení této metody. Pokud jde o váš osobní počítač, budete pravděpodobně již přihlášeni pomocí účtu správce. Pokud jde o počítač, který je součástí sítě, budete muset požádat správce systému o pomoc. Chcete-li ověřit, že jste k systému Windows přihlášeni pomocí uživatelského účtu správce počítače, naleznete v následujícím článku znalostní báze Microsoft knowledge base:

Jak zjistit typ účtu uživatele v systému Windows


DŮLEŽITÉ - informace, které potřebujete znát před odebráním sady Office 2007:
  • Chcete-li použít v nabídce zobrazení nebo Nástroje v systému Windows 7 nebo Vista, musí stiskněte klávesu ALT první Chcete-li zobrazit panel nabídek.
  • Chcete-li zobrazit skryté soubory a složky budete potřebovat. Postupujte následujícím způsobem
    1. Spusťte Průzkumníka Windows.
    2. V nabídce Nástroje klepněte na Možnosti složky. V systému Windows 7 nebo Vista stiskněte klávesu ALT, chcete-li zobrazit panel nabídek.
    3. Klepněte na kartu Zobrazení
    4. V podokně Upřesňující nastavení v části skryté soubory a složky, klepněte na tlačítko Zobrazit skryté soubory a složky.
    5. Zrušte Skrýt příponu souborů známých typů.
    6. Klepněte na tlačítko OK a potom zavřete okna.

Krok 1: Odeberte všechny zbývající balíčky Instalační služba Windows Installer pro systém Microsoft Office 2007.
  1. Klepněte na tlačítko Start.
  2. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  3. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  4. Zadejte příkaz Instalační programa potom klepněte na tlačítko OK.
    Tím se otevře složka %windir%\Installer.

  5. V nabídce Zobrazit klepněte na tlačítko Zvolit podrobnosti.
  6. Klepnutím zaškrtněte políčko Předmět , typ 340Šířka vybraného sloupce (v pixelech) a klepněte na tlačítko OK.
    Poznámka: Může trvat několik minut, zobrazí se vedle každého předmětu.Soubor MSI.

  7. V nabídce Zobrazit přejděte na příkaz Seřadit podle v systému Windows 7 nebo Vista, přejděte na příkaz Seřadit ikony v systému Windows XP a klepněte na položku Předmět.
  8. Pokud se zobrazí dialogové okno Řízení uživatelských účtů, pokračujte klepnutím na tlačítko Povolit pokračovat.
  9. Vyhledejte všechnySoubor MSI, kde je předmět "Microsoft Office <product name="">2007" klepněte pravým tlačítkem myši .MSI soubor a potom klepněte na tlačítko odinstalovat.
    Poznámka: <product name="">je zástupný symbol pro název produktu Microsoft Office 2007.
    </product></product>
Krok 2: Zastavte službu Office Source Engine.
  1. Klepněte na tlačítko Start.
  2. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  3. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  4. Zadejte příkaz Services.msca potom klepněte na tlačítko OK.
  5. V okně Služby zjistěte, zda je spuštěna služba Office Source Engine (ve sloupci Stav se zobrazí "Spuštěno"). Pokud je služba spuštěna, klepněte pravým tlačítkem myšiOffice Source Enginea klepněte na tlačítko Zastavit.
  6. Zavřete okno Služby
Krok 3: Odeberte všechny zbývající složky instalace sady Microsoft Office 2007.
  1. Klepněte na tlačítko Start.
  2. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  3. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  4. Zadejte %CommonProgramFiles%\Microsoft Shareda klepněte na tlačítko OK.
    Poznámka: V počítači se systémem 64bitové verze systému Windows 7 nebo Vista zadejte % %\Microsoft CommonProgramFiles(x86) sdílenéa potom klepněte na tlačítko OK.

  5. Pokud jsou k dispozici následující složky, odstraňte je:
    • Office12
    • Source Engine
  6. Klepněte na tlačítko Start.
  7. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  8. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  9. Zadejte %ProgramFiles%\Microsoft Officea potom klepněte na tlačítko OK.
    Poznámka: V počítači se systémem 64bitové verze systému Windows 7 nebo Vista zadejte % ProgramFiles(x86) %\Microsoft Officea potom klepněte na tlačítko OK.

  10. Odstraňte složku Office12.
  11. V kořenové složce každé jednotky pevného disku vyhledejte a otevřete složku MSOCache . Pokud nevidíte složku, postupujte takto:
    1. Spusťte Průzkumníka Windows a potom v nabídce Nástroje na příkaz Možnosti složky.
    2. Klepněte na kartu Zobrazení
    3. V podokně Upřesňující nastavení v části skryté soubory a složky, klepněte na tlačítko Zobrazit skryté soubory a složky.
    4. Zrušte zaškrtnutí políčka Skrýt chráněné soubory operačního systému a potom klepněte na tlačítko OK.
  12. Ve složce MSOCache otevřete složku All Users a odstraňte všechny složky, které v názvu složky obsahují text 0FF1CE}-.
    Poznámka: Tento text obsahuje nulu a jeden pro písmena "O" a "I."
    Příklad {90140000-001B-0409-0000-0000000FF1CE}-C
Krok 4: Odeberte všechny zbývající instalační soubory sady Microsoft Office 2007.
  1. Klepněte na tlačítko Start.
  2. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  3. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  4. Zadejte %appdata%\microsoft\templatesa potom klepněte na tlačítko OK.
  5. Odstraňte následující soubory:
    • Normal.dotm
    • Normalemail.dotm
  6. Klepněte na tlačítko Start.
  7. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  8. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  9. %Appdata%\microsoft\document stavební blokya klepněte na tlačítko OK.
  10. Otevřete podsložku ve složce Stavební bloky dokumentu
    Poznámka: Název podsložky budou čtyřmístné číslo, které představuje jazyk sady Microsoft Office.

  11. Odstraňte soubor building blocks.dotx
  12. Před provedením zbývajících kroků zavřete všechny programy.
  13. Klepněte na tlačítko Start.
  14. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  15. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  16. Zadejte % temp %a potom klepněte na tlačítko OK.
  17. V nabídce Úpravy klepněte na příkaz Vybrat vše.
  18. V nabídce soubor klepněte na příkaz Odstranit.
  19. Klepněte na tlačítko Start.
  20. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  21. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  22. Zadejte %AllUsersprofile%\Application Data\Microsoft\Office\Dataa potom klepněte na tlačítko OK.
  23. Odstraňte soubor opa12.dat (a pouze tento soubor).
Krok 5: Odstraňte následující podklíče registru pro systém Microsoft Office 2007.
Upozornění: Při nesprávné úpravě registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Důležité Tento článek obsahuje informace o úpravě registru. Před jeho úpravou se ujistěte, že máte jeho záložní kopii. Ujistěte se, že víte, jak registr obnovit v případě výskytu problému. Další informace o zálohování, obnovení a úpravách registru získáte v článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows

Vyhledejte a odstraňte podklíče registru Office 2007, pokud existují. Postupujte následujícím způsobem
  1. Klepněte na tlačítko Start.
  2. Klepněte na položku Všechny programya potom otevřete složku Příslušenství (Přeskočit tento krok v systému Windows XP).
  3. Klepněte na příkaz Spustit a potom klepněte na tlačítko v poli Otevřít
  4. Zadejte příkaz regedita klepněte na tlačítko OK.
  5. Klepněte na následující podklíč registru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  6. V nabídce soubor klepněte na příkaz Exportovat, zadejte DeletedKey01a potom klepněte na tlačítko Uložit.
  7. V nabídce Úpravy klepněte na příkaz Odstranit a potom klepnutím na tlačítko Ano potvrďte.
  8. Opakujte tyto kroky (1 až 7) pro každý podklíč registru uvedený v následujícím seznamu. Změňte název exportovaného klíče pro každý podklíč.
    Příklad Pro druhý klíč zadejte DeletedKey02, pro třetí klíč zadejte DeletedKey03 atd.
Poznámka: V následujících klíčích registru představuje znak hvězdičky (*) jeden nebo více znaků v názvu podklíče.

32bitové verze systému Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\ * Office12 *
64bitové verze systému Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\ * F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\ * F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\ * Office12 *
Pokračujte těmito podklíči registru:
  1. Vyhledejte následující podklíč registru:

    32-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    64-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. V nabídce soubor klepněte na příkaz Exportovat, zadejte UninstallKey01a klepněte na tlačítko Uložit.
  3. V podklíči Uninstall, který jste vyhledali v kroku 1, klepněte na každý podklíč a pak zjistěte, zda má přiřazenou následující hodnotu:
    • Název: UninstallString
    • Data: cesta k název_souboru\Office Controller\Setup.exe

      Poznámka: V tomto příkladě je název_souboru zástupný symbol pro název instalačního programu a cesta je zástupný symbol pro cestu k souboru.
  4. Pokud podklíč obsahuje název a data, která jsou popsána v kroku 3, klepněte na příkaz Odstranit v nabídce Úpravy. V opačném případě přejděte ke kroku 5.
  5. Opakujte kroky 3 a 4, dokud nenajdete a neodstraníte všechny podklíče, odpovídající názvu a datům popsaným v kroku 3.
  6. Ukončete Editor registru.
Krok 6: Restartujte počítač.
Restartujte počítač. Pokud bylo odebrání úspěšné, jste hotoví, a pokud chcete, můžete přeinstalovat systém Microsoft Office. Pokud odebrání nebylo úspěšné, přejděte k části "Odkazy" v tomto článku.
Zmenšit tento obrázekZvětšit tento obrázek
assets folding end collapsed


Vlastnosti

ID článku: 928218 - Poslední aktualizace: 11. března 2014 - Revize: 10.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
Klíčová slova: 
kbexpertiseinter kberrmsg kbregistry kbsetup kbinstallation kbtshoot kbprb kbfixme kbmsifixme kbcip kbmt KB928218 KbMtcs
Strojově přeložený článek
DŮLEŽITÉ: Tento článek je přeložen pomocí softwaru na strojový překlad Microsoft. Nepřesný či chybný překlad lze opravit prostřednictvím technologie Community Translation Framework (CTF). Microsoft nabízí strojově přeložené, komunitou dodatečně upravované články, a články přeložené lidmi s cílem zajistit přístup ke všem článkům v naší znalostní bázi ve více jazycích. Strojově přeložené a dodatečně upravované články mohou obsahovat chyby ve slovníku, syntaxi a gramatice. Společnost Microsoft není odpovědná za jakékoliv nepřesnosti, chyby nebo škody způsobené nesprávným překladem obsahu nebo jeho použitím našimi zákazníky. Více o CTF naleznete na http://support.microsoft.com/gp/machine-translation-corrections/cs.
Projděte si také anglickou verzi článku: 928218

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com