Numéro d'article: 928218 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article fournit des méthodes que vous pouvez suivre pour désinstaller ou supprimer des suites Microsoft Office 2007.

Voulez-vous désinstaller une autre version de Microsoft Office ?

Pour afficher des informations sur la procédure de suppression ou de désinstallation d'une autre version de Microsoft Office, cliquez sur le lien qui correspond à votre version d'Office :

Procédure de désinstallation ou de suppression des suites Microsoft Office 2010
Procédure de désinstallation ou de suppression des suites Microsoft Office 2003
Procédure de désinstallation ou de suppression de Microsoft Office pour Mac 2011
Procédure de désinstallation ou de suppression de Microsoft Office pour Mac 2008

Résolution

Nous vous recommandons de suivre les méthodes fournies dans cet article dans l'ordre. Toutefois, si vous avez déjà essayé l'une des méthode de suppression d'Office et si elle a échoué, vous pouvez passer à une autre méthode rapidement à partir de cette liste :
  • Méthode 1 : Désinstallation des suites Microsoft Office 2007 à partir du Panneau de configuration
  • Méthode 2 : Désinstallation des suites Microsoft Office 2007 à l'aide de Microsoft Fix it
  • Méthode 3 : Désinstallation des suites Microsoft Office 2007 à l'aide de l'utilitaire de résolution des problèmes d'installation et de désinstallation des programmes
  • Méthode 4 : Suppression manuelle des suites Microsoft Office 2007

Méthode 1 : Désinstallation des suites Microsoft Office 2007 à partir du Panneau de configuration

Réduire cette imageAgrandir cette image
assets folding start collapsed
Pour supprimer Microsoft Office 2007 à partir du Panneau de configuration, procédez comme suit :
  1. Cliquez sur Démarrer.
  2. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  3. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  4. Tapez appwiz.cpl, puis cliquez sur OK.
  5. Recherchez l'entrée Microsoft Office dans la liste des programmes installés.
  6. Sélectionnez-la, puis cliquez sur Désinstaller (ou Supprimer dans Windows XP).
Si vous rencontrez des problèmes de désinstallation de Microsoft Office System 2007 dans le Panneau de configuration, passez à la méthode suivante.
Réduire cette imageAgrandir cette image
assets folding end collapsed

Méthode 2 : Désinstallation des suites Microsoft Office 2007 à l'aide de Microsoft Fix it

Réduire cette imageAgrandir cette image
assets folding start collapsed
AVERTISSEMENT La solution de réparation ne supprime pas les programmes Office individuels qui ont été installés séparément sur votre ordinateur. Par exemple, si vous avez Microsoft Office Professionnel 2007 et Microsoft Office Visio 2007, la solution de réparation ne supprime que Microsoft Office Professionnel 2007. Visio 2007 n'est pas supprimé. Cliquez ici pour afficher les informations sur la suppression des différents programmes Office.

IMPORTANT - Lisez ces remarques avant d'utiliser la solution de réparation :
  • Si vous avez un système d'exploitation Windows 64 bits, téléchargez et enregistrez la solution de réparation sur votre Bureau, puis double-cliquez dessus pour l'exécuter sur votre ordinateur. Si vous tentez d'exécuter la solution directement depuis l'article, vous ne parviendrez pas à l'exécuter correctement.
  • Vous devez redémarrer votre ordinateur si vous utilisez la solution de réparation.
  • L'Assistant peut n'exister qu'en anglais. Toutefois, la réparation automatique fonctionne aussi pour d'autres versions linguistiques de Windows.
  • Si vous n'utilisez pas l'ordinateur concerné par le problème, vous pouvez enregistrer la solution sur un lecteur flash, un CD-ROM ou un DVD et ensuite l'exécuter sur l'ordinateur concerné.
La solution de réparation pour les suites Microsoft Office 2007 supprime toutes les éditions d'Office 2007, notamment toutes les éditions d'évaluation d'Office 2007.

Pour désinstaller automatiquement la suite Microsoft Office 2007, cliquez sur le lien ou sur le bouton Résoudre ce problème. Cliquez sur Exécuter dans la boîte de dialogue Téléchargement de fichier, puis suivez la procédure indiquée par l'Assistant Résolution.
Réduire cette imageAgrandir cette image
assets fixit1
Résoudre ce problème
Microsoft Fix it 50154
Réduire cette imageAgrandir cette image
assets fixit2


Si vous ne parvenez toujours pas à désinstaller la suite Microsoft Office, passez à la méthode suivante.
Réduire cette imageAgrandir cette image
assets folding end collapsed

Méthode 3 : Désinstaller les suites Microsoft Office 2007 à l'aide de l'utilitaire de résolution des problèmes d'installation et de désinstallation des programmes

Réduire cette imageAgrandir cette image
assets folding start collapsed
Vous pouvez essayer de désinstaller la suite Microsoft Office en exécutant l'utilitaire de résolution des problèmes d'installation et de désinstallation des programmes. Pour exécuter l'utilitaire de résolution des problèmes, consultez l'article suivant de la base de connaissances Microsoft :



Si vous ne parvenez toujours pas à désinstaller la suite Microsoft Office, passez à la méthode suivante.
Réduire cette imageAgrandir cette image
assets folding end collapsed

Méthode 4 : Suppression manuelle des suites Microsoft Office 2007

Réduire cette imageAgrandir cette image
assets folding start collapsed
Remarque : Pour exécuter cette méthode, vous devez avoir ouvert une session Windows avec un compte d'utilisateur qui est un administrateur système. S'il s'agit de votre ordinateur personnel, vous avez certainement déjà ouvert une session avec un compte d'administrateur. Si cet ordinateur fait partie d'un réseau, vous risquez de devoir demander de l'aide à l'administrateur système. Pour vérifier que vous avez ouvert une session Windows avec un compte d'utilisateur qui est un administrateur d'ordinateur, consultez l'article suivant de la base de connaissances Microsoft :

Comment déterminer votre type de compte d'utilisateur dans Windows


IMPORTANT - Informations que vous devez connaître avant de supprimer Office 2007 :
  • Pour utiliser le menu Affichage ou Outils dans Windows 7 ou Vista, vous devez d'abord appuyer sur la touche Alt pour afficher la barre de menus.
  • Vous devez afficher les fichiers et dossiers cachés. Pour cela, procédez comme suit :
    1. Ouvrez l'Explorateur Windows.
    2. Dans le menu Outils, cliquez sur Options des dossiers. Dans Windows 7 ou Vista, appuyez sur la touche Alt pour afficher la barre de menus.
    3. Cliquez sur l'onglet Affichage.
    4. Dans le volet Paramètres avancés, sous Fichiers et dossiers cachés, cliquez sur Afficher les fichiers et dossiers cachés.
    5. Désélectionnez Masquer les extensions des fichiers dont le type est connu.
    6. Cliquez sur OK, puis fermez les fenêtres.

Étape 1 : Supprimez tous les packages Windows Installer restants de Microsoft Office System 2007.
  1. Cliquez sur Démarrer.
  2. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  3. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  4. Tapez installer, puis cliquez sur OK.
    Le dossier %windir%\Installer s'ouvre.

  5. Dans le menu Affichage, cliquez sur Choisir les détails.
  6. Activez la case à cocher Objet, tapez 340 dans la zone Taille de la colonne sélectionnée (en pixels), puis cliquez sur OK.
    Remarque L'affichage des objets en regard de chaque fichier .MSI peut prendre plusieurs minutes.

  7. Dans le menu Affichage, pointez sur Trier par dans Windows 7 ou Vista ou pointez sur Réorganiser les icônes par dans Windows XP, puis cliquez sur Objet.
  8. Si la boîte de dialogue Contrôle de compte d'utilisateur s'affiche, cliquez sur Autoriser pour continuer.
  9. Cliquez avec le bouton droit sur chaque fichier .MSI dont le nom est « Microsoft Office <nom_produit> 2007 », puis cliquez sur Désinstaller.
    Remarque <nom_produit> est un espace réservé pour le nom du produit Microsoft Office 2007.
Étape 2 : Arrêtez le service Office Source Engine.
  1. Cliquez sur Démarrer.
  2. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  3. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  4. Tapez services.msc, puis cliquez sur OK.
  5. Dans la fenêtre Services, déterminez si le service Office Source Engine est en cours d'exécution (« Démarré » apparaît dans la colonne État). Si c'est le cas, cliquez avec le bouton droit sur Office Source Engine, puis cliquez sur Arrêter.
  6. Fermez la fenêtre Services.
Étape 3 : Supprimez tous les dossiers restants de l'installation de Microsoft Office 2007.
  1. Cliquez sur Démarrer.
  2. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  3. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  4. Tapez %CommonProgramFiles%\Microsoft Shared, puis cliquez sur OK.
    Remarque Sur un ordinateur qui exécute une version 64 bits de Windows 7 ou Vista, tapez %CommonProgramFiles(x86)%\Microsoft Shared, puis cliquez sur OK.

  5. Si les dossiers suivants sont toujours présents, supprimez-les :
    • Office12
    • Source Engine
  6. Cliquez sur Démarrer.
  7. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  8. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  9. Tapez %ProgramFiles%\Microsoft Office, puis cliquez sur OK.
    Remarque Sur un ordinateur qui exécute une version 64 bits de Windows 7 ou Vista, tapez %ProgramFiles(x86)%\Microsoft Office, puis cliquez sur OK.

  10. Supprimez le dossier Office12.
  11. Dans le dossier racine de chaque disque dur, recherchez et ouvrez le dossier MSOCache. Si vous ne trouvez pas ce dossier, procédez comme suit :
    1. Ouvrez l'Explorateur Windows, puis cliquez sur le menu Outils et sur Options des dossiers.
    2. Cliquez sur l'onglet Affichage.
    3. Dans le volet Paramètres avancés, sous Fichiers et dossiers cachés, cliquez sur Afficher les fichiers et dossiers cachés.
    4. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation, puis cliquez sur OK.
  12. Ouvrez le dossier All Users dans le dossier MSOCache, puis supprimez tous les dossiers dont le nom contient 0FF1CE}-.
    Remarque Cette chaîne contient un zéro et un un pour les lettres « O » et « I ».
    Exemple {90140000-001B-0409-0000-0000000FF1CE}-C
Étape 4 : Supprimez tous les fichiers restants de l'installation de Microsoft Office 2007.
  1. Cliquez sur Démarrer.
  2. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  3. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  4. Tapez %appdata%\microsoft\templates, puis cliquez sur OK.
  5. Supprimez les fichiers suivants :
    • Normal.dotm
    • Normalemail.dotm
  6. Cliquez sur Démarrer.
  7. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  8. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  9. Tapez %appdata%\microsoft\document building blocks, puis cliquez sur OK.
  10. Ouvrez le sous-dossier trouvé dans le dossier Blocs de construction de document.
    Remarque Le titre du sous-dossier est un nombre à quatre chiffres correspondant à la langue de la suite Microsoft Office.

  11. Supprimez le fichier building blocks.dotx.
  12. Fermez tous les programmes avant de poursuivre la procédure.
  13. Cliquez sur Démarrer.
  14. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  15. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  16. Tapez %temp%, puis cliquez sur OK.
  17. Dans le menu Edition, cliquez sur Sélectionner tout.
  18. Dans le menu Fichier, cliquez sur Supprimer.
  19. Cliquez sur Démarrer.
  20. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  21. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  22. Tapez %AllUsersprofile%\Application Data\Microsoft\Office\Data, puis cliquez sur OK.
  23. Supprimer le fichier opa14.dat (et UNIQUEMENT ce fichier).
Étape 5 : Supprimez les sous-clés de Registre de Microsoft Office System 2007.
Avertissement Des problèmes sérieux peuvent se produire si vous modifiez le Registre de façon incorrecte à l'aide de l'Éditeur du Registre ou à l'aide d'une autre méthode. Ces problèmes peuvent vous obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.

Important Cet article contient des informations sur la procédure de modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows

Recherchez et supprimez les sous-clés de Registre Office 2007 si elles sont présentes. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer.
  2. Cliquez sur Tous les programmes, puis ouvrez le dossier Accessoires (ignorez cette étape dans Windows XP).
  3. Cliquez sur Exécuter, puis cliquez dans la zone Ouvrir.
  4. Tapez regedit, puis cliquez sur OK.
  5. Cliquez sur la sous-clé de Registre suivante :

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  6. Dans le menu Fichier, cliquez sur Exporter, tapez DeletedKey01, puis cliquez sur Enregistrer.
  7. Dans le menu Edition, cliquez sur Supprimer, puis sur Oui pour confirmer.
  8. Répétez ces étapes (1 à 7) pour chaque sous-clé de Registre de la liste suivante. Remplacez le nom de la clé exportée par celui de l'une des sous-clés.
    Exemple Tapez DeletedKey02 pour la deuxième clé, DeletedKey03 pour la troisième, etc.
Remarque Dans les clés de Registre suivantes, l'astérisque (*) représente un ou plusieurs caractères du nom de la sous-clé.

Versions 32 bits de Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office12*
Versions 64 bits de Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office12*
Continuez avec les sous-clés de Registre suivantes :
  1. Recherchez la sous-clé de Registre suivante :

    32 bits : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    64 bits : HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. Dans le menu Fichier, cliquez sur Exporter, tapez UninstallKey01, puis cliquez sur Enregistrer.
  3. Sous la sous-clé Uninstall trouvée à l'étape 1, cliquez sur chaque sous-clé, puis vérifiez si la valeur suivante lui est affectée :
    • Nom : UninstallString
    • Données : chemin d'accès de chemin_nom_fichier\Office Setup Controller\Setup.exe

      Remarque Dans cet exemple, nom_fichier est un emplacement réservé pour le nom d'un programme d'installation et chemin est un emplacement réservé pour le chemin d'accès au fichier.
  4. Si la sous-clé contient le nom et les données indiqués à l'étape 3, cliquez sur Supprimer dans le menu Edition. Sinon, passez à l'étape 5.
  5. Répétez les étapes 3 et 4 jusqu'à ce que vous ayez identifié et supprimé toutes les sous-clés correspondant au nom et aux données indiqués à l'étape 3.
  6. Fermez l'Éditeur du Registre.
Étape 6 : Redémarrez l'ordinateur.
Redémarrez l'ordinateur. Si la suppression réussit, vous avez terminé et pouvez à présent réinstaller Microsoft Office si vous le souhaitez. Si la suppression échoue, passez à la section « Références » de cet article.
Réduire cette imageAgrandir cette image
assets folding end collapsed


Propriétés

Numéro d'article: 928218 - Dernière mise à jour: vendredi 31 janvier 2014 - Version: 9.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
Mots-clés : 
kbexpertiseinter kberrmsg kbregistry kbsetup kbinstallation kbtshoot kbprb kbfixme kbmsifixme kbcip KB928218
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com