Numer ID artykułu: 928218 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W tym artykule podano metody odinstalowywania i usuwania pakietu Microsoft Office 2007.

Chcesz odinstalować inną wersję pakietu Microsoft Office?

Aby wyświetlić informacje o usuwaniu lub odinstalowywaniu innej wersji pakietu Microsoft Office, kliknij łącze odpowiadające danej wersji pakietu Office:

Jak odinstalować lub usunąć pakiet Microsoft Office 2010
Jak odinstalować lub usunąć pakiet Microsoft Office 2003
Jak odinstalować lub usunąć pakiet Microsoft Office 2011 dla komputerów Mac
Jak odinstalować lub usunąć pakiet Microsoft Office 2008 dla komputerów Mac

Rozwiązanie

Zalecane jest stosowanie metod z tego artykułu w podanej kolejności. Jeśli jednak wypróbowano już jedną z metod usuwania pakietu Office i zakończyło się to niepowodzeniem, można przejść do innej metody z poniższej listy:
  • Metoda 1. Odinstalowanie pakietu Microsoft Office 2007 za pomocą Panelu sterowania
  • Metoda 2. Odinstalowanie pakietu Microsoft Office 2007 za pomocą poprawki automatycznej Microsoft Fix it
  • Metoda 3. Odinstalowanie pakietu Microsoft Office 2007 za pomocą narzędzia do rozwiązywania problemów z instalowaniem i odinstalowywaniem programów
  • Metoda 4. Ręczne usunięcie pakietu Microsoft Office 2007

Metoda 1. Odinstalowanie pakietu Microsoft Office 2007 za pomocą Panelu sterowania

Zwiń ten obrazekRozwiń ten obrazek
assets folding start collapsed
Aby usunąć pakiet Microsoft Office 2007 z Panelu sterowania, wykonaj następujące czynności:
  1. Kliknij przycisk Start.
  2. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  3. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  4. Wpisz ciąg appwiz.cpl, a następnie kliknij przycisk OK.
  5. Na liście obecnie zainstalowanych programów znajdź pozycję Microsoft Office.
  6. Zaznacz ją, a następnie kliknij pozycję Odinstaluj (lub pozycję Usuń w systemie Windows XP).
Jeśli masz problemy z odinstalowaniem pakietu Microsoft Office System 2007 za pomocą Panelu sterowania, przejdź do następnej metody.
Zwiń ten obrazekRozwiń ten obrazek
assets folding end collapsed

Metoda 2. Odinstalowanie pakietu Microsoft Office 2007 za pomocą poprawki automatycznej Microsoft Fix it

Zwiń ten obrazekRozwiń ten obrazek
assets folding start collapsed
OSTRZEŻENIE Rozwiązanie w postaci poprawki automatycznej nie umożliwia usuwania pojedynczych programów pakietu Office, które zostały osobno zainstalowane na komputerze. Jeśli na przykład zainstalowano pakiet Microsoft Office Professional 2007 i program Microsoft Office Visio 2007, rozwiązanie w postaci poprawki automatycznej umożliwia usunięcie tylko pakietu Microsoft Office Professional 2007. Program Visio 2007 nie zostanie usunięty. Kliknij tutaj, aby wyświetlić informacje dotyczące odinstalowywania lub usuwania pakietu Microsoft Office 2007.

WAŻNE — przed zastosowaniem rozwiązania w postaci poprawki automatycznej należy przeczytać poniższe uwagi:
  • W przypadku systemu operacyjnego Windows w wersji 64-bitowej należy pobrać to rozwiązanie w postaci poprawki automatycznej i zapisać je na pulpicie, a następnie kliknąć je dwukrotnie i uruchomić na komputerze. Uruchomienie tego rozwiązania bezpośrednio z poziomu artykułu spowoduje jego niepoprawne działanie.
  • Po zastosowaniu rozwiązania w postaci poprawki automatycznej należy ponownie uruchomić komputer.
  • Ten kreator może być dostępny tylko w języku angielskim. Jednak ta poprawka automatyczna działa również w innych wersjach językowych systemu Windows.
  • Jeśli używany komputer nie jest tym, którego dotyczy problem, można zapisać to rozwiązanie w postaci poprawki automatycznej na dysku flash lub CD/DVD i uruchomić je na odpowiednim komputerze.
Zastosowanie rozwiązania w postaci poprawki automatycznej dla pakietu Microsoft Office 2007 spowoduje usunięcie wszystkich wersji tego pakietu. Dotyczy to również wszystkich wersji próbnych pakietu Office 2007.

Aby automatycznie odinstalować pakiet Microsoft Office 2007, należy kliknąć przycisk lub łącze Rozwiąż ten problem. Następnie należy kliknąć przycisk Uruchom w oknie dialogowym Pobieranie pliku i wykonać kroki kreatora rozwiązywania problemu.
Zwiń ten obrazekRozwiń ten obrazek
assets fixit1
Rozwiąż ten problem
Microsoft Fix it 50154
Zwiń ten obrazekRozwiń ten obrazek
assets fixit2


Jeśli nadal nie można odinstalować pakietu Microsoft Office, przejdź do następnej metody.
Zwiń ten obrazekRozwiń ten obrazek
assets folding end collapsed

Metoda 3. Odinstalowanie pakietu Microsoft Office 2007 za pomocą narzędzia do rozwiązywania problemów z instalowaniem i odinstalowywaniem programów

Zwiń ten obrazekRozwiń ten obrazek
assets folding start collapsed
Aby odinstalować pakiet Microsoft Office, można uruchomić narzędzie do rozwiązywania problemów z instalowaniem i odinstalowywaniem programów. Aby uruchomić narzędzie do rozwiązywania problemów, przejdź do następującego artykułu z bazy wiedzy Microsoft Knowledge Base:



Jeśli nadal nie można odinstalować pakietu Microsoft Office, przejdź do następnej metody.
Zwiń ten obrazekRozwiń ten obrazek
assets folding end collapsed

Metoda 4. Ręczne usunięcie pakietu Microsoft Office 2007

Zwiń ten obrazekRozwiń ten obrazek
assets folding start collapsed
Uwaga: aby wykonać czynności opisane w tej metodzie, należy się zalogować do systemu Windows przy użyciu konta administratora komputera. Jeśli jest to komputer osobisty, użytkownik prawdopodobnie jest zalogowany przy użyciu konta administratora. Jeśli ten komputer należy do sieci, może być konieczne poproszenie o pomoc administratora systemu. Aby upewnić się, że konto użyte podczas logowania do systemu Windows jest kontem administratora komputera, wykonaj czynności opisane w następującym artykule z bazy wiedzy Microsoft Knowledge Base:

Określanie typu konta użytkownika w systemie Windows


WAŻNE — informacje, z którymi należy zapoznać się przed usunięciem pakietu Office 2007:
  • Aby użyć menu Widok lub Narzędzia w systemie Windows 7 lub Windows Vista, należy najpierw nacisnąć klawisz ALT w celu wyświetlenia paska menu.
  • Konieczne jest wyświetlenie ukrytych plików i folderów. Aby to zrobić, wykonaj następujące kroki:
    1. Otwórz Eksploratora Windows.
    2. W menu Narzędzia kliknij polecenie Opcje folderów. W systemie Windows 7 lub Windows Vista naciśnij klawisz ALT w celu wyświetlenia paska menu.
    3. Kliknij kartę Widok.
    4. W okienku Ustawienia zaawansowane w obszarze Ukryte pliki i foldery kliknij pozycję Pokaż ukryte pliki i foldery.
    5. Wyczyść pole wyboru Ukryj rozszerzenia znanych typów plików.
    6. Kliknij przycisk OK, a następnie zamknij otwarte okna.

Krok 1. Usunięcie wszelkich pozostałych pakietów Instalatora Windows związanych z pakietem Microsoft Office System 2007.
  1. Kliknij przycisk Start.
  2. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  3. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  4. Wpisz ciąg installer, a następnie kliknij przycisk OK.
    Spowoduje to otwarcie folderu %windir%\Installer.

  5. W menu Widok kliknij polecenie Wybierz szczegóły.
  6. Zaznacz pole wyboru Temat, w polu Szerokość wybranej kolumny (w pikselach) wpisz wartość 340, a następnie kliknij przycisk OK.
    Uwaga Wyświetlenie tematu obok każdego pliku MSI może potrwać kilka minut.

  7. W menu Widok wskaż polecenie Sortuj według (w systemie Windows 7 lub Vista) albo polecenie Rozmieść ikony według (w systemie Windows XP), a następnie kliknij pozycję Temat.
  8. Jeśli pojawi się okno dialogowe Kontrola konta użytkownika, kliknij przycisk Zezwalaj, aby kontynuować.
  9. Zlokalizuj i kliknij prawym przyciskiem myszy każdy plik MSI, który ma temat „Microsoft Office <nazwa_produktu> 2007”, a następnie kliknij polecenie Odinstaluj.
    Uwaga Pozycja <nazwa_produktu> to symbol zastępczy nazwy produktu pakietu Microsoft Office 2007.
Krok 2. Zatrzymanie usługi Aparat źródłowy pakietu Office.
  1. Kliknij przycisk Start.
  2. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  3. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  4. Wpisz ciąg services.msc, a następnie kliknij przycisk OK.
  5. W oknie Usługi sprawdź, czy jest uruchomiona usługa Aparat źródłowy pakietu Office (w takim przypadku w kolumnie Stan jest wyświetlana wartość „Uruchomiono”). Jeśli ta usługa jest uruchomiona, kliknij prawym przyciskiem myszy pozycję Aparat źródłowy pakietu Office, a następnie kliknij polecenie Zatrzymaj.
  6. Zamknij okno Usługi.
Krok 3. Usunięcie wszelkich pozostałych folderów instalacji pakietu Microsoft Office 2007.
  1. Kliknij przycisk Start.
  2. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  3. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  4. Wpisz ciąg %CommonProgramFiles%\Microsoft Shared, a następnie kliknij przycisk OK.
    Uwaga Na komputerze z 64-bitową wersją systemu Windows 7 lub Windows Vista należy wpisać ciąg %CommonProgramFiles(x86)%\Microsoft Shared, a następnie kliknąć przycisk OK.

  5. Jeśli istnieją następujące foldery, usuń je:
    • Office12
    • Source Engine
  6. Kliknij przycisk Start.
  7. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  8. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  9. Wpisz ciąg %ProgramFiles%\Microsoft Office, a następnie kliknij przycisk OK.
    Uwaga Na komputerze z 64-bitową wersją systemu Windows 7 lub Windows Vista należy wpisać ciąg %ProgramFiles(x86)%\Microsoft Office, a następnie kliknąć przycisk OK.

  10. Usuń folder Office12.
  11. W folderze głównym każdego dysku twardego zlokalizuj i otwórz folder MSOCache. Jeżeli nie możesz znaleźć tego folderu, wykonaj następujące czynności:
    1. Otwórz Eksploratora Windows, a następnie w menu Narzędzia kliknij polecenie Opcje folderów.
    2. Kliknij kartę Widok.
    3. W okienku Ustawienia zaawansowane w obszarze Ukryte pliki i foldery kliknij pozycję Pokaż ukryte pliki i foldery.
    4. Wyczyść pole wyboru Ukryj chronione pliki systemu operacyjnego, a następnie kliknij przycisk OK.
  12. Otwórz folder All Users w folderze MSOCache, a następnie usuń każdy folder zawierający tekst 0FF1CE}- w nazwie folderu.
    Uwaga: ten tekst zawiera cyfrę zero i jedną z liter „O” i „I”.
    Przykład {90140000-001B-0409-0000-0000000FF1CE}-C
Krok 4. Usunięcie wszelkich pozostałych plików instalacji pakietu Microsoft Office 2007.
  1. Kliknij przycisk Start.
  2. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  3. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  4. Wpisz ciąg %appdata%\microsoft\templates, a następnie kliknij przycisk OK.
  5. Usuń następujące pliki:
    • Normal.dotm
    • Normalemail.dotm
  6. Kliknij przycisk Start.
  7. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  8. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  9. Wpisz ciąg %appdata%\microsoft\document building blocks, a następnie kliknij przycisk OK.
  10. Otwórz podfolder znajdujący się w folderze Document Building Blocks.
    Uwaga Nazwa tego podfolderu jest czterocyfrową liczbą odpowiadającą językowi pakietu Microsoft Office.

  11. Usuń plik building blocks.dotx.
  12. Zamknij wszystkie programy przed wykonaniem pozostałych czynności.
  13. Kliknij przycisk Start.
  14. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  15. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  16. Wpisz ciąg %temp%, a następnie kliknij przycisk OK.
  17. W menu Edycja kliknij polecenie Zaznacz wszystko.
  18. W menu Plik kliknij polecenie Usuń.
  19. Kliknij przycisk Start.
  20. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  21. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  22. Wpisz ciąg %AllUsersprofile%\Dane aplikacji\Microsoft\Office\Data, a następnie kliknij przycisk OK.
  23. Usuń TYLKO plik opa12.dat.
Krok 5. Usunięcie podkluczy rejestru pakietu Microsoft Office System 2007.
Ostrzeżenie Niepoprawne zmodyfikowanie rejestru przy użyciu Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Ich rozwiązanie może wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie tych problemów będzie możliwe. Użytkownik modyfikuje rejestr na własną odpowiedzialność.

Ważne Ten artykuł zawiera informacje dotyczące modyfikowania rejestru. Przed zmodyfikowaniem rejestru należy wykonać jego kopię zapasową. Użytkownik powinien wiedzieć, jak przywrócić rejestr w przypadku pojawienia się problemu. Aby uzyskać więcej informacji dotyczących wykonywania kopii zapasowej, przywracania i modyfikowania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Jak wykonywać kopię zapasową rejestru i przywracać go w systemie Windows

Zlokalizuj i usuń podklucze rejestru pakietu Office 2007, jeśli istnieją. W tym celu wykonaj następujące czynności:
  1. Kliknij przycisk Start.
  2. Kliknij pozycję Wszystkie programy, a następnie otwórz folder Akcesoria (w systemie Windows XP pomiń ten krok).
  3. Kliknij pozycję Uruchom, a następnie kliknij pole Otwórz.
  4. Wpisz ciąg regedit, a następnie kliknij przycisk OK.
  5. Kliknij następujący podklucz rejestru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  6. W menu Plik kliknij polecenie Eksportuj, wpisz nazwę Usunięty_klucz_01, a następnie kliknij przycisk Zapisz.
  7. W menu Edycja kliknij polecenie Usuń, a następnie kliknij przycisk Tak w celu potwierdzenia.
  8. Powtórz te czynności (od 1 do 7) dla każdego podklucza rejestru z poniższej listy. Zmień nazwę eksportowanego klucza o jeden dla każdego podklucza.
    Przykład Dla drugiego klucza wpisz nazwę Usunięty_klucz_02, dla trzeciego klucza wpisz nazwę Usunięty_klucz_03 itd.
Uwaga: w następujących kluczach rejestru znak gwiazdki (*) reprezentuje co najmniej jeden znak w nazwie podklucza.

32-bitowe wersje systemu Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office12*
64-bitowe wersje systemu Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office12*
Wykonaj dalsze czynności dla podanych niżej podkluczy rejestru:
  1. Odszukaj następujący podklucz rejestru:

    Wersja 32-bitowa: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    Wersja 64-bitowa: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. W menu Plik kliknij polecenie Eksportuj, wpisz nazwę Klucz_odinstalowywania_01, a następnie kliknij przycisk Zapisz.
  3. W podkluczu Uninstall znalezionym w kroku 1 kliknij każdy z podkluczy i określ, czy jest do niego przypisana następująca wartość:
    • Nazwa: UninstallString
    • Dane: nazwa_pliku ścieżka\Office Setup Controller\Setup.exe ścieżka

      Uwaga: w tym przykładzie nazwa_pliku to symbol zastępczy nazwy programu instalacyjnego, a ścieżka to symbol zastępczy ścieżki do pliku.
  4. Jeśli podklucz zawiera nazwę i dane opisane w kroku 3, kliknij polecenie Usuń w menu Edycja. W przeciwnym razie przejdź do kroku 5.
  5. Powtarzaj kroki 3 i 4 do czasu znalezienia i usunięcia wszystkich podkluczy, których nazwa i dane pasują do nazwy i danych opisanych w kroku 3.
  6. Zamknij Edytor rejestru.
Krok 6. Ponowne uruchomienie komputera.
Należy ponownie uruchomić komputer. Jeśli usuwanie zakończyło się pomyślnie, można zakończyć pracę z tym artykułem i ponownie zainstalować pakiet Microsoft Office w razie potrzeby. Jeśli usuwanie zakończyło się niepomyślnie, przejdź do sekcji „Informacje” w tym artykule.
Zwiń ten obrazekRozwiń ten obrazek
assets folding end collapsed


Właściwości

Numer ID artykułu: 928218 - Ostatnia weryfikacja: 9 marca 2014 - Weryfikacja: 8.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Office 2007 dla Uzytkownikow Domowych
  • Microsoft Office Basic 2007
Słowa kluczowe: 
kbexpertiseinter kberrmsg kbregistry kbsetup kbinstallation kbtshoot kbprb kbfixme kbmsifixme kbcip KB928218

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com