เมื่อคุณพยายามเข้าสู่ระบบ Windows Vista คอมพิวเตอร์ที่ใช้ คุณสั้น ๆ ได้รับข้อความ "ยินดีต้อนรับ" และจากนั้น คุณจะออกจากระบบ

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 929825 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
สิ่งสำคัญ บทความนี้ประกอบด้วยข้อมูลเกี่ยวกับวิธีการปรับเปลี่ยนรีจิสทรี ตรวจสอบให้แน่ใจว่า คุณสำรองรีจิสทรีก่อนที่คุณปรับเปลี่ยน ตรวจสอบให้แน่ใจว่า คุณทราบวิธีการคืนค่ารีจิสทรีหากเกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูล เรียกคืน และการปรับเปลี่ยนรีจิสทรี คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
256986 คำอธิบายเกี่ยวกับรีจิสทรีของ Microsoft Windows
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อคุณพยายามล็อกออนเข้าสู่ คอมพิวเตอร์ โดยใช้แอคเคาท์ที่มีสิทธิ์ระดับผู้ดูแล คุณสั้น ๆ ที่ใช้ Windows Vista ได้รับข้อความ "ยินดีต้อนรับ" และจากนั้น คุณได้รับข้อความ "การเข้าสู่ระบบปิด" นอกจากนี้ คุณอาจได้รับคำเตือนในล็อกแอพลิเคชัน Windows ที่มีลักษณะต่อไปนี้:

The Windows logon process has failed to spawn a user application. Application name: . Command line parameters: c:\windows\system32\userinit.exe.

Source: Winlogon 
Event ID: 4006 
Level: Warning 

ปัญหานี้เกิดขึ้นถ้าคุณเข้าสู่ระบบคอมพิวเตอร์ โดยใช้แอคเคาท์ที่มีสิทธิ์ระดับผู้ดูแล

สาเหตุ

ปัญหานี้เกิดขึ้นถ้ามีการปรับเปลี่ยนคีย์ Userinit ในรีจิสทรีของ Windows ตัวอย่างเช่น ปัญหานี้อาจเกิดขึ้นถ้าคีย์ Userinit มีค่าแต่ไม่มีข้อมูลไบนารี

การแก้ไข

คำเตือน ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้องโดยใช้ Registry Editor หรือโดยใช้วิธีอื่น อาจต้องติดตั้งระบบปฏิบัติการใหม่เพื่อแก้ไขปัญหาเหล่านี้ Microsoft ไม่สามารถรับประกันได้ว่าปัญหาเหล่านี้จะสามารถแก้ไขได้ ปรับเปลี่ยนรีจิสทรีควาด้วยมเสี่ยงของคุณเองเมื่อต้องการแก้ไขปัญหานี้ แก้ไขคีย์ Userinit ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. เข้าสู่ระบบคอมพิวเตอร์ในฐานะผู้ดูแลระบบ หรือใช้บัญชี ที่มีสิทธิ์ระดับผู้ดูแล
  2. เริ่มตัวแก้ไขรีจิสทรี เมื่อต้องการทำเช่นนี้ ให้คลิกปุ่ม สตาร์ท
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่มเริ่ม
    ชนิด regedit ในกล่องเริ่มการค้นหาแล้วกด ENTER
  3. ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิ์ในการควบคุมบัญชีผู้ใช้
    คลิก ดำเนินการต่อ
  4. ค้นหา และคลิกที่คีย์รีจิสทรีต่อไปนี้:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  5. ในบานหน้าต่างด้านขวา คลิกขวาUserinitและจากนั้น คลิกปรับเปลี่ยน
  6. ในกล่องValue dataพิมพ์ hard_disk: \Windows\System32\userinit.exeแล้ว คลิกตกลง

    หมายเหตุ ที่ hard_disk ตัวยึดที่อ้างอิงลงในดิสก์ที่มีการติดตั้ง Windows Vista
  7. ปิดตัวแก้ไขรีจิสทรี

ข้อมูลเพิ่มเติม

คุณอาจพบปัญหานี้หากไม่มีเส้นทางแฟ้มที่ระบุไว้ในกล่องข้อมูลค่าสำหรับคีย์รีจิสทรี Userinit

คุณสมบัติ

หมายเลขบทความ (Article ID): 929825 - รีวิวครั้งสุดท้าย: 29 กันยายน 2556 - Revision: 5.0
ใช้กับ
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Starter
Keywords: 
kblogin kbexpertiseadvanced kbtshoot kbprb kbmt KB929825 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:929825

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com