Messaggio di errore quando si tenta di avviare un'applicazione SoftGrid Client: "codice errore: xxxxxx-xxxxxx0A-20000194"

Traduzione articoli Traduzione articoli
Identificativo articolo: 930614 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Microsoft SoftGrid Client tenta di avviare un'applicazione. Tuttavia, il tentativo non riesce e viene visualizzato un messaggio di errore analogo al seguente:
Impossibile avviare il Client di SoftGrid <application_name></application_name>.
Il pacchetto richiesto non trovato nell'archivio dati di sistema o Impossibile trovare i file associati al pacchetto nel server. Segnala il seguente codice di errore nel sistema Amministratore.
Codice di errore: xxxxxx xxxxxx0A-20000194
Nel file di registro SoftGrid Client (Sftlog.txt) sia presente una voce simile al seguente:

SoftGrid client non Ŕ in grado di connettersi al flusso URL '<protocol></protocol>://<server_name></server_name>:<port></port>/<path></path>/<file name=""></file>SFT ' (stato FS: xxxxxx0A-20000194).
Il client non Ŕ riuscito a connettersi a un server di SoftGrid (rc xxxxxx0A-20000194)

Nel file di registro SoftGrid Virtual Application Server (Sft-log) sia presente una voce simile al seguente:

44808 "Impossibile trovare <provider_policy></provider_policy>."
44811 "Impossibile aprire <path></path>\<file name=""></file>SFT."

Cause

Questo comportamento pu˛ verificarsi se uno o pi¨ delle seguenti condizioni sono vere:
  • Si sta tentando di avviare un'applicazione di SoftGrid che non Ŕ stato aggiunto alla Console di gestione di SoftGrid.
  • Il file. sft specificato nel file OSD non esiste all'interno della struttura di directory del contenuto.
  • Il percorso o il nome del file SFT specificato nel Percorso relativo del File Softricity voce non valida.
  • Il criterio di Provider specificato nel file OSD non esiste.

Risoluzione

Le seguenti informazioni vengono fornite soluzioni per ciascuna causa menzionato nella sezione "Cause".
  • Si sta tentando di avviare un'applicazione di SoftGrid che non Ŕ stato aggiunto alla Console di gestione di SoftGrid

    Esistono due condizioni in cui Ŕ possibile tentare di avviare un'applicazione di SoftGrid che non Ŕ stato aggiunto alla Console di gestione di SoftGrid:
    • Fare doppio clic sul file OSD di un'applicazione abilitata per SoftGrid.
    • Fare doppio clic sul collegamento di un'applicazione di SoftGrid che Ŕ stata rimossa dalla gestione di SoftGrid Client.

      Nota Il collegamento non viene rimosso quando l'applicazione abilitata per SoftGrid viene rimosso dalla gestione di SoftGrid Client. Il collegamento non viene rimosso se copiare manualmente il collegamento in una posizione alternativa quando l'applicazione viene aggiunta alla gestione di SoftGrid Client. Quando l'applicazione viene rimossa, SoftGrid Client Management non Ŕ a conoscenza della posizione alternativa e il collegamento non viene rimosso.
  • Il file. sft specificato nel file OSD non esiste all'interno della struttura di directory del contenuto

    Il file SFT non esiste all'interno della struttura di directory del contenuto. Questo file. sft viene specificato nell'attributo HREF dell'elemento CODEBASE del file OSD.

    Si consideri il seguente scenario. Il file OSD Ŕ configurato come illustrato nell'esempio riportato di seguito:
    HREF="RTSP://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft"
    La directory del contenuto Ŕ configurata come il percorso di esempio riportato di seguito:
    C:\Programmi\Microsoft Files\Softricity\SoftGrid Server\content
    In questo scenario, Microsoft SoftGrid Impossibile avviare l'applicazione se il sft_ea70.v1.sft file non esiste nella sottodirectory Softricity nel seguente percorso di directory del contenuto:
    C:\Programmi\Microsoft Files\Softricity\SoftGrid Server\content\Softricity
    .
  • Il percorso o il nome del file SFT specificato nel "Softricity relativo percorso" non Ŕ valido

    Il Percorso relativo del File Softricity deve contenere solo la sottodirectory della directory del contenuto e il nome del file SFT. Ad esempio, Ŕ il nome del file SFT example.sft e che esiste all'interno di Applicazioni di esempio sottodirectory della directory del contenuto. Se la directory del contenuto Ŕ c:\Programmi\Microsoft Files\Softricity\SoftGrid Server\content, il Percorso relativo del File Softricity Ŕ Applications\example.sft di esempio. Se la directory del contenuto Ŕ \\SERVERNAME\content, il Percorso relativo del File Softricity Ŕ ancora Applications\example.sft di esempio.

    Per verificare che il percorso relativo contiene solo la sottodirectory della directory del contenuto e il nome del file SFT, attenersi alla seguente procedura: procedura:
    1. Da strumenti di amministrazione, avviare la Console di gestione di SoftGrid.
    2. Espandere Sistemi di SoftGrid<server_name> </server_name>Pacchetti <package version="" of="" the="" application="" that="" does="" not="" start=""> </package>.
    3. Fare doppio clic sulla versione del pacchetto dell'applicazione che non si avvia.
    4. Verificare che il Percorso relativo del File Softricity contiene solo la sottodirectory della directory del contenuto e il nome del file SFT.
  • Il criterio di Provider specificato nel file OSD non esiste.

    Il criterio di Provider che ?Cliente = Specifica non esiste. Questo criterio Provider viene specificato nell'attributo HREF dell'elemento CODEBASE del file OSD

    Si consideri il seguente scenario. L'ambiente SoftGrid dispone di pi¨ Provider criteri come il Provider predefinito e criterio di Provider personalizzato denominato anonimo. Inoltre, Ŕ necessario configurare un file OSD per utilizzare il criterio di Provider anonimo. In questo scenario, il.Attributo HREF dell'elemento CODEBASE del file OSD deve apparire come nell'esempio seguente.
    HREF="RTSP://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft?Cliente = anonimo"
    Nota Se il nome del criterio di Provider che segue ?Cliente = non esiste, Microsoft SoftGrid Impossibile avviare l'applicazione.
Per ulteriori informazioni sulle condizioni di utilizzo, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/tou/

ProprietÓ

Identificativo articolo: 930614 - Ultima modifica: lunedý 9 luglio 2012 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft SoftGrid for Terminal Services
  • Microsoft SoftGrid for Windows Desktops
Chiavi:á
kbexpertiseinter kbtshoot kbmt KB930614 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 930614
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com