SoftGrid 클라이언트는 응용 프로그램을 시작 하려고 할 때 오류 메시지: "오류 코드: 20000194-xxxxxx0A-xxxxxx"

기술 자료 번역 기술 자료 번역
기술 자료: 930614 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

Microsoft SoftGrid 클라이언트는 응용 프로그램을 시작 하려고 합니다. 그러나 시도가 성공 하지 및 다음과 유사한 오류 메시지가 나타납니다.
SoftGrid 클라이언트를 시작할 수 없습니다. <application_name></application_name>.
시스템 데이터 저장소에서 요청한 패키지를 찾을 수 없습니다 또는 서버에서이 패키지와 관련 된 파일을 찾을 수 없습니다. 오류 코드는 다음의 시스템에 보고 하십시오 관리자입니다.
오류 코드: xxxxxx xxxxxx0A 20000194
다음과 같은 항목에 SoftGrid 클라이언트 로그 파일 (Sftlog.txt) 나타날 수 있습니다.

SoftGrid 클라이언트는 스트림 URL에 연결할 수 없습니다 '<protocol></protocol>://<server_name></server_name>:<port></port>/<path></path>/<file name=""></file>.sft' (FS 상태: xxxxxx0A 20000194).
클라이언트 SoftGrid 서버 (rc xxxxxx0A-20000194)에 연결할 수 없습니다.

다음과 유사한 항목 (Sft server.log) SoftGrid 가상 응용 프로그램 서버 로그 파일에 나타날 수 있습니다.

"찾을 수 없습니다 44808. <provider_policy></provider_policy>."
"열 수 없습니다 44811. <path></path>\<file name=""></file>.sft입니다. "

원인

경우이 문제가 발생할 수 또는 다음 상황에 해당할:
  • SoftGrid 관리 콘솔에 추가 된 SoftGrid 사용 가능 응용 프로그램을 시작 하려고 합니다.
  • .Osd 파일에서 지정한.sft 파일이 콘텐츠 디렉터리 구조 내에서 존재 하지 않습니다.
  • 지정 된.sft 파일 이름 또는 경로 Softricity 파일 상대 경로 항목이 잘못 되었습니다.
  • .Osd 파일에서 지정한 공급자 정책이 없습니다.

해결 방법

다음 정보는 "원인" 절에 언급 된 각 원인에 대 한 해결책을 제공 합니다.
  • SoftGrid 관리 콘솔에 추가 된 SoftGrid 사용 가능 응용 프로그램을 시작 하려고 하는

    두 가지 조건에서 성공적으로 SoftGrid 관리 콘솔에 추가 된 SoftGrid 사용 가능 응용 프로그램을 시작 해 있습니다.
    • SoftGrid 사용 가능 응용 프로그램의.osd 파일을 두 번 클릭 합니다.
    • SoftGrid 클라이언트 관리에서 제거 된 SoftGrid 사용 가능 응용 프로그램의 바로 가기를 두 번 클릭 합니다.

      참고 SoftGrid 사용 가능 응용 프로그램 SoftGrid 클라이언트 관리에서 제거 될 때 바로 가기가 제거 되지 않습니다. SoftGrid 클라이언트 관리 응용 프로그램을 추가 하면 다른 위치에 바로 가기를 수동으로 복사 하는 경우 바로 가기가 제거 되지 않습니다. 응용 프로그램을 나중에 있을 때 제거 SoftGrid 클라이언트 관리 대체 위치를 인식 하지 하 고 바로 가기 제거 됩니다.
  • .Osd 파일에서 지정한.sft 파일이 콘텐츠 디렉터리 구조 내에 없습니다.

    .Sft 파일이 콘텐츠 디렉터리 구조 내에서 존재 하지 않습니다. 이.sft 파일이.osd 파일 CODEBASE 요소의 HREF 특성에 지정 됩니다.

    다음 시나리오를 고려해 야 합니다. .Osd 파일은 다음 예제와 같이 구성 되어 있습니다.
    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft"
    다음 예제에서는 경로 같이 컨텐트 디렉터리를 구성 합니다.
    C:\Program Files\Softricity\SoftGrid Server\content
    이 시나리오에서는 Microsoft SoftGrid 응용 프로그램을 시작할 수 없습니다를 sft_ea70.v1.sft 다음 콘텐츠 디렉터리 경로에 Softricity 하위 디렉터리에 파일이 존재 하지 않습니다.
    C:\Program Files\Softricity\SoftGrid Server\content\Softricity
    .
  • "Softricity 파일 상대 경로에서" 지정 된.sft 파일 이름 또는 경로 올바르지 않습니다.

    Softricity 파일 상대 경로 만 하위 콘텐츠 디렉터리 및.sft 파일 이름이 포함 되어야 합니다. 예를 들어,.sft 파일 이름이입니다. example.sft 내 존재는 예제 응용 프로그램 콘텐츠 디렉터리의 하위 디렉터리입니다. 콘텐츠 디렉터리 이름을 Files\Softricity\SoftGrid Server\content, 경우에 Softricity 파일 상대 경로 Applications\example.sft 예제입니다. \\SERVERNAME\content, 컨텐트 디렉터리인 경우는 Softricity 파일 상대 경로 여전히 Applications\example.sft 예제입니다.

    상대 경로로 하위 콘텐츠 디렉터리 및.sft 파일 이름이 포함 되어 있는지 확인 하려면 다음이 단계를 수행 하십시오: 단계:
    1. 관리 도구에서 SoftGrid 관리 콘솔을 시작 합니다.
    2. 확장 SoftGrid 시스템<server_name> </server_name>패키지 <package version="" of="" the="" application="" that="" does="" not="" start=""> </package>.
    3. 시작 되지 않는 응용 프로그램 패키지 버전을 두 번 클릭 합니다.
    4. 확인은 Softricity 파일 상대 경로 만 하위를 콘텐츠 디렉터리 및.sft 파일 이름이 포함 되어 있습니다.
  • .Osd 파일에서 지정한 공급자 정책이 없습니다.

    공급자 정책에 ?고객 = 지정 존재 하지 않습니다. 이 공급자 정책.osd 파일 CODEBASE 요소의 HREF 특성에 지정 된

    다음 시나리오를 고려해 야 합니다. SoftGrid 환경의 기본 공급자 및 익명 라는 사용자 지정 공급자 정책을 같은 여러 공급자 정책 있습니다. 또한는.osd 파일을 익명 공급자 정책을 사용 하도록 구성 해야 합니다. 이 시나리오는..Osd 파일 CODEBASE 요소의 HREF 특성에는 다음 예제와 같이 표시 되어야 합니다.
    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft?고객 익명 ="
    참고 공급자 정책 이름에 따르는 경우 ?고객 = 존재 하지 않는 Microsoft SoftGrid 응용 프로그램을 시작할 수 없습니다.
사용 약관에 대 한 자세한 내용은 다음 Microsoft 웹 사이트를 방문 하십시오.
http://support.microsoft.com/tou/

속성

기술 자료: 930614 - 마지막 검토: 2012년 7월 9일 월요일 - 수정: 1.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft SoftGrid for Terminal Services
  • Microsoft SoftGrid for Windows Desktops
키워드:?
kbexpertiseinter kbtshoot kbmt KB930614 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.
이 문서의 영문 버전 보기:930614

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com