Resolver teclas de controlo de Volume ou as teclas de atalho não funcionar em teclados Microsoft

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Sintomas

Teclas de atalho ou as teclas de controlo de volume não funcionam conforme esperado no teclado Microsoft. Algumas teclas de atalho podem funcionar como esperado, mas outros não.

Poderá receber uma mensagem de erro semelhante à seguinte quando tenta iniciar o serviço de Interface humana:
Código de erro 126
Erro 2

Causa

Este problema poderá ocorrer se existir um problema com a ligação USB no computador. Este problema também pode ocorrer se estiver a executar um utilitário de controlo de teclado de outros fabricantes no computador. Exemplos de utilitários de controlo de teclado de outros fabricantes são os seguintes:
  • Compaq acesso fácil
  • Máquina e segredo e tabuleiro
  • Teclado multifunções gateway
  • Hewlett-Packard Multimedia Keyboard utilitário
  • IBM rápida aceder ? Logitech Key Commander
  • Packard Bell MediaSelect
Utilitários de controlo de teclado de outros fabricantes também são fornecidos com computadores Acer, Gateway 2000 e Sony multimédia.

Este problema ocorre porque os códigos de análise emitidos pelo teclado são interpretados de forma diferente por cada utilitário de controlo do teclado. Isto também pode ser devido ao facto de ter inesperado predefinido ou programa redefinido atribuições para as chaves. Muitas das atribuições predefinidas requerem que tem instalado um programa específico, ou que está a utilizar um programa de correio electrónico suportados, o browser da Internet ou o media player.

Se não tiver o programa suportado pode ainda utilizar a chave por reatribuir a chave.

Resolução

Experimente cada um dos métodos abaixo por ordem, as teclas de teste após cada método. Se o problema persistir, avance para o método seguinte.

Método 1: Experimente uma porta USB diferente

Ligue o teclado a uma porta USB diferente e, em seguida, verifique o comportamento do teclado. (Este método testes para problemas de porta específica.)

NotaIgnorar qualquer replicadores de porta, concentradores USB, comutadores KVM e assim sucessivamente. Ligar o receptor directamente a uma porta no computador.

Método 2: Desactive ou desinstale qualquer software de teclado instalados anteriormente

Desactivar qualquer outro teclado controlo software instalado neste computador e, em seguida, tente reatribuir as chaves.


Para mais informações sobre como atribuir funções a chaves, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
237179Atribuir a macro ou função a teclas do teclado


Se o problema persistir, remova qualquer software de teclado no computador. Para desinstalar quaisquer IntelliPoint, Logitech ou outro software de teclado, siga estes passos:
  1. Efectue um dos seguintes procedimentos:
    • Windows Vista ou o Windows 7:
      1. Utilize as teclas de seta para localizar oIniciar procuracaixa, escrevaappwiz. cpl, e, em seguida, prima ENTER.
      2. Na lista de programas, utilize as teclas de seta para seleccionarProgramas e funcionalidades, e, em seguida, prima ENTER.
      3. Utilize as teclas de seta para localizar qualquer controlar software de teclado, prima TAB para localizarRemover, e, em seguida, prima ENTER. Se tiver outro software de rato instalado, poderá pretender considerar desinstalar esse software também.
    • Windows XP e versões anteriores do Windows:
      1. Clique emIniciar, clique emExecutar, tipoappwiz. cplnoAbrire, em seguida, clique emOK.
      2. Utilize as teclas de seta para localizar qualquer controlar software de teclado, prima TAB para localizarRemover, e, em seguida, prima ENTER.
  2. Reinicie o computador se lhe for pedido para efectuar este procedimento.
  3. Transferir o software IntelliType mais recente. Para mais informações, visite o seguinte Web site da Microsoft:
    http://www.microsoft.com/hardware/download/download.aspx?Category=MK

Método 3: Reiniciar o serviço de Interface humano HID

Para corrigir este problema, siga estes passos:
  1. Abrir snap-in da consola Microsoft Management Console (MMC) para serviços.
    • No Windows Vista ou no Windows 7, clique emIniciar
      Reduzir esta imagemExpandir esta imagem
      Botão Iniciar
      , tipoServices. mscnoIniciar procuracaixa e, em seguida, prima ENTER.

      Reduzir esta imagemExpandir esta imagem
      Permissão de controlo de conta de utilizador
      Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique emContinuar.
    • No Windows XP, clique emIniciar, clique emExecutar, tipoServices. mscnoAbrire, em seguida, clique emOK.
  2. Na lista de serviços noDetalhespainel, faça duplo clique emServiço HID de Interface humanae, em seguida, certifique-se de que oTipo de arranqueestá definido paraAutomática.
Se receber um código de erro quando tenta iniciar o serviço de Interface Humana HID, tente o método 4. No entanto, se receber o código de erro 126 ou código de erro 2, tente um dos seguintes procedimentos:
  • Se receber o código de erro 126, extraia o ficheiro Hidserv.dll. Para tal, siga estes passos:
    1. Procure Hidserv.dll na unidade de sistema. Se não conseguir localizá-la na unidade de sistema, localize o ficheiro no CD do Windows.
    2. Utilize as teclas de seta para seleccionarExtrair, e, em seguida, prima ENTER.
    3. Utilize as teclas de seta para seleccionar a pasta C:\Windows\System32 e, em seguida, seleccionar esta pasta como o destino.
    4. Reinicie o computador.
  • Se receber o código de erro 2, altere as definições de registo. Para tal, siga estes passos.

    NotaEste problema também poderá ocorrer devido às alterações nas definições de registo.

    ImportanteEsta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, podem ocorrer problemas graves se modificar o registo incorrectamente. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para uma maior protecção, cópia do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar cópias de segurança e restaurar o registo, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
    322756Como efectuar cópias de segurança e restaurar o registo no Windows
    Para resolver este problema, Active HID serviços no computador. Para tal, siga estes passos:
    1. Inicie o Editor de registo.
      • No Windows Vista ou no Windows 7, clique emIniciar
        Reduzir esta imagemExpandir esta imagem
        botão Iniciar
        , tipoRegeditnoIniciar procuracaixa e, em seguida, prima ENTER.

        Reduzir esta imagemExpandir esta imagem
        Permissão de controlo de conta de utilizador
        Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique emContinuar.
      • No Windows XP, clique emIniciar, clique emExecutar, tipoRegeditnoAbrire, em seguida, clique emOK.
    2. Localize e, em seguida, clique na seguinte chave de registo:
      HKEY_LOCAL_MACHINE/System
    3. ExpandirSistema.
    4. ExpandirControlSet001.
    5. ExpandirServiçose, em seguida, clique emHidServ.
    6. No painel da direita, com o botão direitoTipoe, em seguida, clique emModificar.
    7. NoDados do valorcaixa, certifique-se de que o valor é definido como20e, em seguida, clique emOK.
    8. ExpandirHidServe, em seguida, clique emParâmetros.

      NotaSe a chave de registo de parâmetros não existir, siga estes passos:
      1. Clique emHidServ.
      2. Sobre oEditarmenu, aponte paraNovoe, em seguida, clique emChave.
      3. TipoParâmetros, e, em seguida, prima ENTER.
    9. No painel da direita, com o botão direitoServiceDlle, em seguida, clique emModificar.

      NotaSe o valor de registo ServiceDll não existir, siga estes passos:
      1. Clique emParâmetros.
      2. Sobre oEditarmenu, aponte paraNovoe, em seguida, clique emValor de cadeia expansível.
      3. TipoServiceDll, e, em seguida, prima ENTER.
    10. NoDados do valorcaixa, certifique-se de que o valor é definido como%SystemRoot%\System32\hidserv.dll. (Certifique-se de que existem espaços antes, depois ou neste valor). Se o valor não é%SystemRoot%\System32\hidserv.dll, tipo%SystemRoot%\System32\hidserv.dllnoDados do valore, em seguida, clique emOK.
    11. Repita os passos 5 a 10 para cada chave de registo que contém "controlset" no nome da chave. Por exemplo, se existir uma chave de registo denominado CurrentControlSet ou ControlSet002, clique emCurrentControlSetou clique emControlSet002. Em seguida, repita os passos 5 a 10.
    12. Saia do Editor de registo e, em seguida, reinicie o computador.

Método 4: ensaio num computador diferente

Se o problema persistir, teste o teclado com um computador diferente. Se o teclado não funcionar correctamente com o outro computador, contacte o nosso ambiente de trabalho de encomenda para obter um teclado de substituição. Para tal, ligue para (800) 360-7561.

Para mais informações, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
326246Como substituir perdido, danificado ou em falta hardware ou software da Microsoft

Mais Informação

Para mais informações sobre um problema em que as definições de áudio são repostas quando alterar o hardware de áudio ou de som, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
266680Definições de som do utilizador predefinido são restauradas para as predefinições do Windows
Para mais informações sobre um problema em que volume definições não persistem quando reiniciar o computador, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
273033Definições de controlo de volume não poderão persistir depois de reiniciar o computador

Propriedades

Artigo: 932875 - Última revisão: 15 de março de 2011 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Basic Wireless Optical Desktop
  • Microsoft Comfort Curve Keyboard 2000
  • Microsoft Digital Media Keyboard 3000
  • Microsoft Digital Media Pro Keyboard
  • Microsoft MultiMedia Keyboard
  • Microsoft Natural Ergonomic Desktop 7000
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  • Microsoft Wireless Entertainment Desktop 8000
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Clique aqui para ver a versão em Inglês deste artigo: 932875

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