Resolver teclas de controle de Volume ou teclas de atalho não funcionando em teclados Microsoft

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Sintomas

Teclas de atalho ou as teclas de controle de volume não funcionam como esperado no teclado Microsoft. Algumas teclas de atalho podem se comportar conforme o esperado, mas outros não.

Você receberá uma mensagem de erro semelhante a seguinte mensagem de erro quando você tentar iniciar o serviço de Interface Humana:
Código de erro 126
Erro 2

Causa

Esse problema pode ocorrer se houver um problema com a conexão USB no seu computador.Esse problema também pode ocorrer se um utilitário de controle do teclado de terceiros está em execução no seu computador. Estes são exemplos de utilitários de controle do teclado de terceiros:
  • Compaq fácil acesso
  • Máquina E's E placa
  • Teclado multifuncional de gateway
  • Utilitário de teclado multimídia Hewlett-Packard
  • IBM rápido acesso ?Logitech Key Commander
  • Packard Bell MediaSelect
Utilitários de controle do teclado de terceiros também são fornecidos com computadores Acer, Gateway 2000 e Sony multimídia.

Esse problema ocorre porque os códigos de verificação emitidos pelo teclado são interpretados de modo diferente por cada utilitário de controle do teclado. Isso também pode ser atribuída à existência padrão inesperado ou atribuições de programa definido novamente para as chaves. Muitas das atribuições padrão exigem que você tenha instalado um programa específico ou que você está usando um programa de email compatível, o navegador da Internet ou o media player.

Se você não tiver o programa com suporte, você ainda pode usar a tecla ao reatribuir a chave.

Resolução

Tente cada um dos métodos abaixo na ordem, as chaves de teste após cada método. Vá para o próximo método se o problema ainda ocorre.

Método 1: Tente uma porta USB diferente

Conecte o teclado a uma porta USB diferente e, em seguida, verifique o comportamento do teclado. (Esse método testa para problemas específicos de porta).

Observação Ignore qualquer replicadores de portas, hubs USB, comutadores KVM e assim por diante. Conecte o receptor diretamente a uma porta no computador.

Método 2: Desative ou desinstale qualquer software de teclado instalado anteriormente

Desabilitar qualquer outro software de controle teclado instalado neste computador e então tente reatribuir as chaves.


Para obter mais informações sobre como atribuir funções a teclas, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
237179 Atribuir função ou macro a teclas do teclado


Se o problema persistir, remova qualquer software de teclado no seu computador. Para desinstalar qualquer IntelliPoint, Logitech ou outro software de teclado, siga estas etapas:
  1. Siga um destes procedimentos:
    • Windows Vista ou Windows 7:
      1. Use as teclas de setas para localizar a caixa Iniciar pesquisa , tipo appwiz. cpl, e então pressione ENTER.
      2. Na lista de programas, use as teclas de seta para selecionar programas e recursose, em seguida, pressione ENTER.
      3. Use as teclas de setas para localizar qualquer teclado controlando o software, pressione TAB para localizar Removere, em seguida, pressione ENTER. Se você tiver outro software de mouse instalado, convém considerar também a desinstalação do software.
    • Windows XP e versões anteriores do Windows:
      1. Clique em Iniciar, Executar, tipo appwiz. cpl em Abrir caixa e, em seguida, clique em OK.
      2. Use as teclas de setas para localizar qualquer teclado controlando o software, pressione TAB para localizar Removere, em seguida, pressione ENTER.
  2. Se você for solicitado a fazer isso, reinicie o computador.
  3. Baixe o software IntelliType mais recente. Para obter mais informações, visite o seguinte site da Microsoft:
    http://www.microsoft.com/hardware/download/download.aspx?category=MK

Método 3: Reinicie o serviço de Interface Humana HID

Para corrigir esse problema, execute as seguintes etapas:
  1. Abra o snap-in Microsoft Management Console (MMC) de serviços.
    • No Windows Vista ou Windows 7, clique Iniciar<b00> </b00>
      Recolher esta imagemExpandir esta imagem
      Botão Iniciar
      , tipo Services. msc Na caixa Iniciar pesquisa e pressione ENTER.

      Recolher esta imagemExpandir esta imagem
      Permissão Controle de conta de usuário
      Se você for solicitado para uma senha de administrador ou uma confirmação, digite a senha ou clique em continuar.
    • No Windows XP, clique em Iniciar, clique em Executar, tipo Services. msc em Abrir caixa e, em seguida, clique em OK.
  2. Na lista de serviços no painel de detalhes , clique duas vezes em Serviço de Interface Humana HIDe certifique-se de que o tipo de inicialização está definido como automático.
Se você receber um código de erro ao tentar iniciar o serviço de Interface Humana HID, tente o método 4. No entanto, se você receber o código de erro 126 ou código de erro 2, tente um dos seguintes procedimentos:
  • Se você receber o código de erro 126, extraia o arquivo Hidserv.dll. Para fazer isso, execute as seguintes etapas:
    1. Procure o Hidserv.dll na unidade do sistema. Se você não é possível localizá-lo na sua unidade de sistema, localize o arquivo no CD do Windows.
    2. Use as teclas de direção para selecionar a extraire, em seguida, pressione ENTER.
    3. Use as teclas de direção para selecionar a pasta C:\Windows\System32 e, em seguida, selecione essa pasta como destino.
    4. Reinicie o computador.
  • Se você receber o código de erro 2, altere as configurações do registro. Para fazer isso, siga estas etapas.

    Observação Esse problema também pode ocorrer devido a alterações nas configurações do registro.

    Importante Nesta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o Registro incorretamente. Portanto, certifique-se de que segue estes passos cuidadosamente. Para maior proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
    322756 Como fazer backup e restaurar o registro no Windows
    Para resolver esse problema, ative HID serviços no computador. Para fazer isso, execute as seguintes etapas:
    1. Inicie o Editor do registro.
      • No Windows Vista ou Windows 7, clique Iniciar<b00> </b00>
        Recolher esta imagemExpandir esta imagem
        botão Iniciar
        , tipo Regedit Na caixa Iniciar pesquisa e pressione ENTER.

        Recolher esta imagemExpandir esta imagem
        Permissão Controle de conta de usuário
        Se você for solicitado para uma senha de administrador ou uma confirmação, digite a senha ou clique em continuar.
      • No Windows XP, clique em Iniciar, clique em Executar, tipo Regedit em Abrir caixa e, em seguida, clique emOK.
    2. Localize e clique na seguinte chave do registro:
      HKEY_LOCAL_MACHINE/System
    3. Expanda sistema.
    4. Expanda ControlSet001.
    5. Expanda Serviçose, em seguida, clique em HidServ.
    6. No painel direito, clique com botão direito tipoe, em seguida, clique em Modificar.
    7. Na caixa dados do valor , certifique-se de que o valor é definido como 20e, em seguida, clique em OK.
    8. Expanda HidServe, em seguida, clique em parâmetros.

      Observação Se a chave de parâmetros não existir, siga estas etapas:
      1. Clique em HidServ.
      2. No menu Editar , aponte para novoe, em seguida, clique em chave.
      3. Tipo Parâmetros, e então pressione ENTER.
    9. No painel direito, clique com botão direito ServiceDlle, em seguida, clique em Modificar.

      Observação Se o valor de registro ServiceDll não existir, siga estas etapas:
      1. Clique em parâmetros.
      2. No menu Editar , aponte para novoe, em seguida, clique em Valor da seqüência expansível.
      3. Tipo ServiceDll, e então pressione ENTER.
    10. Na caixa dados do valor , verifique se o valor é definido para %SystemRoot%\System32\hidserv.dll. (Verifique se que não há nenhum espaço antes, depois ou neste valor). Se o valor não for%SystemRoot%\System32\hidserv.dll, digite %SystemRoot%\System32\hidserv.dll os dados do valor caixa e, em seguida, clique em OK.
    11. Repita as etapas 5 a 10 para cada chave do registro que contém "ControlSet" no nome da chave. Por exemplo, se houver uma chave do Registro chamado CurrentControlSet ou ControlSet002, clique em CurrentControlSet ou clique em ControlSet002. Em seguida, repita as etapas 5 a 10.
    12. Saia do Editor do registro e reinicie o computador.

Método 4: Teste em um computador diferente

Se o problema persistir, teste o teclado com um outro computador. Se o teclado não funciona corretamente com o outro computador, entre em contato com o nosso Desktop de ordem para obter um teclado de substituição. Para fazer isso, ligue para (800) 360-7561.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
326246 Como substituir perdido, danificado ou em falta hardware ou software da Microsoft

Mais Informações

Para obter mais informações sobre um problema em que as configurações de áudio são redefinidas quando você alterar o hardware de áudio, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
266680 Configurações de som do usuário padrão são restauradas para as configurações padrão do Windows
Para obter mais informações sobre um problema no qual volume configurações não persistem quando você reiniciar o computador, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
273033 Configurações de controle de volume podem não permanecer após reiniciar o computador

Propriedades

ID do artigo: 932875 - Última revisão: domingo, 1 de dezembro de 2013 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Basic Wireless Optical Desktop
  • Microsoft Comfort Curve Keyboard 2000
  • Microsoft Digital Media Keyboard 3000
  • Microsoft Digital Media Pro Keyboard
  • Microsoft Multimedia Keyboard
  • Microsoft Natural Ergonomic Desktop 7000
  • Microsoft Natural Ergonomic Keyboard 4000
  • Microsoft Natural MultiMedia Keyboard
  • Microsoft Wireless Entertainment Desktop 8000
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  • Microsoft Wireless Laser Desktop 7000
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