Impossibile trovare il file durante la ricerca di un computer basato su Windows Vista, anche se i file presenti sul computer

Traduzione articoli Traduzione articoli
Identificativo articolo: 932989 - Visualizza i prodotti a cui si riferisce l?articolo.

Supporto per Windows Vista senza service pack installato Ŕ terminato il 13 aprile 2010. Per continuare a ricevere gli aggiornamenti della sicurezza per Windows, assicurarsi di eseguire Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento alla pagina web Microsoft: Sta per terminare il supporto per alcune versioni di Windows

Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo viene descritto un problema in cui Ŕ Impossibile trovare il file durante la ricerca di un computer basato su Windows Vista, anche se i file presenti nel computer. In questo articolo vengono elencati i metodi che Ŕ possibile utilizzare per risolvere il problema durante la ricerca in qualsiasi luogo e durante la ricerca dell'indice.

Per informazioni su problemi di Windows Search in Windows Vista automaticamente, scegliere Esegui ora dalla pagina Servizi di risoluzione dei problemi automatica e seguire i passaggi della procedura guidata:

Sintomi

Si verificano problemi quando si tenta di trovare i file in un computer che esegue Windows Vista. Ad esempio, quando si cercano file utilizzando un termine di ricerca, Ŕ possibile trovare i file che si prevedono di trovare. Gli elementi non vengono visualizzati nei risultati della ricerca. Questo sintomo si verifica anche se i file presenti nel computer.

Cause

Questo problema pu˛ verificarsi in uno dei seguenti scenari.
  • Quando si esegue la ricerca di qualsiasi posizione, si verificano i sintomi nella sezione "Sintomi", se una delle seguenti condizioni Ŕ vera:
    • Il file non Ŕ presente nel percorso che sta effettuando la ricerca
    • Il file si trova in una cartella di sistema.
    • Il file Ŕ un file nascosto.
    • Il file non viene visualizzato negli elementi di cinquemila innanzitutto elencati nei risultati della ricerca
    • Il file contiene il termine di ricerca in una delle relative proprietÓ e non nel nome del file
  • Quando si esegue la ricerca dell'indice, si verificano i sintomi nella sezione "Sintomi", se una delle seguenti condizioni Ŕ vera:
    • Il file non Ŕ presente in un percorso indicizzato.
    • Il tipo di file del file non Ŕ indicizzato.
    • Il file include proprietÓ che ne impediscono l'indicizzazione.
    • L'indicizzatore non Ŕ ancora inserito il file in corrispondenza dell'indice.
    • L'indicizzatore Ŕ trascurare il file.
    • Il file che sta cercando non corrispondono gli elementi nei risultati della ricerca.
Windows Vista include nuovi metodi che consentono la ricerca pi¨ rapida dei file. Tuttavia, questi nuovi metodi possono risultare sconosciuto e creare confusione per gli utenti che non hanno familiari con essi.

Risoluzione

Per risolvere questo problema, utilizzare uno o pi¨ dei seguenti metodi, a seconda della situazione.

Quando si ricerca in qualsiasi percorso

In questa sezione vengono elencati i metodi che Ŕ possibile utilizzare per risolvere questo problema quando si esegue la ricerca di qualsiasi percorso di un file. Ogni metodo corrisponde a un elemento elencato nella sezione "Cause".

Causa 1: Il file non Ŕ nella posizione che sta effettuando la ricerca

Assicurarsi che il file che si desidera trovare Ŕ all'interno dell'ambito della posizione in cui si esegue la ricerca. Per determinare il percorso in cui sta effettuando la ricerca, attenersi alla seguente procedura:
  1. Nella casella di gruppo Ha trovato ci˛ che si cercava? nella parte inferiore della finestra Risultati ricerca, fare clic su Ricerca avanzata.
  2. Nella finestra di dialogo Ricerca avanzata area, nota il percorso che sta effettuando la ricerca.
Il percorso in cui si esegue la ricerca deve contenere il file che sta cercando.
Cerca ovunque nel computer
Per eseguire ricerche ovunque nel computer, fare clic su Tutto il mondo nel Posizione casella, quindi fare clic per selezionare il Includi non indicizzati, nascosti e i file di sistema (potrebbe essere lenta) .
Ricerca solo i percorsi indicizzati
Per cercare solo i percorsi di indicizzazione, fare clic su Percorsi indicizzati nel Posizione casella.

Causa 2: Il file si trova in una cartella di sistema

Per impostazione predefinita, quando si tenta di trovare un file che si trova nel computer, Windows Vista non cercare nelle cartelle di sistema. Cartelle di sistema includono la cartella programmi e la cartella di Windows. Per cercare una cartella di sistema, utilizzare uno dei metodi descritti di seguito.
Metodo 1

Ricerca all'interno della cartella di sistema che contiene il file. Ad esempio, se si desidera trovare il Shell32. dll file, non effettuare la ricerca utilizzando il Tutto il mondo opzione. Al contrario, individuare il UnitÓ: Cartella \Windows e quindi cercare la Shell32. dll file.
Metodo 2

Fare clic Organizzare, quindi fare clic su Opzioni cartella e ricerca. Nella finestra di dialogo Opzioni cartella Nella finestra di dialogo, scegliere il Ricerca scheda, quindi in Durante la ricerca di percorsi non indicizzati, fare clic per selezionare il Includi directory di sistema .
Metodo 3

Nella finestra di dialogo Ricerca avanzata area, fare clic per selezionare il Includi non indicizzati, nascosti e i file di sistema (potrebbe essere lenta) .

Causa 3: Il file Ŕ un file nascosto

Per visualizzare i file nascosti nei risultati della ricerca, utilizzare uno dei metodi descritti di seguito.
Metodo 1

Fare clic Organizzare, quindi fare clic su Opzioni cartella e ricerca. Nella finestra di dialogo Opzioni cartella Nella finestra di dialogo, scegliere il Visualizzazione scheda, quindi in Cartelle e file nascosti, fare clic su Visualizza cartelle e file nascosti.
Metodo 2

Nella finestra di dialogo Ricerca avanzata area, fare clic per selezionare il Includi non indicizzati, nascosti e i file di sistema (potrebbe essere lenta) .

Causa 4: Il file non viene visualizzato negli elementi di cinquemila innanzitutto elencati nei risultati della ricerca

Se Windows Vista rileva pi¨ di cinquemila i risultati della ricerca, viene visualizzato il seguente messaggio:
Esistono pi¨ risultati rispetto alle dimensioni in questa visualizzazione. Restringere i risultati con la casella di ricerca o fare clic per visualizzare tutti i risultati...
╚ possibile visualizzare i risultati della ricerca. A tale scopo, fare clic sul messaggio. Oppure Ŕ possibile ridurre il numero di elementi visualizzati nei risultati della ricerca. A tale scopo, aggiungere ulteriori termini di ricerca. Ad esempio, aggiungere il tipo di file come un termine di ricerca. Per utilizzare i metodi pi¨ avanzati per filtrare i risultati della ricerca, utilizzare le opzioni disponibili nel Ricerca avanzata area.

Causa: Il file contiene il termine di ricerca in una delle relative proprietÓ e non nel nome del file

Quando si digita un termine di Ricerca casella, Windows Vista cerca sempre nomi di file. Se il file Ŕ nell'indice, in Windows Vista viene cercato anche le proprietÓ del file. ProprietÓ di file includono il tipo di file, l'autore, il contenuto, ad esempio parole e frasi nel file e i commenti che sono stati aggiunti alle immagini. Per cercare contenuto in un file se il file non Ŕ presente nell'indice, utilizzare uno dei metodi descritti di seguito.
Metodo 1

Fare clic Organizzare, quindi fare clic su Opzioni cartella e ricerca. Nella finestra di dialogo Opzioni cartella Nella finestra di dialogo, scegliere il Ricerca scheda e quindi fare clic per selezionare il Cerca sempre nomi di file e il contenuto (potrebbe essere lenta) .
Metodo 2

Se si esegue la ricerca di un percorso che non Ŕ incluso nell'indice, in Ha trovato ci˛ che si cercava? nella parte inferiore della finestra Risultati ricerca, fare clic su Ricerca nel contenuto del file..

Quando si cerca l'indice

In questa sezione vengono elencati i metodi che Ŕ possibile utilizzare per risolvere il problema durante la ricerca dell'indice di un file. Ogni metodo corrisponde a un elemento elencato nella sezione "Cause".

Causa 1: Il file non Ŕ in un percorso indicizzato

Se si fa clic su Percorsi indicizzati Per cercare i percorsi indicizzati, la posizione dell'elemento che si desidera trovare deve essere nell'indice. Per determinare se i file e cartelle che si prevedono venga visualizzata nei risultati della ricerca si trovano nell'indice, attenersi alla seguente procedura:
  1. Fare clic Inizio
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , fare clic su Pannello di controllo, quindi fare clic su Sistema e manutenzione.
  2. Fare clic Opzioni di indicizzazione. Le cartelle vengono indicizzate sono elencate in Posizioni selezionate nel Opzioni di indicizzazione Nella finestra di dialogo.
  3. Per visualizzare il percorso delle cartelle presenti nell'indice, fare clic su Modificare e quindi fare clic su Mostra tutti i percorsi. Nella casella di gruppo Riepilogo percorsi selezionati, fare clic sull'elemento che si desidera visualizzare.
Per aggiungere una posizione di indice, utilizzare una delle seguenti procedure:
  • Utilizzare le opzioni di Opzioni di indicizzazione Nella finestra di dialogo per aggiungere, rimuovere o escludere percorsi dall'indice.
  • In scenari in cui la ricerca di un percorso che non Ŕ presente nell'indice, viene visualizzato il seguente messaggio:
    La ricerca potrebbe essere lenta in percorsi non indicizzati: Posizione. Fare clic per aggiungere all'indice...
    Per aggiungere la posizione dell'indice, fare clic sul messaggio.
╚ possibile aggiungere solo percorsi sul computer locale e l'indice. Se si ricerca un computer sulla rete che esegue Windows Vista, i percorsi indicizzati vengono configurati nel computer remoto basato su Windows Vista vengono utilizzati nella ricerca.

╚ possibile aggiungere una cartella da un computer della rete che non esegue Windows Vista all'indice. Prima di aggiungere la cartella all'indice, Ŕ necessario utilizzare il Nomecartella ProprietÓ Nella finestra di dialogo per rendere disponibile la cartella fuori rete sul computer remoto.

Causa 2: Il tipo di file del file non indicizzato.

Alcuni tipi di file non sono inclusi nell'indice. Per visualizzare i tipi di file inclusi nell'indice, attenersi alla seguente procedura:
  1. Fare clic Inizio
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , fare clic su Pannello di controllo, quindi fare clic su Sistema e manutenzione.
  2. Fare clic Opzioni di indicizzazione, quindi fare clic su Avanzate.

    Riduci l'immagineEspandi l'immagine
     Autorizzazione di controllo dell'Account utente
    Se viene chiesta una password di amministratore o di confermare, digitare la password o fare clic su Continuare.
  3. Scegliere il Tipi di file scheda e quindi visualizzare l'elenco dei tipi di file. Se la casella di controllo che Ŕ successiva al nome del file estensione Ŕ selezionata, il tipo di file Ŕ incluso nell'indice. Se non Ŕ selezionata la casella di controllo verrÓ visualizzata l'estensione del nome file, il tipo di file non Ŕ incluso nell'indice.
Nota. ╚ inoltre possibile configurare se si desidera indicizzare solo le proprietÓ dei tipi di file specifico o se si desidera indicizzare solo le proprietÓ e il contenuto di determinati tipi di file. Per indicizzare la proprietÓ di un tipo di file, fare clic su Indicizza solo le proprietÓ. Per indicizzare le proprietÓ e il contenuto di un tipo di file specifico, fare clic su ProprietÓ indice e il contenuto del file..

Causa 3: Il file include proprietÓ che ne impediscono l'indicizzazione in corso

I file possono avere proprietÓ che consentono di impedire l'indicizzazione di file. Un file non viene aggiunto all'indice, se una delle seguenti condizioni Ŕ vera:
  • Il Indice di questo file per ricerche pi¨ veloci non Ŕ selezionata la casella di controllo. (Per individuare questa casella di controllo, il file, scegliere ProprietÓ, quindi fare clic su Avanzate.)
  • Il file Ŕ configurato per utilizzare l'attributo nascosto e l'attributo di sistema. Pochi file utilizzano entrambi gli attributi. Il file desktop. ini Ŕ un esempio di un file che utilizza entrambi gli attributi.
Per trovare questi file, utilizzare uno dei metodi descritti di seguito.
Metodo 1

Rimuovere le proprietÓ o gli attributi che consentono di impediscono l'indicizzazione di file.
Metodo 2

Nella finestra di dialogo Ricerca avanzata area, fare clic per selezionare il Includi non indicizzati, nascosti e i file di sistema (potrebbe essere lenta) .
Metodo 3

Fare clic Organizzare, quindi fare clic su Opzioni cartella e ricerca. Nella finestra di dialogo Opzioni cartella Nella finestra di dialogo, scegliere il Ricerca scheda, quindi in ModalitÓ di ricerca, fare clic per selezionare il Non utilizzare l'indice durante la ricerca del file system (potrebbe essere lenta) .

Causa 4: L'indicizzatore Ŕ non ancora inserito il file in corrispondenza dell'indice

I file non vengono immediatamente inseriti in corrispondenza dell'indice dall'indicizzatore. Quando non vi Ŕ alcuna attivitÓ utente, l'indicizzatore utilizza le risorse per elaborare il backlog dei file che non sono state indicizzate. Ad esempio, si apre il Opzioni di indicizzazione Nella finestra di dialogo e quindi si utilizza il mouse o la tastiera per 45 secondi. Nella finestra di dialogo Opzioni di indicizzazione Nella finestra di dialogo verrÓ visualizzato l'indicizzatore consente di aumentare la velocitÓ di indicizzazione per completare l'indicizzazione di elementi. Il Opzioni di indicizzazione Nella finestra di dialogo viene visualizzato anche se l'indicizzazione Ŕ stata completata. In scenari in cui Ŕ possibile aggiungere molti nuovi file al computer, assicurarsi che l'indicizzazione Ŕ stata completata.

Causa 5: L'indicizzatore Ŕ trascurare il file.

Se si sospetta che Ŕ presente un problema che l'indicizzatore non contiene una o pi¨ file deve contenere, ricostruire l'indice. Per ricostruire l'indice per l'utente, Vai al "Risolvere il problema per me"sezione. Se si desidera ricreare l'indice di se stessi, Vai al "Risolvere il problema manualmente"sezione.

Risolvere il problema per me


Per ricreare l'indice automaticamente, scegliere il Risolvere il problemacollegamento. Fare clic Eseguirenel Download di filefinestra di dialogo casella e seguire i passaggi della correzione, procedura guidata.


Risolvere il problema
Microsoft Fix it 50201


Nota. Questa procedura guidata potrebbe essere solo in lingua inglese. Tuttavia, la correzione automatica funziona anche per le versioni di Windows in altre lingue.

Nota. Se non si Ŕ nel computer in cui si verifica il problema, Ŕ possibile salvare la correzione automatica su un'unitÓ di memoria flash o su un CD in modo da eseguirla nel computer in cui si verifica il problema.

Grazie all'esclusiva MVP Anand Khanse Per contribuire a questa correzione.

Successivamente, Vai al "Il problema Ŕ stato risolto?"sezione.



Risolvere il problema manualmente


Per ricreare l'indice, attenersi alla seguente procedura:
  1. Fare clic Inizio
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , fare clic su Pannello di controllo, quindi fare clic su Sistema e manutenzione.
  2. Fare clic Opzioni di indicizzazione, quindi fare clic su Avanzate.

    Riduci l'immagineEspandi l'immagine
     Autorizzazione di controllo dell'Account utente
    Se viene chiesta una password di amministratore o di confermare, digitare la password o fare clic su Continuare.
  3. Fare clic Ricostruzione. Quando viene richiesto di confermare la ricostruzione dell'indice, fare clic su OK.
  4. Una volta completata la ricostruzione, riavviare il computer.
Ricostruzione dell'indice potrebbe richiedere alcuni minuti per completare l'operazione. Durante l'operazione di ricostruzione, l'indicizzatore tenta di inserire nuovamente tutti gli elementi in corrispondenza dell'indice.

Il problema Ŕ stato risolto?

Controllare se il problema Ŕ stato risolto. Se il problema viene risolto, non Ŕ necessario continuare con questa sezione. Se il problema non viene risolto, Ŕ possibile contattare il supporto tecnico.

Causa 6: Gli elementi nei risultati della ricerca non corrisponde al file che sta cercando

Quando si utilizza il Ricerca casella per cercare nell'indice, la ricerca include proprietÓ quali autore, l'artista, tag e contenuto del file. Utilizzare il Ricerca avanzata area per specificare le informazioni desiderate.

Per ulteriori informazioni su come cercare i file utilizzando la sintassi di query avanzate, vedere la Guida di Windows Vista.

ProprietÓ

Identificativo articolo: 932989 - Ultima modifica: domenica 2 giugno 2013 - Revisione: 4.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Starter
Chiavi:á
kbsurveynew kbmsifixme kbfixme kbexpertisebeginner kbprb kbtshoot kbmt KB932989 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo Ŕ stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre Ŕ perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilitÓ per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualitÓ della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 932989
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com