当您尝试启动 Windows Defender 您最近已经升级到 Windows Vista 的计算机上时出现错误消息:"应用程序未能初始化"

文章翻译 文章翻译
文章编号: 935511 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

当试图从 Microsoft Windows XP 升级到 Windows Vista 后启动 Windows Defender 时您会收到以下错误消息:
应用程序初始化失败。

原因

如果您在操作系统升级到 Windows Vista 后从计算机中卸载 Windows Defender,可能会出现此问题。

注意如果您收到"症状"部分中提到的错误信息,但未卸载 程序和功能 通过 Windows Defender 您可能会收到此错误消息由于的一个不同的问题。这篇文章中的步骤解决 Windows Defender 已从系统删除的问题。

解决方案

若要解决此问题,使用方法 1。如果方法 1 不能解决问题,请转到方法 2。

方法 1: 使用系统还原到恢复 Windows Vista

若要返回到此问题发生前创建还原点的 Windows Vista,可以用 $ 系统还原。若要这样做,请按照下列步骤操作:
  1. 从计算机中删除所有软盘、 cd 和 dvd。然后,重新启动计算机。
  2. 单击 开始
    收起这个图片展开这个图片
    Start button
    、 单击 锁定,旁边的箭头,然后单击 重新启动
  3. 根据使用下面的方法之一:
    • 如果计算机中有单一的操作系统安装,按住 F8 为在计算机重新启动。出现 Windows 徽标之前,您必须按 f8 键。如果将出现 Windows 徽标等待出现 Windows 登录提示。然后,退出 Windows,并重新启动计算机。
    • 如果计算机中有多个操作系统使用箭头键突出显示想要在安全模式下启动操作系统。然后,请按 f8 键。
  4. 高级启动选项 屏幕上使用箭头键选择 安全模式 中,然后按 ENTER 键。
  5. 通过使用具有管理员权限的用户帐户登录到计算机。
  6. 单击 开始
    收起这个图片展开这个图片
    Start button
    、 单击 所有程序,都单击 附件、 都单击 系统工具,然后都单击 $ 系统还原
  7. 要返回到以前的还原点的 Windows Vista 在系统还原向导中步骤。

方法 2: 重新安装 Windows Vista

有关如何执行就地升级的 Windows Vista 操作系统的详细信息单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
918884如何安装 Windows Vista
按照"升级过程"部分中执行就地升级的 Windows Vista 中列出的步骤。

状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。

属性

文章编号: 935511 - 最后修改: 2007年4月3日 - 修订: 1.2
这篇文章中的信息适用于:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Defender
关键字:?
kbmt kbuninstall kbexpertisebeginner kbtshoot kbprb KB935511 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 935511
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com