Symptoms
On a computer that has Internet Explorer 7 installed, you click a hyperlink that links to an Internet shortcut file. Then, you save the shortcut file to the local disk. When you double-click the shortcut file, you cannot open the file. Additionally, you receive an error message that resembles the following:
Problem with Shortcut
The target "" of this Internet Shortcut is not valid. Go to the Internet Shortcut property sheet and make sure the target is correct.If you examine the properties of the Internet shortcut file when this problem occurs, the Type of file field indicates that the file type is Internet Shortcut (.url). However, the Web Document tab may disappear. Also, on the Details tab, the URL string may disappear.
Cause
This problem occurs if the Windows shell receives a notification during the process that creates the Internet shortcut file. This notification is received before the file has been completely written to the disk.
Resolution
Windows Vista service pack information
To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
Windows Vista hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
This hotfix has no prerequisites.
Restart requirement
You have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To enable this hotfix yourself, go to the "Let me fix it myself" section.
Let me fix it myself
To enable this hotfix after installation, follow these steps:
-
Click Start, type regedit in the Start Search box, and then press ENTER.
-
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
-
On the Edit menu, point to New, and then click Key.
-
Type the following registry subkey name, and then press ENTER:
FEATURE_URLFILE_CACHEFLUSH_KB936881
-
On the Edit menu, point to New, and then click DWORD Value.
-
Type iexplore.exe, and then press ENTER.
-
On the Edit menu, click Modify.
-
Type 1, and then click OK.
Note To disable the hotfix, type 0, and then click OK. -
Exit Registry Editor.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Update.mum |
Not Applicable |
1,946 |
14-Aug-2007 |
13:43 |
Not Applicable |
X86_14dfeba851e3970d2353a1e826374bbb_31bf3856ad364e35_6.0.6000.20660_none_a96b9b9d2b5f6fc4.manifest |
Not Applicable |
695 |
14-Aug-2007 |
13:43 |
Not Applicable |
X86_microsoft-windows-ieframe_31bf3856ad364e35_6.0.6000.20660_none_6304e956ca46c2a1.manifest |
Not Applicable |
829,599 |
14-Aug-2007 |
13:43 |
Not Applicable |
Ieframe.dll |
7.0.6000.20660 |
6,066,176 |
14-Aug-2007 |
02:22 |
x86 |
Ieui.dll |
7.0.6000.20660 |
180,736 |
14-Aug-2007 |
02:22 |
x86 |
Windows XP hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows XP Service Pack 2 installed on the computer.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
Fix it for me" section. If you prefer to enable this hotfix yourself, go to the "Let me fix it myself" section.
To have us enable this hotfix for you, go to the "Fix it for me
To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.
Notes
-
Please install the hotfix in "Hotfix download available" section at the top of this Knowledge Base article before you run the Fix it solution.
-
This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
-
If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
Did this fix the problem?" section.
Then, go to the "Let me fix it myself
To enable this hotfix after installation, follow these steps:
-
Click Start, click Run, type regedit, and then press ENTER.
-
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
-
On the Edit menu, point to New, and then click Key.
-
Type the following subkey name, and then press ENTER:
FEATURE_URLFILE_CACHEFLUSH_KB936881
-
On the Edit menu, point to New, and then click DWORD Value.
-
Type iexplore.exe, and then press ENTER.
-
On the Edit menu, click Modify.
-
Type 1, and then click OK.
Note To disable the hotfix, type 0, and then click OK. -
Exit Registry Editor.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Ieframe.dll |
7.0.6000.20661 |
6,066,176 |
20-Aug-2007 |
08:29 |
x86 |
Windows Server 2003 hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows Server 2003 Service Pack 2 installed on the computer.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
Fix it for me" section. If you prefer to enable this hotfix yourself, go to the "Let me fix it myself" section.
To have us enable this hotfix for you, go to the "Fix it for me
To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.
Notes
-
Please install the hotfix in "Hotfix download available" section at the top of this Knowledge Base article before you run the Fix it solution.
-
This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
-
If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
Did this fix the problem?" section.
Then, go to the "Let me fix it myself
To enable this hotfix after installation, follow these steps:
-
Click Start, click Run, type regedit, and then press ENTER.
-
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
-
On the Edit menu, point to New, and then click Key.
-
Type the following subkey name, and then press ENTER:
FEATURE_URLFILE_CACHEFLUSH_KB936881
-
On the Edit menu, point to New, and then click DWORD Value.
-
Type iexplore.exe, and then press ENTER.
-
On the Edit menu, click Modify.
-
Type 1, and then click OK.
Note To disable the hotfix, type 0, and then click OK. -
Exit Registry Editor.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP2, x86-based versions
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Ieframe.dll |
7.0.6000.20636 |
6,059,520 |
17-Aug-2007 |
08:25 |
x86 |
Did this fix the problem?
-
Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
-
We would appreciate your feedback. To provide feedback or to report any issues with this solution, please send us an email.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.
More Information
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates