Quando si tenta di convalidare una copia di Windows XP, viene visualizzato il seguente messaggio di errore: "0x80080201 Impossibile determinare il numero di serie (PID)"

Traduzione articoli Traduzione articoli
Identificativo articolo: 938720 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di convalidare una copia di Microsoft Windows XP, viene visualizzato il seguente messaggio di errore di Windows Genuine Advantage (WGA):
0x80080201 Impossibile rilevare il numero di serie (PID)

Cause

Questo problema si verifica perché Windows XP è in uno stato che impedisce l'accesso l'ID prodotto (PID) di WGA. Questo stato può verificarsi per uno qualsiasi dei seguenti motivi:
  • Il file %windir%\System32\Wpa.dbl è mancante o danneggiato.
  • Le impostazioni di protezione o le impostazioni degli attributi per il file %windir%\System32\Wpa.dbl non sono corrette.
  • Alcuni strumenti scaricabili hanno spostato o modificato l'ID prodotto.
  • Il valore di ID di prodotto nel Registro di sistema è mancante o danneggiato.
  • Uno o più dei seguenti file potrebbe essere una versione non corretta o può essere annullate:
    • Licdll
    • Licwmi.dll
    • LegitCheckControl

Risoluzione

Per risolvere il problema, attenersi alla seguente procedura.

Passaggio 1: Verificare che il controllo di convalida ha esito negativo.

  1. Fare clic Inizio, fare clic su Eseguire, tipo oobe/msoobe /a, quindi fare clic su OK.

    Nota. Esiste uno spazio tra msoobe e /a.
  2. Il Attivare Windows verrà visualizzata la finestra di dialogo. Seguire le istruzioni visualizzate sullo schermo per attivare Windows XP. Se viene ancora visualizzato un messaggio di errore, procedere al passaggio 2.

Passaggio 2: Scaricare e quindi registrare la versione più recente del file LegitCheckControl

  1. Per scaricare il file LegitCheckControl.cab, visitare il seguente sito Web Microsoft:
    http://download.microsoft.com/download/9/b/d/9bdc68ef-6a9f-4505-8fb8-d0d2d160e512/LegitCheckControl.cab
  2. Estrarre il file LegitCheckControl.cab in una directory temporanea del computer.
  3. Copiare il file LegitCheckControl nella directory temporanea per la %windir%\System32. Directory.
  4. Fare clic Inizio, fare clic su Eseguire, tipo cmd, quindi fare clic su OK.
  5. Registrare la nuova versione del file LegitCheckControl digitando il seguente comando al prompt dei comandi:
    regsvr32 %windir%\system32\legitcheckcontrol.dll
  6. Riavviare il computer.
  7. Dopo aver riavviato il computer, eseguire il passaggio 1 per determinare se il problema persiste. Se il messaggio di errore viene ancora visualizzato, andare al passaggio 3.

Passaggio 3: Registrare nuovamente il file Licwmi.dll

  1. Fare clic Inizio, fare clic su Eseguire, tipo cmd, quindi fare clic su OK.
  2. Al prompt dei comandi digitare il comando seguente e premere INVIO:
    regsvr32 /u %windir%\system32\licwmi.dll
  3. Eseguire nuovamente il passaggio 1. Se il messaggio di errore viene ancora visualizzato, andare al passaggio 4.

Passaggio 4: Registrare nuovamente il file Licdll dll

  1. Fare clic Inizio, fare clic su Eseguire, tipo cmd, quindi fare clic su OK.
  2. Al prompt dei comandi digitare i comandi seguenti. Premere INVIO dopo ciascun comando.
    regsvr32 /u %windir%\system32\licdll.dll
    net stop winmgmt
  3. Dopo l'arresto del servizio Winmgmt, digitare il seguente comando al prompt dei comandi e premere INVIO:
    Net start winmgmt
  4. Eseguire nuovamente il passaggio 1. Se il messaggio di errore viene ancora visualizzato, andare al passaggio 5.

Passaggio 5: Verificare il valore per ProductID nel Registro di sistema

  1. Fare clic Inizio, fare clic su Eseguire, tipo Regedit, quindi fare clic su OK.
  2. Individuare e quindi fare doppio clic sul seguente valore del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProductID
  3. Verificare che il valore del Registro di sistema viene visualizzato nel formato seguente:
    <12345-VER-1234567-89012></12345-VER-1234567-89012>
  4. Se il valore viene visualizzato correttamente, riavviare il computer ed eseguire nuovamente il passaggio 1.
  5. Se il messaggio di errore viene ancora visualizzato, andare al passaggio 6.

Passaggio 6: Verificare che gli attributi per il file non siano impostati in sola lettura

  1. Fare clic Inizio, fare clic su Eseguire, tipo attrib - r %windir%\system32\wpa.dbl, quindi fare clic su OK.
  2. Eseguire nuovamente il passaggio 1. Se il messaggio di errore viene ancora visualizzato, andare al passaggio 7.

Passaggio 7: Verificare le impostazioni di protezione per il file

  1. In Esplora risorse, individuare il file %windir%\System32\Wpa.dbl.
  2. Pulsante destro del mouse Dbl, quindi fare clic su Proprietà.
  3. Nel Protezione Fare clic per selezionare il gruppo di sistema. Verificare che il Consentire casella di controllo Controllo completo è selezionata. Se Controllo completo non è selezionato per il gruppo di sistema, selezionarlo e quindi fare clic su OK.
  4. Eseguire nuovamente il passaggio 1. Se il messaggio di errore viene ancora visualizzato, andare al passaggio 8.
Nota. In Windows XP Home Edition, il Protezione scheda viene visualizzata solo quando il computer è in esecuzione in modalità provvisoria. Inoltre, In Windows XP Professional, il Protezione scheda viene visualizzata solo quando il Utilizzare la condivisione file semplice (scelta consigliata) casella di controllo il Opzioni cartella Nella finestra di dialogo non è selezionata.

Passaggio 8: Eseguire lo strumento Microsoft Genuine Advantage diagnostica (MGADIAG)

  1. Per eseguire lo strumento, visitare il seguente sito Web Microsoft:
    http://go.microsoft.com/fwlink/?linkid=52012
  2. Nel File Download - avviso di protezione Nella finestra di dialogo, fare clic su Eseguire.
  3. Nel Internet Explorer - Avviso di protezione Nella finestra di dialogo, fare clic su Eseguire.
  4. Nel Strumento di diagnostica di Microsoft Genuine Advantage Nella finestra di dialogo, fare clic su Continua.
  5. Lo strumento MGADIAG termine, fare clic su Copia.
  6. Visitare il forum in linea di problemi di convalida di Windows XP autentico vantaggio il seguente sito Web Microsoft:
    http://forums.microsoft.com/genuine/ShowForum.aspx?ForumID=442&amp;SiteID=25
    È possibile creare un nuovo thread in questo sito Web che include le informazioni copiate dallo strumento MGADIAG.

Status

Microsoft ha confermato che questo è un problema nei prodotti Microsoft elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni su WGA, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/genuine/downloads/whyValidate.aspx
Per ulteriori informazioni, fare clic sui seguenti numeri di articolo per visualizzare gli articoli della Microsoft Knowledge Base:
892130Descrizione di Windows Genuine Advantage (WGA)
916247 Windows Genuine Advantage non convalidare una copia di Windows XP
Per ulteriori informazioni su come attivare Windows XP, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
307890Come attivare Windows XP

Proprietà

Identificativo articolo: 938720 - Ultima modifica: venerdì 1 marzo 2013 - Revisione: 4.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Genuine Advantage
Chiavi: 
kbtshoot kbprb kbmt KB938720 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 938720
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com